SlideShare uma empresa Scribd logo
Aula 05
Estruturas de Repetição
Parte 2
Ênio Prates Vasconcelos Filho
Faculdades Alfa
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Tópicos
Δ Estruturas de Repetição:
• Para...faca
Δ Revisão;
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Até aqui
Δ Condicional:
se condicao entao
// lista de comandos caso a condição seja // verdadeira
fim_se
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Até aqui
Δ Condicional Encadeado:
se (<condição1>) entao
<instrução para condição1 verdadeira>
senao
se (<condição2>) entao
<instrução para condição2 verdadeira, com condicao1 Falsa>
fim_se
se (<condição3>) entao
<instrução para condição3 verdadeira, com condicao1 Falsa>
senão
<instrução para condição3 falsa, com condicao1 Falsa>
fim_se
fim_se
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Até aqui
Laços de repetição:
Δ faca...enquanto
enquanto (condição) faca
//lista de instruções
fim_enquanto
Δ Repita...ate_que
repita
// Lista de instruções
ate_que expressão lógica
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Para...Faca
ΔNesta estrutura, uma variável de controle é inicializada com um
valor inicial. Para cada iteração, seu valor é comparado com um
valor final;
ΔA execução da lista de instruções se repete até que a variável de
controle seja maior que o valor final;
ΔPara cada iteração, a variável de controle é incrementada;
ΔUtilizamos as palavras reservadas para, de, ate, faca e fim_para
para formar o laço de repetição;
ΔA ideia dessa estrutura é facilitar o uso de contadores finitos sem
fazer uso das duas estruturas anteriores, deixando-as para
utilização de loopings em que não se conhece de antemão o
número de vezes que uma determinada sequência de instruções
deverá ser executada
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Para...Faca
ΔForma geral:
para variavel de val_inicial ate val_final faca
// Lista de instruções
fim_para
Δ Define-se uma variável de controle (do tipo inteiro), a ser variada em cada
iteração;
• A cada execução do loop, o código já incrementa o valor da variável sozinho!
• Essa variável é comumente identificada como contador;
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Para...Faca
Δ Diagrama de blocos:
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Para...Faca
Δ Exemplo:
• Pedir a leitura de um valor para a variável X, multiplicar esse valor por 3,
associando esse valor à variável de resposta R, e apresentar o valor obtido,
repetindo esta sequência por cinco vezes (usando a estrutura para...faca):
Δ Solução - Algoritmo:
1. Definir um contador, variando de 1 a 5;
2. Ler um valor para a variável X;
3. Efetuar a multiplicação do valor de X por 3, associando o resultado em R;
4. Apresentar o valor calculado, contido na variável R;
5. Repetir os passos 2, 3 , 4 e 5 até que o contador seja encerrado.
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Para...Faca
Δ Exemplo:
• Pedir a leitura de um valor para a variável X,
multiplicar esse valor por 3, associando esse
valor à variável de resposta R, e apresentar o
valor obtido, repetindo esta sequência por
cinco vezes (usando a estrutura para...faca):
Δ Solução – Diagrama de blocos:
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Para...Faca
Δ Exemplo:
• Pedir a leitura de um valor para a
variável X, multiplicar esse valor por 3,
associando esse valor à variável de
resposta R, e apresentar o valor
obtido, repetindo esta sequência por
cinco vezes (usando a estrutura
para...faca):
Δ Solução – Portucê:
programa LOOPING_2A
var
X, R: inteiro
CONT: inteiro
inicio
para CONT de 1 ate 5 faca
leia X
R<- X * 3
escreva R
fim_para
fim
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Para...Faca
Δ Exemplo - Algoritmo que escreve os números de 1 a 5:
programa Mostra5
var i: inteiro
inicio
i<-1
para i de 1 ate 5 faca
escreva(i)
fim_para
fim
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Para...Faca
Δ Para alterarmos a forma de contagem do laço (crescente ou decrescente) e
quanto a variável de controle vai ser incrementada ou decrementada,
utilizamos a palavra reservada passo, seguida de um valor;
Δ Forma geral:
para variavel de val_inicial ate val_final passo
valor faca
// Lista de instruções
fim_para
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Para...Faca
Δ Exemplo - Algoritmo que escreve os números pares entre 1 e 10 (incluindo
o 10):
programa Mostra10par
var i: inteiro
inicio
i<-1
para i de 1 ate 100 passo 2 faca
escreva(i)
fim_para
fim
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Tipos de Estrutura de Looping
Δ Apresentadas três estruturas de controle em nível de repetição: enquanto,
repita e para,
• Cada qual com sua característica de processamento;
Δ Podemos observar que as estruturas mais versáteis são enquanto e repita,
pois podem ser substituídas uma pela outra além de poderem substituir
perfeitamente a estrutura para;
Δ Porem há de considerar-se que nem toda estrutura enquanto ou repita
poderá ser substituída por uma estrutura para;
• Isto ocorre quando em uma estrutura utilizam-se condições que não
envolvam o uso de variáveis de controle como contador.
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Exercícios
Δ Faça um algoritmo que lê 30 números inteiros. O mesmo deve calcular e
exibir a média aritmética deles (use a estrutura para...faca);
Δ Utilizando a estrutura para...faca, escreva um algoritmo que mostre todos
os números pares entre 0 e 100;
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Exercícios
Δ Elaborar o algoritmo, diagrama de blocos e codificação em português
estruturado de um programa que efetue o cálculo da fatorial de um
número inserido pelo usuário. Em seguida, imprima na tela o valor
calculado. Caso o usuário insira um número negativo, indique que não é um
número aceitável. Se o usuário inserir o número 0, indique que o fatorial é
1.
• 5! = 5*4*3*2*1;
• 0! = 1;
• -2! = Não existe;
Δ Ao final do calculo, pergunte ao usuário se ele quer inserir um novo
número. Somente se a resposta for “sim”, continue. Caso contrário, exiba
uma mensagem e finalize o algoritmo.
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Exercícios - Solução
Δ Algoritmo:
1. Inicializar as variáveis FATORIAL e CONTADOR com 1 ;
2. Definir as variáveis RESP (resposta) para confirmação e N para receber o
limite de valor para o cálculo da fatorial;
3. Enquanto RESP do usuário for sim, executar os passos 3, 4, 5 , 6 e 7;
4. Ler a entrada N do usuário;
I. Verificar se o número N é maior ou igual a zero;
5. Repetir a execução dos passos 4 e 5 por N vezes;
6. FATORIAL <- FATORIAL * CONTADOR;
7. Incrementar 1 à variável CONTADOR;
8. Apresentar ao final o valor obtido.
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Exercícios - Solução
programa FATORIAL_D
var
CONTADOR: inteiro
FATORIAL: inteiro
RESP: caractere
N: inteiro
inicio
RESP <-" SIM“
Cont<- 1
enquanto ( RESP = " SIM" ) faça
FATORIAL <- 1
escreva (“Número : “)
leia (N)
se (N>0) entao
para CONTADOR de 1 até N passo 1 faca
FATORIAL <- FATORIAL * CONTADOR
fim_para
escreva ("Fatorial de " , N , “é = “, FATORIAL)
senao
se (N=0) então
escreva ("Fatorial de " , N , “é = 1”)
senão
escreva (“Não existe Fatorial de " , N)
fim_se
fim_se
escreva ("Deseja continuar ? “)
leia (RESP)
fim_enquanto
fim
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Exercícios
Δ Apresentar o total da soma obtida dos cem primeiros números inteiros
(1 +2+3+4+5+6+7+...97+98+99+100);
Δ E laborar um programa que apresente no final o somatório dos valores
pares existentes na faixa de 1 até 500;
Δ Apresentar todos os valores numéricos inteiros ímpares situados na
faixa de 0 a 20. Para verificar se o número é ímpar, efetuar dentro da
malha a verificação lógica desta condição com a instrução se,
perguntando se o número é ímpar; sendo, mostre-o, não sendo, passe
para o próximo passo;
Δ Escreva um programa que apresente a série de Fibonacci até o décimo
quinto termo. A série de Fibonacci é formada pela sequência: 1, 1, 2,
3, 5, 8, 13, 21, 34, .... Esta série se caracteriza pela soma de um
termo posterior com o seu anterior subsequente.
E
S
T
R
U
T
U
R
A
S
D
E
R
E
P
E
T
I
Ç
Ã
O ALGORITMOS - 02/2015 – ÊNIO FILHO
Exercícios
Δ Elaborar um programa que efetue o cálculo e no final apresente o
somatório do número de grãos de trigo que se pode obter num tabuleiro
de xadrez, obedecendo à seguinte regra:
• colocar um grão de trigo no primeiro quadro e nos quadros seguintes o dobro
do quadro anterior.
oOu seja, no primeiro quadro coloca-se 1 grão;
oNo segundo quadro colocam-se 2 grãos (neste momento têm-se 3 grãos)
oNo terceiro quadro colocam-se 4 grãos (tendo neste momento 7 grãos);
oNo quarto quadro colocam-se 8 grãos (tendo-se então 15 grãos) até atingir o
sexagésimo quarto quadro;
• Imprima também as seguintes informações, a medida que fizerem os cálculos:
oQuadro 1, 1 Grão, Total = 1;
oQuadro 2, 2 Grãos, Total = 3;
oQuadro 3, 4 Grãos, Total = 7...
DÚVIDAS?
Contatos:
E-mail: enio.filho@alfa.br
Skype: eniopvf
Twitter: eniopvf
Bibliografia:
• MANZANO, José Augusto N. G.; OLIVEIRA, Jayr Figueiredo de. Algoritmos: lógica para
desenvolvimento de programação de computadores. 18ª. ed. São Paulo: Érica, 2006. 236 p. ISBN
857194718;
• FORBELLONE, André Luiz Villar; EBERSPACHER, Henri Frederico. Lógica de programação: a construção
de algoritmos e estruturas de dados. 3ª. ed. São Paulo (SP): Pearson Prentice Hall, 2005. 195 p. ISBN
9788576050247;

Mais conteúdo relacionado

Semelhante a Algoritmos e LP - Aula 05 - Estruturas de Repeticao - p2.pdf

Algoritmos - Comandos de Repetição
Algoritmos - Comandos de RepetiçãoAlgoritmos - Comandos de Repetição
Algoritmos - Comandos de Repetição
Elaine Cecília Gatto
 
15080590 aula6-estrutura-de-repeticao
15080590 aula6-estrutura-de-repeticao15080590 aula6-estrutura-de-repeticao
15080590 aula6-estrutura-de-repeticao
Lee Aragão
 
Aula02 condicionais
Aula02   condicionaisAula02   condicionais
Aula02 condicionais
Yuri Passos
 
Lógica de Programação - Unimep/Pronatec - Aula08
Lógica de Programação - Unimep/Pronatec - Aula08Lógica de Programação - Unimep/Pronatec - Aula08
Lógica de Programação - Unimep/Pronatec - Aula08
André Phillip Bertoletti
 
Java: Condicionais
Java: CondicionaisJava: Condicionais
Java: Condicionais
Arthur Emanuel
 
Seg. do Trabalho - Estatística.pptx
Seg. do Trabalho - Estatística.pptxSeg. do Trabalho - Estatística.pptx
Seg. do Trabalho - Estatística.pptx
RafaelFranco466245
 
portugol
portugolportugol
portugol
anselmo alves
 
aula 06 - Logica de programacao
aula 06 - Logica de programacaoaula 06 - Logica de programacao
aula 06 - Logica de programacao
Aislan Rafael
 
Lógica de programação
Lógica de programaçãoLógica de programação
Lógica de programação
Evaldo Savio Araujo
 
Estrutura de controle repetição C++
Estrutura de controle repetição C++Estrutura de controle repetição C++
Estrutura de controle repetição C++
Sedu
 
Algoritmo e lógica de programação - Aula 1
Algoritmo e lógica de programação - Aula 1Algoritmo e lógica de programação - Aula 1
Algoritmo e lógica de programação - Aula 1
engenhariadecomputacao
 
Algoritmos Aula 11
Algoritmos Aula 11Algoritmos Aula 11
Algoritmos Aula 11
IBTA Turma de TI 2009
 
Algop - aula 06
Algop - aula 06Algop - aula 06
Algop - aula 06
Thiago Toscano Ferrari
 
Logica de Progamacao - Aula (1) (1).pptx
Logica de Progamacao - Aula (1) (1).pptxLogica de Progamacao - Aula (1) (1).pptx
Logica de Progamacao - Aula (1) (1).pptx
Momento da Informática
 
Curso De Algoritmo Aula 5
Curso De Algoritmo   Aula 5Curso De Algoritmo   Aula 5
Curso De Algoritmo Aula 5
Felipe Santos
 
Lógica de Programação
Lógica de ProgramaçãoLógica de Programação
Lógica de Programação
Adao Chiavelli
 
Programar Em Pascal
Programar Em PascalProgramar Em Pascal
Programar Em Pascal
Pepe Rocker
 
Algop - aula 03
Algop - aula 03Algop - aula 03
Algop - aula 03
Thiago Toscano Ferrari
 
Alg aula 05-2 - estruturas de-repeticao tp1 (para)
Alg   aula 05-2 - estruturas de-repeticao tp1 (para)Alg   aula 05-2 - estruturas de-repeticao tp1 (para)
Alg aula 05-2 - estruturas de-repeticao tp1 (para)
Thalles Anderson
 
Introducao a Lógica de Programação
Introducao a Lógica de ProgramaçãoIntroducao a Lógica de Programação
Introducao a Lógica de Programação
Marcelo Rodrigues
 

Semelhante a Algoritmos e LP - Aula 05 - Estruturas de Repeticao - p2.pdf (20)

Algoritmos - Comandos de Repetição
Algoritmos - Comandos de RepetiçãoAlgoritmos - Comandos de Repetição
Algoritmos - Comandos de Repetição
 
15080590 aula6-estrutura-de-repeticao
15080590 aula6-estrutura-de-repeticao15080590 aula6-estrutura-de-repeticao
15080590 aula6-estrutura-de-repeticao
 
Aula02 condicionais
Aula02   condicionaisAula02   condicionais
Aula02 condicionais
 
Lógica de Programação - Unimep/Pronatec - Aula08
Lógica de Programação - Unimep/Pronatec - Aula08Lógica de Programação - Unimep/Pronatec - Aula08
Lógica de Programação - Unimep/Pronatec - Aula08
 
Java: Condicionais
Java: CondicionaisJava: Condicionais
Java: Condicionais
 
Seg. do Trabalho - Estatística.pptx
Seg. do Trabalho - Estatística.pptxSeg. do Trabalho - Estatística.pptx
Seg. do Trabalho - Estatística.pptx
 
portugol
portugolportugol
portugol
 
aula 06 - Logica de programacao
aula 06 - Logica de programacaoaula 06 - Logica de programacao
aula 06 - Logica de programacao
 
Lógica de programação
Lógica de programaçãoLógica de programação
Lógica de programação
 
Estrutura de controle repetição C++
Estrutura de controle repetição C++Estrutura de controle repetição C++
Estrutura de controle repetição C++
 
Algoritmo e lógica de programação - Aula 1
Algoritmo e lógica de programação - Aula 1Algoritmo e lógica de programação - Aula 1
Algoritmo e lógica de programação - Aula 1
 
Algoritmos Aula 11
Algoritmos Aula 11Algoritmos Aula 11
Algoritmos Aula 11
 
Algop - aula 06
Algop - aula 06Algop - aula 06
Algop - aula 06
 
Logica de Progamacao - Aula (1) (1).pptx
Logica de Progamacao - Aula (1) (1).pptxLogica de Progamacao - Aula (1) (1).pptx
Logica de Progamacao - Aula (1) (1).pptx
 
Curso De Algoritmo Aula 5
Curso De Algoritmo   Aula 5Curso De Algoritmo   Aula 5
Curso De Algoritmo Aula 5
 
Lógica de Programação
Lógica de ProgramaçãoLógica de Programação
Lógica de Programação
 
Programar Em Pascal
Programar Em PascalProgramar Em Pascal
Programar Em Pascal
 
Algop - aula 03
Algop - aula 03Algop - aula 03
Algop - aula 03
 
Alg aula 05-2 - estruturas de-repeticao tp1 (para)
Alg   aula 05-2 - estruturas de-repeticao tp1 (para)Alg   aula 05-2 - estruturas de-repeticao tp1 (para)
Alg aula 05-2 - estruturas de-repeticao tp1 (para)
 
Introducao a Lógica de Programação
Introducao a Lógica de ProgramaçãoIntroducao a Lógica de Programação
Introducao a Lógica de Programação
 

Mais de Enio Filho

Algoritmos e LP - Aula 02 - Tipos de Dados.pdf
Algoritmos e LP - Aula 02 - Tipos de Dados.pdfAlgoritmos e LP - Aula 02 - Tipos de Dados.pdf
Algoritmos e LP - Aula 02 - Tipos de Dados.pdf
Enio Filho
 
Algoritmos e LP - Aula 07 - Vetores e Introdução ao C.pdf
Algoritmos e LP - Aula 07 - Vetores e Introdução ao C.pdfAlgoritmos e LP - Aula 07 - Vetores e Introdução ao C.pdf
Algoritmos e LP - Aula 07 - Vetores e Introdução ao C.pdf
Enio Filho
 
Algoritmos e LP - Aula 08 - Linguagem C - p1.pdf
Algoritmos e LP - Aula 08 - Linguagem C - p1.pdfAlgoritmos e LP - Aula 08 - Linguagem C - p1.pdf
Algoritmos e LP - Aula 08 - Linguagem C - p1.pdf
Enio Filho
 
Algoritmos e LP - Aula 01 - Introdução a Algoritmos.pdf
Algoritmos e LP - Aula 01 - Introdução a Algoritmos.pdfAlgoritmos e LP - Aula 01 - Introdução a Algoritmos.pdf
Algoritmos e LP - Aula 01 - Introdução a Algoritmos.pdf
Enio Filho
 
Algoritmos e LP - Aula 00 - Introdução e Apresentação.pdf
Algoritmos e LP - Aula 00 - Introdução e Apresentação.pdfAlgoritmos e LP - Aula 00 - Introdução e Apresentação.pdf
Algoritmos e LP - Aula 00 - Introdução e Apresentação.pdf
Enio Filho
 
Eica 2016.1 - Identificando e rastreando itens na era do IOT
Eica 2016.1 - Identificando e rastreando itens na era do IOTEica 2016.1 - Identificando e rastreando itens na era do IOT
Eica 2016.1 - Identificando e rastreando itens na era do IOT
Enio Filho
 
Eica 2015.2 - Introdução ao IOT
Eica 2015.2 - Introdução ao IOTEica 2015.2 - Introdução ao IOT
Eica 2015.2 - Introdução ao IOT
Enio Filho
 
Eica 2016.2 - Industria 4.0
Eica 2016.2 - Industria 4.0Eica 2016.2 - Industria 4.0
Eica 2016.2 - Industria 4.0
Enio Filho
 
Iot - identificando e rastreando - PUC
Iot  - identificando e rastreando - PUCIot  - identificando e rastreando - PUC
Iot - identificando e rastreando - PUC
Enio Filho
 

Mais de Enio Filho (9)

Algoritmos e LP - Aula 02 - Tipos de Dados.pdf
Algoritmos e LP - Aula 02 - Tipos de Dados.pdfAlgoritmos e LP - Aula 02 - Tipos de Dados.pdf
Algoritmos e LP - Aula 02 - Tipos de Dados.pdf
 
Algoritmos e LP - Aula 07 - Vetores e Introdução ao C.pdf
Algoritmos e LP - Aula 07 - Vetores e Introdução ao C.pdfAlgoritmos e LP - Aula 07 - Vetores e Introdução ao C.pdf
Algoritmos e LP - Aula 07 - Vetores e Introdução ao C.pdf
 
Algoritmos e LP - Aula 08 - Linguagem C - p1.pdf
Algoritmos e LP - Aula 08 - Linguagem C - p1.pdfAlgoritmos e LP - Aula 08 - Linguagem C - p1.pdf
Algoritmos e LP - Aula 08 - Linguagem C - p1.pdf
 
Algoritmos e LP - Aula 01 - Introdução a Algoritmos.pdf
Algoritmos e LP - Aula 01 - Introdução a Algoritmos.pdfAlgoritmos e LP - Aula 01 - Introdução a Algoritmos.pdf
Algoritmos e LP - Aula 01 - Introdução a Algoritmos.pdf
 
Algoritmos e LP - Aula 00 - Introdução e Apresentação.pdf
Algoritmos e LP - Aula 00 - Introdução e Apresentação.pdfAlgoritmos e LP - Aula 00 - Introdução e Apresentação.pdf
Algoritmos e LP - Aula 00 - Introdução e Apresentação.pdf
 
Eica 2016.1 - Identificando e rastreando itens na era do IOT
Eica 2016.1 - Identificando e rastreando itens na era do IOTEica 2016.1 - Identificando e rastreando itens na era do IOT
Eica 2016.1 - Identificando e rastreando itens na era do IOT
 
Eica 2015.2 - Introdução ao IOT
Eica 2015.2 - Introdução ao IOTEica 2015.2 - Introdução ao IOT
Eica 2015.2 - Introdução ao IOT
 
Eica 2016.2 - Industria 4.0
Eica 2016.2 - Industria 4.0Eica 2016.2 - Industria 4.0
Eica 2016.2 - Industria 4.0
 
Iot - identificando e rastreando - PUC
Iot  - identificando e rastreando - PUCIot  - identificando e rastreando - PUC
Iot - identificando e rastreando - PUC
 

Último

epidemias endemia-pandemia-e-epidemia (1).ppt
epidemias endemia-pandemia-e-epidemia (1).pptepidemias endemia-pandemia-e-epidemia (1).ppt
epidemias endemia-pandemia-e-epidemia (1).ppt
MarceloMonteiro213738
 
- TEMPLATE DA PRATICA - Psicomotricidade.pptx
- TEMPLATE DA PRATICA - Psicomotricidade.pptx- TEMPLATE DA PRATICA - Psicomotricidade.pptx
- TEMPLATE DA PRATICA - Psicomotricidade.pptx
LucianaCristina58
 
Livro: Pedagogia do Oprimido - Paulo Freire
Livro: Pedagogia do Oprimido - Paulo FreireLivro: Pedagogia do Oprimido - Paulo Freire
Livro: Pedagogia do Oprimido - Paulo Freire
WelberMerlinCardoso
 
Sistema de Bibliotecas UCS - Chronica do emperador Clarimundo, donde os reis ...
Sistema de Bibliotecas UCS - Chronica do emperador Clarimundo, donde os reis ...Sistema de Bibliotecas UCS - Chronica do emperador Clarimundo, donde os reis ...
Sistema de Bibliotecas UCS - Chronica do emperador Clarimundo, donde os reis ...
Biblioteca UCS
 
Famílias Que Contribuíram Para O Crescimento Do Assaré
Famílias Que Contribuíram Para O Crescimento Do AssaréFamílias Que Contribuíram Para O Crescimento Do Assaré
Famílias Que Contribuíram Para O Crescimento Do Assaré
profesfrancleite
 
D20 - Descritores SAEB de Língua Portuguesa
D20 - Descritores SAEB de Língua PortuguesaD20 - Descritores SAEB de Língua Portuguesa
D20 - Descritores SAEB de Língua Portuguesa
eaiprofpolly
 
Aula história , caracteristicas e esteriótipos em relação a DANÇA DE SALAO.pptx
Aula história , caracteristicas e esteriótipos em relação a DANÇA DE SALAO.pptxAula história , caracteristicas e esteriótipos em relação a DANÇA DE SALAO.pptx
Aula história , caracteristicas e esteriótipos em relação a DANÇA DE SALAO.pptx
edivirgesribeiro1
 
slides de Didática 2.pdf para apresentar
slides de Didática 2.pdf para apresentarslides de Didática 2.pdf para apresentar
slides de Didática 2.pdf para apresentar
JoeteCarvalho
 
GÊNERO TEXTUAL - POEMA.pptx
GÊNERO      TEXTUAL     -     POEMA.pptxGÊNERO      TEXTUAL     -     POEMA.pptx
GÊNERO TEXTUAL - POEMA.pptx
Marlene Cunhada
 
Atividade de reforço de matemática 2º ano
Atividade de reforço de matemática 2º anoAtividade de reforço de matemática 2º ano
Atividade de reforço de matemática 2º ano
fernandacosta37763
 
Pintura Romana .pptx
Pintura Romana                     .pptxPintura Romana                     .pptx
Pintura Romana .pptx
TomasSousa7
 
05-os-pre-socraticos sociologia-28-slides.pptx
05-os-pre-socraticos sociologia-28-slides.pptx05-os-pre-socraticos sociologia-28-slides.pptx
05-os-pre-socraticos sociologia-28-slides.pptx
ValdineyRodriguesBez1
 
Vogais Ilustrados para alfabetização infantil
Vogais Ilustrados para alfabetização infantilVogais Ilustrados para alfabetização infantil
Vogais Ilustrados para alfabetização infantil
mamaeieby
 
Reino-Vegetal plantas e demais conceitos .pptx
Reino-Vegetal plantas e demais conceitos .pptxReino-Vegetal plantas e demais conceitos .pptx
Reino-Vegetal plantas e demais conceitos .pptx
CarinaSantos916505
 
OS elementos de uma boa Redação para o ENEM.pdf
OS elementos de uma boa Redação para o ENEM.pdfOS elementos de uma boa Redação para o ENEM.pdf
OS elementos de uma boa Redação para o ENEM.pdf
AmiltonAparecido1
 
A SOCIOLOGIA E O TRABALHO: ANÁLISES E VIVÊNCIAS
A SOCIOLOGIA E O TRABALHO: ANÁLISES E VIVÊNCIASA SOCIOLOGIA E O TRABALHO: ANÁLISES E VIVÊNCIAS
A SOCIOLOGIA E O TRABALHO: ANÁLISES E VIVÊNCIAS
HisrelBlog
 
Educação trabalho HQ em sala de aula uma excelente ideia
Educação  trabalho HQ em sala de aula uma excelente  ideiaEducação  trabalho HQ em sala de aula uma excelente  ideia
Educação trabalho HQ em sala de aula uma excelente ideia
joseanesouza36
 
A QUESTÃO ANTROPOLÓGICA: O QUE SOMOS OU QUEM SOMOS.pdf
A QUESTÃO ANTROPOLÓGICA: O QUE SOMOS OU QUEM SOMOS.pdfA QUESTÃO ANTROPOLÓGICA: O QUE SOMOS OU QUEM SOMOS.pdf
A QUESTÃO ANTROPOLÓGICA: O QUE SOMOS OU QUEM SOMOS.pdf
AurelianoFerreirades2
 
Redação e Leitura_7º ano_58_Produção de cordel .pptx
Redação e Leitura_7º ano_58_Produção de cordel .pptxRedação e Leitura_7º ano_58_Produção de cordel .pptx
Redação e Leitura_7º ano_58_Produção de cordel .pptx
DECIOMAURINARAMOS
 
Leis de Mendel - as ervilhas e a maneira simples de entender.ppt
Leis de Mendel - as ervilhas e a maneira simples de entender.pptLeis de Mendel - as ervilhas e a maneira simples de entender.ppt
Leis de Mendel - as ervilhas e a maneira simples de entender.ppt
PatriciaZanoli
 

Último (20)

epidemias endemia-pandemia-e-epidemia (1).ppt
epidemias endemia-pandemia-e-epidemia (1).pptepidemias endemia-pandemia-e-epidemia (1).ppt
epidemias endemia-pandemia-e-epidemia (1).ppt
 
- TEMPLATE DA PRATICA - Psicomotricidade.pptx
- TEMPLATE DA PRATICA - Psicomotricidade.pptx- TEMPLATE DA PRATICA - Psicomotricidade.pptx
- TEMPLATE DA PRATICA - Psicomotricidade.pptx
 
Livro: Pedagogia do Oprimido - Paulo Freire
Livro: Pedagogia do Oprimido - Paulo FreireLivro: Pedagogia do Oprimido - Paulo Freire
Livro: Pedagogia do Oprimido - Paulo Freire
 
Sistema de Bibliotecas UCS - Chronica do emperador Clarimundo, donde os reis ...
Sistema de Bibliotecas UCS - Chronica do emperador Clarimundo, donde os reis ...Sistema de Bibliotecas UCS - Chronica do emperador Clarimundo, donde os reis ...
Sistema de Bibliotecas UCS - Chronica do emperador Clarimundo, donde os reis ...
 
Famílias Que Contribuíram Para O Crescimento Do Assaré
Famílias Que Contribuíram Para O Crescimento Do AssaréFamílias Que Contribuíram Para O Crescimento Do Assaré
Famílias Que Contribuíram Para O Crescimento Do Assaré
 
D20 - Descritores SAEB de Língua Portuguesa
D20 - Descritores SAEB de Língua PortuguesaD20 - Descritores SAEB de Língua Portuguesa
D20 - Descritores SAEB de Língua Portuguesa
 
Aula história , caracteristicas e esteriótipos em relação a DANÇA DE SALAO.pptx
Aula história , caracteristicas e esteriótipos em relação a DANÇA DE SALAO.pptxAula história , caracteristicas e esteriótipos em relação a DANÇA DE SALAO.pptx
Aula história , caracteristicas e esteriótipos em relação a DANÇA DE SALAO.pptx
 
slides de Didática 2.pdf para apresentar
slides de Didática 2.pdf para apresentarslides de Didática 2.pdf para apresentar
slides de Didática 2.pdf para apresentar
 
GÊNERO TEXTUAL - POEMA.pptx
GÊNERO      TEXTUAL     -     POEMA.pptxGÊNERO      TEXTUAL     -     POEMA.pptx
GÊNERO TEXTUAL - POEMA.pptx
 
Atividade de reforço de matemática 2º ano
Atividade de reforço de matemática 2º anoAtividade de reforço de matemática 2º ano
Atividade de reforço de matemática 2º ano
 
Pintura Romana .pptx
Pintura Romana                     .pptxPintura Romana                     .pptx
Pintura Romana .pptx
 
05-os-pre-socraticos sociologia-28-slides.pptx
05-os-pre-socraticos sociologia-28-slides.pptx05-os-pre-socraticos sociologia-28-slides.pptx
05-os-pre-socraticos sociologia-28-slides.pptx
 
Vogais Ilustrados para alfabetização infantil
Vogais Ilustrados para alfabetização infantilVogais Ilustrados para alfabetização infantil
Vogais Ilustrados para alfabetização infantil
 
Reino-Vegetal plantas e demais conceitos .pptx
Reino-Vegetal plantas e demais conceitos .pptxReino-Vegetal plantas e demais conceitos .pptx
Reino-Vegetal plantas e demais conceitos .pptx
 
OS elementos de uma boa Redação para o ENEM.pdf
OS elementos de uma boa Redação para o ENEM.pdfOS elementos de uma boa Redação para o ENEM.pdf
OS elementos de uma boa Redação para o ENEM.pdf
 
A SOCIOLOGIA E O TRABALHO: ANÁLISES E VIVÊNCIAS
A SOCIOLOGIA E O TRABALHO: ANÁLISES E VIVÊNCIASA SOCIOLOGIA E O TRABALHO: ANÁLISES E VIVÊNCIAS
A SOCIOLOGIA E O TRABALHO: ANÁLISES E VIVÊNCIAS
 
Educação trabalho HQ em sala de aula uma excelente ideia
Educação  trabalho HQ em sala de aula uma excelente  ideiaEducação  trabalho HQ em sala de aula uma excelente  ideia
Educação trabalho HQ em sala de aula uma excelente ideia
 
A QUESTÃO ANTROPOLÓGICA: O QUE SOMOS OU QUEM SOMOS.pdf
A QUESTÃO ANTROPOLÓGICA: O QUE SOMOS OU QUEM SOMOS.pdfA QUESTÃO ANTROPOLÓGICA: O QUE SOMOS OU QUEM SOMOS.pdf
A QUESTÃO ANTROPOLÓGICA: O QUE SOMOS OU QUEM SOMOS.pdf
 
Redação e Leitura_7º ano_58_Produção de cordel .pptx
Redação e Leitura_7º ano_58_Produção de cordel .pptxRedação e Leitura_7º ano_58_Produção de cordel .pptx
Redação e Leitura_7º ano_58_Produção de cordel .pptx
 
Leis de Mendel - as ervilhas e a maneira simples de entender.ppt
Leis de Mendel - as ervilhas e a maneira simples de entender.pptLeis de Mendel - as ervilhas e a maneira simples de entender.ppt
Leis de Mendel - as ervilhas e a maneira simples de entender.ppt
 

Algoritmos e LP - Aula 05 - Estruturas de Repeticao - p2.pdf

  • 1. Aula 05 Estruturas de Repetição Parte 2 Ênio Prates Vasconcelos Filho Faculdades Alfa
  • 2. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Tópicos Δ Estruturas de Repetição: • Para...faca Δ Revisão;
  • 3. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Até aqui Δ Condicional: se condicao entao // lista de comandos caso a condição seja // verdadeira fim_se
  • 4. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Até aqui Δ Condicional Encadeado: se (<condição1>) entao <instrução para condição1 verdadeira> senao se (<condição2>) entao <instrução para condição2 verdadeira, com condicao1 Falsa> fim_se se (<condição3>) entao <instrução para condição3 verdadeira, com condicao1 Falsa> senão <instrução para condição3 falsa, com condicao1 Falsa> fim_se fim_se
  • 5. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Até aqui Laços de repetição: Δ faca...enquanto enquanto (condição) faca //lista de instruções fim_enquanto Δ Repita...ate_que repita // Lista de instruções ate_que expressão lógica
  • 6. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Para...Faca ΔNesta estrutura, uma variável de controle é inicializada com um valor inicial. Para cada iteração, seu valor é comparado com um valor final; ΔA execução da lista de instruções se repete até que a variável de controle seja maior que o valor final; ΔPara cada iteração, a variável de controle é incrementada; ΔUtilizamos as palavras reservadas para, de, ate, faca e fim_para para formar o laço de repetição; ΔA ideia dessa estrutura é facilitar o uso de contadores finitos sem fazer uso das duas estruturas anteriores, deixando-as para utilização de loopings em que não se conhece de antemão o número de vezes que uma determinada sequência de instruções deverá ser executada
  • 7. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Para...Faca ΔForma geral: para variavel de val_inicial ate val_final faca // Lista de instruções fim_para Δ Define-se uma variável de controle (do tipo inteiro), a ser variada em cada iteração; • A cada execução do loop, o código já incrementa o valor da variável sozinho! • Essa variável é comumente identificada como contador;
  • 8. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Para...Faca Δ Diagrama de blocos:
  • 9. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Para...Faca Δ Exemplo: • Pedir a leitura de um valor para a variável X, multiplicar esse valor por 3, associando esse valor à variável de resposta R, e apresentar o valor obtido, repetindo esta sequência por cinco vezes (usando a estrutura para...faca): Δ Solução - Algoritmo: 1. Definir um contador, variando de 1 a 5; 2. Ler um valor para a variável X; 3. Efetuar a multiplicação do valor de X por 3, associando o resultado em R; 4. Apresentar o valor calculado, contido na variável R; 5. Repetir os passos 2, 3 , 4 e 5 até que o contador seja encerrado.
  • 10. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Para...Faca Δ Exemplo: • Pedir a leitura de um valor para a variável X, multiplicar esse valor por 3, associando esse valor à variável de resposta R, e apresentar o valor obtido, repetindo esta sequência por cinco vezes (usando a estrutura para...faca): Δ Solução – Diagrama de blocos:
  • 11. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Para...Faca Δ Exemplo: • Pedir a leitura de um valor para a variável X, multiplicar esse valor por 3, associando esse valor à variável de resposta R, e apresentar o valor obtido, repetindo esta sequência por cinco vezes (usando a estrutura para...faca): Δ Solução – Portucê: programa LOOPING_2A var X, R: inteiro CONT: inteiro inicio para CONT de 1 ate 5 faca leia X R<- X * 3 escreva R fim_para fim
  • 12. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Para...Faca Δ Exemplo - Algoritmo que escreve os números de 1 a 5: programa Mostra5 var i: inteiro inicio i<-1 para i de 1 ate 5 faca escreva(i) fim_para fim
  • 13. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Para...Faca Δ Para alterarmos a forma de contagem do laço (crescente ou decrescente) e quanto a variável de controle vai ser incrementada ou decrementada, utilizamos a palavra reservada passo, seguida de um valor; Δ Forma geral: para variavel de val_inicial ate val_final passo valor faca // Lista de instruções fim_para
  • 14. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Para...Faca Δ Exemplo - Algoritmo que escreve os números pares entre 1 e 10 (incluindo o 10): programa Mostra10par var i: inteiro inicio i<-1 para i de 1 ate 100 passo 2 faca escreva(i) fim_para fim
  • 15. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Tipos de Estrutura de Looping Δ Apresentadas três estruturas de controle em nível de repetição: enquanto, repita e para, • Cada qual com sua característica de processamento; Δ Podemos observar que as estruturas mais versáteis são enquanto e repita, pois podem ser substituídas uma pela outra além de poderem substituir perfeitamente a estrutura para; Δ Porem há de considerar-se que nem toda estrutura enquanto ou repita poderá ser substituída por uma estrutura para; • Isto ocorre quando em uma estrutura utilizam-se condições que não envolvam o uso de variáveis de controle como contador.
  • 16. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Exercícios Δ Faça um algoritmo que lê 30 números inteiros. O mesmo deve calcular e exibir a média aritmética deles (use a estrutura para...faca); Δ Utilizando a estrutura para...faca, escreva um algoritmo que mostre todos os números pares entre 0 e 100;
  • 17. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Exercícios Δ Elaborar o algoritmo, diagrama de blocos e codificação em português estruturado de um programa que efetue o cálculo da fatorial de um número inserido pelo usuário. Em seguida, imprima na tela o valor calculado. Caso o usuário insira um número negativo, indique que não é um número aceitável. Se o usuário inserir o número 0, indique que o fatorial é 1. • 5! = 5*4*3*2*1; • 0! = 1; • -2! = Não existe; Δ Ao final do calculo, pergunte ao usuário se ele quer inserir um novo número. Somente se a resposta for “sim”, continue. Caso contrário, exiba uma mensagem e finalize o algoritmo.
  • 18. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Exercícios - Solução Δ Algoritmo: 1. Inicializar as variáveis FATORIAL e CONTADOR com 1 ; 2. Definir as variáveis RESP (resposta) para confirmação e N para receber o limite de valor para o cálculo da fatorial; 3. Enquanto RESP do usuário for sim, executar os passos 3, 4, 5 , 6 e 7; 4. Ler a entrada N do usuário; I. Verificar se o número N é maior ou igual a zero; 5. Repetir a execução dos passos 4 e 5 por N vezes; 6. FATORIAL <- FATORIAL * CONTADOR; 7. Incrementar 1 à variável CONTADOR; 8. Apresentar ao final o valor obtido.
  • 19. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Exercícios - Solução programa FATORIAL_D var CONTADOR: inteiro FATORIAL: inteiro RESP: caractere N: inteiro inicio RESP <-" SIM“ Cont<- 1 enquanto ( RESP = " SIM" ) faça FATORIAL <- 1 escreva (“Número : “) leia (N) se (N>0) entao para CONTADOR de 1 até N passo 1 faca FATORIAL <- FATORIAL * CONTADOR fim_para escreva ("Fatorial de " , N , “é = “, FATORIAL) senao se (N=0) então escreva ("Fatorial de " , N , “é = 1”) senão escreva (“Não existe Fatorial de " , N) fim_se fim_se escreva ("Deseja continuar ? “) leia (RESP) fim_enquanto fim
  • 20. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Exercícios Δ Apresentar o total da soma obtida dos cem primeiros números inteiros (1 +2+3+4+5+6+7+...97+98+99+100); Δ E laborar um programa que apresente no final o somatório dos valores pares existentes na faixa de 1 até 500; Δ Apresentar todos os valores numéricos inteiros ímpares situados na faixa de 0 a 20. Para verificar se o número é ímpar, efetuar dentro da malha a verificação lógica desta condição com a instrução se, perguntando se o número é ímpar; sendo, mostre-o, não sendo, passe para o próximo passo; Δ Escreva um programa que apresente a série de Fibonacci até o décimo quinto termo. A série de Fibonacci é formada pela sequência: 1, 1, 2, 3, 5, 8, 13, 21, 34, .... Esta série se caracteriza pela soma de um termo posterior com o seu anterior subsequente.
  • 21. E S T R U T U R A S D E R E P E T I Ç Ã O ALGORITMOS - 02/2015 – ÊNIO FILHO Exercícios Δ Elaborar um programa que efetue o cálculo e no final apresente o somatório do número de grãos de trigo que se pode obter num tabuleiro de xadrez, obedecendo à seguinte regra: • colocar um grão de trigo no primeiro quadro e nos quadros seguintes o dobro do quadro anterior. oOu seja, no primeiro quadro coloca-se 1 grão; oNo segundo quadro colocam-se 2 grãos (neste momento têm-se 3 grãos) oNo terceiro quadro colocam-se 4 grãos (tendo neste momento 7 grãos); oNo quarto quadro colocam-se 8 grãos (tendo-se então 15 grãos) até atingir o sexagésimo quarto quadro; • Imprima também as seguintes informações, a medida que fizerem os cálculos: oQuadro 1, 1 Grão, Total = 1; oQuadro 2, 2 Grãos, Total = 3; oQuadro 3, 4 Grãos, Total = 7...
  • 22. DÚVIDAS? Contatos: E-mail: enio.filho@alfa.br Skype: eniopvf Twitter: eniopvf Bibliografia: • MANZANO, José Augusto N. G.; OLIVEIRA, Jayr Figueiredo de. Algoritmos: lógica para desenvolvimento de programação de computadores. 18ª. ed. São Paulo: Érica, 2006. 236 p. ISBN 857194718; • FORBELLONE, André Luiz Villar; EBERSPACHER, Henri Frederico. Lógica de programação: a construção de algoritmos e estruturas de dados. 3ª. ed. São Paulo (SP): Pearson Prentice Hall, 2005. 195 p. ISBN 9788576050247;