PROINTER

1.788 visualizações

Publicada em

Prointer

Publicada em: Arte e fotografia
0 comentários
2 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
1.788
No SlideShare
0
A partir de incorporações
0
Número de incorporações
5
Ações
Compartilhamentos
0
Downloads
17
Comentários
0
Gostaram
2
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

PROINTER

  1. 1. 1º Semestre
  2. 2. Criação de um sistema onde as pessoas poderão comprar/agendar festar proporcionados por nós, sabemos a necessidade de que hoje em dia como é complexo fazer uma festa, pois existe a necessidade de fazer a agenda, valores que irão gastar, divulgação, ambiente propício e etc. Visando essa necessidade nossa empresa tem como alvo acabar com essas complicações e nós iremos proporcionar tudo isso, desde o tipo de ambiente que deseja, o tema da festa, o local, a música, bebidas/comidas e até mesmo a divulgação com cartões e envios do convite pelas redes sociais, a fim de trazer todos seus conhecidos para a festa.
  3. 3. Para que “a idéia” funcione é fundamental a criação de uma ferramenta onde os cliente poderão criar cadastro, agendar, e pagar a festa diretamente no site. Visando isso temos como objetivo criar esse sistema. Para que a idéia se inicie é colocado em pratica algoritmos de cadastro, onde será possível observá-lo no próximo slide
  4. 4. algoritmo "Cadastro de Clientes" var linha: vetor [1..2,1..4] de caractere codigo, confirmdel, pulanum: inteiro cont: inteiro nomepesq, nomedel, snomedel: caractere encontrado, inserir: logico procedimento principal() inicio repita escreval ("") escreval ("Menu Principal") escreval ("--------------") escreval ("0 - Sair") escreval ("1 - Inserir Cadastro") escreval ("2 - Excluir Cadastro") escreval ("3 - Consultar Cadastro por Nome") escreval ("4 - Recarregar Programa") escreva ("Digite uma Opcao: ") leia (codigo) limpatela ate (codigo=0) ou (codigo=1) ou (codigo=2) ou (codigo=3) ou (codigo=4) escolha (codigo) caso 0 cont<-0 interrompa caso 1 cadastro() caso 2 excluir() caso 3 consulta_nome() caso 4 principal() fimescolha fimprocedimento //---------------------- CADASTRO ---------------------- procedimento cadastro() inicio limpatela escreval("--------------------- CADASTRO ---------------------") para cont de 1 ate 2 passo 2 faca escreva ("Digite o nome: ") leia (linha[1,1]) escreva ("Digite o sobrenome: ") leia (linha[1,2]) escreva ("Digite o Numero do telefone: ") leia (linha[1,3]) escreva ("Digite a Idade: ") leia (linha[1,4]) fimpara principal () fimprocedimento //------------------------ EXCLUIR------------------------------------ procedimento excluir() inicio limpatela cont<-1 escreval("---------------------- EXCLUIR ----------------------") escreva ("Digite o nome : ") leia (nomedel) para cont de 1 ate 2 faca se (((linha[cont,1]) = (nomedel))) entao escreval ("1 - Excluir ") escreval("2 - Cancelar ") escreval("Digite a Opcao: ") leia (confirmdel) se (confirmdel=1) entao linha[cont,1]<-"" linha[cont,2]<-"" linha[cont,3]<-"" linha[cont,4]<-"" escreva ("Cadastro excluído") encontrado<-verdadeiro senao limpatela escreval ("")
  5. 5. escreval (" ----------------- Exclusão Cancelada --------------------") Principal() fimse //-------------------------- CONSULTA PELO NOME --------------------- procedimento consulta_nome() inicio limpatela cont<-1 escreval("--------------------- CONSULTA ---------------------") escreva ("Digite um nome para Consulta : ") leia (nomepesq) para cont de 1 ate 2 faca se (linha[cont,1]) = (nomepesq) entao escreval ("---------------------- CONSULTA PELO NOME -------------------") escreval ("Nome: ",linha[cont,1]) escreval ("Sobrenome: ",linha[1,2]) escreval ("Telefone: ",linha[1,3]) escreval ("Idade: ",linha[1,4]) encontrado<-verdadeiro fimse fimpara se encontrado=falso entao escreval ("------------ Nome informado não encontrado! -------------") fimse principal() fimprocedimento inicio // Seção de Comandos principal() fimalgoritmo Seguindo para um algoritmo de Agendamento de Festas.
  6. 6. algoritmo "Agendamento para Festas" var linha: vetor [1..10,1..7] de caractere codigo, confirmdel, pulanum: inteiro cont: inteiro nomepesq, nomedel, snomedel: caractere encontrado, inserir: logico procedimento APRESENTACAO () inicio escreval ("") escreval (" |----------------------------------------------|") escreval (" | Olá, seja bem-vindo ao Agendamento de Festa! |") escreval (" |----------------------------------------------|") escreval ("") escreval (" Comandos do agendamento: ") escreval (" ------------------------ ") escreval ("") escreval (" |----------------------------------------------------------|") escreval (" |-> Para inserir um novo agendamento digite '1' |") escreval (" | |") escreval (" |-> Para deletar um agendamento digite '2' |") escreval (" | |") escreval (" |-> Para pesquisar um agendamento pelo nome digite '3' |") escreval (" | |") escreval (" |-> Para pesquisar um agendamento pelo sobrenome digite '4'|") escreval (" | |") escreval (" | -> E para visualizar os comandos digite '5' |") escreval (" |----------------------------------------------------------|") escreval ("") leia (codigo) limpatela escolha (codigo) caso 1 INSERIRAGENDAMENTO() caso 2 //deleta contato DELETARAGENDAMENTO () caso 3 //pesquisa contato por nome PESQUISA_NOME caso 4 //pesquisa contato por sobrenome PESQUISA_SOBRENOME caso 5 //visualiza comandos APRESENTACAO () fimescolha fimprocedimento /////////////////////////////INSERIR_AGENDAMENTO////////////////////////////// ///// procedimento INSERIRAGENDAMENTO() inicio para cont de 1 ate 10 passo 2 faca escreva ("Digite o nome: ") leia (linha[1,1]) escreva ("Digite o sobrenome: ") leia (linha[1,2]) escreva ("Digite o telefone com DDD: ") leia (linha[1,3]) escreva ("Digite a rua: ") leia (linha[1,4]) escreva ("Digite o número: ") leia (linha[1,5]) escreva ("Digite o bairro: ") leia (linha[1,6]) escreva ("Digite a cidade :") leia (linha[1,7]) fimpara APRESENTACAO () fimenquanto fimprocedimento ////////////////////////////////DELETAR_AGENDAMENTO///////////////////////// /////// procedimento DELETARAGENDAMENTO () inicio cont<-1
  7. 7. //pesquisa AGENDAMENTO, para após deletar escreva ("Digite o nome do AGENDAMENTO que deseja deletar: ") leia (nomedel) escreva ("Digite o sobrenome do AGENDAMENTO que deseja deletar: ") leia (snomedel) para cont de 1 ate 10 faca se (((linha[cont,1]) = (nomedel)) e ((linha[cont,2]) = (snomedel))) então escreva ("Digite '1' para confirmar a exclusão e 2 para cancelar: ") leia (confirmdel) se (confirmdel=1) então linha[cont,1]<-"" linha[cont,2]<-"" linha[cont,3]<-"" linha[cont,4]<-"" linha[cont,5]<-"" linha[cont,6]<-"" linha[cont,7]<-"" escreva ("Contato excluído") encontrado<-verdadeiro senao limpatela escreval ("") escreval (" >>>>>>>>>>>>>>>> Exclusão cancelada <<<<<<<<<<<<<<<<<") APRESENTACAO () fimse fimse fimpara se encontrado=falso então escreval ("O nome informado não consta na agenda") fimse APRESENTACAO () fimprocedimento //////////////////////////PESQUISA_NOME////////////////////////////////////// procedimento PESQUISA_NOME () inicio cont<-1 escreva ("Digite o nome do AGENDAMENTO que deseja pesquisar: ") leia (nomepesq) para cont de 1 ate 10 faca se (linha[cont,1]) = (nomepesq) então escreval ("|-------------------------------|") escreval ("| Informações do AGENDAMENTO: ") escreval ("| Nome: ",linha[cont,1]) escreval ("| Sobrenome: ",linha[1,2]) escreval ("| Telefone: ",linha[1,3]) escreval ("| Rua: ",linha[1,4]) escreval ("| Número: ",linha[1,5]) escreval ("| Bairro: ",[1,6]") escreval ("| Cidade: ",linha[1,7]) escreval ("|-------------------------------|") encontrado<-verdadeiro fimse fimpara se encontrado=falso então escreval ("O nome informado não consta na AGENDAMENTO") fimse APRESENTACAO () fimprocedimento
  8. 8. //////////////////////////PESQUISA_SOBRENOME///////////////////////////////// procedimento PESQUISA_SOBRENOME () inicio escreva ("Digite o sobrenome do AGENDAMENTO que deseja pesquisar: ") leia (nomepesq) para cont de 1 ate 10 faca se (linha[1,1]) = (nomepesq) então escreval ("|-------------------------------|") escreval ("| Informações do AGENDAMENTO: ") escreval ("| Nome: ",linha[cont,1]) escreval ("| Sobrenome: ",linha[1,2]) escreval ("| Telefone: ",linha[1,3]) escreval ("| Rua: ",linha[1,4]) escreval ("| Número: ",linha[1,5]) escreval ("| Bairro: ",[1,6]") escreval ("| Cidade: ",linha[1,7]) escreval ("|-------------------------------|") encontrado<-verdadeiro fimse fimpara se encontrado=falso então escreval ("O nome informado não consta na agenda") fimse APRESENTACAO () fimprocedimento ////////////////////////////////////////////////////////////////////////////// inicio // Seção de Comandos cont<-1 APRESENTACAO () fimalgoritmo

×