Algoritmos Resolvidos – Lista 1
1
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.b...
Algoritmos Resolvidos – Lista 1
2
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.b...
Algoritmos Resolvidos – Lista 1
3
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.b...
Algoritmos Resolvidos – Lista 1
4
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.b...
Algoritmos Resolvidos – Lista 1
5
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.b...
Algoritmos Resolvidos – Lista 1
6
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.b...
Algoritmos Resolvidos – Lista 1
7
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmos Resolvidos – Lista 1
8
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.b...
Algoritmos Resolvidos – Lista 1
9
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.b...
Algoritmos Resolvidos – Lista 1
10
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com....
Algoritmos Resolvidos – Lista 1
11
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com....
Algoritmos Resolvidos – Lista 1
12
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com....
Algoritmos Resolvidos – Lista 1
13
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com....
Algoritmos Resolvidos – Lista 1
14
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com....
Algoritmos Resolvidos – Lista 1
15
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com....
Próximos SlideShares
Carregando em…5
×

Hggyjg

170 visualizações

Publicada em

0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
170
No SlideShare
0
A partir de incorporações
0
Número de incorporações
3
Ações
Compartilhamentos
0
Downloads
1
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Hggyjg

  1. 1. Algoritmos Resolvidos – Lista 1 1 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex1" Faça um algoritmo que receba dois números e exiba o resultado da sua soma. // Seção de Declarações var x, y: inteiro inicio // Seção de Comandos escreval("Digite o primeiro número: ") leia(x) escreval("Digite o segundo número: ") leia(y) escreva("A soma dos números é: ",x+y) fimalgoritmo
  2. 2. Algoritmos Resolvidos – Lista 1 2 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex2" Faça um algoritmo que receba dois números e ao final mostre a soma, subtração, multiplicação e a divisão dos números lidos. // Seção de Declarações var x, y: real inicio // Seção de Comandos escreva("Digite o primeiro número: ") leia(x) escreva("Digite o segundo número: ") leia(y) escreval("A soma é: ",x+y) escreval("A subtração é: ",x-y) escreval("A multiplicação é: ",x*y) escreval("A divisão é: ",x/y) fimalgoritmo
  3. 3. Algoritmos Resolvidos – Lista 1 3 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex3" Escrever um algoritmo para determinar o consumo médio de um automóvel sendo fornecida a distância total percorrida pelo automóvel e o total de combustível gasto. // Seção de Declarações var distancia, combustivel: real inicio // Seção de Comandos escreval("========== Cálculo de consumo médio de combustível =========") escreva("Digite a distância pecorrida: ") leia(distancia) escreva("Digite o combustível gasto: ") leia(combustivel) escreval("O consumo médio de combustível do seu veículo é: ",distancia/combustivel) fimalgoritmo
  4. 4. Algoritmos Resolvidos – Lista 1 4 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex4" Escrever um algoritmo que leia o nome de um vendedor, o seu salário fixo e o total de vendas efetuadas por ele no mês (em dinheiro). Sabendo que este vendedor ganha 15% de comissão sobre suas vendas efetuadas, informar o seu nome, o salário fixo e salário no final do mês. // Seção de Declarações var nome: caractere salario: real vendas: real comissao: real salarioFinal: real inicio // Seção de Comandos escreval("<><><><><> Sistema de gestão de vendedores <><><><><>") escreva(">>> Digite o nome do vendedor: ") leia(nome) escreva(">>> Digite o salário: ") leia(salario) escreva(">>> Informe a quantidade de vendas deste no mês: ") leia(vendas) // Cálculo da comissão e salário final comissao <- 0.15 * vendas salarioFinal <- salario + comissao limpatela escreval(">>>>>>>>>> RESUMO <<<<<<<<<<")
  5. 5. Algoritmos Resolvidos – Lista 1 5 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br escreval("-- Nome: ",nome) escreval("-- Salário: ",salario) escreval("-- Salário Final (salário + comissão): ",salarioFinal) escreval(">>>>>>>>>><><><><><<<<<<<<<<") fimalgoritmo
  6. 6. Algoritmos Resolvidos – Lista 1 6 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex5" Escrever um algoritmo que leia o nome de um aluno e as notas das três provas que ele obteve no semestre. No final informar o nome do aluno e a sua média (aritmética). // Seção de Declarações var aluno: caractere notas: vetor[1..3] de real x: inteiro media: real inicio // Seção de Comandos escreval("============== Média de alunos ==============") escreva("Digite o nome do aluno: ") leia(aluno) para x de 1 ate 3 faca escreva("Digite a ",x,"º nota ") leia(notas[x]) fimpara media <- (notas[1] + notas[2] + notas[3]) / 3 limpatela escreval("==============", aluno," ==============") escreval(">>> Média: ",media) escreval("=======================================") fimalgoritmo
  7. 7. Algoritmos Resolvidos – Lista 1 7 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br
  8. 8. Algoritmos Resolvidos – Lista 1 8 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex6" Ler dois valores para as variáveis A e B, e efetuar as trocas dos valores de forma que a variável A passe a possuir o valor da variável B e a variável B passe a possuir o valor da variável A. Apresentar os valores trocados. // Seção de Declarações var a, b, troca: inteiro inicio // Seção de Comandos escreva("Digite o valor(numérico) da variável A: ") leia(a) escreva("Digite o valor(numérico) da variável B: ") leia(b) troca <- a a <- b b <- troca limpatela escreval("===========================") escreval("O novo valor de A é: ",a) escreval("O novo valor de B é: ",b) escreval("===========================") fimalgoritmo
  9. 9. Algoritmos Resolvidos – Lista 1 9 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex7" Ler uma temperatura em graus Celsius e apresentá-la convertida em graus Fahrenheit. A fórmula de conversão é: F= (9*C+160) / 5, sendo F a temperatura em Fahrenheit e C a temperatura em Celsius. // Seção de Declarações var cel, far: real inicio // Seção de Comandos escreval("=-=-=-=-=- Tabela de conversão: Celcius -> Fahrenheit -=-=-=-=-=") escreva("Digite a temperatura em Celcius: ") leia(cel) far <- (9*cel+160)/5 escreval("A nova temperatura é: ",far,"ºF") fimalgoritmo
  10. 10. Algoritmos Resolvidos – Lista 1 10 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex8" Elaborar um algoritmo que efetue a apresentação do valor da conversão em real (R$) de um valor lido em dólar (US$). O algoritmo deverá solicitar o valor da cotação do dólar e também a quantidade de dólares disponíveis com o usuário. // Seção de Declarações var rs, us, cotacao, dolaDisponivel: real inicio // Seção de Comandos escreval("========= Cotação do Dólar ==========") escreva("Qual a cotação atual do dólar? ") leia(cotacao) escreva("Quantos dólares você possui? ") leia(us) rs <- us/cotacao limpatela escreval(us," Dólares equivalem á: ",rs," R$") fimalgoritmo
  11. 11. Algoritmos Resolvidos – Lista 1 11 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex9" Faça um algoritmo que receba um valor que foi depositado e exiba o valor com rendimento após um mês. Considere fixo o juro da poupança em 0,70% a. m. // Seção de Declarações var correcao, deposito: real inicio // Seção de Comandos escreval("Sistema de depósito do Banco do Oeste") escreva("Digite o valor depositado: ") leia(deposito) correcao <- 0.7 * deposito escreva("O rendimento do depósito após um mês é de: ",deposito+correcao) fimalgoritmo
  12. 12. Algoritmos Resolvidos – Lista 1 12 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex10" A Loja Mamão com Açúcar está vendendo seus produtos em 5 (cinco) prestações sem juros. Faça um algoritmo que receba um valor de uma compra e mostre o valor das prestações. // Seção de Declarações var compra, prestacao: real inicio // Seção de Comandos escreval("========== Loja Mamão com Açúcar ==========") escreva("Digite o valor da compra: ") leia(compra) prestacao <- compra/5 escreval("O cliente deverá pagar 5 prestações de R$",prestacao," cada") fimalgoritmo
  13. 13. Algoritmos Resolvidos – Lista 1 13 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex11" Faça um algoritmo que receba o preço de custo de um produto e mostre o valor de venda. Sabe-se que o preço de custo receberá um acréscimo de acordo com um percentual informado pelo usuário. // Seção de Declarações var custo, venda, percent: real inicio // Seção de Comandos escreva("Digite o custo do produto: ") leia(custo) escreva("Digite o percentual para venda: ") leia(percent) percent <- (percent/100) * custo venda <- custo + percent escreval("O valor de venda é: ",venda) fimalgoritmo
  14. 14. Algoritmos Resolvidos – Lista 1 14 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex12" O custo ao consumidor de um carro novo é a soma do custo de fábrica com a percentagem do distribuidor e dos impostos (aplicados, primeiro os impostos sobre o custo de fábrica, e depois a percentagem do distribuidor sobre o resultado). Supondo que a percentagem do distribuidor seja de 28% e os impostos 45%. Escrever um algoritmo que leia o custo de fábrica de um carro e informe o custo ao consumidor do mesmo. // Seção de Declarações var custoFabrica, custoFinal: real inicio // Seção de Comandos escreva("Informe o custo de fábrica do veículo: ") leia(custoFabrica) custoFinal <- (custoDeFabrica * 1.45) * 1.28 escreval("O custo para o consumidor final é de: ",custoFinal) fimalgoritmo
  15. 15. Algoritmos Resolvidos – Lista 1 15 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex13" Faça um algoritmo que receba um número e mostre uma mensagem caso este número seja maior que 10. // Seção de Declarações var numero: inteiro inicio // Seção de Comandos escreva("Digite um número: ") leia(numero) se numero > 10 entao escreval("O número é maior que 10") fimse fimalgoritmo

×