SlideShare uma empresa Scribd logo
1 de 15
Baixar para ler offline
Algoritmos Resolvidos – Lista 1
1
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex1"
Faça um algoritmo que receba dois números e exiba o resultado da sua
soma.
// Seção de Declarações
var
x, y: inteiro
inicio
// Seção de Comandos
escreval("Digite o primeiro número: ")
leia(x)
escreval("Digite o segundo número: ")
leia(y)
escreva("A soma dos números é: ",x+y)
fimalgoritmo
Algoritmos Resolvidos – Lista 1
2
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex2"
Faça um algoritmo que receba dois números e ao final mostre a soma,
subtração, multiplicação e a divisão dos números lidos.
// Seção de Declarações
var
x, y: real
inicio
// Seção de Comandos
escreva("Digite o primeiro número: ")
leia(x)
escreva("Digite o segundo número: ")
leia(y)
escreval("A soma é: ",x+y)
escreval("A subtração é: ",x-y)
escreval("A multiplicação é: ",x*y)
escreval("A divisão é: ",x/y)
fimalgoritmo
Algoritmos Resolvidos – Lista 1
3
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex3"
Escrever um algoritmo para determinar o consumo médio de um
automóvel sendo fornecida a distância total percorrida pelo automóvel
e o total de combustível gasto.
// Seção de Declarações
var
distancia, combustivel: real
inicio
// Seção de Comandos
escreval("========== Cálculo de consumo médio de combustível =========")
escreva("Digite a distância pecorrida: ")
leia(distancia)
escreva("Digite o combustível gasto: ")
leia(combustivel)
escreval("O consumo médio de combustível do seu veículo é: ",distancia/combustivel)
fimalgoritmo
Algoritmos Resolvidos – Lista 1
4
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex4"
Escrever um algoritmo que leia o nome de um vendedor, o seu salário
fixo e o total de vendas efetuadas por ele no mês (em dinheiro).
Sabendo que este vendedor ganha 15% de comissão sobre suas vendas
efetuadas, informar o seu nome, o salário fixo e salário no final do mês.
// Seção de Declarações
var
nome: caractere
salario: real
vendas: real
comissao: real
salarioFinal: real
inicio
// Seção de Comandos
escreval("<><><><><> Sistema de gestão de vendedores <><><><><>")
escreva(">>> Digite o nome do vendedor: ")
leia(nome)
escreva(">>> Digite o salário: ")
leia(salario)
escreva(">>> Informe a quantidade de vendas deste no mês: ")
leia(vendas)
// Cálculo da comissão e salário final
comissao <- 0.15 * vendas
salarioFinal <- salario + comissao
limpatela
escreval(">>>>>>>>>> RESUMO <<<<<<<<<<")
Algoritmos Resolvidos – Lista 1
5
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
escreval("-- Nome: ",nome)
escreval("-- Salário: ",salario)
escreval("-- Salário Final (salário + comissão): ",salarioFinal)
escreval(">>>>>>>>>><><><><><<<<<<<<<<")
fimalgoritmo
Algoritmos Resolvidos – Lista 1
6
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex5"
Escrever um algoritmo que leia o nome de um aluno e as notas das três
provas que ele obteve no semestre. No final informar o nome do aluno
e a sua média (aritmética).
// Seção de Declarações
var
aluno: caractere
notas: vetor[1..3] de real
x: inteiro
media: real
inicio
// Seção de Comandos
escreval("============== Média de alunos ==============")
escreva("Digite o nome do aluno: ")
leia(aluno)
para x de 1 ate 3 faca
escreva("Digite a ",x,"º nota ")
leia(notas[x])
fimpara
media <- (notas[1] + notas[2] + notas[3]) / 3
limpatela
escreval("==============", aluno," ==============")
escreval(">>> Média: ",media)
escreval("=======================================")
fimalgoritmo
Algoritmos Resolvidos – Lista 1
7
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmos Resolvidos – Lista 1
8
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex6"
Ler dois valores para as variáveis A e B, e efetuar as trocas dos valores
de forma que a variável A passe a possuir o valor da variável B e a
variável B passe a possuir o valor da variável A. Apresentar os valores
trocados.
// Seção de Declarações
var
a, b, troca: inteiro
inicio
// Seção de Comandos
escreva("Digite o valor(numérico) da variável A: ")
leia(a)
escreva("Digite o valor(numérico) da variável B: ")
leia(b)
troca <- a
a <- b
b <- troca
limpatela
escreval("===========================")
escreval("O novo valor de A é: ",a)
escreval("O novo valor de B é: ",b)
escreval("===========================")
fimalgoritmo
Algoritmos Resolvidos – Lista 1
9
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex7"
Ler uma temperatura em graus Celsius e apresentá-la convertida em
graus Fahrenheit. A fórmula de conversão é: F= (9*C+160) / 5, sendo F
a temperatura em Fahrenheit e C a temperatura em Celsius.
// Seção de Declarações
var
cel, far: real
inicio
// Seção de Comandos
escreval("=-=-=-=-=- Tabela de conversão: Celcius -> Fahrenheit -=-=-=-=-=")
escreva("Digite a temperatura em Celcius: ")
leia(cel)
far <- (9*cel+160)/5
escreval("A nova temperatura é: ",far,"ºF")
fimalgoritmo
Algoritmos Resolvidos – Lista 1
10
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex8"
Elaborar um algoritmo que efetue a apresentação do valor da
conversão em real (R$) de um valor lido em dólar (US$). O algoritmo
deverá solicitar o valor da cotação do dólar e também a quantidade de
dólares disponíveis com o usuário.
// Seção de Declarações
var
rs, us, cotacao, dolaDisponivel: real
inicio
// Seção de Comandos
escreval("========= Cotação do Dólar ==========")
escreva("Qual a cotação atual do dólar? ")
leia(cotacao)
escreva("Quantos dólares você possui? ")
leia(us)
rs <- us/cotacao
limpatela
escreval(us," Dólares equivalem á: ",rs," R$")
fimalgoritmo
Algoritmos Resolvidos – Lista 1
11
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex9"
Faça um algoritmo que receba um valor que foi depositado e exiba o
valor com rendimento após um mês. Considere fixo o juro da
poupança em 0,70% a. m.
// Seção de Declarações
var
correcao, deposito: real
inicio
// Seção de Comandos
escreval("Sistema de depósito do Banco do Oeste")
escreva("Digite o valor depositado: ")
leia(deposito)
correcao <- 0.7 * deposito
escreva("O rendimento do depósito após um mês é de: ",deposito+correcao)
fimalgoritmo
Algoritmos Resolvidos – Lista 1
12
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex10"
A Loja Mamão com Açúcar está vendendo seus produtos em 5 (cinco)
prestações sem juros. Faça um algoritmo que receba um valor de uma
compra e mostre o valor das prestações.
// Seção de Declarações
var
compra, prestacao: real
inicio
// Seção de Comandos
escreval("========== Loja Mamão com Açúcar ==========")
escreva("Digite o valor da compra: ")
leia(compra)
prestacao <- compra/5
escreval("O cliente deverá pagar 5 prestações de R$",prestacao," cada")
fimalgoritmo
Algoritmos Resolvidos – Lista 1
13
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex11"
Faça um algoritmo que receba o preço de custo de um produto e
mostre o valor de venda. Sabe-se que o preço de custo receberá um
acréscimo de acordo com um percentual informado pelo usuário.
// Seção de Declarações
var
custo, venda, percent: real
inicio
// Seção de Comandos
escreva("Digite o custo do produto: ")
leia(custo)
escreva("Digite o percentual para venda: ")
leia(percent)
percent <- (percent/100) * custo
venda <- custo + percent
escreval("O valor de venda é: ",venda)
fimalgoritmo
Algoritmos Resolvidos – Lista 1
14
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex12"
O custo ao consumidor de um carro novo é a soma do custo de fábrica
com a percentagem do distribuidor e dos impostos (aplicados,
primeiro os impostos sobre o custo de fábrica, e depois a percentagem
do distribuidor sobre o resultado). Supondo que a percentagem do
distribuidor seja de 28% e os impostos 45%. Escrever um algoritmo
que leia o custo de fábrica de um carro e informe o custo ao
consumidor do mesmo.
// Seção de Declarações
var
custoFabrica, custoFinal: real
inicio
// Seção de Comandos
escreva("Informe o custo de fábrica do veículo: ")
leia(custoFabrica)
custoFinal <- (custoDeFabrica * 1.45) * 1.28
escreval("O custo para o consumidor final é de: ",custoFinal)
fimalgoritmo
Algoritmos Resolvidos – Lista 1
15
Carlão – Carlos Eduardo Martins
contato@desenvolvefacil.com.br
www.desenvolvefacil.com.br
Algoritmo “Ex13"
Faça um algoritmo que receba um número e mostre uma mensagem
caso este número seja maior que 10.
// Seção de Declarações
var
numero: inteiro
inicio
// Seção de Comandos
escreva("Digite um número: ")
leia(numero)
se numero > 10 entao
escreval("O número é maior que 10")
fimse
fimalgoritmo

Mais conteúdo relacionado

Mais procurados

50978145 algoritmos-exercicios-resolvidos
50978145 algoritmos-exercicios-resolvidos50978145 algoritmos-exercicios-resolvidos
50978145 algoritmos-exercicios-resolvidos
Edvan Mateó
 

Mais procurados (20)

Exercicios java básico
Exercicios java básicoExercicios java básico
Exercicios java básico
 
Exercicios resolvidos visu alg vetores
Exercicios resolvidos visu alg vetoresExercicios resolvidos visu alg vetores
Exercicios resolvidos visu alg vetores
 
50978145 algoritmos-exercicios-resolvidos
50978145 algoritmos-exercicios-resolvidos50978145 algoritmos-exercicios-resolvidos
50978145 algoritmos-exercicios-resolvidos
 
1ª lista de_algoritmos
1ª lista de_algoritmos1ª lista de_algoritmos
1ª lista de_algoritmos
 
[Curso Java Basico] Exercicios Aulas 16 17
[Curso Java Basico] Exercicios Aulas 16 17[Curso Java Basico] Exercicios Aulas 16 17
[Curso Java Basico] Exercicios Aulas 16 17
 
Exercicios Pilhas (Stacks) - Estruturas de dados e algoritmos com Java
Exercicios Pilhas (Stacks) - Estruturas de dados e algoritmos com JavaExercicios Pilhas (Stacks) - Estruturas de dados e algoritmos com Java
Exercicios Pilhas (Stacks) - Estruturas de dados e algoritmos com Java
 
[Curso Java Basico] Exercicios Aula 20
[Curso Java Basico] Exercicios Aula 20[Curso Java Basico] Exercicios Aula 20
[Curso Java Basico] Exercicios Aula 20
 
Algoritmos 01 - Semana 07 - Exercícios Múltipla Escolha
Algoritmos 01 - Semana 07 - Exercícios Múltipla EscolhaAlgoritmos 01 - Semana 07 - Exercícios Múltipla Escolha
Algoritmos 01 - Semana 07 - Exercícios Múltipla Escolha
 
Pseudocódigo - Estrutura de Repetição (Lógica de Programação)
Pseudocódigo - Estrutura de Repetição (Lógica de Programação)Pseudocódigo - Estrutura de Repetição (Lógica de Programação)
Pseudocódigo - Estrutura de Repetição (Lógica de Programação)
 
Aula 02 - Escolha caso
Aula 02 - Escolha casoAula 02 - Escolha caso
Aula 02 - Escolha caso
 
[Curso Java Basico] Exercicios Aula 19
[Curso Java Basico] Exercicios Aula 19[Curso Java Basico] Exercicios Aula 19
[Curso Java Basico] Exercicios Aula 19
 
Manual de portugol
Manual de portugolManual de portugol
Manual de portugol
 
Introdução à programação
Introdução à programação Introdução à programação
Introdução à programação
 
[Curso Java Basico] Exercicios Aulas 25 a 27
[Curso Java Basico] Exercicios Aulas 25 a 27[Curso Java Basico] Exercicios Aulas 25 a 27
[Curso Java Basico] Exercicios Aulas 25 a 27
 
Algoritmo recursivo
Algoritmo recursivoAlgoritmo recursivo
Algoritmo recursivo
 
Lógica de Programação - Estrutura de repetição
Lógica de Programação - Estrutura de repetiçãoLógica de Programação - Estrutura de repetição
Lógica de Programação - Estrutura de repetição
 
Algoritmos - Matrizes
Algoritmos - MatrizesAlgoritmos - Matrizes
Algoritmos - Matrizes
 
Aula Lógica de Programação - cap1
Aula Lógica de Programação - cap1 Aula Lógica de Programação - cap1
Aula Lógica de Programação - cap1
 
Exercicios Filas (Queues) - Estruturas de dados e algoritmos com Java
Exercicios Filas (Queues) - Estruturas de dados e algoritmos com JavaExercicios Filas (Queues) - Estruturas de dados e algoritmos com Java
Exercicios Filas (Queues) - Estruturas de dados e algoritmos com Java
 
[Curso Java Basico] Exercicios Aulas 14 15
[Curso Java Basico] Exercicios Aulas 14 15[Curso Java Basico] Exercicios Aulas 14 15
[Curso Java Basico] Exercicios Aulas 14 15
 

Destaque

Simbolos logicos com tabelas verdad
Simbolos logicos com tabelas verdadSimbolos logicos com tabelas verdad
Simbolos logicos com tabelas verdad
Reginaldo Steinhardt
 
Algoritmos Lista 1 de exercícios gabarito
Algoritmos Lista 1 de exercícios gabaritoAlgoritmos Lista 1 de exercícios gabarito
Algoritmos Lista 1 de exercícios gabarito
Ricardo Sonaglio Albano
 
Convenções de código para a linguagem de programação
Convenções de código para a linguagem de programaçãoConvenções de código para a linguagem de programação
Convenções de código para a linguagem de programação
alyssontmv
 
Apresentação linguagem cobol
Apresentação linguagem cobolApresentação linguagem cobol
Apresentação linguagem cobol
AlexByDoomS
 
Documentação CakePHP - Português Br
Documentação CakePHP -  Português BrDocumentação CakePHP -  Português Br
Documentação CakePHP - Português Br
Luiz Ladeira
 
Aula 8 - Lógica de Programação - Variáveis, Tipos de dados e Operadores
Aula 8 - Lógica de Programação - Variáveis, Tipos de dados e OperadoresAula 8 - Lógica de Programação - Variáveis, Tipos de dados e Operadores
Aula 8 - Lógica de Programação - Variáveis, Tipos de dados e Operadores
André Constantino da Silva
 
Lista de exercícios resolvidos
Lista de exercícios resolvidosLista de exercícios resolvidos
Lista de exercícios resolvidos
Crishna Irion
 

Destaque (12)

Algoritmos 1 - Lista de Exercícios 2
Algoritmos 1 - Lista de Exercícios 2Algoritmos 1 - Lista de Exercícios 2
Algoritmos 1 - Lista de Exercícios 2
 
Simbolos logicos com tabelas verdad
Simbolos logicos com tabelas verdadSimbolos logicos com tabelas verdad
Simbolos logicos com tabelas verdad
 
Algoritmos e Programação: Estruturas de repetição
Algoritmos e Programação: Estruturas de repetiçãoAlgoritmos e Programação: Estruturas de repetição
Algoritmos e Programação: Estruturas de repetição
 
Exercícios resolvidos de Algoritmo
Exercícios resolvidos de AlgoritmoExercícios resolvidos de Algoritmo
Exercícios resolvidos de Algoritmo
 
Algoritmos Lista 1 de exercícios gabarito
Algoritmos Lista 1 de exercícios gabaritoAlgoritmos Lista 1 de exercícios gabarito
Algoritmos Lista 1 de exercícios gabarito
 
Aula 2 - Processos de Software
Aula 2 - Processos de SoftwareAula 2 - Processos de Software
Aula 2 - Processos de Software
 
ideias de programação
ideias de programaçãoideias de programação
ideias de programação
 
Convenções de código para a linguagem de programação
Convenções de código para a linguagem de programaçãoConvenções de código para a linguagem de programação
Convenções de código para a linguagem de programação
 
Apresentação linguagem cobol
Apresentação linguagem cobolApresentação linguagem cobol
Apresentação linguagem cobol
 
Documentação CakePHP - Português Br
Documentação CakePHP -  Português BrDocumentação CakePHP -  Português Br
Documentação CakePHP - Português Br
 
Aula 8 - Lógica de Programação - Variáveis, Tipos de dados e Operadores
Aula 8 - Lógica de Programação - Variáveis, Tipos de dados e OperadoresAula 8 - Lógica de Programação - Variáveis, Tipos de dados e Operadores
Aula 8 - Lógica de Programação - Variáveis, Tipos de dados e Operadores
 
Lista de exercícios resolvidos
Lista de exercícios resolvidosLista de exercícios resolvidos
Lista de exercícios resolvidos
 

Semelhante a Algoritmos resolvidos lista 2

Curso De Algoritmo Aula 9
Curso De Algoritmo   Aula 9Curso De Algoritmo   Aula 9
Curso De Algoritmo Aula 9
Felipe Santos
 
Alg aula 03 - construcao algoritmos2 tp1
Alg   aula 03 - construcao algoritmos2 tp1Alg   aula 03 - construcao algoritmos2 tp1
Alg aula 03 - construcao algoritmos2 tp1
Thalles Anderson
 

Semelhante a Algoritmos resolvidos lista 2 (20)

Guia prático para criar algoritmos
Guia prático para criar algoritmosGuia prático para criar algoritmos
Guia prático para criar algoritmos
 
Caderno de exercícios cobol
Caderno de exercícios   cobolCaderno de exercícios   cobol
Caderno de exercícios cobol
 
Algoritmo Lista de exercícios 1 respostas
Algoritmo Lista de exercícios 1   respostasAlgoritmo Lista de exercícios 1   respostas
Algoritmo Lista de exercícios 1 respostas
 
Aula02_Vars_Ident_Ent_Saida_Algoritmos.pptx
Aula02_Vars_Ident_Ent_Saida_Algoritmos.pptxAula02_Vars_Ident_Ent_Saida_Algoritmos.pptx
Aula02_Vars_Ident_Ent_Saida_Algoritmos.pptx
 
Aula 3 - 06/04/11
Aula 3 - 06/04/11Aula 3 - 06/04/11
Aula 3 - 06/04/11
 
Aula 3 algoritmos
Aula 3   algoritmosAula 3   algoritmos
Aula 3 algoritmos
 
Curso De Algoritmo Aula 9
Curso De Algoritmo   Aula 9Curso De Algoritmo   Aula 9
Curso De Algoritmo Aula 9
 
Logica
LogicaLogica
Logica
 
Alg aula 03 - construcao algoritmos2 tp1
Alg   aula 03 - construcao algoritmos2 tp1Alg   aula 03 - construcao algoritmos2 tp1
Alg aula 03 - construcao algoritmos2 tp1
 
60590123 portugol
60590123 portugol60590123 portugol
60590123 portugol
 
TDD em C++
TDD em C++TDD em C++
TDD em C++
 
DOJO - TDD com C++
DOJO - TDD com C++DOJO - TDD com C++
DOJO - TDD com C++
 
Algoritmos - Aula 13 A - Lacos em C
Algoritmos - Aula 13 A - Lacos em CAlgoritmos - Aula 13 A - Lacos em C
Algoritmos - Aula 13 A - Lacos em C
 
02 fp02
02 fp0202 fp02
02 fp02
 
Visualg
VisualgVisualg
Visualg
 
Aula2
Aula2Aula2
Aula2
 
Algop - aula 04 pascal 1
Algop - aula 04 pascal 1Algop - aula 04 pascal 1
Algop - aula 04 pascal 1
 
Tutorial matlab
Tutorial matlabTutorial matlab
Tutorial matlab
 
Algoritmos-SlidesA1_2016_03_01.ppt
Algoritmos-SlidesA1_2016_03_01.pptAlgoritmos-SlidesA1_2016_03_01.ppt
Algoritmos-SlidesA1_2016_03_01.ppt
 
Aula 3-lógica.pptx
Aula 3-lógica.pptxAula 3-lógica.pptx
Aula 3-lógica.pptx
 

Algoritmos resolvidos lista 2

  • 1. Algoritmos Resolvidos – Lista 1 1 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex1" Faça um algoritmo que receba dois números e exiba o resultado da sua soma. // Seção de Declarações var x, y: inteiro inicio // Seção de Comandos escreval("Digite o primeiro número: ") leia(x) escreval("Digite o segundo número: ") leia(y) escreva("A soma dos números é: ",x+y) fimalgoritmo
  • 2. Algoritmos Resolvidos – Lista 1 2 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex2" Faça um algoritmo que receba dois números e ao final mostre a soma, subtração, multiplicação e a divisão dos números lidos. // Seção de Declarações var x, y: real inicio // Seção de Comandos escreva("Digite o primeiro número: ") leia(x) escreva("Digite o segundo número: ") leia(y) escreval("A soma é: ",x+y) escreval("A subtração é: ",x-y) escreval("A multiplicação é: ",x*y) escreval("A divisão é: ",x/y) fimalgoritmo
  • 3. Algoritmos Resolvidos – Lista 1 3 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex3" Escrever um algoritmo para determinar o consumo médio de um automóvel sendo fornecida a distância total percorrida pelo automóvel e o total de combustível gasto. // Seção de Declarações var distancia, combustivel: real inicio // Seção de Comandos escreval("========== Cálculo de consumo médio de combustível =========") escreva("Digite a distância pecorrida: ") leia(distancia) escreva("Digite o combustível gasto: ") leia(combustivel) escreval("O consumo médio de combustível do seu veículo é: ",distancia/combustivel) fimalgoritmo
  • 4. Algoritmos Resolvidos – Lista 1 4 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex4" Escrever um algoritmo que leia o nome de um vendedor, o seu salário fixo e o total de vendas efetuadas por ele no mês (em dinheiro). Sabendo que este vendedor ganha 15% de comissão sobre suas vendas efetuadas, informar o seu nome, o salário fixo e salário no final do mês. // Seção de Declarações var nome: caractere salario: real vendas: real comissao: real salarioFinal: real inicio // Seção de Comandos escreval("<><><><><> Sistema de gestão de vendedores <><><><><>") escreva(">>> Digite o nome do vendedor: ") leia(nome) escreva(">>> Digite o salário: ") leia(salario) escreva(">>> Informe a quantidade de vendas deste no mês: ") leia(vendas) // Cálculo da comissão e salário final comissao <- 0.15 * vendas salarioFinal <- salario + comissao limpatela escreval(">>>>>>>>>> RESUMO <<<<<<<<<<")
  • 5. Algoritmos Resolvidos – Lista 1 5 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br escreval("-- Nome: ",nome) escreval("-- Salário: ",salario) escreval("-- Salário Final (salário + comissão): ",salarioFinal) escreval(">>>>>>>>>><><><><><<<<<<<<<<") fimalgoritmo
  • 6. Algoritmos Resolvidos – Lista 1 6 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex5" Escrever um algoritmo que leia o nome de um aluno e as notas das três provas que ele obteve no semestre. No final informar o nome do aluno e a sua média (aritmética). // Seção de Declarações var aluno: caractere notas: vetor[1..3] de real x: inteiro media: real inicio // Seção de Comandos escreval("============== Média de alunos ==============") escreva("Digite o nome do aluno: ") leia(aluno) para x de 1 ate 3 faca escreva("Digite a ",x,"º nota ") leia(notas[x]) fimpara media <- (notas[1] + notas[2] + notas[3]) / 3 limpatela escreval("==============", aluno," ==============") escreval(">>> Média: ",media) escreval("=======================================") fimalgoritmo
  • 7. Algoritmos Resolvidos – Lista 1 7 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br
  • 8. Algoritmos Resolvidos – Lista 1 8 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex6" Ler dois valores para as variáveis A e B, e efetuar as trocas dos valores de forma que a variável A passe a possuir o valor da variável B e a variável B passe a possuir o valor da variável A. Apresentar os valores trocados. // Seção de Declarações var a, b, troca: inteiro inicio // Seção de Comandos escreva("Digite o valor(numérico) da variável A: ") leia(a) escreva("Digite o valor(numérico) da variável B: ") leia(b) troca <- a a <- b b <- troca limpatela escreval("===========================") escreval("O novo valor de A é: ",a) escreval("O novo valor de B é: ",b) escreval("===========================") fimalgoritmo
  • 9. Algoritmos Resolvidos – Lista 1 9 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex7" Ler uma temperatura em graus Celsius e apresentá-la convertida em graus Fahrenheit. A fórmula de conversão é: F= (9*C+160) / 5, sendo F a temperatura em Fahrenheit e C a temperatura em Celsius. // Seção de Declarações var cel, far: real inicio // Seção de Comandos escreval("=-=-=-=-=- Tabela de conversão: Celcius -> Fahrenheit -=-=-=-=-=") escreva("Digite a temperatura em Celcius: ") leia(cel) far <- (9*cel+160)/5 escreval("A nova temperatura é: ",far,"ºF") fimalgoritmo
  • 10. Algoritmos Resolvidos – Lista 1 10 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex8" Elaborar um algoritmo que efetue a apresentação do valor da conversão em real (R$) de um valor lido em dólar (US$). O algoritmo deverá solicitar o valor da cotação do dólar e também a quantidade de dólares disponíveis com o usuário. // Seção de Declarações var rs, us, cotacao, dolaDisponivel: real inicio // Seção de Comandos escreval("========= Cotação do Dólar ==========") escreva("Qual a cotação atual do dólar? ") leia(cotacao) escreva("Quantos dólares você possui? ") leia(us) rs <- us/cotacao limpatela escreval(us," Dólares equivalem á: ",rs," R$") fimalgoritmo
  • 11. Algoritmos Resolvidos – Lista 1 11 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex9" Faça um algoritmo que receba um valor que foi depositado e exiba o valor com rendimento após um mês. Considere fixo o juro da poupança em 0,70% a. m. // Seção de Declarações var correcao, deposito: real inicio // Seção de Comandos escreval("Sistema de depósito do Banco do Oeste") escreva("Digite o valor depositado: ") leia(deposito) correcao <- 0.7 * deposito escreva("O rendimento do depósito após um mês é de: ",deposito+correcao) fimalgoritmo
  • 12. Algoritmos Resolvidos – Lista 1 12 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex10" A Loja Mamão com Açúcar está vendendo seus produtos em 5 (cinco) prestações sem juros. Faça um algoritmo que receba um valor de uma compra e mostre o valor das prestações. // Seção de Declarações var compra, prestacao: real inicio // Seção de Comandos escreval("========== Loja Mamão com Açúcar ==========") escreva("Digite o valor da compra: ") leia(compra) prestacao <- compra/5 escreval("O cliente deverá pagar 5 prestações de R$",prestacao," cada") fimalgoritmo
  • 13. Algoritmos Resolvidos – Lista 1 13 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex11" Faça um algoritmo que receba o preço de custo de um produto e mostre o valor de venda. Sabe-se que o preço de custo receberá um acréscimo de acordo com um percentual informado pelo usuário. // Seção de Declarações var custo, venda, percent: real inicio // Seção de Comandos escreva("Digite o custo do produto: ") leia(custo) escreva("Digite o percentual para venda: ") leia(percent) percent <- (percent/100) * custo venda <- custo + percent escreval("O valor de venda é: ",venda) fimalgoritmo
  • 14. Algoritmos Resolvidos – Lista 1 14 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex12" O custo ao consumidor de um carro novo é a soma do custo de fábrica com a percentagem do distribuidor e dos impostos (aplicados, primeiro os impostos sobre o custo de fábrica, e depois a percentagem do distribuidor sobre o resultado). Supondo que a percentagem do distribuidor seja de 28% e os impostos 45%. Escrever um algoritmo que leia o custo de fábrica de um carro e informe o custo ao consumidor do mesmo. // Seção de Declarações var custoFabrica, custoFinal: real inicio // Seção de Comandos escreva("Informe o custo de fábrica do veículo: ") leia(custoFabrica) custoFinal <- (custoDeFabrica * 1.45) * 1.28 escreval("O custo para o consumidor final é de: ",custoFinal) fimalgoritmo
  • 15. Algoritmos Resolvidos – Lista 1 15 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br Algoritmo “Ex13" Faça um algoritmo que receba um número e mostre uma mensagem caso este número seja maior que 10. // Seção de Declarações var numero: inteiro inicio // Seção de Comandos escreva("Digite um número: ") leia(numero) se numero > 10 entao escreval("O número é maior que 10") fimse fimalgoritmo