Tipos de Algoritmos
Pseudocódigo / Portugol
GVensino.com.br
ALGORITMO – PSEUDOCÓDIGO
Também conhecido como Portugol ou Português Estruturado
Algumas Instruções Padrões:
Entrada: leia...
ALGORITMO – FLUXOGRAMA / DIAGRAMA DE BLOCOS
Início
n1, n2, n3
Total = n1 + n2 + n3
Total
Fim
ALGORITMO – PSEUDOCÓDIGO
algoritmo "Soma3Numeros"
var
n1 : inteiro
n2: inteiro
n3: inteiro
total : inteiro
inicio
leia(n1)...
ALGORITMO – FLUXOGRAMA / DIAGRAMA DE BLOCOS
Tirar a média de 3 notas e dizer se o aluno
está aprovado ou não.
Media > 6
In...
ALGORITMO – PSEUDOCÓDIGO
algoritmo "MediaNotas"
var
n1 : real
n2: real
n3: real
media : real
inicio
leia(n1)
leia(n2)
leia...
Criado por Cláudio Morgado de Souza
Software de Domínio Público
VISUALG – Simulador de Pseudocódigos
Download: http://gven...
Produzido e Gravado por:
Gabriel Vinicios Silva Maganha
Site: http://gvensino.com.br
Peça autorização do autor caso deseje...
Próximos SlideShares
Carregando em…5
×

Aula 06

680 visualizações

Publicada em

Aula 06 do curso de lógica de programação do site GVensino - http://gvensino.com.br

Publicada em: Educação
0 comentários
2 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
680
No SlideShare
0
A partir de incorporações
0
Número de incorporações
2
Ações
Compartilhamentos
0
Downloads
71
Comentários
0
Gostaram
2
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Aula 06

  1. 1. Tipos de Algoritmos Pseudocódigo / Portugol GVensino.com.br
  2. 2. ALGORITMO – PSEUDOCÓDIGO Também conhecido como Portugol ou Português Estruturado Algumas Instruções Padrões: Entrada: leia() Saída: Escreva() Possuí regras específicas – ao contrário da Descrição Narrativa As instruções são todas padronizadas (vocabulário limitado) Vantagens: Muito parecido com uma Linguagem de Programação de verdade Desvantagens: As regras e a estrutura devem ser seguidas a riscas. Exige estudo e conhecimento das instruções.
  3. 3. ALGORITMO – FLUXOGRAMA / DIAGRAMA DE BLOCOS Início n1, n2, n3 Total = n1 + n2 + n3 Total Fim
  4. 4. ALGORITMO – PSEUDOCÓDIGO algoritmo "Soma3Numeros" var n1 : inteiro n2: inteiro n3: inteiro total : inteiro inicio leia(n1) leia(n2) leia(n3) total <- n1 + n2 + n3 escreva("O resultado deu ", total) fimalgoritmo Declarações Iniciais de Nomes (Variáveis) Nome do Algoritmo Leitura das entradas Início Processamento (soma) Saída (escreve na tela) Fim do Algoritmo
  5. 5. ALGORITMO – FLUXOGRAMA / DIAGRAMA DE BLOCOS Tirar a média de 3 notas e dizer se o aluno está aprovado ou não. Media > 6 Início N1, N2, N3 Media <- (N1 + N2 + N3) / 3 “Aprovado” Fim “Estude Mais” SIM NÃO
  6. 6. ALGORITMO – PSEUDOCÓDIGO algoritmo "MediaNotas" var n1 : real n2: real n3: real media : real inicio leia(n1) leia(n2) leia(n3) media <- (n1 + n2 + n3) / 3 se media > 6 entao escreva("Aluno aprovado") senao escreva("Precisa estudar mais!") fimse fimalgoritmo Declarações Iniciais de Nomes (Variáveis) Nome do Algoritmo Leitura das entradas (notas) Início Processamento (média) Saída (escreve na tela) Fim do Algoritmo Saída (escreve na tela) Condicional (Decisão)
  7. 7. Criado por Cláudio Morgado de Souza Software de Domínio Público VISUALG – Simulador de Pseudocódigos Download: http://gvensino.com.br/2029-visualg-para-simulacao-de-psudocodigo
  8. 8. Produzido e Gravado por: Gabriel Vinicios Silva Maganha Site: http://gvensino.com.br Peça autorização do autor caso deseje utilizar este conteúdo. Aula 06

×