César Augusto Pessôa
Sumário
 Objetivos
 Conceitos básicos de processo
 Comandos de decisão
 Explorando o Visualg
 Dúvidas
Objetivos
 Introduzir os alunos ao conceito de
processo como ferramenta para
modificação de algo já existente.
Demonstrar...
O que é um processo
pro.ces.so:
Substantivo masculino.
1. Sucessão de mudanças numa direção
definida.
2. Maneira de operar...
O que é processamento
pro.ces.sa.men.to:
Substantivo masculino.
1. Ato ou maneira de processar.
2. Conjunto de operações r...
Processo
Todo processo somente existe para realizar uma
modificação, do contrário, não faria sentido.
Todo processamento, ...
Processo
Entrada Processamento Saída
Processo
Entrada Processamento Saída
O que é um comando
co.man.do:
Substantivo masculino.
1. Chefia; liderança.
2. Autoridade.
3. Qualquer mecanismo que faz fu...
Como utilizar um comando
 Um comando deve ser utilizado para
transmitir instruções.
 Estas instruções, serão seguidas pa...
Fluxogramas
INÍCIO / FIM
CÁLCULO /
PROCESSAMENTO
ENTRADA SAÍDA
DECISÃO
Principais comandos
 Comando de desvio condicional:
 se <expressão-lógica> entao
 <seqüência-de-comandos>
 fimse
 se ...
Exercício
INÍCIO
numero
“Entre com um
número inteiro:”
FIM
<numero> / 2
“O número é par!”
<numero>
é par
“O número é
ímpar...
Resposta
var n: inteiro
inicio
escreval ("Entre com um número inteiro: ")
leia (n)
se n % 2 = 0 entao
escreval("O número é...
Exercício
INÍCIO
n1
“Entre com a
primeira nota:”
FIM
Média =
(n1 + n2) / 2
“Aluno aprovado!”
Média >= 7
“Aluno reprovado!”...
Resposta
var n1, n2, media: real
inicio
escreval ("Entre com a primeira nota: ")
leia (n1)
escreval ("Entre com a segunda ...
Visualg – A tela inicial
Visualg – A barra de tarefas
Visualg – A barra de tarefas
Visualg – O botão executar
Visualg – Principais atalhos
 Salvar (Ctrl-S): Grava imediatamente o
texto presente no editor. Na primeira vez
que um nov...
Visualg – Principais atalhos
 Localizar (Ctrl-L): Localiza no texto presente
no editor determinada palavra especificada.
...
Visualg – Principais atalhos
 Executar (F9): Inicia (ou continua) a execução do
pseudocódigo.
 Passo (F8): Inicia (ou co...
Visualg – Principais atalhos
 Desmarcar todos os breakpoints (Ctrl-F5): Desativa
todos os breakpoints.
 Gerar valores al...
Linguagem Visualg
Sugestão de digitação
 A sugestão de digitação é disponibilizada através
das teclas Ctrl-J. Basta começar a digitação de ...
Agradecimentos
Find Icons
http://findicons.com
Iconfinder
https://www.iconfinder.com
Dúvidas?
César Augusto Pessôa
capfg@hotmail.com
Próximos SlideShares
Carregando em…5
×

03 - Introdução a lógica de programação parte 3 - v1.1

301 visualizações

Publicada em

Introduzir os alunos ao conceito de processo como ferramenta para modificação de algo já existente. Demonstrar que um processo só existe, se houver mudança.

Ao final da aula, os alunos devem estar aptos a interpretar e compreender uma atividade, identificando os processos envolvidos e suas respectivas entradas e saídas.

Publicada em: Tecnologia
0 comentários
1 gostou
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
301
No SlideShare
0
A partir de incorporações
0
Número de incorporações
4
Ações
Compartilhamentos
0
Downloads
23
Comentários
0
Gostaram
1
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

03 - Introdução a lógica de programação parte 3 - v1.1

  1. 1. César Augusto Pessôa
  2. 2. Sumário  Objetivos  Conceitos básicos de processo  Comandos de decisão  Explorando o Visualg  Dúvidas
  3. 3. Objetivos  Introduzir os alunos ao conceito de processo como ferramenta para modificação de algo já existente. Demonstrar que um processo só existe, se houver mudança.  Ao final da aula, os alunos devem estar aptos a interpretar e compreender uma atividade, identificando os processos envolvidos e suas respectivas entradas e saídas.
  4. 4. O que é um processo pro.ces.so: Substantivo masculino. 1. Sucessão de mudanças numa direção definida. 2. Maneira de operar, resolver ou ensinar. 3. Série de ações sistemáticas visando a certo resultado. 4. Direito: Ação judicial. Fonte: Dicionário Michaelis, 2008, Ed. Melhoramentos.
  5. 5. O que é processamento pro.ces.sa.men.to: Substantivo masculino. 1. Ato ou maneira de processar. 2. Conjunto de operações realizadas com o fim de obter novas informações, soluções de problemas etc. 3. Informática: Utilização do computador para resolver um problema, organizar dados etc. Fonte: Dicionário Michaelis, 2008, Ed. Melhoramentos.
  6. 6. Processo Todo processo somente existe para realizar uma modificação, do contrário, não faria sentido. Todo processamento, gera uma saída diferente da entrada. Entrada Processamento Saída
  7. 7. Processo Entrada Processamento Saída
  8. 8. Processo Entrada Processamento Saída
  9. 9. O que é um comando co.man.do: Substantivo masculino. 1. Chefia; liderança. 2. Autoridade. 3. Qualquer mecanismo que faz funcionar máquina ou dispositivo. Fonte: Dicionário Michaelis, 2008, Ed. Melhoramentos.
  10. 10. Como utilizar um comando  Um comando deve ser utilizado para transmitir instruções.  Estas instruções, serão seguidas para realização de uma determinada tarefa.  Na informática, utilizamos comandos em algoritmos, para construir programas de computador.
  11. 11. Fluxogramas INÍCIO / FIM CÁLCULO / PROCESSAMENTO ENTRADA SAÍDA DECISÃO
  12. 12. Principais comandos  Comando de desvio condicional:  se <expressão-lógica> entao  <seqüência-de-comandos>  fimse  se <expressão-lógica> entao  <seqüência-de-comandos-1>  senao  <seqüência-de-comandos-2>  fimse
  13. 13. Exercício INÍCIO numero “Entre com um número inteiro:” FIM <numero> / 2 “O número é par!” <numero> é par “O número é ímpar!” SIM NÃO
  14. 14. Resposta var n: inteiro inicio escreval ("Entre com um número inteiro: ") leia (n) se n % 2 = 0 entao escreval("O número é par") senao escreval ("O número é ímpar") fimse fimalgoritmo
  15. 15. Exercício INÍCIO n1 “Entre com a primeira nota:” FIM Média = (n1 + n2) / 2 “Aluno aprovado!” Média >= 7 “Aluno reprovado!” SIM NÃO “Entre com a segunda nota:” n2
  16. 16. Resposta var n1, n2, media: real inicio escreval ("Entre com a primeira nota: ") leia (n1) escreval ("Entre com a segunda nota: ") leia (n2) media <- (n1 + n2) / 2 se media >= 7 entao escreval("Aluno aprovado!") senao escreval("Aluno reprovado!") fimse fimalgoritmo
  17. 17. Visualg – A tela inicial
  18. 18. Visualg – A barra de tarefas
  19. 19. Visualg – A barra de tarefas
  20. 20. Visualg – O botão executar
  21. 21. Visualg – Principais atalhos  Salvar (Ctrl-S): Grava imediatamente o texto presente no editor. Na primeira vez que um novo texto é gravado, o VisuAlg pede seu nome e localização.  Recortar (Ctrl-X)  Copiar (Ctrl-C)  Colar (Ctrl-V)  Desfazer (Ctrl-Z): Desfaz último comando efetuado.  Refazer (Shift-Ctrl-Z): Refaz último comando desfeito.
  22. 22. Visualg – Principais atalhos  Localizar (Ctrl-L): Localiza no texto presente no editor determinada palavra especificada.  Substituir (Ctrl-U): Localiza no texto presente no editor determinada palavra especificada, substituindo-a por outra.  Corrigir Indentação (Ctrl-G): Corrige automaticamente a indentação (ou tabulação) do pseudocódigo, tabulando cada comando interno com espaços à esquerda.  Numerar linhas: Ativa ou desativa a exibição dos números das linhas na área à esquerda do editor.
  23. 23. Visualg – Principais atalhos  Executar (F9): Inicia (ou continua) a execução do pseudocódigo.  Passo (F8): Inicia (ou continua) a execução linha por linha do pseudocódigo, dando ao usuário a oportunidade de acompanhar o fluxo de execução, os valores das variáveis e a pilha de ativação dos subprogramas.  Parar (Ctrl-F2): Termina imediatamente a execução do pseudocódigo. Evidentemente, este botão fica desabilitado quando o pseudocódigo não está sendo executado.  Liga/desliga breakpoint (F5): Insere/remove um ponto de parada na linha em que esteja o cursor. Estes pontos de parada são úteis para a depuração e acompanhamento da execução dos pseudocódigos, pois permitem a verificação dos valores das variáveis e da pilha de ativação de subprogramas.
  24. 24. Visualg – Principais atalhos  Desmarcar todos os breakpoints (Ctrl-F5): Desativa todos os breakpoints.  Gerar valores aleatórios: Ativa a geração de valores aleatórios que substituem a digitação de dados. A faixa padrão de valores gerados é de 0 a 100 inclusive, mas pode ser modificada (basta alterar intervalo ao lado). Para a geração de dados do tipo caractere, não há uma faixa pré-estabelecida: os dados gerados serão sempre strings de 5 letras maiúsculas.  Intervalo dos valores aleatórios: Faixa de valores que serão gerados automaticamente, quando esta opção estiver ativada.  Ajuda (F1): Possibilita acesso às páginas de ajuda e às informações sobre o VisuAlg.
  25. 25. Linguagem Visualg
  26. 26. Sugestão de digitação  A sugestão de digitação é disponibilizada através das teclas Ctrl-J. Basta começar a digitação de uma palavra e teclar Ctrl-J para que o VisuAlg mostre uma lista com sugestões de palavras-chave que completam o que foi digitado. Para escolher, é necessário dar um duplo-clique sobre a opção desejada, ou então selecioná-la com as setas e teclar Enter. Se o usuário continua escrevendo depois que o VisuAlg apresentou a lista de sugestões, o programa continuará procurando palavras que ainda complementem o que foi digitado. Ao se teclar Esc ou clicar "fora da lista", ela desaparece.
  27. 27. Agradecimentos Find Icons http://findicons.com Iconfinder https://www.iconfinder.com
  28. 28. Dúvidas?
  29. 29. César Augusto Pessôa capfg@hotmail.com

×