Algoritmos 01 - Semana 06 - Múltipla Escolha

578 visualizações

Publicada em

Algoritmos 01 - Semana 06 - Múltipla Escolha
Escolha Caso
Instituto Federal de Mato Grosso do Sul
IFMS - Algoritmos 01
Visualg

Publicada em: Educação
0 comentários
1 gostou
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
578
No SlideShare
0
A partir de incorporações
0
Número de incorporações
1
Ações
Compartilhamentos
0
Downloads
23
Comentários
0
Gostaram
1
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos 01 - Semana 06 - Múltipla Escolha

  1. 1. Algoritmo 1 Semana 06 MÚLTIPLA ESCOLHA 1
  2. 2. Algoritmo  Vamos supor que, em um dado algoritmo, um comando genérico W deve ser executado apenas quando forem satisfeitas as condições <Condição 1>, <Condição 2>,<Condição 2> e <Condição 4>
  3. 3. Se então se
  4. 4. Algoritmo  Vamos supor que em determinado algoritmo uma variável X possa assumir apenas quatro valores, V1, V2, V3, V4, e que exista um comando diferente que será executado para cada valor armazenado em X
  5. 5. Se então se Então Se Se (X=V1) entao C1 Fimse Se (X=V2) entao C2 Fimse Se (X=V3) entao C3 Fimse Se (X=V4) entao C4 Fimse Utilizando Encadeamento se (X=V1) então C1 senao se (X=V2) entao C2 senao se (X=V3) entao C3 senao se (X=V4) entao C4 fimse fimse fimse fimse
  6. 6. Mútipla Escolha  Quando um conjunto de valores precisa ser testado e ações diferentes são associadas a esses valores, estamos diante de uma seleção encadeada homogênea do tipo se-senao-se.
  7. 7. escolha - caso escolha X . caso V1:C1 caso V2:C2 caso V3:C3 caso V4:C4 fimescolha escolha valor opção exceção fimescolha valor expressão aritmética variável caracter opção caso açãoconstante exceção caso contrário ação
  8. 8. Algoritmo  Construa um algoritmo que, tendo como dados de entrada o nome e o código do curso de um aluno escreva seu nome e o curso que ele faz. De acordo com a legenda abaixo: Código Estado 1 Informática Vespertino 2 Informática Matutino 3 Agricultura Vespertino 4 Agricultura Matutino
  9. 9. Resolução Algoritmo escolha Var nome: literal codigo: inteiro Inicio escreva(“Digite seu nome”) leia(nome) escreva(“Digite o código de curso”) leia(codigo) escolha codigo caso 1 : escreva (nome, “ – Informática Vespertino”) caso 2 : escreva (nome, “ – Informática Matutino”) caso 3 : escreva (nome, “ – Agricultura Vespertino”) caso 4 : escreva (nome, “ – Agricultuta Matutino”) caso 5 : escreva (nome, “ – Proeja”) casocontrario : escreva(“Código Inválido”) fimescolha fimalgoritmo
  10. 10. Exercício 1 Opção Estado 1 Executa a rotina de Inclusão de Professores 2 Executa a rotina de Alteração de Professores 3 Executa a rotina de Exclusão de Professores 4 Executa a rotina de Consulta de Professores
  11. 11. Resoluçã o Ex. 1 Algoritmo Exemplo1 Var OPCAO : inteiro Início OP11 OP2 2 OP3  3 OP4  4 escreva (“Entre com uma opção de 1 a 4: “) leia (OPCAO) escolha caso OPCAO = OP1 escreva (“Executa a rotina de Inclusão de Professores”) caso OPCAO = OP2 escreva (“Executa a rotina de Alteração de Professores”) caso OPCAO = OP3 escreva (“Executa a rotina de Exclusão de Professores”) caso OPCAO = OP4 escreva (“Executa a rotina de Consulta de Professores”) caso contrário (senão) escreva (“Opção Inválida ! As opções válidas são de 1 a 4.”) fimescolha
  12. 12. Exercício 2  Elabore um algoritmo que leia duas variáveis dadas pelo usuário, em seguida apresente um menu para o usuário perguntando qual operação matemática ele deseja executar. Cuidado com a divisão que não pode ser por 0 (zero).

×