Algoritmo 2 – Aula 4<br />MA12N<br />Prof Eder SamaniegoVillalba<br />
Estruturas de Repetição (Parte 02)<br />Laços Contados<br />Para.. faça<br />
Laços Contados<br />Para algumas aplicações, o controle condicional de laços imposto pela construção ”enquanto”, é desnece...
Exemplo<br />ALGORITMO “exemplo1 da estrutura para “<br />Var<br />TOTALREP 5 <br />NOME : literal <br />Inicio<br />I : ...
Exemplo 2<br />Algoritmo que lê 5 números e escreve todos os que forem positivos.<br />1. Algoritmo "Positivos"<br />2. va...
Exemplo 3<br />Algoritmo que lê um número N e escreve todos os números de 1 a N.<br />1. algoritmo "determina o tamanho do...
Exercícios<br />Escrever um algoritmo que leia informações sobre um grupo de 250 pessoas e calcule alguns dados estatístic...
Próximos SlideShares
Carregando em…5
×

Aula 04 Estruturas de repetição 02 - Para Faça

9.188 visualizações

Publicada em

Algoritmo 2
MA12N

Publicada em: Educação, Tecnologia, Negócios
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
9.188
No SlideShare
0
A partir de incorporações
0
Número de incorporações
18
Ações
Compartilhamentos
0
Downloads
86
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Aula 04 Estruturas de repetição 02 - Para Faça

  1. 1. Algoritmo 2 – Aula 4<br />MA12N<br />Prof Eder SamaniegoVillalba<br />
  2. 2. Estruturas de Repetição (Parte 02)<br />Laços Contados<br />Para.. faça<br />
  3. 3. Laços Contados<br />Para algumas aplicações, o controle condicional de laços imposto pela construção ”enquanto”, é desnecessariamente complicado. Em muitos casos, pode-se desejar executar um laço, um número fixo de vezes, onde este número já é conhecido. Para aplicações como estas, existe uma forma modificada de construção repetitiva.<br />para variável = valor-inicial até valor-final [de <inc/dec> em <inc/dec>] faça <br /> comando(s) <br />fim-para <br />
  4. 4. Exemplo<br />ALGORITMO “exemplo1 da estrutura para “<br />Var<br />TOTALREP 5 <br />NOME : literal <br />Inicio<br />I : inteiro <br />para I=1 até TOTALREP faça <br /> escreva (“Entre com o nome: “) <br /> leia(NOME) <br /> escreva (I,” - “,NOME) <br />fimpara<br />fimalgoritmo<br />
  5. 5. Exemplo 2<br />Algoritmo que lê 5 números e escreve todos os que forem positivos.<br />1. Algoritmo "Positivos"<br />2. var<br />3. i, numero: inteiro<br />4. inicio<br />5. para i de 1 ate 5 passo 1 faca<br /> 6. escreval("Digete um numero")<br /> 7. leia (numero)<br /> 8. se numero>0 entao<br /> 9. escreva (numero)<br /> 10. fimse<br />11. fimpara<br />12. fimalgoritmo<br />
  6. 6. Exemplo 3<br />Algoritmo que lê um número N e escreve todos os números de 1 a N.<br />1. algoritmo "determina o tamanho do laço"<br />2. var<br />3. i, N: INTEIRO<br />4. inicio<br />5. leia (N)<br />6. para i de 1 ate N faca<br />7. escreva (i)<br />8. fimpara<br />9. fimalgoritmo<br />
  7. 7. Exercícios<br />Escrever um algoritmo que leia informações sobre um grupo de 250 pessoas e calcule alguns dados estatísticos. Para cada pessoas do grupo deve ler o nome da pessoa, a altura, o peso e o sexo (“F” para feminino e “M” para o masculino). Calcular e escrever:<br />A quantidade total de homens e mulheres e o percentual de cada.<br />A média de peso das pessoas (somatório dos pesos de todas as pessoas pela quantidade de pessoas)<br />O nome da pessoa mais alta.<br />Faça um algoritmo que gere uma tabela com os números de 1 a 10 e mostre o seu quadrado, cubo, fatorial, número de divisores e uma mensagem dizendo se o número é primo ou não. A cada 20 linhas deve ser escrito o cabeçalho novamente:<br />Número Quadrado Cubo Fatorial Divisores Primo<br />1 1 1 1 1 Sim<br />2 4 8 2 2 Sim<br />

×