SlideShare uma empresa Scribd logo
1 de 10
1. Faça um algoritmo que copie o conteúdo de um vetor em um segundo vetor.
algoritmo "exercicio_01"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
i:inteiro
vetA:vetor[1..5] de inteiro
vetB:vetor[1..5] de inteiro
inicio
// Seção de Comandos
// VETOR A
para i de 1 ate 5 faca
escreval("VETOR A")
escreva("Informe o valor da posicao: ",i,": ")
leia(vetA[i])
fimpara
limpatela
// COPIA VETOR A PARA VETOR B
para i de 1 ate 5 faca
vetB[i]<-vetA[i]
fimpara
//APRESENTANDO VETOR A
escreval("VETOR A")
escreval("")
para i de 1 ate 5 faca
escreval(vetA[i])
fimpara
//APRESENTANDO VETOR B
escreval("")
escreval("VETOR B")
escreval("")
para i de 1 ate 5 faca
escreval(vetB[i])
fimpara
fimalgoritmo
********************************************************************************
**************************************************
2. Faça um algoritmo que some o conteúdo de dois vetores e armazene o resultado
em um terceiro vetor.
algoritmo "exercicio_02"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
i:inteiro
vetA:vetor[1..5] de inteiro
vetB:vetor[1..5] de inteiro
vetC:vetor[1..5] de inteiro
inicio
// Seção de Comandos
// VETOR A
para i de 1 ate 5 faca
escreval("VETOR A")
escreva("Informe o valor da posicao: ",i,": ")
leia(vetA[i])
fimpara
limpatela
// VETOR B
para i de 1 ate 5 faca
escreval("VETOR B")
escreva("Informe o valor da posicao: ",i,": ")
leia(vetB[i])
fimpara
limpatela
// VETOR C
para i de 1 ate 5 faca
vetC[i]<-vetA[i]+vetB[i]
fimpara
//APRESENTANDO VETOR A
escreval("VETOR A")
para i de 1 ate 5 faca
escreval(vetA[i])
fimpara
escreval("")
escreval("")
//APRESENTANDO VETOR B
escreval("VETOR B")
para i de 1 ate 5 faca
escreval(vetB[i])
fimpara
escreval("")
escreval("")
//APRESENTANDO SOMA DOS VETORES
escreval("SOMA DOS VETORES A e B")
para i de 1 ate 5 faca
escreval(vetC[i])
fimpara
escreval("")
escreval("")
fimalgoritmo
********************************************************************************
**************************************************
3. Faça um algoritmo que faça a união de dois vetores de mesmo tamanho e mesmo
tipo em um terceiro vetor com dobro do tamanho.
algoritmo "exercicio_03"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
i:inteiro
vetA:vetor[1..3] de inteiro
vetB:vetor[1..3] de inteiro
vetC:vetor[1..6] de inteiro
inicio
// Seção de Comandos
// VETOR A
para i de 1 ate 3 faca
escreval("VETOR A")
escreva("Informe o valor da posicao: ",i,": ")
leia(vetA[i])
fimpara
limpatela
// VETOR B
para i de 1 ate 3 faca
escreval("VETOR B")
escreva("Informe o valor da posicao: ",i,": ")
leia(vetB[i])
fimpara
limpatela
// UNIAO DOS VETORORES A e B
// VETOR C
para i de 1 ate 3 faca
se vetA[i] <> vetB[i] entao
vetC[i] <- vetA[i]
vetC[i+3]<-vetB[i]
senao
vetC[i] <- vetA[i]
fimse
fimpara
escreval("VETOR A")
para i de 1 ate 3 faca
escreval(vetA[i])
fimpara
escreval("")
escreval("")
escreval("VETOR B")
para i de 1 ate 3 faca
escreval(vetB[i])
fimpara
escreval("")
escreval("")
escreval("UNIAO DOS VETORES A e B")
para i de 1 ate 6 faca
escreval(vetC[i])
fimpara
escreval("")
escreval("")
fimalgoritmo
********************************************************************************
**************************************************
4. Faça um algoritmo que leia um vetor de 20 posições a apresente o maior e o
menor valor e as posições que eles se encontram.
algoritmo "exercicio_04"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
i,maior,menor,posicaomaior,posicaomenor:inteiro
numeros:vetor[1..20] de inteiro
inicio
// Seção de Comandos
para i de 1 ate 20 faca
escreva("Informe o valor da posicao: ",i,": ")
leia(numeros[i])
se i=1 entao
maior<-numeros[i]
menor<-numeros[i]
fimse
se numeros[i]>maior entao
maior<-numeros[i]
posicaomaior<-i
fimse
se numeros[i]<menor entao
menor<-numeros[i]
posicaomenor<-i
fimse
fimpara
escreval("")
escreval("")
escreval("O maior numero é o: ",maior," Na posicão: ",posicaomaior)
escreval("O menor numero é o: ",menor," Na posicão: ",posicaomenor)
fimalgoritmo
********************************************************************************
**************************************************
5. Faça um algoritmo para somar duas matrizes.
algoritmo "exercicio_05"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
l,c:inteiro
matrizA:vetor[1..3,1..3] de inteiro
matrizB:vetor[1..3,1..3] de inteiro
matrizC:vetor[1..3,1..3] de inteiro
inicio
// Seção de Comandos
// MATRIZ A
para l de 1 ate 3 faca
para c de 1 ate 3 faca
escreval("MATRIZ A")
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(matrizA[l,c])
limpatela
fimpara
fimpara
limpatela
// MATRIZ B
para l de 1 ate 3 faca
para c de 1 ate 3 faca
escreval("MATRIZ B")
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(matrizB[l,c])
limpatela
fimpara
fimpara
limpatela
// MATRIZ C
para l de 1 ate 3 faca
para c de 1 ate 3 faca
matrizC[l,c]<-matrizA[l,c]+matrizB[l,c]
fimpara
fimpara
escreval("MATRIZ A")
para l de 1 ate 3 faca
escreval("")
para c de 1 ate 3 faca
escreva(matrizA[l,c])
fimpara
fimpara
escreval("")
escreval("")
escreval("MATRIZ B")
para l de 1 ate 3 faca
escreval("")
para c de 1 ate 3 faca
escreva(matrizB[l,c])
fimpara
fimpara
escreval("")
escreval("")
escreval("A SOMA DAS MATRIZES A e B")
para l de 1 ate 3 faca
escreval("")
para c de 1 ate 3 faca
escreva(matrizC[l,c])
fimpara
fimpara
escreval("")
escreval("")
fimalgoritmo
********************************************************************************
**************************************************
6. Faça um algoritmo que leia uma matriz mat 2 x 3 e imprima na tela a soma de
todos os elementos da matriz mat.
algoritmo "exercicio_06"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
l,c,total:inteiro
numeros:vetor[1..2,1..3] de inteiro
inicio
// Seção de Comandos
total<-0
para l de 1 ate 2 faca
para c de 1 ate 3 faca
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(numeros[l,c])
total<-total+numeros[l,c]
fimpara
fimpara
limpatela
para l de 1 ate 2 faca
escreval("")
para c de 1 ate 3 faca
escreva(numeros[l,c])
fimpara
fimpara
escreval("")
escreval("")
escreva("A soma da Matriz é: ",total)
escreval("")
escreval("")
fimalgoritmo
********************************************************************************
**************************************************
7. Dado uma matriz de 4x5 elementos, escreva um algoritmo para calcular a soma
de cada uma das linhas.
algoritmo "exercicio_07"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
l,c,total:inteiro
numeros:vetor[1..4,1..5] de inteiro
inicio
// Seção de Comandos
para l de 1 ate 4 faca
para c de 1 ate 5 faca
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(numeros[l,c])
fimpara
fimpara
limpatela
para l de 1 ate 4 faca
escreval("")
para c de 1 ate 5 faca
escreva(numeros[l,c])
fimpara
fimpara
escreval("")
escreval("")
para l de 1 ate 4 faca
total<-0;
para c de 1 ate 5 faca
total<-total+numeros[l,c]
fimpara
escreval("A soma da linha: ",l," = ",total)
fimpara
fimalgoritmo
********************************************************************************
**************************************************
8. Escreva um algoritmo para ler uma matriz de 3 linhas e 2 colunas, e determine
o maior valor contido na matriz e imprima este valor e sua posição na matriz.
algoritmo "exercicio_08"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
l,c,maior:inteiro
numeros:vetor[1..3,1..2] de inteiro
linha,coluna:inteiro
inicio
// Seção de Comandos
para l de 1 ate 3 faca
para c de 1 ate 2 faca
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(numeros[l,c])
fimpara
fimpara
maior<-0
para l de 1 ate 3 faca
para c de 1 ate 2 faca
se numeros[l,c]>maior entao
maior<-numeros[l,c]
linha<-l
coluna<-c
fimse
fimpara
fimpara
escreval("O numero: ",maior," Na posicão: ",linha,"-",coluna," É o maior")
fimalgoritmo
********************************************************************************
**************************************************
9. Escreva um algoritmo para ler uma matriz 4x3 e imprima sua diagonal
principal.
algoritmo "exercicio_09"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
l,c:inteiro
numeros:vetor[1..4,1..3] de inteiro
inicio
// Seção de Comandos
para l de 1 ate 4 faca
para c de 1 ate 3 faca
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(numeros[l,c])
fimpara
fimpara
para l de 1 ate 4 faca
para c de 1 ate 3 faca
se l=c entao
escreval("Diagonal Principal: ",numeros[l,c])
fimse
fimpara
fimpara
fimalgoritmo
********************************************************************************
**************************************************
10. Elabore um algoritmo para ler uma matriz 3x4 e apresente somente os valores
acima e abaixo da diagonal principal.
algoritmo "exercicio_10"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
l,c:inteiro
numeros:vetor[1..3,1..4] de inteiro
inicio
// Seção de Comandos
para l de 1 ate 3 faca
para c de 1 ate 4 faca
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(numeros[l,c])
fimpara
fimpara
para l de 1 ate 3 faca
para c de 1 ate 4 faca
se l<c entao
escreval("Diagonal Superior: ",numeros[l,c])
fimse
fimpara
fimpara
para l de 1 ate 3 faca
para c de 1 ate 4 faca
se l>c entao
escreval("Diagonal Inferior: ",numeros[l,c])
fimse
fimpara
fimpara
fimalgoritmo
********************************************************************************
**************************************************

Mais conteúdo relacionado

Mais procurados

Algoritmos e lp parte3-pseudocódigo
Algoritmos e lp parte3-pseudocódigoAlgoritmos e lp parte3-pseudocódigo
Algoritmos e lp parte3-pseudocódigo
Mauro Pereira
 
Lista de exercicios vetores, matrizes, registros e sub-algoritmos
Lista de exercicios   vetores, matrizes, registros e sub-algoritmosLista de exercicios   vetores, matrizes, registros e sub-algoritmos
Lista de exercicios vetores, matrizes, registros e sub-algoritmos
Mauro Pereira
 
Lista de exercícios resolvidos
Lista de exercícios resolvidosLista de exercícios resolvidos
Lista de exercícios resolvidos
Crishna Irion
 
Algoritmos resolvidos lista 2
Algoritmos resolvidos lista 2Algoritmos resolvidos lista 2
Algoritmos resolvidos lista 2
isa_ise
 
Aula 4 - Teste de mesa
Aula 4 - Teste de mesaAula 4 - Teste de mesa
Aula 4 - Teste de mesa
Pacc UAB
 
Logica Algoritmo 05 Repeticao
Logica Algoritmo 05 RepeticaoLogica Algoritmo 05 Repeticao
Logica Algoritmo 05 Repeticao
Regis Magalhães
 

Mais procurados (20)

Descritiva Narrativa (Lógica de Programação)
Descritiva Narrativa (Lógica de Programação)Descritiva Narrativa (Lógica de Programação)
Descritiva Narrativa (Lógica de Programação)
 
Banco de dados exercícios resolvidos
Banco de dados exercícios resolvidosBanco de dados exercícios resolvidos
Banco de dados exercícios resolvidos
 
Alguns algoritmos resolvidos
Alguns algoritmos resolvidosAlguns algoritmos resolvidos
Alguns algoritmos resolvidos
 
Fluxograma (Lógica de Programação)
Fluxograma (Lógica de Programação)Fluxograma (Lógica de Programação)
Fluxograma (Lógica de Programação)
 
Algoritmos e lp parte3-pseudocódigo
Algoritmos e lp parte3-pseudocódigoAlgoritmos e lp parte3-pseudocódigo
Algoritmos e lp parte3-pseudocódigo
 
Algoritmos e lp parte 4-vetores matrizes e registros
Algoritmos e lp parte 4-vetores matrizes e registrosAlgoritmos e lp parte 4-vetores matrizes e registros
Algoritmos e lp parte 4-vetores matrizes e registros
 
Lista de exercicios vetores, matrizes, registros e sub-algoritmos
Lista de exercicios   vetores, matrizes, registros e sub-algoritmosLista de exercicios   vetores, matrizes, registros e sub-algoritmos
Lista de exercicios vetores, matrizes, registros e sub-algoritmos
 
Lista de exercícios resolvidos
Lista de exercícios resolvidosLista de exercícios resolvidos
Lista de exercícios resolvidos
 
Algoritmos resolvidos lista 2
Algoritmos resolvidos lista 2Algoritmos resolvidos lista 2
Algoritmos resolvidos lista 2
 
Algoritmos visualg
Algoritmos visualgAlgoritmos visualg
Algoritmos visualg
 
Aula 4 - Teste de mesa
Aula 4 - Teste de mesaAula 4 - Teste de mesa
Aula 4 - Teste de mesa
 
Logica Algoritmo 05 Repeticao
Logica Algoritmo 05 RepeticaoLogica Algoritmo 05 Repeticao
Logica Algoritmo 05 Repeticao
 
Algoritmos 01 - Semana 07 - Exercícios Múltipla Escolha
Algoritmos 01 - Semana 07 - Exercícios Múltipla EscolhaAlgoritmos 01 - Semana 07 - Exercícios Múltipla Escolha
Algoritmos 01 - Semana 07 - Exercícios Múltipla Escolha
 
Aula01 - Logica de Programação
Aula01 - Logica de ProgramaçãoAula01 - Logica de Programação
Aula01 - Logica de Programação
 
Algoritmo aula 01-f
Algoritmo   aula 01-fAlgoritmo   aula 01-f
Algoritmo aula 01-f
 
Aula 01 - Algoritmo e Programação
Aula 01 - Algoritmo e ProgramaçãoAula 01 - Algoritmo e Programação
Aula 01 - Algoritmo e Programação
 
Aula 3 algoritmos
Aula 3   algoritmosAula 3   algoritmos
Aula 3 algoritmos
 
Algoritmos - Vetores
Algoritmos - VetoresAlgoritmos - Vetores
Algoritmos - Vetores
 
Algoritmos 05 - Estruturas de repetição
Algoritmos 05 - Estruturas de repetiçãoAlgoritmos 05 - Estruturas de repetição
Algoritmos 05 - Estruturas de repetição
 
Aula Lógica de Programação - cap1
Aula Lógica de Programação - cap1 Aula Lógica de Programação - cap1
Aula Lógica de Programação - cap1
 

Semelhante a Exercicios resolvidos visu alg vetores

Alg aula 07 - matrizes tp1
Alg   aula 07 - matrizes tp1Alg   aula 07 - matrizes tp1
Alg aula 07 - matrizes tp1
Thalles Anderson
 
Introdução a Linguagem C
Introdução a Linguagem CIntrodução a Linguagem C
Introdução a Linguagem C
apolllorj
 

Semelhante a Exercicios resolvidos visu alg vetores (20)

Alg aula 07 - matrizes tp1
Alg   aula 07 - matrizes tp1Alg   aula 07 - matrizes tp1
Alg aula 07 - matrizes tp1
 
Filtro_matlab_toobox
Filtro_matlab_tooboxFiltro_matlab_toobox
Filtro_matlab_toobox
 
Linguagem c wellington telles - aula 06
Linguagem c   wellington telles - aula 06Linguagem c   wellington telles - aula 06
Linguagem c wellington telles - aula 06
 
Introdução ao Octave
Introdução ao OctaveIntrodução ao Octave
Introdução ao Octave
 
095 A 134 Material Auxiliar Para Curso AvançAdo I Msp430
095 A 134   Material Auxiliar Para Curso AvançAdo I Msp430095 A 134   Material Auxiliar Para Curso AvançAdo I Msp430
095 A 134 Material Auxiliar Para Curso AvançAdo I Msp430
 
Introdução a Linguagem C
Introdução a Linguagem CIntrodução a Linguagem C
Introdução a Linguagem C
 
Algoritmos - Aula 13 B - Vetores em C
Algoritmos - Aula 13 B - Vetores em CAlgoritmos - Aula 13 B - Vetores em C
Algoritmos - Aula 13 B - Vetores em C
 
Algop - aula 04 pascal 1
Algop - aula 04 pascal 1Algop - aula 04 pascal 1
Algop - aula 04 pascal 1
 
Algoritmos e LP - Aula 09 - Linguagem C - p2.pdf
Algoritmos e LP - Aula 09 - Linguagem C - p2.pdfAlgoritmos e LP - Aula 09 - Linguagem C - p2.pdf
Algoritmos e LP - Aula 09 - Linguagem C - p2.pdf
 
Lista de exercício
Lista de exercício   Lista de exercício
Lista de exercício
 
Introdução ao c++
Introdução ao c++Introdução ao c++
Introdução ao c++
 
Aula6 programação
Aula6 programaçãoAula6 programação
Aula6 programação
 
3 vetor.matriz
3 vetor.matriz3 vetor.matriz
3 vetor.matriz
 
Matlab – curso básico (1)
Matlab – curso básico (1)Matlab – curso básico (1)
Matlab – curso básico (1)
 
5423 c ou c++
5423 c ou c++5423 c ou c++
5423 c ou c++
 
Apostila C++
Apostila C++ Apostila C++
Apostila C++
 
C++ basico
C++ basicoC++ basico
C++ basico
 
C ou c++
C ou c++C ou c++
C ou c++
 
Curso de PostgreSQL: Um pouco Além dos Comandos
Curso de PostgreSQL: Um pouco Além dos ComandosCurso de PostgreSQL: Um pouco Além dos Comandos
Curso de PostgreSQL: Um pouco Além dos Comandos
 
Algoritmos-SlidesA1_2016_03_01.ppt
Algoritmos-SlidesA1_2016_03_01.pptAlgoritmos-SlidesA1_2016_03_01.ppt
Algoritmos-SlidesA1_2016_03_01.ppt
 

Último

Regulamento do Festival de Teatro Negro - FESTIAFRO 2024 - 10ª edição - CEI...
Regulamento do Festival de Teatro Negro -  FESTIAFRO 2024 - 10ª edição -  CEI...Regulamento do Festival de Teatro Negro -  FESTIAFRO 2024 - 10ª edição -  CEI...
Regulamento do Festival de Teatro Negro - FESTIAFRO 2024 - 10ª edição - CEI...
Eró Cunha
 
História concisa da literatura brasileira- Alfredo Bosi..pdf
História concisa da literatura brasileira- Alfredo Bosi..pdfHistória concisa da literatura brasileira- Alfredo Bosi..pdf
História concisa da literatura brasileira- Alfredo Bosi..pdf
GisellySobral
 

Último (20)

Quiz | Dia da Europa 2024 (comemoração)
Quiz | Dia da Europa 2024  (comemoração)Quiz | Dia da Europa 2024  (comemoração)
Quiz | Dia da Europa 2024 (comemoração)
 
Regulamento do Festival de Teatro Negro - FESTIAFRO 2024 - 10ª edição - CEI...
Regulamento do Festival de Teatro Negro -  FESTIAFRO 2024 - 10ª edição -  CEI...Regulamento do Festival de Teatro Negro -  FESTIAFRO 2024 - 10ª edição -  CEI...
Regulamento do Festival de Teatro Negro - FESTIAFRO 2024 - 10ª edição - CEI...
 
APRENDA COMO USAR CONJUNÇÕES COORDENATIVAS
APRENDA COMO USAR CONJUNÇÕES COORDENATIVASAPRENDA COMO USAR CONJUNÇÕES COORDENATIVAS
APRENDA COMO USAR CONJUNÇÕES COORDENATIVAS
 
Religiosidade de Assaré - Prof. Francisco Leite
Religiosidade de Assaré - Prof. Francisco LeiteReligiosidade de Assaré - Prof. Francisco Leite
Religiosidade de Assaré - Prof. Francisco Leite
 
Edital do processo seletivo para contratação de agentes de saúde em Floresta, PE
Edital do processo seletivo para contratação de agentes de saúde em Floresta, PEEdital do processo seletivo para contratação de agentes de saúde em Floresta, PE
Edital do processo seletivo para contratação de agentes de saúde em Floresta, PE
 
425416820-Testes-7º-Ano-Leandro-Rei-Da-Heliria-Com-Solucoes.pdf
425416820-Testes-7º-Ano-Leandro-Rei-Da-Heliria-Com-Solucoes.pdf425416820-Testes-7º-Ano-Leandro-Rei-Da-Heliria-Com-Solucoes.pdf
425416820-Testes-7º-Ano-Leandro-Rei-Da-Heliria-Com-Solucoes.pdf
 
Acróstico - Maio Laranja
Acróstico  - Maio Laranja Acróstico  - Maio Laranja
Acróstico - Maio Laranja
 
Slides Lição 7, Betel, Ordenança para uma vida de fidelidade e lealdade, 2Tr2...
Slides Lição 7, Betel, Ordenança para uma vida de fidelidade e lealdade, 2Tr2...Slides Lição 7, Betel, Ordenança para uma vida de fidelidade e lealdade, 2Tr2...
Slides Lição 7, Betel, Ordenança para uma vida de fidelidade e lealdade, 2Tr2...
 
Poema - Maio Laranja
Poema - Maio Laranja Poema - Maio Laranja
Poema - Maio Laranja
 
Apresentação | Símbolos e Valores da União Europeia
Apresentação | Símbolos e Valores da União EuropeiaApresentação | Símbolos e Valores da União Europeia
Apresentação | Símbolos e Valores da União Europeia
 
Pré-História do Brasil, Luzia e Serra da Capivara
Pré-História do Brasil, Luzia e Serra da CapivaraPré-História do Brasil, Luzia e Serra da Capivara
Pré-História do Brasil, Luzia e Serra da Capivara
 
História concisa da literatura brasileira- Alfredo Bosi..pdf
História concisa da literatura brasileira- Alfredo Bosi..pdfHistória concisa da literatura brasileira- Alfredo Bosi..pdf
História concisa da literatura brasileira- Alfredo Bosi..pdf
 
Histogramas.pptx...............................
Histogramas.pptx...............................Histogramas.pptx...............................
Histogramas.pptx...............................
 
QUESTÃO 4 Os estudos das competências pessoais é de extrema importância, pr...
QUESTÃO 4   Os estudos das competências pessoais é de extrema importância, pr...QUESTÃO 4   Os estudos das competências pessoais é de extrema importância, pr...
QUESTÃO 4 Os estudos das competências pessoais é de extrema importância, pr...
 
Dados espaciais em R - 2023 - UFABC - Geoprocessamento
Dados espaciais em R - 2023 - UFABC - GeoprocessamentoDados espaciais em R - 2023 - UFABC - Geoprocessamento
Dados espaciais em R - 2023 - UFABC - Geoprocessamento
 
Quando a escola é de vidro, de Ruth Rocha
Quando a escola é de vidro, de Ruth RochaQuando a escola é de vidro, de Ruth Rocha
Quando a escola é de vidro, de Ruth Rocha
 
Proposta de redação Soneto de texto do gênero poema para a,usos do 9 ano do e...
Proposta de redação Soneto de texto do gênero poema para a,usos do 9 ano do e...Proposta de redação Soneto de texto do gênero poema para a,usos do 9 ano do e...
Proposta de redação Soneto de texto do gênero poema para a,usos do 9 ano do e...
 
Modelos de Inteligencia Emocional segundo diversos autores
Modelos de Inteligencia Emocional segundo diversos autoresModelos de Inteligencia Emocional segundo diversos autores
Modelos de Inteligencia Emocional segundo diversos autores
 
nocoes-basicas-de-hereditariedade 9º ano.ppt
nocoes-basicas-de-hereditariedade 9º ano.pptnocoes-basicas-de-hereditariedade 9º ano.ppt
nocoes-basicas-de-hereditariedade 9º ano.ppt
 
Power Point sobre as etapas do Desenvolvimento infantil
Power Point sobre as etapas do Desenvolvimento infantilPower Point sobre as etapas do Desenvolvimento infantil
Power Point sobre as etapas do Desenvolvimento infantil
 

Exercicios resolvidos visu alg vetores

  • 1. 1. Faça um algoritmo que copie o conteúdo de um vetor em um segundo vetor. algoritmo "exercicio_01" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var i:inteiro vetA:vetor[1..5] de inteiro vetB:vetor[1..5] de inteiro inicio // Seção de Comandos // VETOR A para i de 1 ate 5 faca escreval("VETOR A") escreva("Informe o valor da posicao: ",i,": ") leia(vetA[i]) fimpara limpatela // COPIA VETOR A PARA VETOR B para i de 1 ate 5 faca vetB[i]<-vetA[i] fimpara //APRESENTANDO VETOR A escreval("VETOR A") escreval("") para i de 1 ate 5 faca escreval(vetA[i]) fimpara //APRESENTANDO VETOR B escreval("") escreval("VETOR B") escreval("") para i de 1 ate 5 faca escreval(vetB[i]) fimpara fimalgoritmo ******************************************************************************** ************************************************** 2. Faça um algoritmo que some o conteúdo de dois vetores e armazene o resultado
  • 2. em um terceiro vetor. algoritmo "exercicio_02" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var i:inteiro vetA:vetor[1..5] de inteiro vetB:vetor[1..5] de inteiro vetC:vetor[1..5] de inteiro inicio // Seção de Comandos // VETOR A para i de 1 ate 5 faca escreval("VETOR A") escreva("Informe o valor da posicao: ",i,": ") leia(vetA[i]) fimpara limpatela // VETOR B para i de 1 ate 5 faca escreval("VETOR B") escreva("Informe o valor da posicao: ",i,": ") leia(vetB[i]) fimpara limpatela // VETOR C para i de 1 ate 5 faca vetC[i]<-vetA[i]+vetB[i] fimpara //APRESENTANDO VETOR A escreval("VETOR A") para i de 1 ate 5 faca escreval(vetA[i]) fimpara escreval("") escreval("") //APRESENTANDO VETOR B escreval("VETOR B") para i de 1 ate 5 faca escreval(vetB[i]) fimpara escreval("")
  • 3. escreval("") //APRESENTANDO SOMA DOS VETORES escreval("SOMA DOS VETORES A e B") para i de 1 ate 5 faca escreval(vetC[i]) fimpara escreval("") escreval("") fimalgoritmo ******************************************************************************** ************************************************** 3. Faça um algoritmo que faça a união de dois vetores de mesmo tamanho e mesmo tipo em um terceiro vetor com dobro do tamanho. algoritmo "exercicio_03" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var i:inteiro vetA:vetor[1..3] de inteiro vetB:vetor[1..3] de inteiro vetC:vetor[1..6] de inteiro inicio // Seção de Comandos // VETOR A para i de 1 ate 3 faca escreval("VETOR A") escreva("Informe o valor da posicao: ",i,": ") leia(vetA[i]) fimpara limpatela // VETOR B para i de 1 ate 3 faca escreval("VETOR B") escreva("Informe o valor da posicao: ",i,": ") leia(vetB[i]) fimpara limpatela // UNIAO DOS VETORORES A e B // VETOR C para i de 1 ate 3 faca se vetA[i] <> vetB[i] entao
  • 4. vetC[i] <- vetA[i] vetC[i+3]<-vetB[i] senao vetC[i] <- vetA[i] fimse fimpara escreval("VETOR A") para i de 1 ate 3 faca escreval(vetA[i]) fimpara escreval("") escreval("") escreval("VETOR B") para i de 1 ate 3 faca escreval(vetB[i]) fimpara escreval("") escreval("") escreval("UNIAO DOS VETORES A e B") para i de 1 ate 6 faca escreval(vetC[i]) fimpara escreval("") escreval("") fimalgoritmo ******************************************************************************** ************************************************** 4. Faça um algoritmo que leia um vetor de 20 posições a apresente o maior e o menor valor e as posições que eles se encontram. algoritmo "exercicio_04" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var i,maior,menor,posicaomaior,posicaomenor:inteiro numeros:vetor[1..20] de inteiro inicio // Seção de Comandos para i de 1 ate 20 faca escreva("Informe o valor da posicao: ",i,": ") leia(numeros[i])
  • 5. se i=1 entao maior<-numeros[i] menor<-numeros[i] fimse se numeros[i]>maior entao maior<-numeros[i] posicaomaior<-i fimse se numeros[i]<menor entao menor<-numeros[i] posicaomenor<-i fimse fimpara escreval("") escreval("") escreval("O maior numero é o: ",maior," Na posicão: ",posicaomaior) escreval("O menor numero é o: ",menor," Na posicão: ",posicaomenor) fimalgoritmo ******************************************************************************** ************************************************** 5. Faça um algoritmo para somar duas matrizes. algoritmo "exercicio_05" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var l,c:inteiro matrizA:vetor[1..3,1..3] de inteiro matrizB:vetor[1..3,1..3] de inteiro matrizC:vetor[1..3,1..3] de inteiro inicio // Seção de Comandos // MATRIZ A para l de 1 ate 3 faca para c de 1 ate 3 faca escreval("MATRIZ A") escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(matrizA[l,c]) limpatela fimpara fimpara limpatela // MATRIZ B para l de 1 ate 3 faca
  • 6. para c de 1 ate 3 faca escreval("MATRIZ B") escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(matrizB[l,c]) limpatela fimpara fimpara limpatela // MATRIZ C para l de 1 ate 3 faca para c de 1 ate 3 faca matrizC[l,c]<-matrizA[l,c]+matrizB[l,c] fimpara fimpara escreval("MATRIZ A") para l de 1 ate 3 faca escreval("") para c de 1 ate 3 faca escreva(matrizA[l,c]) fimpara fimpara escreval("") escreval("") escreval("MATRIZ B") para l de 1 ate 3 faca escreval("") para c de 1 ate 3 faca escreva(matrizB[l,c]) fimpara fimpara escreval("") escreval("") escreval("A SOMA DAS MATRIZES A e B") para l de 1 ate 3 faca escreval("") para c de 1 ate 3 faca escreva(matrizC[l,c]) fimpara fimpara escreval("") escreval("") fimalgoritmo ******************************************************************************** ************************************************** 6. Faça um algoritmo que leia uma matriz mat 2 x 3 e imprima na tela a soma de todos os elementos da matriz mat.
  • 7. algoritmo "exercicio_06" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var l,c,total:inteiro numeros:vetor[1..2,1..3] de inteiro inicio // Seção de Comandos total<-0 para l de 1 ate 2 faca para c de 1 ate 3 faca escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(numeros[l,c]) total<-total+numeros[l,c] fimpara fimpara limpatela para l de 1 ate 2 faca escreval("") para c de 1 ate 3 faca escreva(numeros[l,c]) fimpara fimpara escreval("") escreval("") escreva("A soma da Matriz é: ",total) escreval("") escreval("") fimalgoritmo ******************************************************************************** ************************************************** 7. Dado uma matriz de 4x5 elementos, escreva um algoritmo para calcular a soma de cada uma das linhas. algoritmo "exercicio_07" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015
  • 8. // Seção de Declarações var l,c,total:inteiro numeros:vetor[1..4,1..5] de inteiro inicio // Seção de Comandos para l de 1 ate 4 faca para c de 1 ate 5 faca escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(numeros[l,c]) fimpara fimpara limpatela para l de 1 ate 4 faca escreval("") para c de 1 ate 5 faca escreva(numeros[l,c]) fimpara fimpara escreval("") escreval("") para l de 1 ate 4 faca total<-0; para c de 1 ate 5 faca total<-total+numeros[l,c] fimpara escreval("A soma da linha: ",l," = ",total) fimpara fimalgoritmo ******************************************************************************** ************************************************** 8. Escreva um algoritmo para ler uma matriz de 3 linhas e 2 colunas, e determine o maior valor contido na matriz e imprima este valor e sua posição na matriz. algoritmo "exercicio_08" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var l,c,maior:inteiro numeros:vetor[1..3,1..2] de inteiro linha,coluna:inteiro
  • 9. inicio // Seção de Comandos para l de 1 ate 3 faca para c de 1 ate 2 faca escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(numeros[l,c]) fimpara fimpara maior<-0 para l de 1 ate 3 faca para c de 1 ate 2 faca se numeros[l,c]>maior entao maior<-numeros[l,c] linha<-l coluna<-c fimse fimpara fimpara escreval("O numero: ",maior," Na posicão: ",linha,"-",coluna," É o maior") fimalgoritmo ******************************************************************************** ************************************************** 9. Escreva um algoritmo para ler uma matriz 4x3 e imprima sua diagonal principal. algoritmo "exercicio_09" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var l,c:inteiro numeros:vetor[1..4,1..3] de inteiro inicio // Seção de Comandos para l de 1 ate 4 faca para c de 1 ate 3 faca escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(numeros[l,c]) fimpara fimpara para l de 1 ate 4 faca para c de 1 ate 3 faca se l=c entao escreval("Diagonal Principal: ",numeros[l,c])
  • 10. fimse fimpara fimpara fimalgoritmo ******************************************************************************** ************************************************** 10. Elabore um algoritmo para ler uma matriz 3x4 e apresente somente os valores acima e abaixo da diagonal principal. algoritmo "exercicio_10" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var l,c:inteiro numeros:vetor[1..3,1..4] de inteiro inicio // Seção de Comandos para l de 1 ate 3 faca para c de 1 ate 4 faca escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(numeros[l,c]) fimpara fimpara para l de 1 ate 3 faca para c de 1 ate 4 faca se l<c entao escreval("Diagonal Superior: ",numeros[l,c]) fimse fimpara fimpara para l de 1 ate 3 faca para c de 1 ate 4 faca se l>c entao escreval("Diagonal Inferior: ",numeros[l,c]) fimse fimpara fimpara fimalgoritmo ******************************************************************************** **************************************************