SlideShare uma empresa Scribd logo
1. Faça um algoritmo que copie o conteúdo de um vetor em um segundo vetor.
algoritmo "exercicio_01"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
i:inteiro
vetA:vetor[1..5] de inteiro
vetB:vetor[1..5] de inteiro
inicio
// Seção de Comandos
// VETOR A
para i de 1 ate 5 faca
escreval("VETOR A")
escreva("Informe o valor da posicao: ",i,": ")
leia(vetA[i])
fimpara
limpatela
// COPIA VETOR A PARA VETOR B
para i de 1 ate 5 faca
vetB[i]<-vetA[i]
fimpara
//APRESENTANDO VETOR A
escreval("VETOR A")
escreval("")
para i de 1 ate 5 faca
escreval(vetA[i])
fimpara
//APRESENTANDO VETOR B
escreval("")
escreval("VETOR B")
escreval("")
para i de 1 ate 5 faca
escreval(vetB[i])
fimpara
fimalgoritmo
********************************************************************************
**************************************************
2. Faça um algoritmo que some o conteúdo de dois vetores e armazene o resultado
em um terceiro vetor.
algoritmo "exercicio_02"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
i:inteiro
vetA:vetor[1..5] de inteiro
vetB:vetor[1..5] de inteiro
vetC:vetor[1..5] de inteiro
inicio
// Seção de Comandos
// VETOR A
para i de 1 ate 5 faca
escreval("VETOR A")
escreva("Informe o valor da posicao: ",i,": ")
leia(vetA[i])
fimpara
limpatela
// VETOR B
para i de 1 ate 5 faca
escreval("VETOR B")
escreva("Informe o valor da posicao: ",i,": ")
leia(vetB[i])
fimpara
limpatela
// VETOR C
para i de 1 ate 5 faca
vetC[i]<-vetA[i]+vetB[i]
fimpara
//APRESENTANDO VETOR A
escreval("VETOR A")
para i de 1 ate 5 faca
escreval(vetA[i])
fimpara
escreval("")
escreval("")
//APRESENTANDO VETOR B
escreval("VETOR B")
para i de 1 ate 5 faca
escreval(vetB[i])
fimpara
escreval("")
escreval("")
//APRESENTANDO SOMA DOS VETORES
escreval("SOMA DOS VETORES A e B")
para i de 1 ate 5 faca
escreval(vetC[i])
fimpara
escreval("")
escreval("")
fimalgoritmo
********************************************************************************
**************************************************
3. Faça um algoritmo que faça a união de dois vetores de mesmo tamanho e mesmo
tipo em um terceiro vetor com dobro do tamanho.
algoritmo "exercicio_03"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
i:inteiro
vetA:vetor[1..3] de inteiro
vetB:vetor[1..3] de inteiro
vetC:vetor[1..6] de inteiro
inicio
// Seção de Comandos
// VETOR A
para i de 1 ate 3 faca
escreval("VETOR A")
escreva("Informe o valor da posicao: ",i,": ")
leia(vetA[i])
fimpara
limpatela
// VETOR B
para i de 1 ate 3 faca
escreval("VETOR B")
escreva("Informe o valor da posicao: ",i,": ")
leia(vetB[i])
fimpara
limpatela
// UNIAO DOS VETORORES A e B
// VETOR C
para i de 1 ate 3 faca
se vetA[i] <> vetB[i] entao
vetC[i] <- vetA[i]
vetC[i+3]<-vetB[i]
senao
vetC[i] <- vetA[i]
fimse
fimpara
escreval("VETOR A")
para i de 1 ate 3 faca
escreval(vetA[i])
fimpara
escreval("")
escreval("")
escreval("VETOR B")
para i de 1 ate 3 faca
escreval(vetB[i])
fimpara
escreval("")
escreval("")
escreval("UNIAO DOS VETORES A e B")
para i de 1 ate 6 faca
escreval(vetC[i])
fimpara
escreval("")
escreval("")
fimalgoritmo
********************************************************************************
**************************************************
4. Faça um algoritmo que leia um vetor de 20 posições a apresente o maior e o
menor valor e as posições que eles se encontram.
algoritmo "exercicio_04"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
i,maior,menor,posicaomaior,posicaomenor:inteiro
numeros:vetor[1..20] de inteiro
inicio
// Seção de Comandos
para i de 1 ate 20 faca
escreva("Informe o valor da posicao: ",i,": ")
leia(numeros[i])
se i=1 entao
maior<-numeros[i]
menor<-numeros[i]
fimse
se numeros[i]>maior entao
maior<-numeros[i]
posicaomaior<-i
fimse
se numeros[i]<menor entao
menor<-numeros[i]
posicaomenor<-i
fimse
fimpara
escreval("")
escreval("")
escreval("O maior numero é o: ",maior," Na posicão: ",posicaomaior)
escreval("O menor numero é o: ",menor," Na posicão: ",posicaomenor)
fimalgoritmo
********************************************************************************
**************************************************
5. Faça um algoritmo para somar duas matrizes.
algoritmo "exercicio_05"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
l,c:inteiro
matrizA:vetor[1..3,1..3] de inteiro
matrizB:vetor[1..3,1..3] de inteiro
matrizC:vetor[1..3,1..3] de inteiro
inicio
// Seção de Comandos
// MATRIZ A
para l de 1 ate 3 faca
para c de 1 ate 3 faca
escreval("MATRIZ A")
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(matrizA[l,c])
limpatela
fimpara
fimpara
limpatela
// MATRIZ B
para l de 1 ate 3 faca
para c de 1 ate 3 faca
escreval("MATRIZ B")
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(matrizB[l,c])
limpatela
fimpara
fimpara
limpatela
// MATRIZ C
para l de 1 ate 3 faca
para c de 1 ate 3 faca
matrizC[l,c]<-matrizA[l,c]+matrizB[l,c]
fimpara
fimpara
escreval("MATRIZ A")
para l de 1 ate 3 faca
escreval("")
para c de 1 ate 3 faca
escreva(matrizA[l,c])
fimpara
fimpara
escreval("")
escreval("")
escreval("MATRIZ B")
para l de 1 ate 3 faca
escreval("")
para c de 1 ate 3 faca
escreva(matrizB[l,c])
fimpara
fimpara
escreval("")
escreval("")
escreval("A SOMA DAS MATRIZES A e B")
para l de 1 ate 3 faca
escreval("")
para c de 1 ate 3 faca
escreva(matrizC[l,c])
fimpara
fimpara
escreval("")
escreval("")
fimalgoritmo
********************************************************************************
**************************************************
6. Faça um algoritmo que leia uma matriz mat 2 x 3 e imprima na tela a soma de
todos os elementos da matriz mat.
algoritmo "exercicio_06"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
l,c,total:inteiro
numeros:vetor[1..2,1..3] de inteiro
inicio
// Seção de Comandos
total<-0
para l de 1 ate 2 faca
para c de 1 ate 3 faca
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(numeros[l,c])
total<-total+numeros[l,c]
fimpara
fimpara
limpatela
para l de 1 ate 2 faca
escreval("")
para c de 1 ate 3 faca
escreva(numeros[l,c])
fimpara
fimpara
escreval("")
escreval("")
escreva("A soma da Matriz é: ",total)
escreval("")
escreval("")
fimalgoritmo
********************************************************************************
**************************************************
7. Dado uma matriz de 4x5 elementos, escreva um algoritmo para calcular a soma
de cada uma das linhas.
algoritmo "exercicio_07"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
l,c,total:inteiro
numeros:vetor[1..4,1..5] de inteiro
inicio
// Seção de Comandos
para l de 1 ate 4 faca
para c de 1 ate 5 faca
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(numeros[l,c])
fimpara
fimpara
limpatela
para l de 1 ate 4 faca
escreval("")
para c de 1 ate 5 faca
escreva(numeros[l,c])
fimpara
fimpara
escreval("")
escreval("")
para l de 1 ate 4 faca
total<-0;
para c de 1 ate 5 faca
total<-total+numeros[l,c]
fimpara
escreval("A soma da linha: ",l," = ",total)
fimpara
fimalgoritmo
********************************************************************************
**************************************************
8. Escreva um algoritmo para ler uma matriz de 3 linhas e 2 colunas, e determine
o maior valor contido na matriz e imprima este valor e sua posição na matriz.
algoritmo "exercicio_08"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
l,c,maior:inteiro
numeros:vetor[1..3,1..2] de inteiro
linha,coluna:inteiro
inicio
// Seção de Comandos
para l de 1 ate 3 faca
para c de 1 ate 2 faca
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(numeros[l,c])
fimpara
fimpara
maior<-0
para l de 1 ate 3 faca
para c de 1 ate 2 faca
se numeros[l,c]>maior entao
maior<-numeros[l,c]
linha<-l
coluna<-c
fimse
fimpara
fimpara
escreval("O numero: ",maior," Na posicão: ",linha,"-",coluna," É o maior")
fimalgoritmo
********************************************************************************
**************************************************
9. Escreva um algoritmo para ler uma matriz 4x3 e imprima sua diagonal
principal.
algoritmo "exercicio_09"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
l,c:inteiro
numeros:vetor[1..4,1..3] de inteiro
inicio
// Seção de Comandos
para l de 1 ate 4 faca
para c de 1 ate 3 faca
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(numeros[l,c])
fimpara
fimpara
para l de 1 ate 4 faca
para c de 1 ate 3 faca
se l=c entao
escreval("Diagonal Principal: ",numeros[l,c])
fimse
fimpara
fimpara
fimalgoritmo
********************************************************************************
**************************************************
10. Elabore um algoritmo para ler uma matriz 3x4 e apresente somente os valores
acima e abaixo da diagonal principal.
algoritmo "exercicio_10"
// Função : Laço de Repetição
// Autor : Willians Miyabara (miyabara@hotmail.com)
// Graduando em Sistemas de Informação.
// UFMT - Universidade Federal de Mato Grosso
// Data : 18/2/2015
// Seção de Declarações
var
l,c:inteiro
numeros:vetor[1..3,1..4] de inteiro
inicio
// Seção de Comandos
para l de 1 ate 3 faca
para c de 1 ate 4 faca
escreva("Informe o valor da posicao: ",l,"-",c,": ")
leia(numeros[l,c])
fimpara
fimpara
para l de 1 ate 3 faca
para c de 1 ate 4 faca
se l<c entao
escreval("Diagonal Superior: ",numeros[l,c])
fimse
fimpara
fimpara
para l de 1 ate 3 faca
para c de 1 ate 4 faca
se l>c entao
escreval("Diagonal Inferior: ",numeros[l,c])
fimse
fimpara
fimpara
fimalgoritmo
********************************************************************************
**************************************************

Mais conteúdo relacionado

Mais procurados

Exercicios resolvidos algoritmos
Exercicios resolvidos algoritmosExercicios resolvidos algoritmos
Exercicios resolvidos algoritmos
Débora Inocêncio
 
Lista de exercícios resolvidos
Lista de exercícios resolvidosLista de exercícios resolvidos
Lista de exercícios resolvidos
Crishna Irion
 
Lista de exercicios algoritmos com pseudocodigo
Lista de exercicios   algoritmos com pseudocodigoLista de exercicios   algoritmos com pseudocodigo
Lista de exercicios algoritmos com pseudocodigo
Mauro Pereira
 
Alguns algoritmos resolvidos
Alguns algoritmos resolvidosAlguns algoritmos resolvidos
Alguns algoritmos resolvidos
jaoozinhoqi123
 
Algoritmos - Aula 05 B - Correcao de Exercicios
Algoritmos - Aula 05 B - Correcao de ExerciciosAlgoritmos - Aula 05 B - Correcao de Exercicios
Algoritmos - Aula 05 B - Correcao de Exercicios
Rodrigo Kiyoshi Saito
 
Fluxograma (Lógica de Programação)
Fluxograma (Lógica de Programação)Fluxograma (Lógica de Programação)
Fluxograma (Lógica de Programação)
Gercélia Ramos
 
Algoritmos - Formas de Representação de Algoritmos
Algoritmos - Formas de Representação de AlgoritmosAlgoritmos - Formas de Representação de Algoritmos
Algoritmos - Formas de Representação de Algoritmos
Elaine Cecília Gatto
 
Variáveis e portugol
Variáveis e portugolVariáveis e portugol
Variáveis e portugol
Carlos Wagner Costa
 
Estrutura de repetição
Estrutura de repetiçãoEstrutura de repetição
Estrutura de repetição
Jailson Torquato
 
Algoritmos - Lógica de Programação
Algoritmos - Lógica de ProgramaçãoAlgoritmos - Lógica de Programação
Algoritmos - Lógica de Programação
Elaine Cecília Gatto
 
Lista de exercícios em portugol
Lista de exercícios em portugolLista de exercícios em portugol
Lista de exercícios em portugol
Gabriel Faustino
 
Algoritmos - Aula 05 A - Correcao de Exercicios
Algoritmos - Aula 05 A - Correcao de ExerciciosAlgoritmos - Aula 05 A - Correcao de Exercicios
Algoritmos - Aula 05 A - Correcao de Exercicios
Rodrigo Kiyoshi Saito
 
Introdução a linguagem C# (CSharp)
Introdução a linguagem C# (CSharp)Introdução a linguagem C# (CSharp)
Introdução a linguagem C# (CSharp)
Marcos Castro
 
Aula 02 - Escolha caso
Aula 02 - Escolha casoAula 02 - Escolha caso
Aula 02 - Escolha caso
Eder Samaniego
 
Material de Apoio de Algoritmo e Lógica de Programação
Material de Apoio de Algoritmo e Lógica de ProgramaçãoMaterial de Apoio de Algoritmo e Lógica de Programação
Material de Apoio de Algoritmo e Lógica de Programação
rodfernandes
 
Variaveis
VariaveisVariaveis
Variaveis
Sedu
 
Aula 3 algoritmos
Aula 3   algoritmosAula 3   algoritmos
Aula 3 algoritmos
Patrick_turma10
 
Algoritmos - Pseudocódigo
Algoritmos - PseudocódigoAlgoritmos - Pseudocódigo
Algoritmos - Pseudocódigo
Elaine Cecília Gatto
 
Algoritmos - Vetores
Algoritmos - VetoresAlgoritmos - Vetores
Algoritmos - Vetores
Elaine Cecília Gatto
 
Linguagem C - Vetores
Linguagem C - VetoresLinguagem C - Vetores
Linguagem C - Vetores
Elaine Cecília Gatto
 

Mais procurados (20)

Exercicios resolvidos algoritmos
Exercicios resolvidos algoritmosExercicios resolvidos algoritmos
Exercicios resolvidos algoritmos
 
Lista de exercícios resolvidos
Lista de exercícios resolvidosLista de exercícios resolvidos
Lista de exercícios resolvidos
 
Lista de exercicios algoritmos com pseudocodigo
Lista de exercicios   algoritmos com pseudocodigoLista de exercicios   algoritmos com pseudocodigo
Lista de exercicios algoritmos com pseudocodigo
 
Alguns algoritmos resolvidos
Alguns algoritmos resolvidosAlguns algoritmos resolvidos
Alguns algoritmos resolvidos
 
Algoritmos - Aula 05 B - Correcao de Exercicios
Algoritmos - Aula 05 B - Correcao de ExerciciosAlgoritmos - Aula 05 B - Correcao de Exercicios
Algoritmos - Aula 05 B - Correcao de Exercicios
 
Fluxograma (Lógica de Programação)
Fluxograma (Lógica de Programação)Fluxograma (Lógica de Programação)
Fluxograma (Lógica de Programação)
 
Algoritmos - Formas de Representação de Algoritmos
Algoritmos - Formas de Representação de AlgoritmosAlgoritmos - Formas de Representação de Algoritmos
Algoritmos - Formas de Representação de Algoritmos
 
Variáveis e portugol
Variáveis e portugolVariáveis e portugol
Variáveis e portugol
 
Estrutura de repetição
Estrutura de repetiçãoEstrutura de repetição
Estrutura de repetição
 
Algoritmos - Lógica de Programação
Algoritmos - Lógica de ProgramaçãoAlgoritmos - Lógica de Programação
Algoritmos - Lógica de Programação
 
Lista de exercícios em portugol
Lista de exercícios em portugolLista de exercícios em portugol
Lista de exercícios em portugol
 
Algoritmos - Aula 05 A - Correcao de Exercicios
Algoritmos - Aula 05 A - Correcao de ExerciciosAlgoritmos - Aula 05 A - Correcao de Exercicios
Algoritmos - Aula 05 A - Correcao de Exercicios
 
Introdução a linguagem C# (CSharp)
Introdução a linguagem C# (CSharp)Introdução a linguagem C# (CSharp)
Introdução a linguagem C# (CSharp)
 
Aula 02 - Escolha caso
Aula 02 - Escolha casoAula 02 - Escolha caso
Aula 02 - Escolha caso
 
Material de Apoio de Algoritmo e Lógica de Programação
Material de Apoio de Algoritmo e Lógica de ProgramaçãoMaterial de Apoio de Algoritmo e Lógica de Programação
Material de Apoio de Algoritmo e Lógica de Programação
 
Variaveis
VariaveisVariaveis
Variaveis
 
Aula 3 algoritmos
Aula 3   algoritmosAula 3   algoritmos
Aula 3 algoritmos
 
Algoritmos - Pseudocódigo
Algoritmos - PseudocódigoAlgoritmos - Pseudocódigo
Algoritmos - Pseudocódigo
 
Algoritmos - Vetores
Algoritmos - VetoresAlgoritmos - Vetores
Algoritmos - Vetores
 
Linguagem C - Vetores
Linguagem C - VetoresLinguagem C - Vetores
Linguagem C - Vetores
 

Destaque

Algoritmo 06 - Array e Matrizes
Algoritmo 06 - Array e MatrizesAlgoritmo 06 - Array e Matrizes
Algoritmo 06 - Array e Matrizes
Professor Samuel Ribeiro
 
Aula 5 aed - vetores
Aula 5   aed - vetoresAula 5   aed - vetores
Aula 5 aed - vetores
Elaine Cecília Gatto
 
Exercicio Vetores Pascal
Exercicio Vetores PascalExercicio Vetores Pascal
Exercicio Vetores Pascal
Marcus Vinicius
 
Exercicio Matrizes Pascal
Exercicio Matrizes PascalExercicio Matrizes Pascal
Exercicio Matrizes Pascal
Marcus Vinicius
 
Sessão 6. Cenários de Aprendizagem
Sessão 6. Cenários de Aprendizagem  Sessão 6. Cenários de Aprendizagem
Sessão 6. Cenários de Aprendizagem
Fernanda Ledesma
 
Historias & cenarios de aprendizagem
Historias & cenarios de aprendizagemHistorias & cenarios de aprendizagem
Historias & cenarios de aprendizagem
Fernando Rui Campos
 

Destaque (6)

Algoritmo 06 - Array e Matrizes
Algoritmo 06 - Array e MatrizesAlgoritmo 06 - Array e Matrizes
Algoritmo 06 - Array e Matrizes
 
Aula 5 aed - vetores
Aula 5   aed - vetoresAula 5   aed - vetores
Aula 5 aed - vetores
 
Exercicio Vetores Pascal
Exercicio Vetores PascalExercicio Vetores Pascal
Exercicio Vetores Pascal
 
Exercicio Matrizes Pascal
Exercicio Matrizes PascalExercicio Matrizes Pascal
Exercicio Matrizes Pascal
 
Sessão 6. Cenários de Aprendizagem
Sessão 6. Cenários de Aprendizagem  Sessão 6. Cenários de Aprendizagem
Sessão 6. Cenários de Aprendizagem
 
Historias & cenarios de aprendizagem
Historias & cenarios de aprendizagemHistorias & cenarios de aprendizagem
Historias & cenarios de aprendizagem
 

Semelhante a Exercicios resolvidos visu alg vetores

Alg aula 07 - matrizes tp1
Alg   aula 07 - matrizes tp1Alg   aula 07 - matrizes tp1
Alg aula 07 - matrizes tp1
Thalles Anderson
 
Filtro_matlab_toobox
Filtro_matlab_tooboxFiltro_matlab_toobox
Filtro_matlab_toobox
Diego Menezes
 
Linguagem c wellington telles - aula 06
Linguagem c   wellington telles - aula 06Linguagem c   wellington telles - aula 06
Linguagem c wellington telles - aula 06
profwtelles
 
Introdução ao Octave
Introdução ao OctaveIntrodução ao Octave
Introdução ao Octave
PeslPinguim
 
095 A 134 Material Auxiliar Para Curso AvançAdo I Msp430
095 A 134   Material Auxiliar Para Curso AvançAdo I Msp430095 A 134   Material Auxiliar Para Curso AvançAdo I Msp430
095 A 134 Material Auxiliar Para Curso AvançAdo I Msp430
Texas Instruments
 
Introdução a Linguagem C
Introdução a Linguagem CIntrodução a Linguagem C
Introdução a Linguagem C
apolllorj
 
Algoritmos - Aula 13 B - Vetores em C
Algoritmos - Aula 13 B - Vetores em CAlgoritmos - Aula 13 B - Vetores em C
Algoritmos - Aula 13 B - Vetores em C
Rodrigo Kiyoshi Saito
 
C aula introdutoria, programacao iniciante.ppt
C aula introdutoria, programacao iniciante.pptC aula introdutoria, programacao iniciante.ppt
C aula introdutoria, programacao iniciante.ppt
MuriloSilvaSantana2
 
Algop - aula 04 pascal 1
Algop - aula 04 pascal 1Algop - aula 04 pascal 1
Algop - aula 04 pascal 1
Thiago Toscano Ferrari
 
Algoritmos e LP - Aula 09 - Linguagem C - p2.pdf
Algoritmos e LP - Aula 09 - Linguagem C - p2.pdfAlgoritmos e LP - Aula 09 - Linguagem C - p2.pdf
Algoritmos e LP - Aula 09 - Linguagem C - p2.pdf
Enio Filho
 
Lista de exercício
Lista de exercício   Lista de exercício
Lista de exercício
Jota Thin
 
PCA - Aula4 de programação - Estruturas repeticao.pdf
PCA - Aula4 de programação - Estruturas repeticao.pdfPCA - Aula4 de programação - Estruturas repeticao.pdf
PCA - Aula4 de programação - Estruturas repeticao.pdf
jucimarengenh
 
Introdução ao c++
Introdução ao c++Introdução ao c++
Introdução ao c++
Jonas Silva
 
Aula6 programação
Aula6 programaçãoAula6 programação
Aula6 programação
IFPB
 
3 vetor.matriz
3 vetor.matriz3 vetor.matriz
3 vetor.matriz
profwtelles
 
Matlab – curso básico (1)
Matlab – curso básico (1)Matlab – curso básico (1)
Matlab – curso básico (1)
Felipe Meganha
 
Apostila C++
Apostila C++ Apostila C++
Apostila C++
Fernando Palma
 
5423 c ou c++
5423 c ou c++5423 c ou c++
5423 c ou c++
Lucas Júnio
 
C ou c++
C ou c++C ou c++
C ou c++
Jônatas Amin
 
C++ basico
C++ basicoC++ basico
C++ basico
Rui Duarte
 

Semelhante a Exercicios resolvidos visu alg vetores (20)

Alg aula 07 - matrizes tp1
Alg   aula 07 - matrizes tp1Alg   aula 07 - matrizes tp1
Alg aula 07 - matrizes tp1
 
Filtro_matlab_toobox
Filtro_matlab_tooboxFiltro_matlab_toobox
Filtro_matlab_toobox
 
Linguagem c wellington telles - aula 06
Linguagem c   wellington telles - aula 06Linguagem c   wellington telles - aula 06
Linguagem c wellington telles - aula 06
 
Introdução ao Octave
Introdução ao OctaveIntrodução ao Octave
Introdução ao Octave
 
095 A 134 Material Auxiliar Para Curso AvançAdo I Msp430
095 A 134   Material Auxiliar Para Curso AvançAdo I Msp430095 A 134   Material Auxiliar Para Curso AvançAdo I Msp430
095 A 134 Material Auxiliar Para Curso AvançAdo I Msp430
 
Introdução a Linguagem C
Introdução a Linguagem CIntrodução a Linguagem C
Introdução a Linguagem C
 
Algoritmos - Aula 13 B - Vetores em C
Algoritmos - Aula 13 B - Vetores em CAlgoritmos - Aula 13 B - Vetores em C
Algoritmos - Aula 13 B - Vetores em C
 
C aula introdutoria, programacao iniciante.ppt
C aula introdutoria, programacao iniciante.pptC aula introdutoria, programacao iniciante.ppt
C aula introdutoria, programacao iniciante.ppt
 
Algop - aula 04 pascal 1
Algop - aula 04 pascal 1Algop - aula 04 pascal 1
Algop - aula 04 pascal 1
 
Algoritmos e LP - Aula 09 - Linguagem C - p2.pdf
Algoritmos e LP - Aula 09 - Linguagem C - p2.pdfAlgoritmos e LP - Aula 09 - Linguagem C - p2.pdf
Algoritmos e LP - Aula 09 - Linguagem C - p2.pdf
 
Lista de exercício
Lista de exercício   Lista de exercício
Lista de exercício
 
PCA - Aula4 de programação - Estruturas repeticao.pdf
PCA - Aula4 de programação - Estruturas repeticao.pdfPCA - Aula4 de programação - Estruturas repeticao.pdf
PCA - Aula4 de programação - Estruturas repeticao.pdf
 
Introdução ao c++
Introdução ao c++Introdução ao c++
Introdução ao c++
 
Aula6 programação
Aula6 programaçãoAula6 programação
Aula6 programação
 
3 vetor.matriz
3 vetor.matriz3 vetor.matriz
3 vetor.matriz
 
Matlab – curso básico (1)
Matlab – curso básico (1)Matlab – curso básico (1)
Matlab – curso básico (1)
 
Apostila C++
Apostila C++ Apostila C++
Apostila C++
 
5423 c ou c++
5423 c ou c++5423 c ou c++
5423 c ou c++
 
C ou c++
C ou c++C ou c++
C ou c++
 
C++ basico
C++ basicoC++ basico
C++ basico
 

Último

Tabela Funções Orgânicas.pdfnsknsknksnksn nkasn
Tabela Funções Orgânicas.pdfnsknsknksnksn nkasnTabela Funções Orgânicas.pdfnsknsknksnksn nkasn
Tabela Funções Orgânicas.pdfnsknsknksnksn nkasn
CarlosJean21
 
O século XVII e o nascimento da pedagogia.pptx
O século XVII e o nascimento da pedagogia.pptxO século XVII e o nascimento da pedagogia.pptx
O século XVII e o nascimento da pedagogia.pptx
geiseortiz1
 
planejamento maternal 2 atualizado.pdf e
planejamento maternal 2 atualizado.pdf eplanejamento maternal 2 atualizado.pdf e
planejamento maternal 2 atualizado.pdf e
HelenStefany
 
PP Slides Lição 11, Betel, Ordenança para exercer a fé, 2Tr24.pptx
PP Slides Lição 11, Betel, Ordenança para exercer a fé, 2Tr24.pptxPP Slides Lição 11, Betel, Ordenança para exercer a fé, 2Tr24.pptx
PP Slides Lição 11, Betel, Ordenança para exercer a fé, 2Tr24.pptx
LuizHenriquedeAlmeid6
 
Pedagogia universitária em ciência e tecnologia
Pedagogia universitária em ciência e tecnologiaPedagogia universitária em ciência e tecnologia
Pedagogia universitária em ciência e tecnologia
Nertan Dias
 
cidadas 5° ano - ensino fundamental 2 ..
cidadas 5° ano - ensino fundamental 2 ..cidadas 5° ano - ensino fundamental 2 ..
cidadas 5° ano - ensino fundamental 2 ..
MatheusSousa716350
 
Roteiro para análise do Livro Didático.pptx
Roteiro para análise do Livro Didático.pptxRoteiro para análise do Livro Didático.pptx
Roteiro para análise do Livro Didático.pptx
pamellaaraujo10
 
Caça-palavaras e cruzadinha - Dígrafos.
Caça-palavaras  e cruzadinha  - Dígrafos.Caça-palavaras  e cruzadinha  - Dígrafos.
Caça-palavaras e cruzadinha - Dígrafos.
Mary Alvarenga
 
Psicologia e Sociologia - Módulo 2 – Sociedade e indivíduo.pptx
Psicologia e Sociologia - Módulo 2 – Sociedade e indivíduo.pptxPsicologia e Sociologia - Módulo 2 – Sociedade e indivíduo.pptx
Psicologia e Sociologia - Módulo 2 – Sociedade e indivíduo.pptx
TiagoLouro8
 
UFCD_6580_Cuidados na saúde a populações mais vulneráveis_índice.pdf
UFCD_6580_Cuidados na saúde a populações mais vulneráveis_índice.pdfUFCD_6580_Cuidados na saúde a populações mais vulneráveis_índice.pdf
UFCD_6580_Cuidados na saúde a populações mais vulneráveis_índice.pdf
Manuais Formação
 
PALAVRA SECRETA - ALFABETIZAÇÃO- REFORÇO
PALAVRA SECRETA - ALFABETIZAÇÃO- REFORÇOPALAVRA SECRETA - ALFABETIZAÇÃO- REFORÇO
PALAVRA SECRETA - ALFABETIZAÇÃO- REFORÇO
ARIADNEMARTINSDACRUZ
 
-Rudolf-Laban-e-a-teoria-do-movimento.ppt
-Rudolf-Laban-e-a-teoria-do-movimento.ppt-Rudolf-Laban-e-a-teoria-do-movimento.ppt
-Rudolf-Laban-e-a-teoria-do-movimento.ppt
fagnerlopes11
 
UFCD_3546_Prevenção e primeiros socorros_geriatria.pdf
UFCD_3546_Prevenção e primeiros socorros_geriatria.pdfUFCD_3546_Prevenção e primeiros socorros_geriatria.pdf
UFCD_3546_Prevenção e primeiros socorros_geriatria.pdf
Manuais Formação
 
Telepsiquismo Utilize seu poder extrassensorial para atrair prosperidade (Jos...
Telepsiquismo Utilize seu poder extrassensorial para atrair prosperidade (Jos...Telepsiquismo Utilize seu poder extrassensorial para atrair prosperidade (Jos...
Telepsiquismo Utilize seu poder extrassensorial para atrair prosperidade (Jos...
fran0410
 
Exercicios de Word Básico para a aulas de informatica Basica
Exercicios de Word Básico para a aulas de informatica BasicaExercicios de Word Básico para a aulas de informatica Basica
Exercicios de Word Básico para a aulas de informatica Basica
ElinarioCosta
 
O Mito da Caverna de Platão_ Uma Jornada em Busca da Verdade.pdf
O Mito da Caverna de Platão_ Uma Jornada em Busca da Verdade.pdfO Mito da Caverna de Platão_ Uma Jornada em Busca da Verdade.pdf
O Mito da Caverna de Platão_ Uma Jornada em Busca da Verdade.pdf
silvamelosilva300
 
TREINAMENTO DE BRIGADA DE INCENDIO BRIGADA CCB 2023.pptx
TREINAMENTO DE BRIGADA DE INCENDIO BRIGADA CCB 2023.pptxTREINAMENTO DE BRIGADA DE INCENDIO BRIGADA CCB 2023.pptx
TREINAMENTO DE BRIGADA DE INCENDIO BRIGADA CCB 2023.pptx
erssstcontato
 
Aula 1 - Ordem Mundial Aula de Geografia
Aula 1 - Ordem Mundial Aula de GeografiaAula 1 - Ordem Mundial Aula de Geografia
Aula 1 - Ordem Mundial Aula de Geografia
WELTONROBERTOFREITAS
 
Resumo de Química 10º ano Estudo exames nacionais
Resumo de Química 10º ano Estudo exames nacionaisResumo de Química 10º ano Estudo exames nacionais
Resumo de Química 10º ano Estudo exames nacionais
beatrizsilva525654
 
Cartinhas de solidariedade e esperança.pptx
Cartinhas de solidariedade e esperança.pptxCartinhas de solidariedade e esperança.pptx
Cartinhas de solidariedade e esperança.pptx
Zenir Carmen Bez Trombeta
 

Último (20)

Tabela Funções Orgânicas.pdfnsknsknksnksn nkasn
Tabela Funções Orgânicas.pdfnsknsknksnksn nkasnTabela Funções Orgânicas.pdfnsknsknksnksn nkasn
Tabela Funções Orgânicas.pdfnsknsknksnksn nkasn
 
O século XVII e o nascimento da pedagogia.pptx
O século XVII e o nascimento da pedagogia.pptxO século XVII e o nascimento da pedagogia.pptx
O século XVII e o nascimento da pedagogia.pptx
 
planejamento maternal 2 atualizado.pdf e
planejamento maternal 2 atualizado.pdf eplanejamento maternal 2 atualizado.pdf e
planejamento maternal 2 atualizado.pdf e
 
PP Slides Lição 11, Betel, Ordenança para exercer a fé, 2Tr24.pptx
PP Slides Lição 11, Betel, Ordenança para exercer a fé, 2Tr24.pptxPP Slides Lição 11, Betel, Ordenança para exercer a fé, 2Tr24.pptx
PP Slides Lição 11, Betel, Ordenança para exercer a fé, 2Tr24.pptx
 
Pedagogia universitária em ciência e tecnologia
Pedagogia universitária em ciência e tecnologiaPedagogia universitária em ciência e tecnologia
Pedagogia universitária em ciência e tecnologia
 
cidadas 5° ano - ensino fundamental 2 ..
cidadas 5° ano - ensino fundamental 2 ..cidadas 5° ano - ensino fundamental 2 ..
cidadas 5° ano - ensino fundamental 2 ..
 
Roteiro para análise do Livro Didático.pptx
Roteiro para análise do Livro Didático.pptxRoteiro para análise do Livro Didático.pptx
Roteiro para análise do Livro Didático.pptx
 
Caça-palavaras e cruzadinha - Dígrafos.
Caça-palavaras  e cruzadinha  - Dígrafos.Caça-palavaras  e cruzadinha  - Dígrafos.
Caça-palavaras e cruzadinha - Dígrafos.
 
Psicologia e Sociologia - Módulo 2 – Sociedade e indivíduo.pptx
Psicologia e Sociologia - Módulo 2 – Sociedade e indivíduo.pptxPsicologia e Sociologia - Módulo 2 – Sociedade e indivíduo.pptx
Psicologia e Sociologia - Módulo 2 – Sociedade e indivíduo.pptx
 
UFCD_6580_Cuidados na saúde a populações mais vulneráveis_índice.pdf
UFCD_6580_Cuidados na saúde a populações mais vulneráveis_índice.pdfUFCD_6580_Cuidados na saúde a populações mais vulneráveis_índice.pdf
UFCD_6580_Cuidados na saúde a populações mais vulneráveis_índice.pdf
 
PALAVRA SECRETA - ALFABETIZAÇÃO- REFORÇO
PALAVRA SECRETA - ALFABETIZAÇÃO- REFORÇOPALAVRA SECRETA - ALFABETIZAÇÃO- REFORÇO
PALAVRA SECRETA - ALFABETIZAÇÃO- REFORÇO
 
-Rudolf-Laban-e-a-teoria-do-movimento.ppt
-Rudolf-Laban-e-a-teoria-do-movimento.ppt-Rudolf-Laban-e-a-teoria-do-movimento.ppt
-Rudolf-Laban-e-a-teoria-do-movimento.ppt
 
UFCD_3546_Prevenção e primeiros socorros_geriatria.pdf
UFCD_3546_Prevenção e primeiros socorros_geriatria.pdfUFCD_3546_Prevenção e primeiros socorros_geriatria.pdf
UFCD_3546_Prevenção e primeiros socorros_geriatria.pdf
 
Telepsiquismo Utilize seu poder extrassensorial para atrair prosperidade (Jos...
Telepsiquismo Utilize seu poder extrassensorial para atrair prosperidade (Jos...Telepsiquismo Utilize seu poder extrassensorial para atrair prosperidade (Jos...
Telepsiquismo Utilize seu poder extrassensorial para atrair prosperidade (Jos...
 
Exercicios de Word Básico para a aulas de informatica Basica
Exercicios de Word Básico para a aulas de informatica BasicaExercicios de Word Básico para a aulas de informatica Basica
Exercicios de Word Básico para a aulas de informatica Basica
 
O Mito da Caverna de Platão_ Uma Jornada em Busca da Verdade.pdf
O Mito da Caverna de Platão_ Uma Jornada em Busca da Verdade.pdfO Mito da Caverna de Platão_ Uma Jornada em Busca da Verdade.pdf
O Mito da Caverna de Platão_ Uma Jornada em Busca da Verdade.pdf
 
TREINAMENTO DE BRIGADA DE INCENDIO BRIGADA CCB 2023.pptx
TREINAMENTO DE BRIGADA DE INCENDIO BRIGADA CCB 2023.pptxTREINAMENTO DE BRIGADA DE INCENDIO BRIGADA CCB 2023.pptx
TREINAMENTO DE BRIGADA DE INCENDIO BRIGADA CCB 2023.pptx
 
Aula 1 - Ordem Mundial Aula de Geografia
Aula 1 - Ordem Mundial Aula de GeografiaAula 1 - Ordem Mundial Aula de Geografia
Aula 1 - Ordem Mundial Aula de Geografia
 
Resumo de Química 10º ano Estudo exames nacionais
Resumo de Química 10º ano Estudo exames nacionaisResumo de Química 10º ano Estudo exames nacionais
Resumo de Química 10º ano Estudo exames nacionais
 
Cartinhas de solidariedade e esperança.pptx
Cartinhas de solidariedade e esperança.pptxCartinhas de solidariedade e esperança.pptx
Cartinhas de solidariedade e esperança.pptx
 

Exercicios resolvidos visu alg vetores

  • 1. 1. Faça um algoritmo que copie o conteúdo de um vetor em um segundo vetor. algoritmo "exercicio_01" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var i:inteiro vetA:vetor[1..5] de inteiro vetB:vetor[1..5] de inteiro inicio // Seção de Comandos // VETOR A para i de 1 ate 5 faca escreval("VETOR A") escreva("Informe o valor da posicao: ",i,": ") leia(vetA[i]) fimpara limpatela // COPIA VETOR A PARA VETOR B para i de 1 ate 5 faca vetB[i]<-vetA[i] fimpara //APRESENTANDO VETOR A escreval("VETOR A") escreval("") para i de 1 ate 5 faca escreval(vetA[i]) fimpara //APRESENTANDO VETOR B escreval("") escreval("VETOR B") escreval("") para i de 1 ate 5 faca escreval(vetB[i]) fimpara fimalgoritmo ******************************************************************************** ************************************************** 2. Faça um algoritmo que some o conteúdo de dois vetores e armazene o resultado
  • 2. em um terceiro vetor. algoritmo "exercicio_02" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var i:inteiro vetA:vetor[1..5] de inteiro vetB:vetor[1..5] de inteiro vetC:vetor[1..5] de inteiro inicio // Seção de Comandos // VETOR A para i de 1 ate 5 faca escreval("VETOR A") escreva("Informe o valor da posicao: ",i,": ") leia(vetA[i]) fimpara limpatela // VETOR B para i de 1 ate 5 faca escreval("VETOR B") escreva("Informe o valor da posicao: ",i,": ") leia(vetB[i]) fimpara limpatela // VETOR C para i de 1 ate 5 faca vetC[i]<-vetA[i]+vetB[i] fimpara //APRESENTANDO VETOR A escreval("VETOR A") para i de 1 ate 5 faca escreval(vetA[i]) fimpara escreval("") escreval("") //APRESENTANDO VETOR B escreval("VETOR B") para i de 1 ate 5 faca escreval(vetB[i]) fimpara escreval("")
  • 3. escreval("") //APRESENTANDO SOMA DOS VETORES escreval("SOMA DOS VETORES A e B") para i de 1 ate 5 faca escreval(vetC[i]) fimpara escreval("") escreval("") fimalgoritmo ******************************************************************************** ************************************************** 3. Faça um algoritmo que faça a união de dois vetores de mesmo tamanho e mesmo tipo em um terceiro vetor com dobro do tamanho. algoritmo "exercicio_03" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var i:inteiro vetA:vetor[1..3] de inteiro vetB:vetor[1..3] de inteiro vetC:vetor[1..6] de inteiro inicio // Seção de Comandos // VETOR A para i de 1 ate 3 faca escreval("VETOR A") escreva("Informe o valor da posicao: ",i,": ") leia(vetA[i]) fimpara limpatela // VETOR B para i de 1 ate 3 faca escreval("VETOR B") escreva("Informe o valor da posicao: ",i,": ") leia(vetB[i]) fimpara limpatela // UNIAO DOS VETORORES A e B // VETOR C para i de 1 ate 3 faca se vetA[i] <> vetB[i] entao
  • 4. vetC[i] <- vetA[i] vetC[i+3]<-vetB[i] senao vetC[i] <- vetA[i] fimse fimpara escreval("VETOR A") para i de 1 ate 3 faca escreval(vetA[i]) fimpara escreval("") escreval("") escreval("VETOR B") para i de 1 ate 3 faca escreval(vetB[i]) fimpara escreval("") escreval("") escreval("UNIAO DOS VETORES A e B") para i de 1 ate 6 faca escreval(vetC[i]) fimpara escreval("") escreval("") fimalgoritmo ******************************************************************************** ************************************************** 4. Faça um algoritmo que leia um vetor de 20 posições a apresente o maior e o menor valor e as posições que eles se encontram. algoritmo "exercicio_04" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var i,maior,menor,posicaomaior,posicaomenor:inteiro numeros:vetor[1..20] de inteiro inicio // Seção de Comandos para i de 1 ate 20 faca escreva("Informe o valor da posicao: ",i,": ") leia(numeros[i])
  • 5. se i=1 entao maior<-numeros[i] menor<-numeros[i] fimse se numeros[i]>maior entao maior<-numeros[i] posicaomaior<-i fimse se numeros[i]<menor entao menor<-numeros[i] posicaomenor<-i fimse fimpara escreval("") escreval("") escreval("O maior numero é o: ",maior," Na posicão: ",posicaomaior) escreval("O menor numero é o: ",menor," Na posicão: ",posicaomenor) fimalgoritmo ******************************************************************************** ************************************************** 5. Faça um algoritmo para somar duas matrizes. algoritmo "exercicio_05" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var l,c:inteiro matrizA:vetor[1..3,1..3] de inteiro matrizB:vetor[1..3,1..3] de inteiro matrizC:vetor[1..3,1..3] de inteiro inicio // Seção de Comandos // MATRIZ A para l de 1 ate 3 faca para c de 1 ate 3 faca escreval("MATRIZ A") escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(matrizA[l,c]) limpatela fimpara fimpara limpatela // MATRIZ B para l de 1 ate 3 faca
  • 6. para c de 1 ate 3 faca escreval("MATRIZ B") escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(matrizB[l,c]) limpatela fimpara fimpara limpatela // MATRIZ C para l de 1 ate 3 faca para c de 1 ate 3 faca matrizC[l,c]<-matrizA[l,c]+matrizB[l,c] fimpara fimpara escreval("MATRIZ A") para l de 1 ate 3 faca escreval("") para c de 1 ate 3 faca escreva(matrizA[l,c]) fimpara fimpara escreval("") escreval("") escreval("MATRIZ B") para l de 1 ate 3 faca escreval("") para c de 1 ate 3 faca escreva(matrizB[l,c]) fimpara fimpara escreval("") escreval("") escreval("A SOMA DAS MATRIZES A e B") para l de 1 ate 3 faca escreval("") para c de 1 ate 3 faca escreva(matrizC[l,c]) fimpara fimpara escreval("") escreval("") fimalgoritmo ******************************************************************************** ************************************************** 6. Faça um algoritmo que leia uma matriz mat 2 x 3 e imprima na tela a soma de todos os elementos da matriz mat.
  • 7. algoritmo "exercicio_06" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var l,c,total:inteiro numeros:vetor[1..2,1..3] de inteiro inicio // Seção de Comandos total<-0 para l de 1 ate 2 faca para c de 1 ate 3 faca escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(numeros[l,c]) total<-total+numeros[l,c] fimpara fimpara limpatela para l de 1 ate 2 faca escreval("") para c de 1 ate 3 faca escreva(numeros[l,c]) fimpara fimpara escreval("") escreval("") escreva("A soma da Matriz é: ",total) escreval("") escreval("") fimalgoritmo ******************************************************************************** ************************************************** 7. Dado uma matriz de 4x5 elementos, escreva um algoritmo para calcular a soma de cada uma das linhas. algoritmo "exercicio_07" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015
  • 8. // Seção de Declarações var l,c,total:inteiro numeros:vetor[1..4,1..5] de inteiro inicio // Seção de Comandos para l de 1 ate 4 faca para c de 1 ate 5 faca escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(numeros[l,c]) fimpara fimpara limpatela para l de 1 ate 4 faca escreval("") para c de 1 ate 5 faca escreva(numeros[l,c]) fimpara fimpara escreval("") escreval("") para l de 1 ate 4 faca total<-0; para c de 1 ate 5 faca total<-total+numeros[l,c] fimpara escreval("A soma da linha: ",l," = ",total) fimpara fimalgoritmo ******************************************************************************** ************************************************** 8. Escreva um algoritmo para ler uma matriz de 3 linhas e 2 colunas, e determine o maior valor contido na matriz e imprima este valor e sua posição na matriz. algoritmo "exercicio_08" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var l,c,maior:inteiro numeros:vetor[1..3,1..2] de inteiro linha,coluna:inteiro
  • 9. inicio // Seção de Comandos para l de 1 ate 3 faca para c de 1 ate 2 faca escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(numeros[l,c]) fimpara fimpara maior<-0 para l de 1 ate 3 faca para c de 1 ate 2 faca se numeros[l,c]>maior entao maior<-numeros[l,c] linha<-l coluna<-c fimse fimpara fimpara escreval("O numero: ",maior," Na posicão: ",linha,"-",coluna," É o maior") fimalgoritmo ******************************************************************************** ************************************************** 9. Escreva um algoritmo para ler uma matriz 4x3 e imprima sua diagonal principal. algoritmo "exercicio_09" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var l,c:inteiro numeros:vetor[1..4,1..3] de inteiro inicio // Seção de Comandos para l de 1 ate 4 faca para c de 1 ate 3 faca escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(numeros[l,c]) fimpara fimpara para l de 1 ate 4 faca para c de 1 ate 3 faca se l=c entao escreval("Diagonal Principal: ",numeros[l,c])
  • 10. fimse fimpara fimpara fimalgoritmo ******************************************************************************** ************************************************** 10. Elabore um algoritmo para ler uma matriz 3x4 e apresente somente os valores acima e abaixo da diagonal principal. algoritmo "exercicio_10" // Função : Laço de Repetição // Autor : Willians Miyabara (miyabara@hotmail.com) // Graduando em Sistemas de Informação. // UFMT - Universidade Federal de Mato Grosso // Data : 18/2/2015 // Seção de Declarações var l,c:inteiro numeros:vetor[1..3,1..4] de inteiro inicio // Seção de Comandos para l de 1 ate 3 faca para c de 1 ate 4 faca escreva("Informe o valor da posicao: ",l,"-",c,": ") leia(numeros[l,c]) fimpara fimpara para l de 1 ate 3 faca para c de 1 ate 4 faca se l<c entao escreval("Diagonal Superior: ",numeros[l,c]) fimse fimpara fimpara para l de 1 ate 3 faca para c de 1 ate 4 faca se l>c entao escreval("Diagonal Inferior: ",numeros[l,c]) fimse fimpara fimpara fimalgoritmo ******************************************************************************** **************************************************