Algoritmo Estruturado

Prof. André Nobre
Tipos de Dados
• Opções que nunca irão mudar ao declarar
variáveis:
– Inteiros
– Reais;
– Caracteres;
– Lógicos;
Constantes e Variáveis
• Exemplos de declaração:
Var
Nome : Caractere;
Idade : Inteiro;
Media,N1,N2 : Real;
Status : Logic...
Constantes e Variáveis
• Exemplos de nomes Validos:
• nome1
• informacao
•x
• N_41
• resp_soma
Constantes e Variáveis
• Exemplos de nomes Validos:
• nome1
• informacao
•x
• N_41
• resp_soma
Constantes e Variáveis
• Exemplos de nomes Invalidos:
• 1nome
• informação
• #x
• N 41
• Inteiro
Constantes e Variáveis
• Exemplos de nomes Invalidos:
• 1nome
• informação
• #x
• N 41
• Inteiro(nome reservado para decla...
Constantes e Variáveis
• Atribuição de Valores: A atribuição de dados a
uma variável ou constante é efetuada através
do co...
Operadores e Expressões
• Operadores Aritméticos:
+
/
*

(Subtração)
(Adição)
(Divisão)
(Multiplicação)
Operadores e Expressões
• Operadores Relacionais:
=
<>
>
<
>=
<=

(Igualdade)
(Desigualdade)
(Maior que)
(Menor que)
(Maio...
Operadores e Expressões
• Operadores Lógicos:
E
Ou
Não

(Conjunção)
(Disjunção)
(Negação)
Operadores e Expressões
• Expressões: são combinações de constantes,
variáveis e operadores para produzir um
resultado. Ex...
Operadores e Expressões

• Expressões: são combinações de constantes,
variáveis e operadores para produzir um
resultado. E...
Operadores e Expressões
• Expressões: são combinações de constantes,
variáveis e operadores para produzir um
resultado. Ex...
Operadores e Expressões
• Expressões: são combinações de constantes,
variáveis e operadores para produzir um
resultado. Ex...
Comando de Entrada
• Leia
Exemplo:
Leia(nota1);
Leia(nome);

Leia(“Media ”);
Aspas só para String,
nunca para Variável.
Comando de Saída
• Escreva
Exemplo:
Escreva(“Digite a Nota:”);
Escreva(“Digite o Nome:”, nome);
Escreva(Media);
Exemplo de Algoritmo
Programa SomaDeDoisValores
var
SOMA : real;
Inicio
Escreva(“Entre com o valor de A e B”);
Leia(A,B);
...
Exemplo de Algoritmo
Nome do Algoritmo
Programa SomaDeDoisValores
var
SOMA : real;
Inicio
Escreva(“Entre com o valor de A ...
Exemplo de Algoritmo
Programa SomaDeDoisValores
var
SOMA : real;
Inicio Inicio e Fim
Escreva(“Entre com o valor de A e B”)...
Exemplo de Algoritmo
Programa SomaDeDoisValores
var
SOMA : real;

Declaração de Variáveis

Inicio
Escreva(“Entre com o val...
Exemplo de Algoritmo
Programa SomaDeDoisValores
var
SOMA : real;
Inicio
Escreva(“Entre com o valor de A e B”);
Leia(A,B);
...
Programação NÃO Estruturada

Programa SomaDeDoisValores
Inicio
var
SOMA : real;
Escreva(“Entre com o valor de A e B”);
Lei...
Programação Estruturada
Programa SomaDeDoisValores
Inicio
var
SOMA : real;
Escreva(“Entre com o valor de A e B”);
Leia(A,B...
Comando Condicional
• Se
Exemplo 1:
Se Nota >= 7 então
Escreva(“Aluno Aprovado”);
FimSe;
Comando Condicional
• Se
Exemplo 2:
Se Nota >= 7 então
Escreva(“Aluno Aprovado”);
senão se nota <= 4
Escreva(“Aluno Aprova...
Exercícios
7.

Faça um algoritmo onde o usuario deverá digitar um numero de 1 a 3 e
exibir os resultados:
–
–
–
–

8.

Igu...
Comando de Repetição
• Enquanto
Exemplo:
Enquanto N < 5 faça
Escreva(“Numero= ”,N);
N := N + 1;
FimEnquanto;
Próximos SlideShares
Carregando em…5
×

Algoritmo Variaveis

759 visualizações

Publicada em

Definições sobre:
- Variaveis e Constantes
- Tipos de Dados
- Operadores de Atribuição
- Operadores Aritméticos
- Operadores Lógicos

Tire suas Dúvidas: andrevallenobre@gmail.com

Publicada em: Tecnologia
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
759
No SlideShare
0
A partir de incorporações
0
Número de incorporações
5
Ações
Compartilhamentos
0
Downloads
12
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmo Variaveis

  1. 1. Algoritmo Estruturado Prof. André Nobre
  2. 2. Tipos de Dados • Opções que nunca irão mudar ao declarar variáveis: – Inteiros – Reais; – Caracteres; – Lógicos;
  3. 3. Constantes e Variáveis • Exemplos de declaração: Var Nome : Caractere; Idade : Inteiro; Media,N1,N2 : Real; Status : Logico;
  4. 4. Constantes e Variáveis • Exemplos de nomes Validos: • nome1 • informacao •x • N_41 • resp_soma
  5. 5. Constantes e Variáveis • Exemplos de nomes Validos: • nome1 • informacao •x • N_41 • resp_soma
  6. 6. Constantes e Variáveis • Exemplos de nomes Invalidos: • 1nome • informação • #x • N 41 • Inteiro
  7. 7. Constantes e Variáveis • Exemplos de nomes Invalidos: • 1nome • informação • #x • N 41 • Inteiro(nome reservado para declaração de variáveis)
  8. 8. Constantes e Variáveis • Atribuição de Valores: A atribuição de dados a uma variável ou constante é efetuada através do comando de atribuição normalmente simbolizado por Exemplo: <- Cont <- 100; Curso := “Redes”; ou :=
  9. 9. Operadores e Expressões • Operadores Aritméticos: + / * (Subtração) (Adição) (Divisão) (Multiplicação)
  10. 10. Operadores e Expressões • Operadores Relacionais: = <> > < >= <= (Igualdade) (Desigualdade) (Maior que) (Menor que) (Maior ou igual) (Menor ou igual)
  11. 11. Operadores e Expressões • Operadores Lógicos: E Ou Não (Conjunção) (Disjunção) (Negação)
  12. 12. Operadores e Expressões • Expressões: são combinações de constantes, variáveis e operadores para produzir um resultado. Ex.: Total := SubTotal - Desc; Media := (N1+N2)/2; Juros := (Total * 8)+Total;
  13. 13. Operadores e Expressões • Expressões: são combinações de constantes, variáveis e operadores para produzir um resultado. Ex.: Total := SubTotal - Desc; Media := (N1+N2)/2; Juros := (Total * 8)+Total;
  14. 14. Operadores e Expressões • Expressões: são combinações de constantes, variáveis e operadores para produzir um resultado. Ex.: Total := SubTotal - Desc; Media := (N1+N2)/2; Juros := (Total * 8)+Total;
  15. 15. Operadores e Expressões • Expressões: são combinações de constantes, variáveis e operadores para produzir um resultado. Ex.: Total := SubTotal - Desc; Media := (N1+N2)/2; Juros := (Total * 8)+Total;
  16. 16. Comando de Entrada • Leia Exemplo: Leia(nota1); Leia(nome); Leia(“Media ”); Aspas só para String, nunca para Variável.
  17. 17. Comando de Saída • Escreva Exemplo: Escreva(“Digite a Nota:”); Escreva(“Digite o Nome:”, nome); Escreva(Media);
  18. 18. Exemplo de Algoritmo Programa SomaDeDoisValores var SOMA : real; Inicio Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Escreva(“Resposta=”,SOMA); Fim
  19. 19. Exemplo de Algoritmo Nome do Algoritmo Programa SomaDeDoisValores var SOMA : real; Inicio Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Escreva(“Resposta=”,SOMA); Fim
  20. 20. Exemplo de Algoritmo Programa SomaDeDoisValores var SOMA : real; Inicio Inicio e Fim Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Escreva(“Resposta=”,SOMA); Fim
  21. 21. Exemplo de Algoritmo Programa SomaDeDoisValores var SOMA : real; Declaração de Variáveis Inicio Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Escreva(“Resposta=”,SOMA); Fim
  22. 22. Exemplo de Algoritmo Programa SomaDeDoisValores var SOMA : real; Inicio Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Escreva(“Resposta=”,SOMA); Fim Blocos estruturados de comandos
  23. 23. Programação NÃO Estruturada Programa SomaDeDoisValores Inicio var SOMA : real; Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Se SOMA > 10 então Escreva(“Valor Maior que 10!”); Escreva(“Valor Maior que 10!”); Escreva(“Valor Maior que 10!”); Senão se SOMA > 20 então Escreva(“Valor Maior que 20!”); Escreva(“Valor Maior que 20!”); Escreva(“Valor Maior que 20!”); Senão se SOMA > 30 então Escreva(“Valor Maior que 30!”); Escreva(“Valor Maior que 30!”); Escreva(“Valor Maior que 30!”); FimSe Fim
  24. 24. Programação Estruturada Programa SomaDeDoisValores Inicio var SOMA : real; Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Se SOMA > 10 então Escreva(“Valor Maior que 10!”); Escreva(“Valor Maior que 10!”); Escreva(“Valor Maior que 10!”); Senão se SOMA > 20 então Escreva(“Valor Maior que 20!”); Escreva(“Valor Maior que 20!”); Escreva(“Valor Maior que 20!”); Senão se SOMA > 30 então Escreva(“Valor Maior que 30!”); Escreva(“Valor Maior que 30!”); Escreva(“Valor Maior que 30!”); FimSe Fim
  25. 25. Comando Condicional • Se Exemplo 1: Se Nota >= 7 então Escreva(“Aluno Aprovado”); FimSe;
  26. 26. Comando Condicional • Se Exemplo 2: Se Nota >= 7 então Escreva(“Aluno Aprovado”); senão se nota <= 4 Escreva(“Aluno Aprovado”); senão Escreva(“Aluno Aprovado”); FimSe;
  27. 27. Exercícios 7. Faça um algoritmo onde o usuario deverá digitar um numero de 1 a 3 e exibir os resultados: – – – – 8. Igual a 1 -> “Ruim!” Igual a 2 -> “Bom!” Igual a 3 -> “Ótimo!” Maior que 3 ou menor que 1 -> “Erro!” Faça um algoritmo exiba a mensagem conforme o sexo informado: – Feminino = “Você é bonita!” – Masculino = “Você é Bonito!” 9. Faça um algoritmo no qual o professor informa 2 notas e baseado na média exiba os resultados: – >= 7 -> Aprovado – <7 e >=4 -> Recuperação – <4 -> Reprovado – >10 ou <0 -> Erro!
  28. 28. Comando de Repetição • Enquanto Exemplo: Enquanto N < 5 faça Escreva(“Numero= ”,N); N := N + 1; FimEnquanto;

×