02 - Introdução a lógica de programação parte 2 - v1.2

408 visualizações

Publicada em

Objetivos: Ao final da aula, os alunos devem estar aptos a interpretar e compreender um algoritmo, apresentado no formato de fluxograma ou pseudocódigo.

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
408
No SlideShare
0
A partir de incorporações
0
Número de incorporações
4
Ações
Compartilhamentos
0
Downloads
46
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

02 - Introdução a lógica de programação parte 2 - v1.2

  1. 1. César Augusto Pessôa
  2. 2. Sumário  Objetivos  Fluxogramas  Pseudocódigos  Ferramentas sugeridas  Agradecimentos  Dúvidas
  3. 3. Objetivos  Ao final da aula, os alunos devem estar aptos a interpretar e compreender um algoritmo, apresentado no formato de fluxograma ou pseudocódigo.
  4. 4. Pseudocódigo  Também conhecido como portugol, é uma ferramenta para escrita de algoritmos de forma organizada e estruturada.  A primeira vista, parece uma linguagem de programação muito simplória, porém, sua vantagem está justamente em ter semelhanças com muitas linguagens de programação, assim como, com o nosso idioma.
  5. 5. Pseudocódigo  Para iniciar a escrita de um algoritmo em pseudocódigo é necessário conhecer algumas regras e nomenclaturas:  Constantes;  Variáveis (ou identificadores);  Tipos de dados; e  Expressões e operadores.
  6. 6. Constantes  Constante gravitacional universal:  9,80665 m/s²  Placa da minha moto:  ABC2016  Endereço  Data de nascimento  Meses do ano  ...
  7. 7. Variáveis  Clima:  Primavera, verão, outono, inverno.  Nível de gasolina de um tanque.  Nível de água dos reservatórios.  Espaço livre de um HD / pen drive.  ...
  8. 8. Variáveis São recipientes para informações. Usados para armazenar dados que podem ser alterados a qualquer momento. Geralmente dados que vem de um usuário. São como caixas!
  9. 9. E todas as caixas, são iguais?
  10. 10. Tipos de dados  Inteiro: números inteiros, sem casas decimais.  Real: números reais, com casas decimais.  Caractere ou literal: cadeia de caracteres, palavras.  Lógico: variáveis do tipo booleano, ou seja, com valor VERDADEIRO ou FALSO.
  11. 11. Porque existem os tipos de dados  Quando declaramos o tipo de dados de uma variável, estamos anunciando para o computador quais serão as possíveis operações que realizaremos com aquela variável.  Quando falamos de variáveis do tipo real e inteiro, temos que ter em mente a quantidade que dígitos e precisão que desejamos armazenar.
  12. 12. Inteiro VS Real  Outro fator decisivo para a seleção do tipo de variáveis será o espaço utilizado para armazenar as informações.  Por exemplo, podemos fazer uma analogia a contagem de 1 a 5.  Inteiros: 1; 2; 3; 4 e 5.  Reais com uma casa decimal: 1,0; 1,1; 1,2; 1,3; 1,4; ... 4,6; 4,7; 4,8; 4,9 e 5.  Matematicamente: ℝ ⊃ ℤ
  13. 13. Expressões e operadores Expressões são conjuntos de variáveis e constantes que unidos, apresentam um resultado. Por exemplo, uma expressão matemática!
  14. 14. Hello world (olá mundo) inicio escreva (“Olá mundo!") fimalgoritmo
  15. 15. Principais comandos  Comando de entrada de dados:  leia() – captura uma entrada do usuário.  Comando de saída de dados:  escreva() – apresenta uma mensagem na tela.  escreval() – apresenta uma mensagem na tela e uma quebra de linha.  E como aplicamos?
  16. 16. Usando pseudocódigo var nome: caractere inicio escreva ("Escreva seu nome:") leia(nome) escreva (“Seja bem-vindo “, nome, “ !!!”) fimalgoritmo
  17. 17. Usando pseudocódigo escreva ("Escreva seu nome:") leia(nome) escreva ("Escreva seu sobrenome:") leia(sobrenome) escreva ("Informe a sua idade:") leia(idade) escreva ("Seja bem-vindo ", nome, " ", sobrenome, "!!!") escreva ("Sua idade é: ", idade)
  18. 18. Soma usando pseudocódigo var n1, n2, soma: inteiro inicio escreva ("Entre com um número inteiro:") leia(n1) escreva ("Entre com outro número inteiro:") leia(n2) soma <- n1 + n2 escreva(soma) fimalgoritmo
  19. 19. Fluxogramas  É uma ferramenta para representar algoritmos de forma gráfica, isto é, com figuras que representam as instruções de um algoritmo.  Tem a vantagem de facilitar a visualização e compreensão das instruções, porém, não são aconselháveis para grandes algoritmos.
  20. 20. Fluxogramas Podem ser comparados a mapas, pois, são desenhos que indicam qual o caminho a ser seguido pelo programa. O caminho é defino com base em decisões, geralmente, booleanas.
  21. 21. Fluxogramas INÍCIO / FIM CÁLCULO / PROCESSO ENTRADA SAÍDA DECISÃO
  22. 22. Fluxogramas ENTRADA GENÉRICA ENTRADA MANUAL
  23. 23. Usando fluxogramas var nome: caractere inicio escreva ("Escreva seu nome:") leia(nome) escreva (“Seja bem- vindo “, nome, “ !!!”) fimalgoritmo INÍCIO nome “Escreva seu nome:” “Seja bem-vindo <nome> !!!” FIM
  24. 24. Soma usando fluxogramas var n1, n2, soma: inteiro inicio escreva ("Entre com um número inteiro:") leia(n1) escreva ("Entre com outro número inteiro:") leia(n2) soma <- n1 + n2 escreva(soma) fimalgoritmo INÍCIO n1 “Entre com um número inteiro:” FIM “Entre com outro número inteiro:” n2 soma = n1 + n2 soma
  25. 25. Decisões INÍCIO numero “Entre com um número inteiro:” FIM <numero> / 2 “O número é par!” <numero> é par “O número é ímpar!” SIM NÃO
  26. 26. Exemplo...
  27. 27. Ferramentas sugeridas Dia Diagram Editor http://dia-installer.de VisualG http://www.apoioinformatica.inf.br/produtos/visualg
  28. 28. VisuAlg
  29. 29. Agradecimentos Find Icons http://findicons.com Iconfinder https://www.iconfinder.com
  30. 30. Dúvidas?
  31. 31. César Augusto Pessôa capfg@hotmail.com

×