SlideShare uma empresa Scribd logo
1 de 24
Baixar para ler offline
ZXR10 M6000
BGP Configuration
V1.1
Objectives
Understand the configuration steps of BGP
Grasp the configuration of BGP
Grasp the Maintenance of BGP
BGP configuration steps
Configuring BGP neighbor
Configuring BGP Route Advertisement
BGP Fault Treatment
Contents.
BGP configuration steps
Enable BGP routing process, <as-number> is the AS system ID
of router, 1~65535.
Configure a BGP neighbor and AS number of a peer
Configure BGP Route Advertisement
ZXR10(config)# router bgp < as-number>
ZXR10(config-bgp)# neighbor [ < ipv4-address> | < peer-group-name>
] remote-as < number>
ZXR10(config-bgp)# network< ip-address> < net-mask>
ZXR10(config-bgp)# redistribute < protocol>
BGP configuration steps
Configuring BGP neighbor
Configuring BGP Route Advertisement
BGP Fault Treatment
Contents.
Establishing EBGP Neighbor
EBGP:physical connected directly
--Use IP addresses of interconnected interfaces
to create BGP connection
--Use IP addresses of loopback interfaces to
create BGP connection
Establishing EBGP Neighbor--Direct Connected
Address
R1# config terminal
R1(config)# interface fei-0/1/0/1
R1(config-if)# ip address 129.213.1.1 255.255.255.252
R1(config-if)# exit
R1(config)# router bgp 65000
R1(config-bgp)# neighbor 129.213.1.2 remote-as 65001
R1(config-bgp)# exit
R2# config terminal
R2(config)# interface fei-0/1/0/1
R2(config-if)# ip address 129.213.1.2 255.255.255.252
R2(config-if)# exit
R2(config)# router bgp 65001
R2(config-bgp)# neighbor 129.213.1.1 remote-as 65000
R2(config-bgp)# exit
Establishing EBGP Neighbor--Show BGP neighbor
R1#show ip bgp neighbor
BGP neighbor is 129.213.1.2, remote AS 65001, external link
BGP version 4, remote router ID 129.213.1.2
BGP state = Established, up for 00:04:21
hold time is 90 seconds, keepalive interval is 30 seconds
……
Connections established 1
Local host: 129.213.1.1, Local port: 179
Foreign host: 129.213.1.2, Foreign port: 1024
R2#show ip bgp neighbor
BGP neighbor is 129.213.1.1, remote AS 65000, external link
BGP version 4, remote router ID 129.213.1.1
BGP state = Established, up for 00:00:27
hold time is 90 seconds, keepalive interval is 30 seconds
……
Connections established 1
Local host: 129.213.1.2, Local port: 1024
Foreign host: 129.213.1.1, Foreign port: 179
Establishing EBGP Neighbor--Loopback address
R1# config terminal
R1(config)# interface fei-0/1/0/1
R1(config-if)# ip address 192.168.1.1 255.255.255.252
R1(config-if)# exit
R1(config)# interface Loopback1
R1(config-if)# ip address 1.1.1.1 255.255.255.255
R1(config-if)# exit
R1(config)# router bgp 65000
R1(config-bgp)# neighbor 1.1.1.2 remote-as 65001
R1(config-bgp)# neighbor 1.1.1.2 ebgp-multihop
R1(config-bgp)# neighbor 1.1.1.2 update-source Loopback1
R1(config-bgp)# exit
R1(config)# ip route 1.1.1.2 255.255.255.255 192.168.1.2
R2(config)# router bgp 65001
R2(config-bgp)# neighbor 1.1.1.1 remote-as 65000
R2(config-bgp)# neighbor 1.1.1.1 ebgp-multihop ttl 5
R2(config-bgp)# neighbor 1.1.1.1 update-source Loopback1
R2(config-bgp)# exit
R2(config)# ip route 1.1.1.1 255.255.255.255 192.168.1.1
By default, TTL value for EBGP is 1
use "ebgp-multihop" command while
establishing EBGP neighbor on not
directly connected interfaces. default TTL
value is 8
R1#show ip bgp neighbor
BGP neighbor is 1.1.1.2, remote AS 65001, external link
BGP version 4, remote router ID 1.1.1.2
BGP state = Established, up for 00:01:01
hold time is 90 seconds, keepalive interval is 30 seconds
……
Connections established 1
Local host: 1.1.1.1, Local port: 179
Foreign host: 1.1.1.2, Foreign port: 1026
R2#show ip bgp neighbor
BGP neighbor is 1.1.1.1, remote AS 65000, external link
BGP version 4, remote router ID 1.1.1.1
BGP state = Established, up for 00:02:03
hold time is 90 seconds, keepalive interval is 30 seconds
……
Connections established 1
Local host: 1.1.1.2, Local port: 1026
Foreign host: 1.1.1.1, Foreign port: 179
Establishing EBGP Neighbor--Show BGP neighbor
Establishing IBGP Neighbor
IBGP:physical connected directly
or not connected directly
-- Use IP addresses of loopback interfaces to
create BGP connection
-- Synchronization
-- Full mesh
-- valuable nexthop(have reachable route)
Establishing EBGP Neighbor --Loopback address
R2# config terminal
R2(config)# interface fei-0/1/0/1
R2(config-if)# ip address 192.168.2.1 255.255.255.252
R2(config-if)# exit
R2(config)# interface Loopback1
R2(config-if)# ip address 1.1.1.2 255.255.255.255
R2(config-if)# exit
R2(config)# router bgp 65001
R2(config-bgp)# neighbor 1.1.1.3 remote-as 65001
R2(config-bgp)# neighbor 1.1.1.3 update-source Loopback1
R2(config-bgp)# neighbor 1.1.1.3 next-hop-self
R2(config-bgp)# no synchronization
R2(config-bgp)# exit
R2(config)# router ospf 1
R2(config-ospfv2)# network 192.168.2.0 0.0.0.3 area 0
R2(config-ospfv2)# network 1.1.1.2 0.0.0.0 area 0
R2(config-ospfv2)# exit
R3(config)# router bgp 65001
R3(config-bgp)#neighbor 1.1.1.2 remote-as 65001
R3(config-bgp)#neighbor 1.1.1.2 update-source Loopback1
R3(config-bgp)#neighbor 1.1.1.2 next-hop-self
R3(config-bgp)#no synchronization
R3(config-bgp)#exit
R3(config)#router ospf 1
R3(config-ospfv2)#network 192.168.2.0 0.0.0.3 area 0
R3(config-ospfv2)#network 1.1.1.3 0.0.0.0 area 0
R3(config-ospfv2)#exit
Establishing IBGP Neighbor--Show BGP Neighbor
R2#show ip bgp neighbor
BGP neighbor is 1.1.1.3, remote AS 65001, internal link
BGP version 4, remote router ID 1.1.1.3
BGP state = Established, up for 00:01:25
hold time is 90 seconds, keepalive interval is 30 seconds
……
Connections established 1
last error code is 6
Local host: 1.1.1.2, Local port: 179
Foreign host: 1.1.1.3, Foreign port: 1096
R3#show ip bgp neighbor
BGP neighbor is 1.1.1.2, remote AS 65001, internal link
BGP version 4, remote router ID 1.1.1.2
BGP state = Established, up for 00:03:07
……
Connections established 1
last error code is 5
Local host: 1.1.1.3, Local port: 1096
Foreign host: 1.1.1.2, Foreign port: 179
BGP configuration steps
Configuring BGP neighbor
Configuring BGP Route Advertisement
BGP Fault Treatment
Contents.
Configuring BGP Route Advertisement
1. Use network command to advertise route
Advertise the concrete network routes learned from IGP protocol
(static,RIP、OSPF、ISIS etc)
2. Use redistribute command to advertise route
Redistribute all the routes learned from IGP protocol(s) while
there are a lot of routes which are hard to aggregate
3. BGP route aggregation
Aggregate the routes to one summary route and advertise to
other BGP neighbors, therefore can reduce the size of IP routing
table significantly.
Make sure the mask of all the routes are equal while configuring
route aggregation on routers, in order to avoid black hole route
Using network to Advertise Route
R2 runs OSPF as IGP protocol.
R2 requires advertising the
network segment 18.0.0.0/8 which is
discovered by OSPF in BGP.
R2#config terminal
R2(config)#interface fei-0/1/0/1
R2(config-if)#ip address 192.168.2.1 255.255.255.252
R2(config-if)#exit
R2(config)#router bgp 65001
R2(config-bgp)#neighbor 192.168.2.2 remote-as 65000
R2(config-bgp)#network 18.0.0.0 255.255.255.0
R2(config-bgp)#exit
R2(config)#router ospf 1
R2(config-ospfv2)#network 18.0.0.0 0.255.255.255 area 0
R2(config-ospfv2)#exit
R1#config terminal
R1(config)#interface fei-0/1/0/1
R1(config-if)#ip address 192.168.2.2 255.255.255.252
R1(config-if)#exit
R1(config)#router bgp 65000
R1(config-bgp)#neighbor 192.168.2.1 remote-as 65001
R1(config-bgp)#exit
Using network to Advertise Route-- Show BGP route
R2 runs OSPF as IGP protocol.
R2 requires advertising the
network segment 18.0.0.0/8 which is
discovered by OSPF in BGP.
R1#show ip bgp route
Status codes: *-valid, >-best, i-internal,s-stale
Origin codes: i-IGP, e-EGP, ?-incomplete
Dest NextHop Metric LocPrf RtPrf Path
*>18.0.0.0/8 192.168.2.1 20 65001 i
“*” indicates the route is available
“>” indicates the route is the best choice
“i” indicates this is a IBGP route, without “i” indicates
this is a EBGP route or local route
Next-hop:If the address is full zero, that means this
route is generated by router itself
Local-Pre:the priority level of route which is learned
by BGP. The default value is 100
Path:shows the origin of this route. Three types:
IGP, EGP and incomplete
Using redistribute to Advertise Route
R2 runs OSPF as IGP protocol.
Now it needs to redistribute all
OSPF routes information on R2 into BGP.
R2#config terminal
R2(config)#interface fei-0/1/0/1
R2(config-if)#ip address 192.168.2.1 255.255.255.252
R2(config-if)#exit
R2(config)#router ospf 1
R2(config-ospfv2)#network 18.0.0.0 0.0.0.255 area 0
R2(config-ospfv2)#exit
R2(config)#router bgp 65001
R2(config-bgp)#neighbor 192.168.2.2 remote-as 65000
R2(config-bgp)#redistribute ospf-int
R2(config-bgp)#redistribute connected
R2(config-bgp)#exit
Using redistribute to Advertise Route-- Show BGP
Route
R1#show ip bgp route
Status codes: *-valid, >-best, i-internal,s-stale
Origin codes: i-IGP, e-EGP, ?-incomplete
Dest NextHop Metric LocPrf RtPrf Path
*> 18.0.0.0/8 192.168.2.1 20 65001 ?
R2 runs OSPF as IGP protocol.
Now it needs to redistribute all
OSPF routes information on R2 into BGP.
Configuring Route Aggregation
R1 advertises the segments of its own and
the segments of R3 (192.168.0.0/24,
192.168.1.0/24, 192.168.2.0/24 and
192.168.3.0/24) to R2 in AS300.
OSPF is run on the link between R1 and R3.
R1(config)#interface fei-0/1/0/1
R1(config-if)#ip address 2.2.2.2 255.255.255.0
R1(config-if)#exit
R1(config)#router bgp 100
R1(config-bgp)#neighbor 2.2.2.1 remote-as 300
R1(config-bgp)#aggregate-address 192.168.0.0
255.255.252.0 count 0 summary-only
R1(config-bgp)#redistribute ospf-int
R1(config-bgp)#redistribute connected
R1(config-bgp)#exit
R1(config)#router ospf 1
R1(config-ospfv2)#network 192.168.3.0 0.0.0.255 area 0
R1(config-ospfv2)#network 10.1.1.0 0.0.0.3 area 0
R1(config-ospfv2)#exit
If the command is used without the parameter
summary-only, R2 will advertise the detailed
routes with the aggregated route
Configuring Route Aggregation-- Show BGP route
R2#show ip bgp route
Status codes: *valid, >best, i-internal
Origin codes: i-IGP, e-EGP, ?-incomplete
Dest NextHop Metric LocPrf RtPrf Path
*>192.168.0.0/22 2.2.2.2 20 100 i
R2#show ip bgp route detail 192.168.0.0 255.255.252.0
BGP routing table entry for 192.168.0.0/22
01:02:19 received from 2.2.2.2
origin i, nexthop 2.2.2.2,atomic,aggr 100 2.2.2.2,
as path [100]
R1 advertises the segments of its own and
the segments of R3 (192.168.0.0/24,
192.168.1.0/24, 192.168.2.0/24 and
192.168.3.0/24) to R2 in AS300.
OSPF is run on the link between R1 and R3.
BGP configuration steps
Configures a BGP neighbor
Configuring BGP Route Advertisement
BGP Fault Treatment
Contents
BGP Fault Treatment Flow
08 ip oc304 2_e1_1 zxr10 m6000 bgp configuration 24

Mais conteúdo relacionado

Mais procurados

Deferred shading
Deferred shadingDeferred shading
Deferred shading
Frank Chao
 

Mais procurados (11)

Taking Killzone Shadow Fall Image Quality Into The Next Generation
Taking Killzone Shadow Fall Image Quality Into The Next GenerationTaking Killzone Shadow Fall Image Quality Into The Next Generation
Taking Killzone Shadow Fall Image Quality Into The Next Generation
 
Deferred shading
Deferred shadingDeferred shading
Deferred shading
 
Putting the AI Back Into Air: Navigating the Air Space of Horizon Zero Dawn
Putting the AI Back Into Air: Navigating the Air Space of Horizon Zero DawnPutting the AI Back Into Air: Navigating the Air Space of Horizon Zero Dawn
Putting the AI Back Into Air: Navigating the Air Space of Horizon Zero Dawn
 
Modelo rerratificacao
Modelo rerratificacaoModelo rerratificacao
Modelo rerratificacao
 
UE4 Lightmass for Large Console Games (UE4 Lightmass Deep Dive)
UE4 Lightmass for Large Console Games  (UE4 Lightmass Deep Dive)UE4 Lightmass for Large Console Games  (UE4 Lightmass Deep Dive)
UE4 Lightmass for Large Console Games (UE4 Lightmass Deep Dive)
 
4K Checkerboard in Battlefield 1 and Mass Effect Andromeda
4K Checkerboard in Battlefield 1 and Mass Effect Andromeda4K Checkerboard in Battlefield 1 and Mass Effect Andromeda
4K Checkerboard in Battlefield 1 and Mass Effect Andromeda
 
Edital de licitação de materiais esportivos
Edital de licitação de materiais esportivosEdital de licitação de materiais esportivos
Edital de licitação de materiais esportivos
 
Bending the Graphics Pipeline
Bending the Graphics PipelineBending the Graphics Pipeline
Bending the Graphics Pipeline
 
Unite Berlin 2018 - Book of the Dead Optimizing Performance for High End Cons...
Unite Berlin 2018 - Book of the Dead Optimizing Performance for High End Cons...Unite Berlin 2018 - Book of the Dead Optimizing Performance for High End Cons...
Unite Berlin 2018 - Book of the Dead Optimizing Performance for High End Cons...
 
FEMA Valuation Aspects(FDI & ODI) and Registered Valuation
FEMA Valuation Aspects(FDI & ODI) and Registered ValuationFEMA Valuation Aspects(FDI & ODI) and Registered Valuation
FEMA Valuation Aspects(FDI & ODI) and Registered Valuation
 
Stochastic Screen-Space Reflections
Stochastic Screen-Space ReflectionsStochastic Screen-Space Reflections
Stochastic Screen-Space Reflections
 

Destaque

01 ip oc180 e1_1 zxr10 m6000_t8000 basic operation (v1.00.20)
01 ip oc180 e1_1 zxr10 m6000_t8000 basic operation (v1.00.20)01 ip oc180 e1_1 zxr10 m6000_t8000 basic operation (v1.00.20)
01 ip oc180 e1_1 zxr10 m6000_t8000 basic operation (v1.00.20)
legasu zemene
 
04 zxr10 bc-en-acl principle and configuration (acl principle)-1-ppt-201105 24
04 zxr10 bc-en-acl principle and configuration (acl principle)-1-ppt-201105 2404 zxr10 bc-en-acl principle and configuration (acl principle)-1-ppt-201105 24
04 zxr10 bc-en-acl principle and configuration (acl principle)-1-ppt-201105 24
legasu zemene
 
11 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 26
11 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 2611 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 26
11 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 26
legasu zemene
 
05 ip oc305 2_e1_1 zxr10 m6000&amp;t8000 acl configuration (v1.00.30) 31
05 ip oc305 2_e1_1 zxr10 m6000&amp;t8000 acl configuration (v1.00.30) 3105 ip oc305 2_e1_1 zxr10 m6000&amp;t8000 acl configuration (v1.00.30) 31
05 ip oc305 2_e1_1 zxr10 m6000&amp;t8000 acl configuration (v1.00.30) 31
legasu zemene
 
Deploying IP/MPLS VPN - Cisco Networkers 2010
Deploying IP/MPLS VPN - Cisco Networkers 2010Deploying IP/MPLS VPN - Cisco Networkers 2010
Deploying IP/MPLS VPN - Cisco Networkers 2010
Febrian ‎
 

Destaque (20)

01 ip oc180 e1_1 zxr10 m6000_t8000 basic operation (v1.00.20)
01 ip oc180 e1_1 zxr10 m6000_t8000 basic operation (v1.00.20)01 ip oc180 e1_1 zxr10 m6000_t8000 basic operation (v1.00.20)
01 ip oc180 e1_1 zxr10 m6000_t8000 basic operation (v1.00.20)
 
04 zxr10 bc-en-acl principle and configuration (acl principle)-1-ppt-201105 24
04 zxr10 bc-en-acl principle and configuration (acl principle)-1-ppt-201105 2404 zxr10 bc-en-acl principle and configuration (acl principle)-1-ppt-201105 24
04 zxr10 bc-en-acl principle and configuration (acl principle)-1-ppt-201105 24
 
11 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 26
11 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 2611 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 26
11 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 26
 
Zxsdr bs8900 a product description 20101026
Zxsdr bs8900 a product description 20101026Zxsdr bs8900 a product description 20101026
Zxsdr bs8900 a product description 20101026
 
05 ip oc305 2_e1_1 zxr10 m6000&amp;t8000 acl configuration (v1.00.30) 31
05 ip oc305 2_e1_1 zxr10 m6000&amp;t8000 acl configuration (v1.00.30) 3105 ip oc305 2_e1_1 zxr10 m6000&amp;t8000 acl configuration (v1.00.30) 31
05 ip oc305 2_e1_1 zxr10 m6000&amp;t8000 acl configuration (v1.00.30) 31
 
Cisco Call Manager on CISCO IOS
Cisco Call Manager on CISCO IOSCisco Call Manager on CISCO IOS
Cisco Call Manager on CISCO IOS
 
Zxmw nr8250 v1.00 commissioning guide ¸±±¾
Zxmw nr8250 v1.00 commissioning guide   ¸±±¾Zxmw nr8250 v1.00 commissioning guide   ¸±±¾
Zxmw nr8250 v1.00 commissioning guide ¸±±¾
 
Deploying IP/MPLS VPN - Cisco Networkers 2010
Deploying IP/MPLS VPN - Cisco Networkers 2010Deploying IP/MPLS VPN - Cisco Networkers 2010
Deploying IP/MPLS VPN - Cisco Networkers 2010
 
Authentification des protocoles de routage
Authentification des protocoles de routageAuthentification des protocoles de routage
Authentification des protocoles de routage
 
EtherChannel
EtherChannelEtherChannel
EtherChannel
 
MPLS-based Metro Ethernet Networks
MPLS-based Metro Ethernet NetworksMPLS-based Metro Ethernet Networks
MPLS-based Metro Ethernet Networks
 
Services IP
Services IPServices IP
Services IP
 
ZXSDR Trainning
ZXSDR TrainningZXSDR Trainning
ZXSDR Trainning
 
Virtuals LAN
Virtuals LANVirtuals LAN
Virtuals LAN
 
Protocole IKE/IPsec
Protocole IKE/IPsecProtocole IKE/IPsec
Protocole IKE/IPsec
 
GPON Introduction
GPON IntroductionGPON Introduction
GPON Introduction
 
Protocoles SSL/TLS
Protocoles SSL/TLSProtocoles SSL/TLS
Protocoles SSL/TLS
 
JunOS - Fondamentaux
JunOS - FondamentauxJunOS - Fondamentaux
JunOS - Fondamentaux
 
Cis82 e2-1-packet forwarding
Cis82 e2-1-packet forwardingCis82 e2-1-packet forwarding
Cis82 e2-1-packet forwarding
 
Cisco ASA
Cisco ASACisco ASA
Cisco ASA
 

Semelhante a 08 ip oc304 2_e1_1 zxr10 m6000 bgp configuration 24

Bgp For Presentation
Bgp For PresentationBgp For Presentation
Bgp For Presentation
Alp isik
 
Bgp 6 advanced transit as issues
Bgp 6   advanced transit as issuesBgp 6   advanced transit as issues
Bgp 6 advanced transit as issues
Auguste Behe
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRP
Kishore Kumar
 

Semelhante a 08 ip oc304 2_e1_1 zxr10 m6000 bgp configuration 24 (20)

Bgp For Presentation
Bgp For PresentationBgp For Presentation
Bgp For Presentation
 
EBGP MultiHop
EBGP MultiHopEBGP MultiHop
EBGP MultiHop
 
07.bgp
07.bgp07.bgp
07.bgp
 
Inter as vpn option c
Inter as vpn option c Inter as vpn option c
Inter as vpn option c
 
Bgp 6 advanced transit as issues
Bgp 6   advanced transit as issuesBgp 6   advanced transit as issues
Bgp 6 advanced transit as issues
 
Bgp Toc
Bgp TocBgp Toc
Bgp Toc
 
bgp features presentation routing protocle
bgp features presentation routing protoclebgp features presentation routing protocle
bgp features presentation routing protocle
 
Eigrp
EigrpEigrp
Eigrp
 
B G P Part2
B G P  Part2B G P  Part2
B G P Part2
 
B G P Part2
B G P  Part2B G P  Part2
B G P Part2
 
EIGRP CCNA
EIGRP CCNAEIGRP CCNA
EIGRP CCNA
 
BGP (border gateway routing protocol)
BGP (border gateway routing protocol)BGP (border gateway routing protocol)
BGP (border gateway routing protocol)
 
BGP Next-hop-self
BGP Next-hop-selfBGP Next-hop-self
BGP Next-hop-self
 
CCNP Route 642 902 BGP
CCNP Route 642 902 BGPCCNP Route 642 902 BGP
CCNP Route 642 902 BGP
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRP
 
EIGRP ZERO TO HERO
EIGRP ZERO TO HEROEIGRP ZERO TO HERO
EIGRP ZERO TO HERO
 
Bgp attribute-case study
Bgp attribute-case studyBgp attribute-case study
Bgp attribute-case study
 
Bgp
BgpBgp
Bgp
 
BGP Loop Prevention
BGP Loop Prevention BGP Loop Prevention
BGP Loop Prevention
 
Dynamic routing OSPF 1
Dynamic routing OSPF 1Dynamic routing OSPF 1
Dynamic routing OSPF 1
 

Último

Call Girls in Ramesh Nagar Delhi 💯 Call Us 🔝9953056974 🔝 Escort Service
Call Girls in Ramesh Nagar Delhi 💯 Call Us 🔝9953056974 🔝 Escort ServiceCall Girls in Ramesh Nagar Delhi 💯 Call Us 🔝9953056974 🔝 Escort Service
Call Girls in Ramesh Nagar Delhi 💯 Call Us 🔝9953056974 🔝 Escort Service
9953056974 Low Rate Call Girls In Saket, Delhi NCR
 
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
ssuser89054b
 
Call Now ≽ 9953056974 ≼🔝 Call Girls In New Ashok Nagar ≼🔝 Delhi door step de...
Call Now ≽ 9953056974 ≼🔝 Call Girls In New Ashok Nagar  ≼🔝 Delhi door step de...Call Now ≽ 9953056974 ≼🔝 Call Girls In New Ashok Nagar  ≼🔝 Delhi door step de...
Call Now ≽ 9953056974 ≼🔝 Call Girls In New Ashok Nagar ≼🔝 Delhi door step de...
9953056974 Low Rate Call Girls In Saket, Delhi NCR
 
Call Girls In Bangalore ☎ 7737669865 🥵 Book Your One night Stand
Call Girls In Bangalore ☎ 7737669865 🥵 Book Your One night StandCall Girls In Bangalore ☎ 7737669865 🥵 Book Your One night Stand
Call Girls In Bangalore ☎ 7737669865 🥵 Book Your One night Stand
amitlee9823
 
FULL ENJOY Call Girls In Mahipalpur Delhi Contact Us 8377877756
FULL ENJOY Call Girls In Mahipalpur Delhi Contact Us 8377877756FULL ENJOY Call Girls In Mahipalpur Delhi Contact Us 8377877756
FULL ENJOY Call Girls In Mahipalpur Delhi Contact Us 8377877756
dollysharma2066
 
notes on Evolution Of Analytic Scalability.ppt
notes on Evolution Of Analytic Scalability.pptnotes on Evolution Of Analytic Scalability.ppt
notes on Evolution Of Analytic Scalability.ppt
MsecMca
 
Cara Menggugurkan Sperma Yang Masuk Rahim Biyar Tidak Hamil
Cara Menggugurkan Sperma Yang Masuk Rahim Biyar Tidak HamilCara Menggugurkan Sperma Yang Masuk Rahim Biyar Tidak Hamil
Cara Menggugurkan Sperma Yang Masuk Rahim Biyar Tidak Hamil
Cara Menggugurkan Kandungan 087776558899
 

Último (20)

Block diagram reduction techniques in control systems.ppt
Block diagram reduction techniques in control systems.pptBlock diagram reduction techniques in control systems.ppt
Block diagram reduction techniques in control systems.ppt
 
Call Girls in Ramesh Nagar Delhi 💯 Call Us 🔝9953056974 🔝 Escort Service
Call Girls in Ramesh Nagar Delhi 💯 Call Us 🔝9953056974 🔝 Escort ServiceCall Girls in Ramesh Nagar Delhi 💯 Call Us 🔝9953056974 🔝 Escort Service
Call Girls in Ramesh Nagar Delhi 💯 Call Us 🔝9953056974 🔝 Escort Service
 
(INDIRA) Call Girl Aurangabad Call Now 8617697112 Aurangabad Escorts 24x7
(INDIRA) Call Girl Aurangabad Call Now 8617697112 Aurangabad Escorts 24x7(INDIRA) Call Girl Aurangabad Call Now 8617697112 Aurangabad Escorts 24x7
(INDIRA) Call Girl Aurangabad Call Now 8617697112 Aurangabad Escorts 24x7
 
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
 
Top Rated Pune Call Girls Budhwar Peth ⟟ 6297143586 ⟟ Call Me For Genuine Se...
Top Rated  Pune Call Girls Budhwar Peth ⟟ 6297143586 ⟟ Call Me For Genuine Se...Top Rated  Pune Call Girls Budhwar Peth ⟟ 6297143586 ⟟ Call Me For Genuine Se...
Top Rated Pune Call Girls Budhwar Peth ⟟ 6297143586 ⟟ Call Me For Genuine Se...
 
(INDIRA) Call Girl Bhosari Call Now 8617697112 Bhosari Escorts 24x7
(INDIRA) Call Girl Bhosari Call Now 8617697112 Bhosari Escorts 24x7(INDIRA) Call Girl Bhosari Call Now 8617697112 Bhosari Escorts 24x7
(INDIRA) Call Girl Bhosari Call Now 8617697112 Bhosari Escorts 24x7
 
Call Now ≽ 9953056974 ≼🔝 Call Girls In New Ashok Nagar ≼🔝 Delhi door step de...
Call Now ≽ 9953056974 ≼🔝 Call Girls In New Ashok Nagar  ≼🔝 Delhi door step de...Call Now ≽ 9953056974 ≼🔝 Call Girls In New Ashok Nagar  ≼🔝 Delhi door step de...
Call Now ≽ 9953056974 ≼🔝 Call Girls In New Ashok Nagar ≼🔝 Delhi door step de...
 
Thermal Engineering Unit - I & II . ppt
Thermal Engineering  Unit - I & II . pptThermal Engineering  Unit - I & II . ppt
Thermal Engineering Unit - I & II . ppt
 
Call Girls In Bangalore ☎ 7737669865 🥵 Book Your One night Stand
Call Girls In Bangalore ☎ 7737669865 🥵 Book Your One night StandCall Girls In Bangalore ☎ 7737669865 🥵 Book Your One night Stand
Call Girls In Bangalore ☎ 7737669865 🥵 Book Your One night Stand
 
Thermal Engineering-R & A / C - unit - V
Thermal Engineering-R & A / C - unit - VThermal Engineering-R & A / C - unit - V
Thermal Engineering-R & A / C - unit - V
 
NFPA 5000 2024 standard .
NFPA 5000 2024 standard                                  .NFPA 5000 2024 standard                                  .
NFPA 5000 2024 standard .
 
Thermal Engineering -unit - III & IV.ppt
Thermal Engineering -unit - III & IV.pptThermal Engineering -unit - III & IV.ppt
Thermal Engineering -unit - III & IV.ppt
 
Unleashing the Power of the SORA AI lastest leap
Unleashing the Power of the SORA AI lastest leapUnleashing the Power of the SORA AI lastest leap
Unleashing the Power of the SORA AI lastest leap
 
Booking open Available Pune Call Girls Pargaon 6297143586 Call Hot Indian Gi...
Booking open Available Pune Call Girls Pargaon  6297143586 Call Hot Indian Gi...Booking open Available Pune Call Girls Pargaon  6297143586 Call Hot Indian Gi...
Booking open Available Pune Call Girls Pargaon 6297143586 Call Hot Indian Gi...
 
FULL ENJOY Call Girls In Mahipalpur Delhi Contact Us 8377877756
FULL ENJOY Call Girls In Mahipalpur Delhi Contact Us 8377877756FULL ENJOY Call Girls In Mahipalpur Delhi Contact Us 8377877756
FULL ENJOY Call Girls In Mahipalpur Delhi Contact Us 8377877756
 
notes on Evolution Of Analytic Scalability.ppt
notes on Evolution Of Analytic Scalability.pptnotes on Evolution Of Analytic Scalability.ppt
notes on Evolution Of Analytic Scalability.ppt
 
Generative AI or GenAI technology based PPT
Generative AI or GenAI technology based PPTGenerative AI or GenAI technology based PPT
Generative AI or GenAI technology based PPT
 
Cara Menggugurkan Sperma Yang Masuk Rahim Biyar Tidak Hamil
Cara Menggugurkan Sperma Yang Masuk Rahim Biyar Tidak HamilCara Menggugurkan Sperma Yang Masuk Rahim Biyar Tidak Hamil
Cara Menggugurkan Sperma Yang Masuk Rahim Biyar Tidak Hamil
 
Design For Accessibility: Getting it right from the start
Design For Accessibility: Getting it right from the startDesign For Accessibility: Getting it right from the start
Design For Accessibility: Getting it right from the start
 
Work-Permit-Receiver-in-Saudi-Aramco.pptx
Work-Permit-Receiver-in-Saudi-Aramco.pptxWork-Permit-Receiver-in-Saudi-Aramco.pptx
Work-Permit-Receiver-in-Saudi-Aramco.pptx
 

08 ip oc304 2_e1_1 zxr10 m6000 bgp configuration 24

  • 2. Objectives Understand the configuration steps of BGP Grasp the configuration of BGP Grasp the Maintenance of BGP
  • 3. BGP configuration steps Configuring BGP neighbor Configuring BGP Route Advertisement BGP Fault Treatment Contents.
  • 4. BGP configuration steps Enable BGP routing process, <as-number> is the AS system ID of router, 1~65535. Configure a BGP neighbor and AS number of a peer Configure BGP Route Advertisement ZXR10(config)# router bgp < as-number> ZXR10(config-bgp)# neighbor [ < ipv4-address> | < peer-group-name> ] remote-as < number> ZXR10(config-bgp)# network< ip-address> < net-mask> ZXR10(config-bgp)# redistribute < protocol>
  • 5. BGP configuration steps Configuring BGP neighbor Configuring BGP Route Advertisement BGP Fault Treatment Contents.
  • 6. Establishing EBGP Neighbor EBGP:physical connected directly --Use IP addresses of interconnected interfaces to create BGP connection --Use IP addresses of loopback interfaces to create BGP connection
  • 7. Establishing EBGP Neighbor--Direct Connected Address R1# config terminal R1(config)# interface fei-0/1/0/1 R1(config-if)# ip address 129.213.1.1 255.255.255.252 R1(config-if)# exit R1(config)# router bgp 65000 R1(config-bgp)# neighbor 129.213.1.2 remote-as 65001 R1(config-bgp)# exit R2# config terminal R2(config)# interface fei-0/1/0/1 R2(config-if)# ip address 129.213.1.2 255.255.255.252 R2(config-if)# exit R2(config)# router bgp 65001 R2(config-bgp)# neighbor 129.213.1.1 remote-as 65000 R2(config-bgp)# exit
  • 8. Establishing EBGP Neighbor--Show BGP neighbor R1#show ip bgp neighbor BGP neighbor is 129.213.1.2, remote AS 65001, external link BGP version 4, remote router ID 129.213.1.2 BGP state = Established, up for 00:04:21 hold time is 90 seconds, keepalive interval is 30 seconds …… Connections established 1 Local host: 129.213.1.1, Local port: 179 Foreign host: 129.213.1.2, Foreign port: 1024 R2#show ip bgp neighbor BGP neighbor is 129.213.1.1, remote AS 65000, external link BGP version 4, remote router ID 129.213.1.1 BGP state = Established, up for 00:00:27 hold time is 90 seconds, keepalive interval is 30 seconds …… Connections established 1 Local host: 129.213.1.2, Local port: 1024 Foreign host: 129.213.1.1, Foreign port: 179
  • 9. Establishing EBGP Neighbor--Loopback address R1# config terminal R1(config)# interface fei-0/1/0/1 R1(config-if)# ip address 192.168.1.1 255.255.255.252 R1(config-if)# exit R1(config)# interface Loopback1 R1(config-if)# ip address 1.1.1.1 255.255.255.255 R1(config-if)# exit R1(config)# router bgp 65000 R1(config-bgp)# neighbor 1.1.1.2 remote-as 65001 R1(config-bgp)# neighbor 1.1.1.2 ebgp-multihop R1(config-bgp)# neighbor 1.1.1.2 update-source Loopback1 R1(config-bgp)# exit R1(config)# ip route 1.1.1.2 255.255.255.255 192.168.1.2 R2(config)# router bgp 65001 R2(config-bgp)# neighbor 1.1.1.1 remote-as 65000 R2(config-bgp)# neighbor 1.1.1.1 ebgp-multihop ttl 5 R2(config-bgp)# neighbor 1.1.1.1 update-source Loopback1 R2(config-bgp)# exit R2(config)# ip route 1.1.1.1 255.255.255.255 192.168.1.1 By default, TTL value for EBGP is 1 use "ebgp-multihop" command while establishing EBGP neighbor on not directly connected interfaces. default TTL value is 8
  • 10. R1#show ip bgp neighbor BGP neighbor is 1.1.1.2, remote AS 65001, external link BGP version 4, remote router ID 1.1.1.2 BGP state = Established, up for 00:01:01 hold time is 90 seconds, keepalive interval is 30 seconds …… Connections established 1 Local host: 1.1.1.1, Local port: 179 Foreign host: 1.1.1.2, Foreign port: 1026 R2#show ip bgp neighbor BGP neighbor is 1.1.1.1, remote AS 65000, external link BGP version 4, remote router ID 1.1.1.1 BGP state = Established, up for 00:02:03 hold time is 90 seconds, keepalive interval is 30 seconds …… Connections established 1 Local host: 1.1.1.2, Local port: 1026 Foreign host: 1.1.1.1, Foreign port: 179 Establishing EBGP Neighbor--Show BGP neighbor
  • 11. Establishing IBGP Neighbor IBGP:physical connected directly or not connected directly -- Use IP addresses of loopback interfaces to create BGP connection -- Synchronization -- Full mesh -- valuable nexthop(have reachable route)
  • 12. Establishing EBGP Neighbor --Loopback address R2# config terminal R2(config)# interface fei-0/1/0/1 R2(config-if)# ip address 192.168.2.1 255.255.255.252 R2(config-if)# exit R2(config)# interface Loopback1 R2(config-if)# ip address 1.1.1.2 255.255.255.255 R2(config-if)# exit R2(config)# router bgp 65001 R2(config-bgp)# neighbor 1.1.1.3 remote-as 65001 R2(config-bgp)# neighbor 1.1.1.3 update-source Loopback1 R2(config-bgp)# neighbor 1.1.1.3 next-hop-self R2(config-bgp)# no synchronization R2(config-bgp)# exit R2(config)# router ospf 1 R2(config-ospfv2)# network 192.168.2.0 0.0.0.3 area 0 R2(config-ospfv2)# network 1.1.1.2 0.0.0.0 area 0 R2(config-ospfv2)# exit R3(config)# router bgp 65001 R3(config-bgp)#neighbor 1.1.1.2 remote-as 65001 R3(config-bgp)#neighbor 1.1.1.2 update-source Loopback1 R3(config-bgp)#neighbor 1.1.1.2 next-hop-self R3(config-bgp)#no synchronization R3(config-bgp)#exit R3(config)#router ospf 1 R3(config-ospfv2)#network 192.168.2.0 0.0.0.3 area 0 R3(config-ospfv2)#network 1.1.1.3 0.0.0.0 area 0 R3(config-ospfv2)#exit
  • 13. Establishing IBGP Neighbor--Show BGP Neighbor R2#show ip bgp neighbor BGP neighbor is 1.1.1.3, remote AS 65001, internal link BGP version 4, remote router ID 1.1.1.3 BGP state = Established, up for 00:01:25 hold time is 90 seconds, keepalive interval is 30 seconds …… Connections established 1 last error code is 6 Local host: 1.1.1.2, Local port: 179 Foreign host: 1.1.1.3, Foreign port: 1096 R3#show ip bgp neighbor BGP neighbor is 1.1.1.2, remote AS 65001, internal link BGP version 4, remote router ID 1.1.1.2 BGP state = Established, up for 00:03:07 …… Connections established 1 last error code is 5 Local host: 1.1.1.3, Local port: 1096 Foreign host: 1.1.1.2, Foreign port: 179
  • 14. BGP configuration steps Configuring BGP neighbor Configuring BGP Route Advertisement BGP Fault Treatment Contents.
  • 15. Configuring BGP Route Advertisement 1. Use network command to advertise route Advertise the concrete network routes learned from IGP protocol (static,RIP、OSPF、ISIS etc) 2. Use redistribute command to advertise route Redistribute all the routes learned from IGP protocol(s) while there are a lot of routes which are hard to aggregate 3. BGP route aggregation Aggregate the routes to one summary route and advertise to other BGP neighbors, therefore can reduce the size of IP routing table significantly. Make sure the mask of all the routes are equal while configuring route aggregation on routers, in order to avoid black hole route
  • 16. Using network to Advertise Route R2 runs OSPF as IGP protocol. R2 requires advertising the network segment 18.0.0.0/8 which is discovered by OSPF in BGP. R2#config terminal R2(config)#interface fei-0/1/0/1 R2(config-if)#ip address 192.168.2.1 255.255.255.252 R2(config-if)#exit R2(config)#router bgp 65001 R2(config-bgp)#neighbor 192.168.2.2 remote-as 65000 R2(config-bgp)#network 18.0.0.0 255.255.255.0 R2(config-bgp)#exit R2(config)#router ospf 1 R2(config-ospfv2)#network 18.0.0.0 0.255.255.255 area 0 R2(config-ospfv2)#exit R1#config terminal R1(config)#interface fei-0/1/0/1 R1(config-if)#ip address 192.168.2.2 255.255.255.252 R1(config-if)#exit R1(config)#router bgp 65000 R1(config-bgp)#neighbor 192.168.2.1 remote-as 65001 R1(config-bgp)#exit
  • 17. Using network to Advertise Route-- Show BGP route R2 runs OSPF as IGP protocol. R2 requires advertising the network segment 18.0.0.0/8 which is discovered by OSPF in BGP. R1#show ip bgp route Status codes: *-valid, >-best, i-internal,s-stale Origin codes: i-IGP, e-EGP, ?-incomplete Dest NextHop Metric LocPrf RtPrf Path *>18.0.0.0/8 192.168.2.1 20 65001 i “*” indicates the route is available “>” indicates the route is the best choice “i” indicates this is a IBGP route, without “i” indicates this is a EBGP route or local route Next-hop:If the address is full zero, that means this route is generated by router itself Local-Pre:the priority level of route which is learned by BGP. The default value is 100 Path:shows the origin of this route. Three types: IGP, EGP and incomplete
  • 18. Using redistribute to Advertise Route R2 runs OSPF as IGP protocol. Now it needs to redistribute all OSPF routes information on R2 into BGP. R2#config terminal R2(config)#interface fei-0/1/0/1 R2(config-if)#ip address 192.168.2.1 255.255.255.252 R2(config-if)#exit R2(config)#router ospf 1 R2(config-ospfv2)#network 18.0.0.0 0.0.0.255 area 0 R2(config-ospfv2)#exit R2(config)#router bgp 65001 R2(config-bgp)#neighbor 192.168.2.2 remote-as 65000 R2(config-bgp)#redistribute ospf-int R2(config-bgp)#redistribute connected R2(config-bgp)#exit
  • 19. Using redistribute to Advertise Route-- Show BGP Route R1#show ip bgp route Status codes: *-valid, >-best, i-internal,s-stale Origin codes: i-IGP, e-EGP, ?-incomplete Dest NextHop Metric LocPrf RtPrf Path *> 18.0.0.0/8 192.168.2.1 20 65001 ? R2 runs OSPF as IGP protocol. Now it needs to redistribute all OSPF routes information on R2 into BGP.
  • 20. Configuring Route Aggregation R1 advertises the segments of its own and the segments of R3 (192.168.0.0/24, 192.168.1.0/24, 192.168.2.0/24 and 192.168.3.0/24) to R2 in AS300. OSPF is run on the link between R1 and R3. R1(config)#interface fei-0/1/0/1 R1(config-if)#ip address 2.2.2.2 255.255.255.0 R1(config-if)#exit R1(config)#router bgp 100 R1(config-bgp)#neighbor 2.2.2.1 remote-as 300 R1(config-bgp)#aggregate-address 192.168.0.0 255.255.252.0 count 0 summary-only R1(config-bgp)#redistribute ospf-int R1(config-bgp)#redistribute connected R1(config-bgp)#exit R1(config)#router ospf 1 R1(config-ospfv2)#network 192.168.3.0 0.0.0.255 area 0 R1(config-ospfv2)#network 10.1.1.0 0.0.0.3 area 0 R1(config-ospfv2)#exit If the command is used without the parameter summary-only, R2 will advertise the detailed routes with the aggregated route
  • 21. Configuring Route Aggregation-- Show BGP route R2#show ip bgp route Status codes: *valid, >best, i-internal Origin codes: i-IGP, e-EGP, ?-incomplete Dest NextHop Metric LocPrf RtPrf Path *>192.168.0.0/22 2.2.2.2 20 100 i R2#show ip bgp route detail 192.168.0.0 255.255.252.0 BGP routing table entry for 192.168.0.0/22 01:02:19 received from 2.2.2.2 origin i, nexthop 2.2.2.2,atomic,aggr 100 2.2.2.2, as path [100] R1 advertises the segments of its own and the segments of R3 (192.168.0.0/24, 192.168.1.0/24, 192.168.2.0/24 and 192.168.3.0/24) to R2 in AS300. OSPF is run on the link between R1 and R3.
  • 22. BGP configuration steps Configures a BGP neighbor Configuring BGP Route Advertisement BGP Fault Treatment Contents