SlideShare uma empresa Scribd logo
1 de 33
CCNA
(CISCO CERTIFIED NETWORK ASSOCIATE)
List of Tables
1. Internetworking
2. Internet Protocols
3. IP Subnetting and Variable Length Subnet Mask
4. Introduction to the Cisco IOS
5. IP Routing
6. Switching
7. IPv4 vs IPv6
Name: Abhishek Parihari
Reg. No. : 11311575
Introduction about NETWORK and PROTOCOL
Network is simply defined as something that connects things together for a specific purpose.
The term network is used in a variety of contexts, including telephone, television, computer,
or even people networks.
A computer network connects two or more devices together to share a nearly limitless range of information and
services, including:
 Documents
 Email and messaging
 Websites
 Databases
 Music
 Printers and faxes
 Telephony and video conferencing
Protocols are rules that govern how devices communicate and share information across a
network. Examples of protocols include:
• IP – Internet Protocol
• HTTP - Hyper Text Transfer Protocol
• SMTP – Simple mailTransfer Protocol
Internetworking Model ( Reference Model )
Open System Interconnection (OSI) reference model was created by the International Organization for Standardization (ISO)
A reference model is a conceptual blueprint of how communications should take place. It addresses all the processes
required for effective communication and divides theses process into logical groupings called layers.
Seven Layers that define the different stages that data must go through to travel from one device to another
over a network.
Application Set
• Layer 7 : Application
( interacts with the operating system or application
whenever the user chooses to transfer files,
read messages or perform other network-related activities)
• Layer 6 : Presentation
(takes the data provided by the Application layer and
converts it into a standard format that the other layers can
understand)
• Layer 5 : Session
(establishes, maintains and ends communication with the
receiving device)
Transport Set
• Layer 4 : Transport
(maintains flow control of data and provides for error checking
and recovery of data between the devices)
• Layer 3 : Network
(The way that the data will be sent to the recipient device is
determined in this layer. Logical protocols, routing and
addressing are handled)
• Layer 2 : Data
(the appropriate physical protocol is assigned to the data. Also,
the type of network and the packet sequencing is defined)
• Layer 1 : Physical
(defines the physical characteristics of the network such as
connections, voltage levels and timimg)
TCP(Transmission Control Protocol) UDP(User Datagram Protocol)
Protocol No. - 6 Protocol No. - 17
Connection Oriented Connection Less
Secure Insecure
3 way handshaking Doesn’t support 3 way handshaking
Slower than UDP Faster than TCP
e.g. HTTP, HTTPS, SMTP, FTP, Telnet etc. e.g. DHCP, DNS, TFTP, RIP
Client Server
3 way handshaking
SYNC
SYNC + ACK
ACK
● 32 bits address
● Format- Dotted Decimal
● No. of Addresses = 2^32 = 4.3 Billion (approx.)
To get IP Addresses
1- IANA ( Internet Assigned Number Authority )
2- RIR ( Regional Internet Registry )
3- NIR ( National Internet Registries )
4- LIR ( Local Internet Registries )
5- Local ISP( Internet Service Provider )
6- Customers
Network Addressing
Classes of IP Address and their ranges
CLASS A 1 - 126
CLASS B 128 - 191
CLASS C 192 - 223
CLASS D 224 - 239
CLASS E 240 - 255
Reserved for multicasting
Research & Development
127 – Reserved for loopback address
CLASS A : NETWORK HOST HOST HOST
CLASS B : NETWORK NETWORK HOST HOST
CLASS C : NETWORK NETWORK NETWORK HOST
8 Bits 8 Bits 8 Bits 8 Bits
In a network
First Address – Network Address
Last Address – Broadcast Address
IP ADDRESSING
Subnetting
divides a network into small networks
Benefits of subnetting :
• Reduced network traffic
• Optimized network performance
• Simplified management
• Facilitated spanning of large geographical distances
Subnet Mask only informs about the network bits out
of 32 bits address
CLASS DEFAULT SUBNET MASK
A 255.0.0.0
B 255.255.0.0
C 255.255.255.0
Default Subnet Mask Table
VLSM ( Variable Level Subnet Masking)
Public IP address – allowed in internet
Private IP address – not allowed in intrnet
Private IP Addresses
Class A : 10.0.0.0 – 10.255.255.255
Class B : 172.16.0.0 – 172.31.255.255
Class C : 192.168.0.0 – 192.168.255.255
Supernetting or Summarization
The process of taking a range of IP addresses and
advertising them in one address block
e.g. – let’s take 4 IP addresses
1. 192.168.1.1/24
2. 192.168.2.1/24
3. 192.168.3.1/24
4. 192.168.4.1/24
After Summarization we can
create a new Network as
192.168.0.0/21
CISCO ROUTER IOS
●The Cisco IOS was created to deliver network services and enable networked applications.
● Some of the important things that the Cisco router IOS software is responsible for include
– Carrying network protocols and functions
– Connecting high-speed traffic between devices
– Adding Security to control access and stop unauthorised network use
– Providing scalability for ease of network growth and redundancy
– Supplying network reliability for connecting to network resources
● Connecting to a Cisco Router
We can connect to a Cisco Router to
– configure it
– verify its configuration
– check statistics
We can connect to a Cisco Router through
– console port
– auxiliary port
Console Port
Auxiliary Port
Physical View of Router
Basic Routing Configuration
Router>enable // user mode
Router#configure terminal // privilege mode
Router(config)#hostname R1 // to change the name of Router (hostname - keyword)
R1(config)#interface f0/0 // global mode or configuration mode
R1(config-if)#ip address 192.168.1.1 255.255.255.0 // global interface mode
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#exit
R1#write
or
R1#copy running-config startup-config
To Set PASSWORD in CONSOLE PORT / AUX PORT
R1(config)#line con 0
R1(config-line)#password abcd
R1(config-line)#login
R1(config-line)#exit
R1(config)#enable password 1234
R1(config)#enable secret 1234
To save the configuration of router
R1(config)#line aux 0
R1(config-line)#password abcd
R1(config-line)#login
R1(config-line)#exit
R1(config)#enable password 1234
R1(config)#enable secret 1234
R1(config)#service password-encryption
[hides all the plain text password and
encrypt the password]
To Create IOS BACKUP
Router#dir flash:
Directory of flash:/
3 -rw- 5571584 <no date> pt1000-i-mz.122-28.bin
2 -rw- 28282 <no date> sigdef-category.xml
1 -rw- 227537 <no date> sigdef-default.xml
64016384 bytes total (58188981 bytes free)
Router#copy flash: tftp:
Source filename []? pt1000-i-mz.122-28.bin
Address or name of remote host []? 192.168.1.2
Destination filename [pt1000-i-mz.122-28.bin]? yes
Writing pt1000-i-mz.122-28.bin....!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK - 5571584 bytes]
5571584 bytes copied in 3.1 secs (411811 bytes/sec)
TO DELETE ROUTER IOS
Router#delete flash
Delete filename []?pt1000-i-mz.122-28.bin
Delete flash:/pt1000-i-mz.122-28.bin? [confirm]y
Router#reload
Proceed with reload? [confirm]y System Bootstrap, Version
12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
RESTORING ROUTER IOS
rommon 1 > IP_ADDRESS=192.168.1.1
rommon 2 > TFTP_SERVER=192.168.1.2
rommon 3 > TFTP_FILE=pt1000-i-mz.122-28.bin
rommon 4 > IP_SUBNET_MASK=255.255.255.0
rommon 5 > DEFAULT_GATEWAY=192.168.1.2
rommon 6 > tftpdnld
IP_ADDRESS: 192.168.1.1
IP_SUBNET_MASK: 255.255.255.0
DEFAULT_GATEWAY: 192.168.1.2
TFTP_SERVER: 192.168.1.2
TFTP_FILE: pt1000-i-mz.122-28.bin
Invoke this command for disaster recovery only.
WARNING: all existing data in all partitions on flash will
be lost!
Do you wish to continue? y/n: [n]: y
rommon 7 > boot
IP ROUTING
● IP routing is the process of moving packets from one network to another network using routers.
● A routing protocol is used by routers to dynamically find all the networks in the internetwork and to ensure all
routers have same routing table. Basically, a routing protocol determines the path of a packet through an
internetwork.
e.g. RIP, IGRP, EIGRP, OSPF ROUTING
PROTOCOL
STATIC
(AD=1)
DEFAULT
(AD=254)
DYNAMIC
IGP EGP
DISTANCE VECTOR
i) RIP
ii) IGRP
LINK STATE
i) OSPF
ii) IS-IS
HYBRID
i) EIGRP
-IGP – Interior Gateway Protocol
-EGP – Exterior Gateway Protocol
● Administrative Value (AD) [range 0-255]
- shows the trustworthiness of any routing protocol
- least AD value is always preferred
● Router’s priority
1st Highest Prefix Match
2nd AD Value
3rd Metric Value
Border
Gateway
Protocol
STATIC ROUTING
Static routing is a form of routing that occurs when a router uses a manually-configured routing entry, rather than information
from a dynamic routing traffic. Static routers are manually configured by a network administrator by adding entries into routing
table.
R1(config)#int f0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int s2/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip route 172.16.0.0 255.255.0.0 s2/0
R1(config)#exit
R1# show ip route
R2(config)#int f0/0
R2(config-if)#ip address 172.16.0.1 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int s2/0
R2(config-if)#ip address 10.0.0.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#ip route 192.168.1.0 255.255.255.0 s2/0
R2(config)#exit
DEFAULT ROUTING
• to make all unknown networks reachable we use default routing
• default routing suppresses the routing table
STUB ROUTER – The router who has only single exit interface point to share the traffic.
Default routing is implemented on stub router
R1 and R2 are stub routers. Default routing
will be implemented.
On R2 we will implement static routing.
For default routing
Router(config)# ip route
<unknown n/w><unknown s/m><exit int>
R1(config)# ip route 0.0.0.0 0.0.0.0 s2/0
R3(config)# ip route 0.0.0.0 0.0.0.0 s2/0
R2(config)# ip route 192.168.1.0 255.255.255.0 s2/0
R2(config)# ip route 192.168.3.0 255.255.255.0 s3/0
ROUTING INFORMATION PROTOCOL ( RIP )
AD=120
Metric = hop count ( 0-15 )
Multicast address = 224.0.0.9
Algorithm = Bellman Ford
UDP Port No. 520
Hop count : when packet travels from one network to another network. ( least no of hop count is preferred )
RIP Version 1 RIP Version 2
Classful Classless
Broadcast Multicast
Broadcast address-
255.255.255.255
Multicast address-
224.0.0.9
Doesn’t support VLSM Supports VLSM
Doesn’t support summarization Supports summarization
Doesn’t support authentication Supports authentication
RIP TIMER
Update – 30 seconds
Invalid – 180 seconds
Total Down – 180 seconds
Flush out – 240 seconds
SLOW CONVERGENCE is the reason that RIP abolished from market
RIP Ver1 and Ver2 are not compatible with each other.
R1(config)#router rip
R1(config-router)#network 192.168.1.0
R1(config-router)#network 10.0.0.0
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#exit
R2(config)#router rip
R2(config-router)#network 11.0.0.0
R2(config-router)#network 10.0.0.0
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#exit
R3(config)#router eigrp 10
R3(config-router)#network 12.0.0.0
R3(config-router)#network 11.0.0.0
R3(config-router)#version 2
R3(config-router)#no auto-summary
R3(config-router)#exit
Router(config-router)# no auto-summary is used to make the protocol classless
Interior Gateway Routing Protocol (IGRP)
- Cisco proprietary routing protocol
- Works on distance vector
- Hop count =100
- AD Value = 100
Enhanced Interior Gateway Routing Protocol ( EIGRP )
- hybrid routing protocol
- Works on advance distance vector
- Hop counts = 100 (by default), can be extended upto 255
- Maintains three types of table
• Neighbor Table
• Topology Table
• Routing Table
- Sends partial update
- Fast convergence routing protocol
- Multicast address : 224.0.0.10
- Algorithm : Diffusing Update Algorithm (DUAL)
- AD Value = 90 {for internal routes}
= 170 {for external routes}
- Independent protocol, Protocol No. – 88
- Classful routing protocol (by default), can be used as classless also
- Works on AUTONOMOUS SYSTEM
Autonomous System
- A group of routers belong to a single domain
- Range : 1 to 65535
- To reduce the complexity of hop counts we
divide the networks into different autonomous
system
EIGRP can do unequal host load sharing
Matric Values
Default Values
K1 Bandwidth 1
K2 Load 0
K3 Delay 1
K4 Reliability 0
K5 MTU
(Maximum Transfer Unit)
0
Matric Calculation Formula
[10^7 / least bandwidth + sum of delay / 10] * 256
R1(config)#router eigrp 10
R1(config-router)#network 192.168.1.0
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#exit
R2(config)#router eigrp 10
R2(config-router)#network 11.0.0.0
R2(config-router)#network 10.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#exit
R3(config)#router eigrp 10
R3(config-router)#network 12.0.0.0
R3(config-router)#network 11.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#exit
eigrp 10 ; here 10 is referred to as Autonomous System (AS) Value
Open Shortest Path First (OSPF)
• Works on link state routing protocol
• Unlimited hop counts
• Hop counts divided into areas
• Area 0 is created first and is known as backbone area or management area
• All the areas must be connected with area 0
• AD Value = 110
• Multicast Address : 224.0.0.5 (for updates / to send a hello message)
: 224.0.0.6 (for DR/BDR)
• Metric = cost (Bandwidth)
• Algorithm = SPF ( Shortest Path First)
Area Boarder Router (ABR) – to make a router ABR one of the interface must be present in AREA 0. From above diagram
R2 and R3 are Area Boarder Router (ABR).
Autonomous System Boarder Router (ASBR) – to make a router ASBR one of the interface must be present in OSPF and
another interface in different routing protocol. From above diagram
R4 is ASBR.
AREA 1
OSPF
AREA 0
OSPF
AREA 2
OSPF
AREA 3
EIGRP
AREA 0 AREA 1
R1(config)#router ospf 10
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#network 10.0.0.0 0.255.255.255 area 0
R1(config-router)#exit
R3(config)#router ospf 10
R3(config-router)#network 11.0.0.0 0.255.255.255 area 1
R3(config-router)#network 12.0.0.0 0.255.255.255 area 1
R3(config-router)#exit
R2(config)#router ospf 10
R2(config-router)#network 10.0.0.0 0.255.255.255 area 0
R2(config-router)#network 11.0.0.0 0.255.255.255 area 1
R2(config-router)#exit
To make a router DR (Designated Router) and
BDR (Backup Designated Router)
1. Highest priority value is preferred. (Priority Value 0-255)
if priority value is 0, it’s neither DR nor BDR
2. Highest loopback address is preferred.
3. Highest interface IP address is preferred.
[Second Highest is preferred to make a router BDR]
- Remaining routers DRO(designated Router Others)
- DRO will form neighborship with DR and BDR
To save BANDWIDTH we use DR / BDR
Link State Advertisement ( LSA)
LSA’s 1 – Router LSA
LSA’s 2 – Network LSA
LSA’s 3 – Summary LSA
LSA’s 4 – ASBR Summary LSA
LSA’s 5 – External LSA
Wild Card Mask or Inverse Mask Table
Class A – 0.255.255.255
Class B – 0.0.255.255
Class C – 0.0.0.255
SWITCHING
Switching is the process of using the hardware address of devices on a LAN to segment a network.
- works on single broadcast domain
- With the help of VLAN (Virtual Local Area Network) broadcast domain will be divided.
- Total no. of VLAN = 4096 {range ( 0-4095 )}
- Same VLAN and same subnet mask communicate with each other
- VLAN 1’s IP address is known as management IP address
VLAN NO. DESCRIPTION
0 , 4095 Reserved for the systems
1 Cisco reserved
[default VLAN / management VLAN / Native
VLAN / Untagged VLAN ]
2 – 1001 Normal VLAN
1002 – 1005 Reserved for different technologies
1006 – 4094 Extended VLAN
SALE SALEIT IT
Case: Traffic of SALE Department shouldn’t be shared with IT Department
Put SALE Department in VLAN 10 and IT Department in VLAN 20
TRUNK : Carry the traffic of multiple VLAN
To check the status of VLAN : Switch# show vlan brief
Switch>enable
Switch#configure terminal
Switch(config)#hostname Switch1
Switch1(config)#VLAN 10
Switch1(config-vlan)#name sale
Switch1(config-vlan)#VLAN 20
Switch1(config-vlan)#name IT
Switch1(config-vlan)#exit
Switch1(config)#interface range f0/1-02
Switch1(config-if-range)#switchport mode access
Switch1(config-if-range)#switchport access VLAN 10
Switch1(config-if-range)#exit
Switch1(config)#interface range f0/3-04
Switch1(config-if-range)#switchport mode access
Switch1(config-if-range)#switchport access VLAN 20
Switch1(config-if-range)#exit
Switch>enable
Switch#configure terminal
Switch(config)#hostname Switch2
Switch2(config)#VLAN 10
Switch2(config-vlan)#name sale
Switch2(config-vlan)#VLAN 20
Switch2(config-vlan)#name IT
Switch2(config-vlan)#exit
Switch2(config)#interface range f0/2-03
Switch2(config-if-range)#switchport mode access
Switch2(config-if-range)#switchport access VLAN 10
Switch2(config-if-range)#exit
Switch2(config)#interface range f0/4-05
Switch2(config-if-range)#switchport mode access
Switch2(config-if-range)#switchport access VLAN 20
Switch2(config-if-range)#exit
To make interface TRUNK
Switch1(config)#interface f0/5
Switch1(config-if)#switchport mode trunk
Switch>enable
Switch#configure terminal
Switch(config)#hostname Switch1
Switch1(config)#VLAN 10
Switch1(config-vlan)#name sale
Switch1(config-vlan)#VLAN 20
Switch1(config-vlan)#name IT
Switch1(config-vlan)#exit
Router(config)#interface f0/0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int f0/0.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config)#int f0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 10.0.0.1 255.0.0.0
Router(config-subif)#exit
192.168.1.0/24 10.0.0.0/8
INTER VLAN ROUTING
( Router on a stick )
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface range f0/1-02
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#exit
Switch(config)#interface range f0/3-04
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#exit
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#ip address 10.0.0.1 255.0.0.0
Switch(config-if)#exit
Switch(config)#ip routing // to maintain the routing table
for switch
By default switch maintains CAM table
SWITCH VIRTUAL INTERFACE ( SVI )
Switch>enable
Switch#configure terminal
Switch(config)#interface f0/1 //port where security to be enabled
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 1
Switch(config-if)#switchport port-security
Switch(config-if)#switchport port-security maximum 1
Switch(config-if)#switchport port-security violation shutdown
Switch(config-if)#switchport port-security mac-address FFFF.FFFF.FFFF
Switch# show port-security : to check the status of port security
Switch# show mac-address-table : to check the mac address connected to
the ports
PORT SECURITY
DYNAMIC HOST CONFIGURATION PROTOCOL ( DHCP )
Works on the concept of D O R A
• DISCOVER
- discover message generated by client
- Broadcast message sent to all, accepted by
only server, rejected by other clients due to
port no. 67
• OFFER
- Server offers IP address, gateway, DNS
server to all clients (broadcast)
- Packets are accepted and discarded with
the help of mac address
• REQUEST
- To cross check whether the same IP address
has been assigned to any other clients or
not.
- Requests for time of expiry
• ACKNOWLEDGEMENT
- From server to client if everything is okay
and allright
Automatic Private IP Address ( APIPA )
It is an error which provides IP address in
the range of
169.254.0.0 - 169.254.254.254
- DHCP is a standardized network protocol used on Internet Protocol (IP) networks for dynamically distributing network
configuration parameters.
- Computers request IP addresses and networking parameters automatically from a DHCP server
- Port No. 67 for request
- Port No. 68 for reply
Router(config)#ip dhcp pool abcd
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.1.1
Router(config)#ip dhcp excluded-address 192.168.1.4 192.168.1.11
(to exclude the IP addresses from pool and to provide it manually)
HOT STANDBY ROUTING PROTOCOL ( HSRP )
We use HSRP to overcome the problem of link damage of default gateway
Conditions for a router to become active
- Highest priority value [by default priority value = 100] [range 0 - 255]
- Highest interface IP address
Hello message – 3 seconds
Hold on time – 10 seconds
Router1(config)#interface f0/0
Router1(config-if)#standby 1 ip 192.168.1.254
Router1(config-if)#standby 1 priority 150
Router1(config-if)#standby 1 preempt
Router1(config-if)#exit
Router2(config)#interface f0/0
Router2(config-if)#standby 1 ip 192.168.1.254
Router2(config-if)#standby 1 priority 50
Router2(config-if)#standby 1 preempt
Router2(config-if)#exit
INTERNET
Router1(config-if)#standby 1 preempt
Is used for the automatic elections to find out the active router
ACCESS CONTROL LIST (ACL)
used for FILTERING purpose
STANDARD EXTENDED NAMING
1 – 99 100 – 199 Any name
Blocks all services or
complete protocol.
e.g. – UDP, ICMP, IGRP and
other routing protocols
Filtering can be done i.e.
few services should be
allowed and others should
be blocked
Takes decision based on
source address
Takes decision based on
both source and destination
address
Implemented near to
destination
Implemented near to source
To block a network
R2 (config)#access-list 1 deny 192.168.1.0 0.0.0.255
R2 (config)#interface f0/0
R2 (config-if)#ip access-group 1 out
To block particular IP addresses
R2(config)#access-list 5 deny host 192.168.1.2
R2(config)#access-list 5 deny host 192.168.1.3
R2(config)#access-list 5 permit any
R2(config)#int f0/0
R2(config-if)#ip access-group 5 out
Block IP address using extended
R1(config)#access-list 100 deny tcp host 192.168.1.2 host 192.168.3.5 eq 80
R1(config)#access-list 100 deny tcp host 192.168.1.2 host 192.168.3.5 eq 443
R1(config)#access-list 100 permit ip any any
R1(config)#int s2/0
R1(config-if)#ip access-group 100 out
NETWORK ADDRESS TRANSLATION ( NAT )
Types:
• Static – one private address to one public address. It’s a hard-core binding.
• Dynamic – many private addresses to many public addresses. It’s no hard-core binding
• Port Address Translation (PAT) – many private addresses to one public address
STATIC TYPE
R1(config)#ip nat inside source static 192.168.1.2 121.1.1.3
R1(config)#interface f0/0
R1(config-if)#ip nat inside
R1(config-if)#interface s2/0
R1(config-if)#ip nat outside
R1(config-if)#exit
DYNAMIC TYPE
R1(config)#access-list 1 permit host 192.168.1.2
R1(config)#access-list 1 permit host 192.168.1.3
R1(config)#ip nat inside source list 1 pool abcd
R1(config)#ip nat pool abcd 121.1.1.3 121.1.1.10 netmask 255.0.0.0
PAT
R1(config)#access-list 1 permit 192.168.1.0 0.0.0.255
R1(config)#ip nat inside source list pool abcd overload
R1(config)#ip nat pool abcd 121.1.1.3 121.1.1.3 netmask 255.0.0.0 192.168.1.0 / 24
IPv4 IPv6
32 bits 128 bits
Dotted decimal Hexadecimal
4 octant (1 octant = 8 bits) 8 field (1 field = 16 bits)
Separated by “ . ” (dot) Separated by “ : ” (colon)
Broadcast Any cast
IP Security – Not Available IP Security – Available
No. of IP Addresses = 2^32 No. of IP Addresses = 2^128
DIFFERENCE BETWEEN IPv4 and IPv6

Mais conteúdo relacionado

Mais procurados

CCNP Switching Chapter 1
CCNP Switching Chapter 1CCNP Switching Chapter 1
CCNP Switching Chapter 1Chaing Ravuth
 
CCNA 1 Routing and Switching v5.0 Chapter 8
CCNA 1 Routing and Switching v5.0 Chapter 8CCNA 1 Routing and Switching v5.0 Chapter 8
CCNA 1 Routing and Switching v5.0 Chapter 8Nil Menon
 
Presentation on ccna
Presentation on ccnaPresentation on ccna
Presentation on ccnaHoneyKumar34
 
CCNAv5 - S3: Chapter 4 Wireless Lans
CCNAv5 - S3: Chapter 4 Wireless LansCCNAv5 - S3: Chapter 4 Wireless Lans
CCNAv5 - S3: Chapter 4 Wireless LansVuz Dở Hơi
 
CCNA 1 Routing and Switching v5.0 Chapter 3
CCNA 1 Routing and Switching v5.0 Chapter 3CCNA 1 Routing and Switching v5.0 Chapter 3
CCNA 1 Routing and Switching v5.0 Chapter 3Nil Menon
 
CCNA training 101
CCNA training 101CCNA training 101
CCNA training 101Rohan Reddy
 
Tn 310 vlan-trunking
Tn 310 vlan-trunkingTn 310 vlan-trunking
Tn 310 vlan-trunkingsali Ibrahimu
 
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...Tarun Khaneja
 
Chapter 17 : static routing
Chapter 17 : static routingChapter 17 : static routing
Chapter 17 : static routingteknetir
 
Ccna rse chp7 Access Control List (ACL)
Ccna rse chp7 Access Control List (ACL)Ccna rse chp7 Access Control List (ACL)
Ccna rse chp7 Access Control List (ACL)newbie2019
 
CCNA 1 Routing and Switching v5.0 Chapter 2
CCNA 1 Routing and Switching v5.0 Chapter 2CCNA 1 Routing and Switching v5.0 Chapter 2
CCNA 1 Routing and Switching v5.0 Chapter 2Nil Menon
 
CCNA PPT
CCNA PPTCCNA PPT
CCNA PPTAIRTEL
 
Ccna PPT
Ccna PPTCcna PPT
Ccna PPTAIRTEL
 
CCNAv5 - S3: Chapter 7 EIGRP
CCNAv5 - S3: Chapter 7 EIGRPCCNAv5 - S3: Chapter 7 EIGRP
CCNAv5 - S3: Chapter 7 EIGRPVuz Dở Hơi
 
Cisco router basic
Cisco router basicCisco router basic
Cisco router basicTapan Khilar
 
CCNAv5 - S2: Chapter3 Vlans
CCNAv5 - S2: Chapter3 VlansCCNAv5 - S2: Chapter3 Vlans
CCNAv5 - S2: Chapter3 VlansVuz Dở Hơi
 
Cisco-Press-CCNP-and-CCIE-Enterprise-Core-ENCOR-350-401-Official-Cert-Guide.pdf
Cisco-Press-CCNP-and-CCIE-Enterprise-Core-ENCOR-350-401-Official-Cert-Guide.pdfCisco-Press-CCNP-and-CCIE-Enterprise-Core-ENCOR-350-401-Official-Cert-Guide.pdf
Cisco-Press-CCNP-and-CCIE-Enterprise-Core-ENCOR-350-401-Official-Cert-Guide.pdfLeeRonald2
 

Mais procurados (20)

CCNP Switching Chapter 1
CCNP Switching Chapter 1CCNP Switching Chapter 1
CCNP Switching Chapter 1
 
CCNA 1 Routing and Switching v5.0 Chapter 8
CCNA 1 Routing and Switching v5.0 Chapter 8CCNA 1 Routing and Switching v5.0 Chapter 8
CCNA 1 Routing and Switching v5.0 Chapter 8
 
ccna networking ppt
ccna networking pptccna networking ppt
ccna networking ppt
 
CCNA IP Addressing
CCNA IP AddressingCCNA IP Addressing
CCNA IP Addressing
 
Presentation on ccna
Presentation on ccnaPresentation on ccna
Presentation on ccna
 
CCNAv5 - S3: Chapter 4 Wireless Lans
CCNAv5 - S3: Chapter 4 Wireless LansCCNAv5 - S3: Chapter 4 Wireless Lans
CCNAv5 - S3: Chapter 4 Wireless Lans
 
CCNA 1 Routing and Switching v5.0 Chapter 3
CCNA 1 Routing and Switching v5.0 Chapter 3CCNA 1 Routing and Switching v5.0 Chapter 3
CCNA 1 Routing and Switching v5.0 Chapter 3
 
CCNA training 101
CCNA training 101CCNA training 101
CCNA training 101
 
Ccna command
Ccna commandCcna command
Ccna command
 
Tn 310 vlan-trunking
Tn 310 vlan-trunkingTn 310 vlan-trunking
Tn 310 vlan-trunking
 
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
 
Chapter 17 : static routing
Chapter 17 : static routingChapter 17 : static routing
Chapter 17 : static routing
 
Ccna rse chp7 Access Control List (ACL)
Ccna rse chp7 Access Control List (ACL)Ccna rse chp7 Access Control List (ACL)
Ccna rse chp7 Access Control List (ACL)
 
CCNA 1 Routing and Switching v5.0 Chapter 2
CCNA 1 Routing and Switching v5.0 Chapter 2CCNA 1 Routing and Switching v5.0 Chapter 2
CCNA 1 Routing and Switching v5.0 Chapter 2
 
CCNA PPT
CCNA PPTCCNA PPT
CCNA PPT
 
Ccna PPT
Ccna PPTCcna PPT
Ccna PPT
 
CCNAv5 - S3: Chapter 7 EIGRP
CCNAv5 - S3: Chapter 7 EIGRPCCNAv5 - S3: Chapter 7 EIGRP
CCNAv5 - S3: Chapter 7 EIGRP
 
Cisco router basic
Cisco router basicCisco router basic
Cisco router basic
 
CCNAv5 - S2: Chapter3 Vlans
CCNAv5 - S2: Chapter3 VlansCCNAv5 - S2: Chapter3 Vlans
CCNAv5 - S2: Chapter3 Vlans
 
Cisco-Press-CCNP-and-CCIE-Enterprise-Core-ENCOR-350-401-Official-Cert-Guide.pdf
Cisco-Press-CCNP-and-CCIE-Enterprise-Core-ENCOR-350-401-Official-Cert-Guide.pdfCisco-Press-CCNP-and-CCIE-Enterprise-Core-ENCOR-350-401-Official-Cert-Guide.pdf
Cisco-Press-CCNP-and-CCIE-Enterprise-Core-ENCOR-350-401-Official-Cert-Guide.pdf
 

Semelhante a CCNA: Introduction to Networking and Protocols

ccna project on topic company infrastructure
ccna project on topic company infrastructureccna project on topic company infrastructure
ccna project on topic company infrastructurePrince Gautam
 
Introduction 140318015826-phpapp01
Introduction 140318015826-phpapp01Introduction 140318015826-phpapp01
Introduction 140318015826-phpapp01amit singh
 
Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Saurav Pandey
 
BASIC TO ADVANCED NETWORKING TUTORIALS
BASIC TO ADVANCED NETWORKING TUTORIALSBASIC TO ADVANCED NETWORKING TUTORIALS
BASIC TO ADVANCED NETWORKING TUTORIALSVarinder Singh Walia
 
Networking
NetworkingNetworking
NetworkingRashmi
 
Training Day Slides
Training Day SlidesTraining Day Slides
Training Day Slidesadam_merritt
 
Session 2 Tp 2
Session 2 Tp 2Session 2 Tp 2
Session 2 Tp 2githe26200
 
G3 phase1 final ppt.pptx
G3 phase1 final ppt.pptxG3 phase1 final ppt.pptx
G3 phase1 final ppt.pptxvisheshs4
 
Routing of netwok protocls and how .pptx
Routing of netwok protocls and how .pptxRouting of netwok protocls and how .pptx
Routing of netwok protocls and how .pptxsayidkhalif
 
Basic ccna interview questions and answers ~ sysnet notes
Basic ccna interview questions and answers ~ sysnet notesBasic ccna interview questions and answers ~ sysnet notes
Basic ccna interview questions and answers ~ sysnet notesVamsi Krishna Kalavala
 
ConfigureTwo networks principle
ConfigureTwo networks principleConfigureTwo networks principle
ConfigureTwo networks principleDrAlneami
 
Chapter_6_ Network Layer.pptx
Chapter_6_ Network Layer.pptxChapter_6_ Network Layer.pptx
Chapter_6_ Network Layer.pptxduotchol
 

Semelhante a CCNA: Introduction to Networking and Protocols (20)

ccna project on topic company infrastructure
ccna project on topic company infrastructureccna project on topic company infrastructure
ccna project on topic company infrastructure
 
Introduction 140318015826-phpapp01
Introduction 140318015826-phpapp01Introduction 140318015826-phpapp01
Introduction 140318015826-phpapp01
 
Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0
 
Basic network training2
Basic network training2Basic network training2
Basic network training2
 
BASIC TO ADVANCED NETWORKING TUTORIALS
BASIC TO ADVANCED NETWORKING TUTORIALSBASIC TO ADVANCED NETWORKING TUTORIALS
BASIC TO ADVANCED NETWORKING TUTORIALS
 
Networking
NetworkingNetworking
Networking
 
Training Day Slides
Training Day SlidesTraining Day Slides
Training Day Slides
 
Ccna Imp Guide
Ccna Imp GuideCcna Imp Guide
Ccna Imp Guide
 
Session 2 Tp 2
Session 2 Tp 2Session 2 Tp 2
Session 2 Tp 2
 
G3 phase1 final ppt.pptx
G3 phase1 final ppt.pptxG3 phase1 final ppt.pptx
G3 phase1 final ppt.pptx
 
Routing of netwok protocls and how .pptx
Routing of netwok protocls and how .pptxRouting of netwok protocls and how .pptx
Routing of netwok protocls and how .pptx
 
Ccna1 presentation
Ccna1 presentationCcna1 presentation
Ccna1 presentation
 
TCP/IP Basics
TCP/IP BasicsTCP/IP Basics
TCP/IP Basics
 
Ccna pres
Ccna presCcna pres
Ccna pres
 
Tcp
TcpTcp
Tcp
 
Basic ccna interview questions and answers ~ sysnet notes
Basic ccna interview questions and answers ~ sysnet notesBasic ccna interview questions and answers ~ sysnet notes
Basic ccna interview questions and answers ~ sysnet notes
 
ConfigureTwo networks principle
ConfigureTwo networks principleConfigureTwo networks principle
ConfigureTwo networks principle
 
Network Layer
Network LayerNetwork Layer
Network Layer
 
Ducat
DucatDucat
Ducat
 
Chapter_6_ Network Layer.pptx
Chapter_6_ Network Layer.pptxChapter_6_ Network Layer.pptx
Chapter_6_ Network Layer.pptx
 

Último

Arihant handbook biology for class 11 .pdf
Arihant handbook biology for class 11 .pdfArihant handbook biology for class 11 .pdf
Arihant handbook biology for class 11 .pdfchloefrazer622
 
Privatization and Disinvestment - Meaning, Objectives, Advantages and Disadva...
Privatization and Disinvestment - Meaning, Objectives, Advantages and Disadva...Privatization and Disinvestment - Meaning, Objectives, Advantages and Disadva...
Privatization and Disinvestment - Meaning, Objectives, Advantages and Disadva...RKavithamani
 
SOCIAL AND HISTORICAL CONTEXT - LFTVD.pptx
SOCIAL AND HISTORICAL CONTEXT - LFTVD.pptxSOCIAL AND HISTORICAL CONTEXT - LFTVD.pptx
SOCIAL AND HISTORICAL CONTEXT - LFTVD.pptxiammrhaywood
 
A Critique of the Proposed National Education Policy Reform
A Critique of the Proposed National Education Policy ReformA Critique of the Proposed National Education Policy Reform
A Critique of the Proposed National Education Policy ReformChameera Dedduwage
 
mini mental status format.docx
mini    mental       status     format.docxmini    mental       status     format.docx
mini mental status format.docxPoojaSen20
 
Introduction to ArtificiaI Intelligence in Higher Education
Introduction to ArtificiaI Intelligence in Higher EducationIntroduction to ArtificiaI Intelligence in Higher Education
Introduction to ArtificiaI Intelligence in Higher Educationpboyjonauth
 
Presentation by Andreas Schleicher Tackling the School Absenteeism Crisis 30 ...
Presentation by Andreas Schleicher Tackling the School Absenteeism Crisis 30 ...Presentation by Andreas Schleicher Tackling the School Absenteeism Crisis 30 ...
Presentation by Andreas Schleicher Tackling the School Absenteeism Crisis 30 ...EduSkills OECD
 
Nutritional Needs Presentation - HLTH 104
Nutritional Needs Presentation - HLTH 104Nutritional Needs Presentation - HLTH 104
Nutritional Needs Presentation - HLTH 104misteraugie
 
Beyond the EU: DORA and NIS 2 Directive's Global Impact
Beyond the EU: DORA and NIS 2 Directive's Global ImpactBeyond the EU: DORA and NIS 2 Directive's Global Impact
Beyond the EU: DORA and NIS 2 Directive's Global ImpactPECB
 
POINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptx
POINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptxPOINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptx
POINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptxSayali Powar
 
Hybridoma Technology ( Production , Purification , and Application )
Hybridoma Technology  ( Production , Purification , and Application  ) Hybridoma Technology  ( Production , Purification , and Application  )
Hybridoma Technology ( Production , Purification , and Application ) Sakshi Ghasle
 
Web & Social Media Analytics Previous Year Question Paper.pdf
Web & Social Media Analytics Previous Year Question Paper.pdfWeb & Social Media Analytics Previous Year Question Paper.pdf
Web & Social Media Analytics Previous Year Question Paper.pdfJayanti Pande
 
Contemporary philippine arts from the regions_PPT_Module_12 [Autosaved] (1).pptx
Contemporary philippine arts from the regions_PPT_Module_12 [Autosaved] (1).pptxContemporary philippine arts from the regions_PPT_Module_12 [Autosaved] (1).pptx
Contemporary philippine arts from the regions_PPT_Module_12 [Autosaved] (1).pptxRoyAbrique
 
Advanced Views - Calendar View in Odoo 17
Advanced Views - Calendar View in Odoo 17Advanced Views - Calendar View in Odoo 17
Advanced Views - Calendar View in Odoo 17Celine George
 
Separation of Lanthanides/ Lanthanides and Actinides
Separation of Lanthanides/ Lanthanides and ActinidesSeparation of Lanthanides/ Lanthanides and Actinides
Separation of Lanthanides/ Lanthanides and ActinidesFatimaKhan178732
 
BASLIQ CURRENT LOOKBOOK LOOKBOOK(1) (1).pdf
BASLIQ CURRENT LOOKBOOK  LOOKBOOK(1) (1).pdfBASLIQ CURRENT LOOKBOOK  LOOKBOOK(1) (1).pdf
BASLIQ CURRENT LOOKBOOK LOOKBOOK(1) (1).pdfSoniaTolstoy
 

Último (20)

Arihant handbook biology for class 11 .pdf
Arihant handbook biology for class 11 .pdfArihant handbook biology for class 11 .pdf
Arihant handbook biology for class 11 .pdf
 
Privatization and Disinvestment - Meaning, Objectives, Advantages and Disadva...
Privatization and Disinvestment - Meaning, Objectives, Advantages and Disadva...Privatization and Disinvestment - Meaning, Objectives, Advantages and Disadva...
Privatization and Disinvestment - Meaning, Objectives, Advantages and Disadva...
 
SOCIAL AND HISTORICAL CONTEXT - LFTVD.pptx
SOCIAL AND HISTORICAL CONTEXT - LFTVD.pptxSOCIAL AND HISTORICAL CONTEXT - LFTVD.pptx
SOCIAL AND HISTORICAL CONTEXT - LFTVD.pptx
 
A Critique of the Proposed National Education Policy Reform
A Critique of the Proposed National Education Policy ReformA Critique of the Proposed National Education Policy Reform
A Critique of the Proposed National Education Policy Reform
 
mini mental status format.docx
mini    mental       status     format.docxmini    mental       status     format.docx
mini mental status format.docx
 
Introduction to ArtificiaI Intelligence in Higher Education
Introduction to ArtificiaI Intelligence in Higher EducationIntroduction to ArtificiaI Intelligence in Higher Education
Introduction to ArtificiaI Intelligence in Higher Education
 
Staff of Color (SOC) Retention Efforts DDSD
Staff of Color (SOC) Retention Efforts DDSDStaff of Color (SOC) Retention Efforts DDSD
Staff of Color (SOC) Retention Efforts DDSD
 
INDIA QUIZ 2024 RLAC DELHI UNIVERSITY.pptx
INDIA QUIZ 2024 RLAC DELHI UNIVERSITY.pptxINDIA QUIZ 2024 RLAC DELHI UNIVERSITY.pptx
INDIA QUIZ 2024 RLAC DELHI UNIVERSITY.pptx
 
Presentation by Andreas Schleicher Tackling the School Absenteeism Crisis 30 ...
Presentation by Andreas Schleicher Tackling the School Absenteeism Crisis 30 ...Presentation by Andreas Schleicher Tackling the School Absenteeism Crisis 30 ...
Presentation by Andreas Schleicher Tackling the School Absenteeism Crisis 30 ...
 
Nutritional Needs Presentation - HLTH 104
Nutritional Needs Presentation - HLTH 104Nutritional Needs Presentation - HLTH 104
Nutritional Needs Presentation - HLTH 104
 
Beyond the EU: DORA and NIS 2 Directive's Global Impact
Beyond the EU: DORA and NIS 2 Directive's Global ImpactBeyond the EU: DORA and NIS 2 Directive's Global Impact
Beyond the EU: DORA and NIS 2 Directive's Global Impact
 
POINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptx
POINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptxPOINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptx
POINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptx
 
Hybridoma Technology ( Production , Purification , and Application )
Hybridoma Technology  ( Production , Purification , and Application  ) Hybridoma Technology  ( Production , Purification , and Application  )
Hybridoma Technology ( Production , Purification , and Application )
 
Web & Social Media Analytics Previous Year Question Paper.pdf
Web & Social Media Analytics Previous Year Question Paper.pdfWeb & Social Media Analytics Previous Year Question Paper.pdf
Web & Social Media Analytics Previous Year Question Paper.pdf
 
Contemporary philippine arts from the regions_PPT_Module_12 [Autosaved] (1).pptx
Contemporary philippine arts from the regions_PPT_Module_12 [Autosaved] (1).pptxContemporary philippine arts from the regions_PPT_Module_12 [Autosaved] (1).pptx
Contemporary philippine arts from the regions_PPT_Module_12 [Autosaved] (1).pptx
 
Mattingly "AI & Prompt Design: The Basics of Prompt Design"
Mattingly "AI & Prompt Design: The Basics of Prompt Design"Mattingly "AI & Prompt Design: The Basics of Prompt Design"
Mattingly "AI & Prompt Design: The Basics of Prompt Design"
 
Advanced Views - Calendar View in Odoo 17
Advanced Views - Calendar View in Odoo 17Advanced Views - Calendar View in Odoo 17
Advanced Views - Calendar View in Odoo 17
 
Separation of Lanthanides/ Lanthanides and Actinides
Separation of Lanthanides/ Lanthanides and ActinidesSeparation of Lanthanides/ Lanthanides and Actinides
Separation of Lanthanides/ Lanthanides and Actinides
 
Código Creativo y Arte de Software | Unidad 1
Código Creativo y Arte de Software | Unidad 1Código Creativo y Arte de Software | Unidad 1
Código Creativo y Arte de Software | Unidad 1
 
BASLIQ CURRENT LOOKBOOK LOOKBOOK(1) (1).pdf
BASLIQ CURRENT LOOKBOOK  LOOKBOOK(1) (1).pdfBASLIQ CURRENT LOOKBOOK  LOOKBOOK(1) (1).pdf
BASLIQ CURRENT LOOKBOOK LOOKBOOK(1) (1).pdf
 

CCNA: Introduction to Networking and Protocols

  • 1. CCNA (CISCO CERTIFIED NETWORK ASSOCIATE) List of Tables 1. Internetworking 2. Internet Protocols 3. IP Subnetting and Variable Length Subnet Mask 4. Introduction to the Cisco IOS 5. IP Routing 6. Switching 7. IPv4 vs IPv6 Name: Abhishek Parihari Reg. No. : 11311575
  • 2. Introduction about NETWORK and PROTOCOL Network is simply defined as something that connects things together for a specific purpose. The term network is used in a variety of contexts, including telephone, television, computer, or even people networks. A computer network connects two or more devices together to share a nearly limitless range of information and services, including:  Documents  Email and messaging  Websites  Databases  Music  Printers and faxes  Telephony and video conferencing Protocols are rules that govern how devices communicate and share information across a network. Examples of protocols include: • IP – Internet Protocol • HTTP - Hyper Text Transfer Protocol • SMTP – Simple mailTransfer Protocol
  • 3. Internetworking Model ( Reference Model ) Open System Interconnection (OSI) reference model was created by the International Organization for Standardization (ISO) A reference model is a conceptual blueprint of how communications should take place. It addresses all the processes required for effective communication and divides theses process into logical groupings called layers. Seven Layers that define the different stages that data must go through to travel from one device to another over a network. Application Set • Layer 7 : Application ( interacts with the operating system or application whenever the user chooses to transfer files, read messages or perform other network-related activities) • Layer 6 : Presentation (takes the data provided by the Application layer and converts it into a standard format that the other layers can understand) • Layer 5 : Session (establishes, maintains and ends communication with the receiving device) Transport Set • Layer 4 : Transport (maintains flow control of data and provides for error checking and recovery of data between the devices) • Layer 3 : Network (The way that the data will be sent to the recipient device is determined in this layer. Logical protocols, routing and addressing are handled) • Layer 2 : Data (the appropriate physical protocol is assigned to the data. Also, the type of network and the packet sequencing is defined) • Layer 1 : Physical (defines the physical characteristics of the network such as connections, voltage levels and timimg)
  • 4. TCP(Transmission Control Protocol) UDP(User Datagram Protocol) Protocol No. - 6 Protocol No. - 17 Connection Oriented Connection Less Secure Insecure 3 way handshaking Doesn’t support 3 way handshaking Slower than UDP Faster than TCP e.g. HTTP, HTTPS, SMTP, FTP, Telnet etc. e.g. DHCP, DNS, TFTP, RIP Client Server 3 way handshaking SYNC SYNC + ACK ACK
  • 5. ● 32 bits address ● Format- Dotted Decimal ● No. of Addresses = 2^32 = 4.3 Billion (approx.) To get IP Addresses 1- IANA ( Internet Assigned Number Authority ) 2- RIR ( Regional Internet Registry ) 3- NIR ( National Internet Registries ) 4- LIR ( Local Internet Registries ) 5- Local ISP( Internet Service Provider ) 6- Customers Network Addressing Classes of IP Address and their ranges CLASS A 1 - 126 CLASS B 128 - 191 CLASS C 192 - 223 CLASS D 224 - 239 CLASS E 240 - 255 Reserved for multicasting Research & Development 127 – Reserved for loopback address CLASS A : NETWORK HOST HOST HOST CLASS B : NETWORK NETWORK HOST HOST CLASS C : NETWORK NETWORK NETWORK HOST 8 Bits 8 Bits 8 Bits 8 Bits In a network First Address – Network Address Last Address – Broadcast Address IP ADDRESSING
  • 6. Subnetting divides a network into small networks Benefits of subnetting : • Reduced network traffic • Optimized network performance • Simplified management • Facilitated spanning of large geographical distances Subnet Mask only informs about the network bits out of 32 bits address CLASS DEFAULT SUBNET MASK A 255.0.0.0 B 255.255.0.0 C 255.255.255.0 Default Subnet Mask Table VLSM ( Variable Level Subnet Masking) Public IP address – allowed in internet Private IP address – not allowed in intrnet Private IP Addresses Class A : 10.0.0.0 – 10.255.255.255 Class B : 172.16.0.0 – 172.31.255.255 Class C : 192.168.0.0 – 192.168.255.255 Supernetting or Summarization The process of taking a range of IP addresses and advertising them in one address block e.g. – let’s take 4 IP addresses 1. 192.168.1.1/24 2. 192.168.2.1/24 3. 192.168.3.1/24 4. 192.168.4.1/24 After Summarization we can create a new Network as 192.168.0.0/21
  • 7. CISCO ROUTER IOS ●The Cisco IOS was created to deliver network services and enable networked applications. ● Some of the important things that the Cisco router IOS software is responsible for include – Carrying network protocols and functions – Connecting high-speed traffic between devices – Adding Security to control access and stop unauthorised network use – Providing scalability for ease of network growth and redundancy – Supplying network reliability for connecting to network resources ● Connecting to a Cisco Router We can connect to a Cisco Router to – configure it – verify its configuration – check statistics We can connect to a Cisco Router through – console port – auxiliary port Console Port Auxiliary Port Physical View of Router
  • 8. Basic Routing Configuration Router>enable // user mode Router#configure terminal // privilege mode Router(config)#hostname R1 // to change the name of Router (hostname - keyword) R1(config)#interface f0/0 // global mode or configuration mode R1(config-if)#ip address 192.168.1.1 255.255.255.0 // global interface mode R1(config-if)#no shutdown R1(config-if)#exit R1(config)#exit R1#write or R1#copy running-config startup-config To Set PASSWORD in CONSOLE PORT / AUX PORT R1(config)#line con 0 R1(config-line)#password abcd R1(config-line)#login R1(config-line)#exit R1(config)#enable password 1234 R1(config)#enable secret 1234 To save the configuration of router R1(config)#line aux 0 R1(config-line)#password abcd R1(config-line)#login R1(config-line)#exit R1(config)#enable password 1234 R1(config)#enable secret 1234 R1(config)#service password-encryption [hides all the plain text password and encrypt the password]
  • 9. To Create IOS BACKUP Router#dir flash: Directory of flash:/ 3 -rw- 5571584 <no date> pt1000-i-mz.122-28.bin 2 -rw- 28282 <no date> sigdef-category.xml 1 -rw- 227537 <no date> sigdef-default.xml 64016384 bytes total (58188981 bytes free) Router#copy flash: tftp: Source filename []? pt1000-i-mz.122-28.bin Address or name of remote host []? 192.168.1.2 Destination filename [pt1000-i-mz.122-28.bin]? yes Writing pt1000-i-mz.122-28.bin....!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! [OK - 5571584 bytes] 5571584 bytes copied in 3.1 secs (411811 bytes/sec)
  • 10. TO DELETE ROUTER IOS Router#delete flash Delete filename []?pt1000-i-mz.122-28.bin Delete flash:/pt1000-i-mz.122-28.bin? [confirm]y Router#reload Proceed with reload? [confirm]y System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1) Copyright (c) 2000 by cisco Systems, Inc. RESTORING ROUTER IOS rommon 1 > IP_ADDRESS=192.168.1.1 rommon 2 > TFTP_SERVER=192.168.1.2 rommon 3 > TFTP_FILE=pt1000-i-mz.122-28.bin rommon 4 > IP_SUBNET_MASK=255.255.255.0 rommon 5 > DEFAULT_GATEWAY=192.168.1.2 rommon 6 > tftpdnld IP_ADDRESS: 192.168.1.1 IP_SUBNET_MASK: 255.255.255.0 DEFAULT_GATEWAY: 192.168.1.2 TFTP_SERVER: 192.168.1.2 TFTP_FILE: pt1000-i-mz.122-28.bin Invoke this command for disaster recovery only. WARNING: all existing data in all partitions on flash will be lost! Do you wish to continue? y/n: [n]: y rommon 7 > boot
  • 11. IP ROUTING ● IP routing is the process of moving packets from one network to another network using routers. ● A routing protocol is used by routers to dynamically find all the networks in the internetwork and to ensure all routers have same routing table. Basically, a routing protocol determines the path of a packet through an internetwork. e.g. RIP, IGRP, EIGRP, OSPF ROUTING PROTOCOL STATIC (AD=1) DEFAULT (AD=254) DYNAMIC IGP EGP DISTANCE VECTOR i) RIP ii) IGRP LINK STATE i) OSPF ii) IS-IS HYBRID i) EIGRP -IGP – Interior Gateway Protocol -EGP – Exterior Gateway Protocol ● Administrative Value (AD) [range 0-255] - shows the trustworthiness of any routing protocol - least AD value is always preferred ● Router’s priority 1st Highest Prefix Match 2nd AD Value 3rd Metric Value Border Gateway Protocol
  • 12. STATIC ROUTING Static routing is a form of routing that occurs when a router uses a manually-configured routing entry, rather than information from a dynamic routing traffic. Static routers are manually configured by a network administrator by adding entries into routing table. R1(config)#int f0/0 R1(config-if)#ip address 192.168.1.1 255.255.255.0 R1(config-if)#no shutdown R1(config-if)#exit R1(config)#int s2/0 R1(config-if)#ip address 10.0.0.1 255.0.0.0 R1(config-if)#no shutdown R1(config-if)#exit R1(config)#ip route 172.16.0.0 255.255.0.0 s2/0 R1(config)#exit R1# show ip route R2(config)#int f0/0 R2(config-if)#ip address 172.16.0.1 255.255.0.0 R2(config-if)#no shutdown R2(config-if)#exit R2(config)#int s2/0 R2(config-if)#ip address 10.0.0.2 255.0.0.0 R2(config-if)#no shutdown R2(config-if)#exit R2(config)#ip route 192.168.1.0 255.255.255.0 s2/0 R2(config)#exit
  • 13. DEFAULT ROUTING • to make all unknown networks reachable we use default routing • default routing suppresses the routing table STUB ROUTER – The router who has only single exit interface point to share the traffic. Default routing is implemented on stub router R1 and R2 are stub routers. Default routing will be implemented. On R2 we will implement static routing. For default routing Router(config)# ip route <unknown n/w><unknown s/m><exit int> R1(config)# ip route 0.0.0.0 0.0.0.0 s2/0 R3(config)# ip route 0.0.0.0 0.0.0.0 s2/0 R2(config)# ip route 192.168.1.0 255.255.255.0 s2/0 R2(config)# ip route 192.168.3.0 255.255.255.0 s3/0
  • 14. ROUTING INFORMATION PROTOCOL ( RIP ) AD=120 Metric = hop count ( 0-15 ) Multicast address = 224.0.0.9 Algorithm = Bellman Ford UDP Port No. 520 Hop count : when packet travels from one network to another network. ( least no of hop count is preferred ) RIP Version 1 RIP Version 2 Classful Classless Broadcast Multicast Broadcast address- 255.255.255.255 Multicast address- 224.0.0.9 Doesn’t support VLSM Supports VLSM Doesn’t support summarization Supports summarization Doesn’t support authentication Supports authentication RIP TIMER Update – 30 seconds Invalid – 180 seconds Total Down – 180 seconds Flush out – 240 seconds SLOW CONVERGENCE is the reason that RIP abolished from market RIP Ver1 and Ver2 are not compatible with each other.
  • 15. R1(config)#router rip R1(config-router)#network 192.168.1.0 R1(config-router)#network 10.0.0.0 R1(config-router)#version 2 R1(config-router)#no auto-summary R1(config-router)#exit R2(config)#router rip R2(config-router)#network 11.0.0.0 R2(config-router)#network 10.0.0.0 R2(config-router)#version 2 R2(config-router)#no auto-summary R2(config-router)#exit R3(config)#router eigrp 10 R3(config-router)#network 12.0.0.0 R3(config-router)#network 11.0.0.0 R3(config-router)#version 2 R3(config-router)#no auto-summary R3(config-router)#exit Router(config-router)# no auto-summary is used to make the protocol classless
  • 16. Interior Gateway Routing Protocol (IGRP) - Cisco proprietary routing protocol - Works on distance vector - Hop count =100 - AD Value = 100 Enhanced Interior Gateway Routing Protocol ( EIGRP ) - hybrid routing protocol - Works on advance distance vector - Hop counts = 100 (by default), can be extended upto 255 - Maintains three types of table • Neighbor Table • Topology Table • Routing Table - Sends partial update - Fast convergence routing protocol - Multicast address : 224.0.0.10 - Algorithm : Diffusing Update Algorithm (DUAL) - AD Value = 90 {for internal routes} = 170 {for external routes} - Independent protocol, Protocol No. – 88 - Classful routing protocol (by default), can be used as classless also - Works on AUTONOMOUS SYSTEM Autonomous System - A group of routers belong to a single domain - Range : 1 to 65535 - To reduce the complexity of hop counts we divide the networks into different autonomous system EIGRP can do unequal host load sharing Matric Values Default Values K1 Bandwidth 1 K2 Load 0 K3 Delay 1 K4 Reliability 0 K5 MTU (Maximum Transfer Unit) 0 Matric Calculation Formula [10^7 / least bandwidth + sum of delay / 10] * 256
  • 17. R1(config)#router eigrp 10 R1(config-router)#network 192.168.1.0 R1(config-router)#network 10.0.0.0 R1(config-router)#no auto-summary R1(config-router)#exit R2(config)#router eigrp 10 R2(config-router)#network 11.0.0.0 R2(config-router)#network 10.0.0.0 R2(config-router)#no auto-summary R2(config-router)#exit R3(config)#router eigrp 10 R3(config-router)#network 12.0.0.0 R3(config-router)#network 11.0.0.0 R3(config-router)#no auto-summary R3(config-router)#exit eigrp 10 ; here 10 is referred to as Autonomous System (AS) Value
  • 18. Open Shortest Path First (OSPF) • Works on link state routing protocol • Unlimited hop counts • Hop counts divided into areas • Area 0 is created first and is known as backbone area or management area • All the areas must be connected with area 0 • AD Value = 110 • Multicast Address : 224.0.0.5 (for updates / to send a hello message) : 224.0.0.6 (for DR/BDR) • Metric = cost (Bandwidth) • Algorithm = SPF ( Shortest Path First) Area Boarder Router (ABR) – to make a router ABR one of the interface must be present in AREA 0. From above diagram R2 and R3 are Area Boarder Router (ABR). Autonomous System Boarder Router (ASBR) – to make a router ASBR one of the interface must be present in OSPF and another interface in different routing protocol. From above diagram R4 is ASBR. AREA 1 OSPF AREA 0 OSPF AREA 2 OSPF AREA 3 EIGRP
  • 19. AREA 0 AREA 1 R1(config)#router ospf 10 R1(config-router)#network 192.168.1.0 0.0.0.255 area 0 R1(config-router)#network 10.0.0.0 0.255.255.255 area 0 R1(config-router)#exit R3(config)#router ospf 10 R3(config-router)#network 11.0.0.0 0.255.255.255 area 1 R3(config-router)#network 12.0.0.0 0.255.255.255 area 1 R3(config-router)#exit R2(config)#router ospf 10 R2(config-router)#network 10.0.0.0 0.255.255.255 area 0 R2(config-router)#network 11.0.0.0 0.255.255.255 area 1 R2(config-router)#exit
  • 20. To make a router DR (Designated Router) and BDR (Backup Designated Router) 1. Highest priority value is preferred. (Priority Value 0-255) if priority value is 0, it’s neither DR nor BDR 2. Highest loopback address is preferred. 3. Highest interface IP address is preferred. [Second Highest is preferred to make a router BDR] - Remaining routers DRO(designated Router Others) - DRO will form neighborship with DR and BDR To save BANDWIDTH we use DR / BDR Link State Advertisement ( LSA) LSA’s 1 – Router LSA LSA’s 2 – Network LSA LSA’s 3 – Summary LSA LSA’s 4 – ASBR Summary LSA LSA’s 5 – External LSA Wild Card Mask or Inverse Mask Table Class A – 0.255.255.255 Class B – 0.0.255.255 Class C – 0.0.0.255
  • 21. SWITCHING Switching is the process of using the hardware address of devices on a LAN to segment a network. - works on single broadcast domain - With the help of VLAN (Virtual Local Area Network) broadcast domain will be divided. - Total no. of VLAN = 4096 {range ( 0-4095 )} - Same VLAN and same subnet mask communicate with each other - VLAN 1’s IP address is known as management IP address VLAN NO. DESCRIPTION 0 , 4095 Reserved for the systems 1 Cisco reserved [default VLAN / management VLAN / Native VLAN / Untagged VLAN ] 2 – 1001 Normal VLAN 1002 – 1005 Reserved for different technologies 1006 – 4094 Extended VLAN
  • 22. SALE SALEIT IT Case: Traffic of SALE Department shouldn’t be shared with IT Department Put SALE Department in VLAN 10 and IT Department in VLAN 20 TRUNK : Carry the traffic of multiple VLAN To check the status of VLAN : Switch# show vlan brief
  • 23. Switch>enable Switch#configure terminal Switch(config)#hostname Switch1 Switch1(config)#VLAN 10 Switch1(config-vlan)#name sale Switch1(config-vlan)#VLAN 20 Switch1(config-vlan)#name IT Switch1(config-vlan)#exit Switch1(config)#interface range f0/1-02 Switch1(config-if-range)#switchport mode access Switch1(config-if-range)#switchport access VLAN 10 Switch1(config-if-range)#exit Switch1(config)#interface range f0/3-04 Switch1(config-if-range)#switchport mode access Switch1(config-if-range)#switchport access VLAN 20 Switch1(config-if-range)#exit Switch>enable Switch#configure terminal Switch(config)#hostname Switch2 Switch2(config)#VLAN 10 Switch2(config-vlan)#name sale Switch2(config-vlan)#VLAN 20 Switch2(config-vlan)#name IT Switch2(config-vlan)#exit Switch2(config)#interface range f0/2-03 Switch2(config-if-range)#switchport mode access Switch2(config-if-range)#switchport access VLAN 10 Switch2(config-if-range)#exit Switch2(config)#interface range f0/4-05 Switch2(config-if-range)#switchport mode access Switch2(config-if-range)#switchport access VLAN 20 Switch2(config-if-range)#exit To make interface TRUNK Switch1(config)#interface f0/5 Switch1(config-if)#switchport mode trunk
  • 24. Switch>enable Switch#configure terminal Switch(config)#hostname Switch1 Switch1(config)#VLAN 10 Switch1(config-vlan)#name sale Switch1(config-vlan)#VLAN 20 Switch1(config-vlan)#name IT Switch1(config-vlan)#exit Router(config)#interface f0/0 Router(config-if)#no shutdown Router(config-if)#exit Router(config)#int f0/0.10 Router(config-subif)#encapsulation dot1Q 10 Router(config-subif)#ip address 192.168.1.1 255.255.255.0 Router(config)#int f0/0.20 Router(config-subif)#encapsulation dot1Q 20 Router(config-subif)#ip address 10.0.0.1 255.0.0.0 Router(config-subif)#exit 192.168.1.0/24 10.0.0.0/8 INTER VLAN ROUTING ( Router on a stick )
  • 25. Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#exit Switch(config)#interface range f0/1-02 Switch(config-if-range)#switchport mode access Switch(config-if-range)#switchport access vlan 10 Switch(config-if-range)#exit Switch(config)#interface range f0/3-04 Switch(config-if-range)#switchport mode access Switch(config-if-range)#switchport access vlan 20 Switch(config-if-range)#exit Switch(config)#interface vlan 10 Switch(config-if)#ip address 192.168.1.1 255.255.255.0 Switch(config-if)#exit Switch(config)#interface vlan 20 Switch(config-if)#ip address 10.0.0.1 255.0.0.0 Switch(config-if)#exit Switch(config)#ip routing // to maintain the routing table for switch By default switch maintains CAM table SWITCH VIRTUAL INTERFACE ( SVI )
  • 26. Switch>enable Switch#configure terminal Switch(config)#interface f0/1 //port where security to be enabled Switch(config-if)#switchport mode access Switch(config-if)#switchport access vlan 1 Switch(config-if)#switchport port-security Switch(config-if)#switchport port-security maximum 1 Switch(config-if)#switchport port-security violation shutdown Switch(config-if)#switchport port-security mac-address FFFF.FFFF.FFFF Switch# show port-security : to check the status of port security Switch# show mac-address-table : to check the mac address connected to the ports PORT SECURITY
  • 27. DYNAMIC HOST CONFIGURATION PROTOCOL ( DHCP ) Works on the concept of D O R A • DISCOVER - discover message generated by client - Broadcast message sent to all, accepted by only server, rejected by other clients due to port no. 67 • OFFER - Server offers IP address, gateway, DNS server to all clients (broadcast) - Packets are accepted and discarded with the help of mac address • REQUEST - To cross check whether the same IP address has been assigned to any other clients or not. - Requests for time of expiry • ACKNOWLEDGEMENT - From server to client if everything is okay and allright Automatic Private IP Address ( APIPA ) It is an error which provides IP address in the range of 169.254.0.0 - 169.254.254.254 - DHCP is a standardized network protocol used on Internet Protocol (IP) networks for dynamically distributing network configuration parameters. - Computers request IP addresses and networking parameters automatically from a DHCP server - Port No. 67 for request - Port No. 68 for reply
  • 28. Router(config)#ip dhcp pool abcd Router(dhcp-config)#network 192.168.1.0 255.255.255.0 Router(dhcp-config)#default-router 192.168.1.1 Router(config)#ip dhcp excluded-address 192.168.1.4 192.168.1.11 (to exclude the IP addresses from pool and to provide it manually)
  • 29. HOT STANDBY ROUTING PROTOCOL ( HSRP ) We use HSRP to overcome the problem of link damage of default gateway Conditions for a router to become active - Highest priority value [by default priority value = 100] [range 0 - 255] - Highest interface IP address Hello message – 3 seconds Hold on time – 10 seconds Router1(config)#interface f0/0 Router1(config-if)#standby 1 ip 192.168.1.254 Router1(config-if)#standby 1 priority 150 Router1(config-if)#standby 1 preempt Router1(config-if)#exit Router2(config)#interface f0/0 Router2(config-if)#standby 1 ip 192.168.1.254 Router2(config-if)#standby 1 priority 50 Router2(config-if)#standby 1 preempt Router2(config-if)#exit INTERNET Router1(config-if)#standby 1 preempt Is used for the automatic elections to find out the active router
  • 30. ACCESS CONTROL LIST (ACL) used for FILTERING purpose STANDARD EXTENDED NAMING 1 – 99 100 – 199 Any name Blocks all services or complete protocol. e.g. – UDP, ICMP, IGRP and other routing protocols Filtering can be done i.e. few services should be allowed and others should be blocked Takes decision based on source address Takes decision based on both source and destination address Implemented near to destination Implemented near to source
  • 31. To block a network R2 (config)#access-list 1 deny 192.168.1.0 0.0.0.255 R2 (config)#interface f0/0 R2 (config-if)#ip access-group 1 out To block particular IP addresses R2(config)#access-list 5 deny host 192.168.1.2 R2(config)#access-list 5 deny host 192.168.1.3 R2(config)#access-list 5 permit any R2(config)#int f0/0 R2(config-if)#ip access-group 5 out Block IP address using extended R1(config)#access-list 100 deny tcp host 192.168.1.2 host 192.168.3.5 eq 80 R1(config)#access-list 100 deny tcp host 192.168.1.2 host 192.168.3.5 eq 443 R1(config)#access-list 100 permit ip any any R1(config)#int s2/0 R1(config-if)#ip access-group 100 out
  • 32. NETWORK ADDRESS TRANSLATION ( NAT ) Types: • Static – one private address to one public address. It’s a hard-core binding. • Dynamic – many private addresses to many public addresses. It’s no hard-core binding • Port Address Translation (PAT) – many private addresses to one public address STATIC TYPE R1(config)#ip nat inside source static 192.168.1.2 121.1.1.3 R1(config)#interface f0/0 R1(config-if)#ip nat inside R1(config-if)#interface s2/0 R1(config-if)#ip nat outside R1(config-if)#exit DYNAMIC TYPE R1(config)#access-list 1 permit host 192.168.1.2 R1(config)#access-list 1 permit host 192.168.1.3 R1(config)#ip nat inside source list 1 pool abcd R1(config)#ip nat pool abcd 121.1.1.3 121.1.1.10 netmask 255.0.0.0 PAT R1(config)#access-list 1 permit 192.168.1.0 0.0.0.255 R1(config)#ip nat inside source list pool abcd overload R1(config)#ip nat pool abcd 121.1.1.3 121.1.1.3 netmask 255.0.0.0 192.168.1.0 / 24
  • 33. IPv4 IPv6 32 bits 128 bits Dotted decimal Hexadecimal 4 octant (1 octant = 8 bits) 8 field (1 field = 16 bits) Separated by “ . ” (dot) Separated by “ : ” (colon) Broadcast Any cast IP Security – Not Available IP Security – Available No. of IP Addresses = 2^32 No. of IP Addresses = 2^128 DIFFERENCE BETWEEN IPv4 and IPv6