06 algoritmo

169 visualizações

Publicada em

Algoritmo - Estrutura Condicionais

Publicada em: Tecnologia
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

06 algoritmo

  1. 1. Logica de Programação Estrutura condicionais
  2. 2. Apresentação • Estruturas condicionais estão presente em todos os momentos de nossa vida. • Condicional é quando precisamos que algo seja verdade para que possamos realizar tal tarefa • É o chamado “SE” • Ex: – Se eu tiver dinheiro então • Vou fazer uma viagem
  3. 3. CONDICIONAL SIMPLES
  4. 4. Estrutura do SE (condicional simples) • Se (expressão) então – Bloco • fimSe • Se (dinheiro >= 10000) entao – Escreva (“Partiu Disney”) • fimSe
  5. 5. exercitar algoritmo "semnome" var ano_atual, ano_nasci, idade : real inicio escreval ("Em que ano estamos?" ) leia (ano_atual) escreval ("Em que ano vc nasceu? ") leia (ano_nasci) idade <- ano_atual - ano_nasci escreva ("Em ",ano_atual," você terá ",idade," anos") se (idade >= 18) entao escreva ( " e já pode dirigir") fimSe fimalgoritmo
  6. 6. CONDICIONAL COMPOSTA
  7. 7. Condicional Composta • Se (expressão) então – BlocoA • Senao – BlocoB • fimSe
  8. 8. Estrutura do SE (condicional composta) • Se (dinheiro >= 10000) entao – Escreva (“Partiu Disney”) • Senao – Escreva (“#chateado”) • fimSe
  9. 9. Indentação • A indentação é muito importante para você entender, quem bloco está dentro de quem! • Não é obrigatório, mas é um boa pratica, e usada por todos os programadores na hora de escrever seu código. • Assim facilita a leitura do mesmo • Temos no VisualG o “Ctrl + G” que faz essa indentação • Se (dinheiro >= 10000) entao – Escreva (“Partiu Disney”) • Senao – Escreva (“#chateado”) • fimSe
  10. 10. Par ou impar 5 2 1 2 8 2 0 4 5 é Impar pois dividido por 2 resta 1 8 é par pois dividido por 2 resta 0
  11. 11. Par ou impar algoritmo "semnome" var N : inteiro inicio escreval ("Digite um número: ") leia (N) se (N % 2 = 0) entao escreva ("O numero", N, " é Par") senao escreva ("O numero", N, " é Impar") fimse fimalgoritmo
  12. 12. EXERCÍCIO IMC
  13. 13. Exercício IMC = Peso Ideal IMC entre 18,5 e 25 Massa Altura²
  14. 14. Exercício
  15. 15. Exercício
  16. 16. SE ANINHADO
  17. 17. Se aninhado • Essa estrutura vem da ideia de colocar um “Se” dentro de outro “SE” • Dai o termo “Aninhado”, Ninho!
  18. 18. Estrutura do se aninhado Se (Situação 01) entao Bloco A Senão Se (Situação 02) entao Bloco B Senão Bloco C fimse fimse
  19. 19. Exercício
  20. 20. IMC IMC INFORME Abaixo de 17 Muito Abaixo do Peso Entre 17 e 18.5 Abaixo do Peso De 18,5 a 25 Peso Ideal De 25 a 30 Sobre Peso De 30 a 35 Obesidade De 35 a 40 Obesidade Severa Acima de 40 Obesidade Mórbida • Calcule o IMC e retorne as Informações conforme a Tabela de IMC abaixo:
  21. 21. Resposta do IMC
  22. 22. ESCOLHA CASO
  23. 23. Estrutura do Escolha Caso Escolha (Variável) Caso Valor Bloco A Caso Valor Bloco B Caso Valor Bloco C OutroCaso Bloco D FimEscolha
  24. 24. Exercício - Criança Esperança algoritmo "semnome" var D : Inteiro Valor : real inicio escreval (" CRIANÇA ESPERANÇA ") escreval (" Muito Obrigado por Ajudar") escreval (" [1] para doar R$10") escreval (" [2] para doar R$25") escreval (" [3] para doar R$50") escreval (" [4] para doar outro Valores") escreval (" [5] para Cancelar") Escreval ("Digite o Número") leia (D) Escolha D Caso 1 valor <-10 Caso 2 valor <-25 Caso 3 valor <- 50 Caso 4 Escreva ("Qual o Valor da doação? R$") Leia (valor) Caso 5 Valor <- 0 Fimescolha escreval (" Sua doação foi de R$",valor:5:2) escreval (" Muito Obrigado") fimalgoritmo
  25. 25. Exercício - Novo Salário algoritmo "semnome" var nome: Caractere sal, nsal: real dep : inteiro inicio escreva ("Qual o nome do Funcionário? ") leia (nome) escreva ("Qual o Salario do Funcionário? ") leia (sal) escreva ("Qual Quantidade de dependentes? ") leia (dep) escolha dep caso 0 nsal <- sal + (sal*5/100) caso 1, 2, 3 nsal <- sal + (sal*10/100) caso 4, 5, 6 nsal <- sal + (sal*15/100) outrocaso nsal <- sal + (sal*18/100) fimescolha escreva ("O novo Salário de ",nome," será de R$",nsal:5:2) fimalgoritmo
  26. 26. Pratique Nota Classificação em Números A 10 -9 B 8.9 – 8 C 7.9 – 7 D 6.9 – 6 E 5.9 – 5 F Abaixo de 500
  27. 27. Pratique 2 Faça um programa onde peça o nome de dois times, depois peça quantos gols cada um fez, após isso informe qual a situação da Partida! Diferença de Gol é 0, Empate Diferença de Gol de 1 a 3, Partida Normal Diferença de Gol Maios que 5, Goleada

×