Anúncio
Anúncio

Mais conteúdo relacionado

Anúncio

Dados

  1. Ley de los grandes números Vamos a realizar un programa con Calc que simule el lanzamiento de dados y comprobar que cuantas más tiradas se realicen, más se acercará la probabilidad de cada uno de los sucesos a 1/6.
  2. Abrimos Calc. Vamos a usar como simulador de lanzamientos la función matemática ALEATORIO.ENTRE. Para crearla nos vamos a situar en la primera casilla, la A1 e insertaremos la función. Ley de los grandes números
  3. Una vez se abra la ventana, se elegirá ALEATORIO.ENTRE en la categoría de Matemáticas. En el siguiente paso se eligen los valores mínimo y máximo, que serán 1 y 6 al ser un dado de 6 caras. Se acepta y estará el generador de dados hecho, con el primer resultado en la casilla A1. Ley de los grandes números
  4. Ley de los grandes números Como queremos realizar un número elevado de lanzamientos, habrá que copiar la fórmula anterior a más casillas. Para ello, se pincha en el cuadrito negro que aparece en la esquina inferior derecha de la casilla al situarse sobre ella y arrastrar hasta abarcar el número de casillas deseado. En este primer experimento realizaremos 50 lanzamientos.
  5. Ley de los grandes números Vamos a hacer una tabla en la que se reflejen los distintos resultados para cada cara del dado con su frecuencia, su frecuencia relativa y la probabilidad. Usaremos las columnas C, D, E y F para estos cálculos. En C, desde C2 introduciremos xi, 1, 2, 3, 4, 5, 6. En D2, ni (frecuencias). En E2, fi (frecuencias relativas). Y en F2, pi (probabilidad).
  6. Ley de los grandes números Para calcular las frecuencias de las caras usaremos las función contar.si. Habrá que usar los resultados obtenidos (rango de la función) y el resultado a comparar (cara que se quiere contar). Quedando: =CONTAR.SI(A1:A50;C3) =CONTAR.SI(A1:A50;C6) =CONTAR.SI(A1:A50;C4) =CONTAR.SI(A1:A50;C7) =CONTAR.SI(A1:A50;C5) =CONTAR.SI(A1:A50;C8)
  7. Ley de los grandes números En la casilla D9, calcularemos la suma de las frecuencias, que debe salir 50 en este caso. Para ello se usa la función suma: =SUMA(D3:D8) En la columna E situaremos las frecuencia relativas. Para calcularlas habrá que dividir cada frecuencia entre el total de tiradas. Así, quedará: =D3/$D$9 =D4/$D$9 =D5/$D$9 =D6/$D$9 =D7/$D$9 =D8/$D$9
  8. Ley de los grandes números Se ha puesto $D$9 para que siempre se divida entre la casilla del total. Para calcular el total de lasa frecuencias relativas, que tiene que ser 1, usamos la función suma: =SUMA(E3:E8)
  9. Ley de los grandes números Para calcular las probabilidades se copian los datos de la columna E (frecuencias relativas) y se formatean las celdas para que aparezcan en forma de fracción. Para ello basta con seleccionar las celdas, botón derecho del ratón, formatear celdas y en la pestaña Números de la ventana que se abre, marcar Fracción. Para sumar todas las fracción, se usa la función suma: =SUMA(F3:F8)
  10. Ley de los grandes números xi ni fi pi 1 10 0,2 1/5 2 8 0,16 1/6 3 10 0,2 1/5 4 4 0,08 1/9 5 6 0,12 1/8 6 12 0,24 1/4 50 1 1 Después de realizar los cálculos, queda la siguiente tabla:
  11. Ley de los grandes números Vamos a aumentar el número de tiradas a 100. Para ello se arrastra en la primera columna el cursor pinchando en el cuadradito negro hasta la A100. Para los nuevos datos, crearemos una tabla nueva, que será como la anterior pero modificando las casillas a tener en cuenta, como el número de lanzamientos (cada vez que pusiera A50, ahora será A100) y el lugar en el que se encuentran las casillas ahora.
  12. Ley de los grandes números Después de realizar los cálculos, queda la siguiente tabla: xi ni fi pi 1 23 0,23 2/9 2 17 0,17 1/6 3 17 0,17 1/6 4 10 0,1 1/9 5 12 0,12 1/8 6 21 0,21 1/5 100 1 1
  13. Ley de los grandes números Conforme se va aumentando el número de tiradas, las probabilidades van pareciéndose más. Vamos a volver a aumentar las tiradas a 200 y posteriormente a 500, 1000 y 5000. En cada uno de los casos las modificaciones a realizar son las mismas.
  14. Ley de los grandes números xi ni fi pi 1 31 0,16 1/6 2 28 0,14 1/7 3 27 0,14 1/7 4 34 0,17 1/6 5 29 0,15 1/7 6 51 0,26 1/4 200 1 1 Para 200 y 500 tiradas: xi ni fi pi 1 78 0,16 1/6 2 80 0,16 1/6 3 82 0,16 1/6 4 87 0,17 1/6 5 71 0,14 1/7 6 102 0,2 1/5 500 1 1
  15. Ley de los grandes números Para 1000 y 5000 tiradas: xi ni fi pi 1 162 0,16 1/6 2 160 0,16 1/6 3 164 0,16 1/6 4 170 0,17 1/6 5 152 0,15 1/7 6 192 0,19 1/5 1000 1 1 xi ni fi pi 1 835 0,17 1/6 2 845 0,17 1/6 3 835 0,17 1/6 4 820 0,16 1/6 5 849 0,17 1/6 6 816 0,16 1/6 5000 1 1
  16. Ley de los grandes números Después de realizar este experimento, queda claro que si hacemos un número muy grande de tiradas de un dado, 1/6 de veces va a salir 1, 1/6 de veces va a salir 2, 1/6 de veces va a salir 3, 1/6 de veces a salir 4, 1/6 de veces saldrá 5 y 1/6 de veces saldrá el número 6. En definitiva, que la teoría se cumple en la práctica.
  17. Ley de los grandes números Ejercicios 1. Realizar un programa que simule el lanzamiento de dados con forma de tetraedro. 2. Realizar un programa que simule el lanzamiento de dados con forma de dodecaedro. 3. Realizar un programa que simule el lanzamiento de monedas. Utiliza un 1 para cara y un 2 para cruz.
Anúncio