Python + AlgoritmoIf nota <= 3.5 :  print “você precisa estudar”else:  print “Estude do mesmo jeito”
Instruções de controle• Algoritmo           • Python  – SE                   • If  se condição           If condição:    e...
• Lembre-se da identação, no python não  temos estruturas de fechamento de blocos de  códigos!! A instrução elif permite q...
• Exemplo de problema onde pode ser utilizado a  instrução de controle if:  – Quatro notas bimestrais de um aluno, podemos...
• Mesmo exemplo em python: N1 = input (“Digite a 1º nota: ”)     #lê o valor da nota 1. N2 = input (“Digite a 2º nota: ”) ...
Próximos SlideShares
Carregando em…5
×

Python + algoritmo

1.076 visualizações

Publicada em

  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Python + algoritmo

  1. 1. Python + AlgoritmoIf nota <= 3.5 : print “você precisa estudar”else: print “Estude do mesmo jeito”
  2. 2. Instruções de controle• Algoritmo • Python – SE • If se condição If condição: então #bloco de código inicio elif condição: comando 1; #outro bloco comando 2; else: . #bloco final . comando n; fim; fimse;
  3. 3. • Lembre-se da identação, no python não temos estruturas de fechamento de blocos de códigos!! A instrução elif permite que se inclua exceção condicional – algo como: “... senão se isso...”. O else é uma exceção absoluta.
  4. 4. • Exemplo de problema onde pode ser utilizado a instrução de controle if: – Quatro notas bimestrais de um aluno, podemos avaliar sua situação quanto à aprovação, considerando uma média superior ou igual a 7 e, N1, N2, N3 e N4, as notas relativas aos bimestres. Solução no algoritmo Inicio real: N1, N2, N3, N4, MA; //notas bimestrais e média anual. leia: (N1,N2,N3,N4); // entrada de dados. MA <- (N1 + N2 + N3 + N4) / 4 ; //cálculo da média. escreva: (MA); //saída de dados. se (MA >= 7) então escreva (“Aluno Aprovado”); senão escreva (“É preciso estudar mais”); fimse; Fim.
  5. 5. • Mesmo exemplo em python: N1 = input (“Digite a 1º nota: ”) #lê o valor da nota 1. N2 = input (“Digite a 2º nota: ”) #lê o valor da nota 2. N3 = input (“Digite a 3º nota: ”) #lê o valor da nota3. N4 = input (“Digite a 4º nota: ”) #lê o valor da nota4. MA = (N1 + N2 + N3 + N4) / 4 #calcula a média MA. print ( “A média é: ”, MA) #imprime o valor da media na tela. if (MA >= 7): print (“Aluno aprovado”) else: print (“É preciso estudar mais”)

×