Função desloc

1.016 visualizações

Publicada em

Funçao poderosa q. lhe ajudará em muitas tarefas

  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Função desloc

  1. 1. Função DESLOCO que é?A função DESLOC é uma função extremamente versátil, através dela podemos reduzir ouexpandir uma matriz de uma fórmula. Quando dizemos matriz estamos falando de intervalosde células.Como aplicar a funçãoVeja a sintaxe abaixo:=DESLOC(referência; linhas; colunas; altura; largura)Onde:O argumento referência especifica a célula de onde o deslocamento será calculado;O argumento linhas especifica quantas linhas abaixo ou acima da célula de referênciaencontra-se a célula de início do intervalo de dados. Lembrando que número positivo indicaabaixo e número negativo indica acima da célula de referência;O argumento colunas especifica quantas colunas a esquerda ou a direita da célula dereferência encontra-se o início do intervalo de dados. Lembrando que número positivo indica adireita e número negativo indica a esquerda da célula de referência;Os argumentos altura e largura especificam quantas células e quantas colunas a funçãoDESLOC abrangerá. Ou seja, suponhamos que temos um intervalo de dados B1:B4 ondefaremos a soma abrangendo o intervalo. Queremos que esta soma tenha abragência de ummaior número de células, então colocamos a quantidade de células desejadas no argumentoaltura e ela trará automaticamente a soma de todas as células e das que forem inseridas nesteintervalo. Isto vale também para colunas.(Este número deve ser sempre positivo).Usaremos como exemplo a planilha abaixo:Deslocamento (DESLOC)Onde utilizaremos a função DESLOC para que a soma a ser exibida na célula D13 sejaautomaticamente atualizada quando da inserção de novos valores a tabela que compreende ointervalo de células B1:B12. Siga os passos abaixo:
  2. 2. Clicar na célula de destino D13;Digitar a seguinte função:=SOMA(DESLOC(B1;0;0;12;1))Veja na figura abaixo:Neste caso usamos como referência a célula B1, que esta localizada na mesma coluna de ondedeslocaremos os dados.Seguidos os passos o resultado obtido será o da figura abaixo:ExemploVeja que o resultado é o mesmo da função SOMA, mas agora podemos inserir novos valoresna tabela e estes serão atualizados(somados) automaticamente na célula de destino, conforme
  3. 3. figura abaixo:

×