Construcao de Algoritmos - Aula 09

30 visualizações

Publicada em

Estruturas de decisão:
- Se e senao
- Escolha ... caso
Estruturas de repetição:
- Enquanto
- Repita ... ate
- Para

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
30
No SlideShare
0
A partir de incorporações
0
Número de incorporações
3
Ações
Compartilhamentos
0
Downloads
3
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Construcao de Algoritmos - Aula 09

  1. 1. Disciplina: Constr. de Algoritmos e Prog. de Sistemas Professor: Jeovane Reges Caxias – MA 2015 ACULDADE DE CIÊNCIAS E TECNOLOGIA DO MARANHÃO
  2. 2. Link Drive bit.ly/ads-algoritmos 2
  3. 3. 3 Algoritmos
  4. 4. 4 Exemplos Resolvidos <Comandos de Repetições>
  5. 5. 5 Problema I Faça um algoritmo que imprima os números contidos no intervalo de 10 à 0 na tela.
  6. 6. • Algoritmos • Comandos de Repetições  Resolução do Problema I <enquanto> 6 algoritmo "Problema 01" var contador: inteiro inicio contador ← 10 enquanto (contador >= 0) faca escreval(contador) contador ← contador - 1 fimenquanto fimalgoritmo
  7. 7. • Algoritmos • Comandos de Repetições  Resolução do Problema I <para> 7 algoritmo "Problema 01" var contador: inteiro inicio para contador de 10 ate 0 passo -1 faca escreval(contador) fimpara fimalgoritmo
  8. 8. 8 Problema II Faça um algoritmo que imprima os números pares contidos no intervalo de 1 à 10.
  9. 9. • Algoritmos • Comandos de Repetições  Resolução Problema II <enquanto> 9 algoritmo "Problema 02" var contador: inteiro inicio contador ← 1 enquanto (contador <= 10) faca se (contador % 2 = 0) entao escreval(contador) fimse contador ← contador + 1 fimenquanto fimalgoritmo
  10. 10. • Algoritmos • Comandos de Repetições  Resolução do Problema II <para> 10 algoritmo "Problema 02" var contador: inteiro inicio para contador de 1 ate 10 faca se (contador % 2 = 0) entao escreval(contador) fimse fimpara fimalgoritmo
  11. 11. 11 Problema III Faça um algoritmo que apresente os números múltiplos de 2 e 3 no intervalo de 1 à 100.
  12. 12. • Algoritmos • Comandos de Repetições  Resolução do Problema III <enquanto> 12 algoritmo "Problema 03" var i: inteiro inicio i ← 1 enquanto (i <= 100) faca se ((i % 2 = 0) E (i % 3 = 0)) entao escreval(i) fimse i ← i + 1 fimenquanto fimalgoritmo
  13. 13. • Algoritmos • Comandos de Repetições  Resolução do Problema III <para> 13 algoritmo "Problema 03" var i: inteiro inicio para i de 1 ate 100 faca se ((i % 2 = 0) E (i % 3 = 0)) entao escreval(i) fimse fimpara fimalgoritmo
  14. 14. 14 Problema IV Faça um algoritmo que realize a soma de cinco valores "fornecidos" pelo usuário.
  15. 15. • Algoritmos • Comandos de Repetições  Resolução do Problema IV <para> 15 algoritmo "Problema 04" var contador, valor, soma: inteiro inicio soma ← 0 para contador de 1 ate 5 faca escreva("Digite um valor: ") leia(valor) soma ← soma + valor fimpara escreval("A soma é: ", soma) fimalgoritmo
  16. 16. • Algoritmos • Comandos de Repetições  Resolução do Problema IV <enquanto> 16 algoritmo "Problema 04" var contador, valor, soma: inteiro inicio contador ← 1 soma ← 0 enquanto (contador <= 5) faca escreva("Digite um valor: ") leia(valor) soma ← soma + valor contador ← contador + 1 fimenquanto escreval("A soma é: ", soma) fimalgoritmo
  17. 17. 17 Problema V Crie um algoritmo que solicite 10 números inteiros digitados pelo usuário e que realize a soma dos números pares.
  18. 18. • Algoritmos • Comandos de Repetições • Resolução do Problema V <para> 18 algoritmo "Problema 05" var i, valor, soma: inteiro inicio soma ← 0 para i de 1 ate 10 faca escreva("Digite um valor: ") leia(valor) se (valor % 2 = 0) entao soma ← soma + valor fimse fimpara escreval("A soma é: ", soma) fimalgoritmo
  19. 19. • Algoritmos • Comandos de Repetições 19 algoritmo "Problema 05" var i, valor, soma: inteiro inicio i ← 1 soma ← 0 enquanto (i <= 10) faca escreva("Digite um valor: ") leia(valor) se (valor % 2 = 0) entao soma ← soma + valor fimse i ← i + 1 fimenquanto escreval("A soma é: ", soma) fimalgoritmo Resolução<enquanto>
  20. 20. 20 Problema VI Dadas as três notas de um aluno, apresente sua média final.
  21. 21. • Algoritmos • Comandos de Repetições  Resolução do Problema VI 21 algoritmo "Problema12" var n1, n2, n3, media: real inicio n1 ← 8.5 n2 ← 6.2 n3 ← 9 media ← (n1 + n2 + n3) / 3 escreva(media) fimalgoritmo
  22. 22. • Algoritmos • Resolução do Problema VI 22 algoritmo "Problema 06" var i: inteiro nota, soma, media: real inicio soma ← 0 para i de 1 ate 3 faca escreva("Digite uma nota: ") leia(nota) soma ← soma + nota fimpara media ← soma / 3 escreval("A média é: ", media) fimalgoritmo Resolução<para>
  23. 23. • Algoritmos • Comandos de Repetições 23 algoritmo "Problema 06" var i: inteiro nota, soma, media: real inicio i ← 1 soma ← 0 enquanto (i <= 3) faca escreva("Digite uma nota: ") leia(nota) soma ← soma + nota i ← i + 1 fimenquanto media ← soma / 3 escreval("A média é: ", media) fimalgoritmo Resolução<enquanto>
  24. 24. 24 Problema VII Crie um algoritmo que faça a leitura de vários números digitados pelo usuário e apresente a quantidade de valores positivos. O algoritmo encerra quando for digitado o valor ZERO.
  25. 25. • Algoritmos • Comandos de Repetições  Resolução do Problema VII 25 algoritmo "Problema 07" var valor, conta_pos: inteiro inicio repita escreva("Digite um valor: ") leia(valor) se (valor > 0) entao conta_pos ← conta_pos + 1 fimse ate(valor = 0) escreval("Positivos: ", conta_pos) fimalgoritmo

×