Produção analise e desenvolvimento de sistemas

1.807 visualizações

Publicada em

Documento do curso de analise e desenvolvimento de sistemas

Publicada em: Tecnologia
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
1.807
No SlideShare
0
A partir de incorporações
0
Número de incorporações
3
Ações
Compartilhamentos
0
Downloads
64
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Produção analise e desenvolvimento de sistemas

  1. 1. SISTEMA DE ENSINO PRESENCIAL CONECTADO ANALISE E DESENVOLVIMENTO DE SISTEMAS GLEYSON DAS CHAGAS CORREA PRODUÇÃO TEXTUAL INTERDICIPLINAR - INDIVIDUAL Castanhal 2012
  2. 2. GLEYSON DAS CHAGAS CORREA PRODUÇÃO TEXTUAL INTERDICIPLINAR - INDIVIDUAL Trabalho de Analise e Desenvolvimento de Sistemas apresentado à Universidade Norte do Paraná - UNOPAR, como requisito parcial para a obtenção de média bimestral nas disciplinas de Educação à Distancia, Fundamentos da Administração da Informação, Fundamentos de Lógica e Matemática Discreta, Organização de Computadores, e Linguagens e Técnicas de Programação I. Orientadores: Professores Everson Morais, Marco Hisatomi, Merris Mozer, Adriane Loper, e Veronice de Freitas. Castanhal 2012
  3. 3. SUMÁRIO INTRODUÇÃO.............................................................................................................3 DESENVOLVIMENTO.................................................................................................4 2 Com o cenário da “Nossa Locadora de Livros”, temos a informação que em 1995, a empresa adquiriu o seu primeiro computador e teve a necessidade de contratar uma empresa de TI (Tecnologia da Informação) para informatizar as primeiras rotinas. A empresa “Alunos da UNOPAR” assumiu esse compromisso e atua plenamente no desenvolvimento do sistema de locação de livros. Pesquise quantos e qual o computador mais indicado, descrevendo processador, memoria e dispositivos de entrada e saída.....................................................................................7 3 Baseado no cenário proposto crie três proposições verdadeiras com a relação ao cenário “Nossa Locadora De Livros”, exemplo: p: O estoque da “Nossa Locadora De Livros” atual possui 20.000 títulos.................................................................................8 5 CONCLUSÃO...........................................................................................................13 LINKS DE REFERÊNCIAS........................................................................................14 ANEXOS 15 ANEXO A – Organograma da Empresa “Nossa Locadora de Livros”.......................16
  4. 4. INTRODUÇÃO 3 O trabalho aqui apresentado a vocês é uma produção textual sintetizada sobre a Tecnologia em Análise e Desenvolvimento de Sistemas, no qual serão abordados assuntos sobre tipos de sistemas de informação, matemática discreta e logica de programação. Dentro de um contexto geral abordado, em analises feitas em documentações adquiridas em pesquisas realizadas, a elaboração deste trabalho torna a obtenção de conhecimento facilitada para o desenvolvimento a introdução no desenvolvimento de programações. É esperada uma boa compreensão do texto aqui apresentado em cada tópico explorado como no primeiro momento a introdução de tipos de sistema de informação num segundo momento é a elaboração de uma proposta de equipamentos ao cliente e valores verdade, e no quarto e ultimo momento é a inicialização a leitura e escrita de algoritmos.
  5. 5. DESENVOLVIMENTO 4 Com base no cenário proposto “Nossa Locadora de Livros”, elabore as atividades a partir das seguintes diretrizes: 1 REALIZE UMA PESQUISA BIBLIOGRÁFICA SINTETIZADA E DESCREVA AS PRINCIPAIS CARACTERÍSTICAS DOS SEGUINTES TIPOS DE SISTEMAS DE INFORMAÇÃO: 1.1Sistema de Informação Operacional O sistema de Informação Operacional tem como principais características uma rotina de operações, trabalha com grande volume de entrada e saída de operações, tem um grande volume de relatórios e formulários. Exemplos: formulários de cadastros, relatórios de conferência de dados, listagens, consultas e modificações de dados. 1.1.2 Sistemas de Informação Gerencial O sistema de Informação Gerencial funciona como apoio na tomada de decisão e trabalha com informações agrupadas que são geradas pela interação colaborativa entre pessoas, tecnologia e procedimentos. Esse tipo de sistema também usa as informações coletadas pelo sistema operacional para criar mecanismos na tomada de decisão. Exemplos: Projeção de vendas para o mês seguinte; Análise de clientes, produtos ou mercado; Lucro efetivo por produto; Comparativo de desempenho da empresa, segmentos ou produtos. Relatórios analíticos e sintéticos. 1.1.3 Sistema de Suporte a Decisão É um sistema que auxilia um administrador seja ele gerente ou diretor na tomada de decisões em um determinado processo. Em um modelo genérico de sistema de tomada de decisões que auxilia no posicionamento da tomada de decisões a uma determinada questão. Finlay (1994) e outros autores
  6. 6. 5 definem o SAD de um modo geral como “um sistema computacional que auxilia o processo de tomada de decisão”. 1.1.4 ERP – Enterprise Resource Planning Os ERP’s em termos gerais são uma plataforma de software desenvolvida para integrar os diversos departamentos de uma empresa, possibilitando a automação e armazenamento de todas as informações de negócios. O software integrado é parte de uma tecnologia que registra e processa cada evento empresarial resultante das funções empresariais básicas, a partir de uma única entrada para processamento. A partir dessa entrada e armazenamento dos dados, o software integrado distribui a informação para todos na empresa, de acordo com o nível estratégico, tático e operacional em que se encontrem. Para isso, usa critérios de segurança efetivos, claros, consistentes, em tempo real e com qualidade, ou seja, informação oportuna. A tecnologia ERP e seus recursos, ao processar os dados cotidianos das funções empresariais operacionais, possibilitam a integração de suas informações interdependentes. Em resumo ERP é sistema de informação que integram todos os dados e processos de uma organização em um único sistema. A integração pode ser vista sob a perspectiva funcional (sistemas de: finanças, contabilidade, recursos humanos, fabricação, marketing, vendas, compras, etc.) e sob a perspectiva sistêmica (sistema de processamento de transações, sistemas de informações gerenciais, sistemas de apoio à decisão, etc.). 1.1.5 CRM – Customer Relationship Manager O CRM é uma abordagem que coloca o cliente no centro dos processos do negócio, sendo desenhado para perceber e antecipar as necessidades dos clientes atuais e potenciais. Trata-se, sem dúvida, de uma estratégia de negócio, em primeira linha, que posteriormente se consubstancia em soluções tecnológicas. É assim um sistema integrado de gestão com foco no cliente, constituído por um conjunto de procedimentos/processos organizados e integrados num modelo de gestão de
  7. 7. negócios. 6
  8. 8. 7 2 Com o cenário da “Nossa Locadora de Livros”, temos a informação que em 1995, a empresa adquiriu o seu primeiro computador e teve a necessidade de contratar uma empresa de TI (Tecnologia da Informação) para informatizar as primeiras rotinas. A empresa “Alunos da UNOPAR” assumiu esse compromisso e atua plenamente no desenvolvimento do sistema de locação de livros. Pesquise quantos e qual o computador mais indicado, descrevendo processador, memoria e dispositivos de entrada e saída. PROPOSTA DE EQUIPAMENTOS A SER ADQUIRIDA PARA INFRAESTRUTURA DA LOCADORA DE LIVROS “NOSSA LOCADORA DE LIVROS”. O CLIENTE DEVERÁ ADQUIRIR 6 (SEIS) COMPUTADORES, SENDO 1 (UM) SERVIDOR E 5 (CINCO) ESTAÇÕES, 3 (TRÊS) IMPRESSORAS FISCAIS BEMATECH, 1 (UMA) IMPRESSORA MONOCROMATICA MULTFUNCIONAL BROTHER MFC-8480dn. SERVIDOR: COMPUTADOR COM GABINETE TIPO TORRE, PLACA-MÃE ONBOARD ASUS 733, PROCESSADOR INTEL CORE2DUO, MEMORIA RAM 4 GB , HD 1 TB, GRAVADORA DE DVD, LEITORA DE CODIGO DE BARRAS OPTICA, TECLADO E MOUSE PS2, 1 MONITOR LED 17”, 1 NO-BREAK TS-SHARA PROFISSIONAL, SISTEMA OPERACIONAL WINDOWS 2008 SERVER. ESTAÇÕES BALCÃO DE VENDA: COMPUTADOR COM GABINETE TIPO TORRE, PLACA-MÃE ONBORAD ASUS 733, PROCESSADOR INTEL CELERON CORE2DUO, MEMORIA RAM 2 GB, HD 360 GB, TECLADO E MOUSE PS2, LEITORA DE CODIGO DE BARRAS OPTICA, SISTEMA OPERACIONAL WINDOWS SEVEN PROFESSIONAL. ESTAÇÕES ADMINISTRATIVAS: COMPUTADOR COM GABINETE TIPO TORRE, PLACA-MÃE ONBORAD ASUS 733, PROCESSADOR INTEL CELERON CORE2DUO, MEMORIA RAM 2 GB, HD 360 GB, TECLADO E MOUSE PS2, SISTEMA OPERACIONAL WINDOWS SEVEN PROFESSIONAL.
  9. 9. 8 3 Baseado no cenário proposto crie três proposições verdadeiras com a relação ao cenário “Nossa Locadora De Livros”, exemplo: p: O estoque da “Nossa Locadora De Livros” atual possui 20.000 títulos. p: Os valores das locações dos livros são R$ 20,00 para livros de classificação diamante, R$ 15,00 para livros de classificação ouro, R$ 10,00 para livros de classificação prata e R$ 5,00 para livros de classificação bronze. p: A empresa “Nossa Locadora de Livros” é uma empresa privada e com fins lucrativos. p: O objetivo da empresa “Nossa Locadora de Livros” é atender a demanda de locação de livros. 3.1 Faça uma pesquisa e descreva alguns conceitos da nossa disciplina de fundamentos de lógica e matemática discreta, quais sejam:  PROPOSIÇÃO: uma proposição é uma afirmação passível de assumir um valor logico de verdadeiro ou falso. Toda proposição é verdadeiro ou falso (principio do terceiro excluído); uma proposição não pode ser verdadeira e falsa (principio da não-contradição).  TAUTOLOGIA: é uma expressão booleana que avalia sempre como verdadeiro independentemente dos valores de suas variáveis.  CONTRADIÇÃO : é uma expressão booleana que avalia sempre como falso, independentemente dos valores de suas variáveis. 3.1.2 E quanto às proposições destaque os conceitos quanto ao valor lógico de:  NEGAÇÃO : O valor lógico de negação inverte os valores na tabela verdade, ou seja, onde p=v torna-se p=f e vice-versa.  CONJUNÇÃO : O valor lógico de conjunção trata na tabela verdade os valores de p e q são iguais, ou seja, quando verdadeiros o resultado é verdadeiro e para falso quando os valores de p e q são diferentes.  DISJUNÇÃO : O valor lógico da disjunção trata na tabela verdade os valores de p ou q verdadeiro quando existir um valor verdade em qualquer uma das
  10. 10. colunas e para falso quando existir dois valores falsos para p ou q.  DISJUNÇÃO EXCLUSIVA: O valor verdade trata na tabela verdade o valor logico na disjunção como verdadeiro quando p e q tiverem valores diferente e falso quando tiverem valores iguais.  CONDICIONAL : O valor lógico trata na tabela verdade os valores de p e q quando q=f e p=v o resultado é falso, e para verdadeiro para o restante da tabela.  BICONDICIONAL : O valor lógico trata na tabela verdade os valores de p e q como verdadeiro quando existir pelo menos um dos valores com resultado verdadeiro e falso para outros resultados. 4 Pesquise e descreva sobre os dois mecanismos de busca SEQUENCIAL e BINARIA. 4.1 BUSCA SEQUENCIAL: é um modo de pesquisa que utiliza um método intuitivo e indutivo, é utilizado para determinar a presença de um ou vários elementos numa sequência, onde os dados não se encontram numa ordem. A ideia base desse método de pesquisa é percorrer o vetor, comparando os elementos que constituem, com o elemento procurado. Seu funcionamento inicia-se no primeiro elemento do vetor, este vai percorrendo o vetor com n elementos, efetuando comparações para cada posição. Exemplo: var j,k, vb : inteiro v : vetor[1..10] de inteiro achou : logico procedimento preenchevetor // Preenche o vetor com numeros aleatorios entre 0 e 100 var j : inteiro inicio para j de 1 ate 10 faca v[j] <- randi(100) escreval(j:5,v[j]:5) 9
  11. 11. fimpara fimprocedimento inicio preenchevetor escreva("Entre com o valor de busca (ESC termina) :") leia(vb) // Busca Seqüencial j <- 1 repita se v[j] = vb entao achou <- verdadeiro senao J <- j+1 fimse ate (achou=verdadeiro) ou (j>10) se achou entao escreval("Achei ", vb , " na posição ", j) senao escreval("Nao achei.") fimse fimalgoritmo 10 4.2 BUSCA BINARIA: é um método simples, mas muito eficiente, é aplicado a conjuntos de dados e consiste em ir dividindo o intervalo ao meio de forma a torna-lo menor. Exemplo: var li,ls,j,vbusca, ind : inteiro v : vetor[1..20] de inteiro achou : logico inicio // Preenche um vetor com 20 números aleatórios, entre 0 e 100
  12. 12. aleatorio 0, 100 para j de 1 ate 20 faca leia(v[j]) fimpara aleatorio off // Ordena o vetor, usando Bubblesort e reaproveitando as variáveis para li de 1 ate 20 faca para ls de 1 ate 19 faca se v[ls] > v[ls+1] entao vbusca <- v[ls] v[ls] <- v[ls+1] v[ls+1] <- vbusca fimse fimpara fimpara // Busca binária repita escreva( "Valor para busca (ESC ou menor que 0 termina) : ") leia( vbusca) se vbusca >= 0 entao li <- 1 ls <- 20 achou <- Falso enquanto (nao achou) e (li <= ls) faca ind <- (li+ls) 2 se v[ind] = vbusca entao achou <- verdadeiro senao se v[ind] < vbusca entao li <- ind + 1 senao ls <- ind - 1 fimse 11
  13. 13. fimse fimenquanto se achou entao escreval( "Valor encontrado na posição ", ind) senao escreval( "O valor ", vbusca, " não está na lista.") fimse // Pausa o programa. Tecle F9 neste ponto para continuar pausa fimse ate vbusca < 0 fimalgoritmo 12
  14. 14. 5 CONCLUSÃO 13 Encerro aqui minha produção textual, de forma que me trouxe uma gama imensa de conhecimentos, capaz de abranger as informações necessárias para o desenvolvimento de sistemas de informação. Fico feliz por ter elaborado esse documento que é capaz de mostrar o quão importante é o Analista de Sistemas para a sociedade empresarial.
  15. 15. LINKS DE REFERÊNCIAS www.luis.blog.br/sistemas-informacao-operacional-tatico-estrategico.aspx www.infoescola.com/administracao_/sistema-de-informacao-gerencial http://www.pt.wikipedia.org/wiki/Sistema_de_suporte_à_decisão http://www.pt.wikipedia.org/wiki/Sistema_integrado_de_gestão_empresarial 14 http://www.pt.wikipedia.org/wiki/Customer_relationship_management http://books.google.com.br/books? id=2jlz6_IkF3UC&pg=PA32&lpg=PA32&dq=matematica+discreta+tautologia&source =bl&ots=NYWMrLd0Ov&sig=3eQkA57xdzbXbmJ6d2bp0G6SzIw&hl=pt- BR&sa=X&ei=AVV0UJfGJoqi8ATw2oCwBw&ved=0CEQQ6AEwBg#v=onepage&q= matematica%20discreta%20tautologia&f=false http://www.mat.ufmg.br/~michel/inicmat2010/livros/glaucio.pdf
  16. 16. ANEXOS 15
  17. 17. ANEXO A – Organograma da Empresa “Nossa Locadora de Livros” 16 A “Nossa Locadora de Livros” é uma empresa privada com fins lucrativos e está situada na região central da cidade de São Paulo, fundada em 20 de janeiro de 1990, com o objetivo de atender a demanda de locação de livros. Seu fundador o Sr. João Carlos é diretor e conta com um quadro de 7 funcionários que atuam em diversas áreas, sendo: Paulo Rodrigues, Ana Paula e José Roberto (depto locação), Marcia Regina (depto compras), André Augusto (depto de controle de estoque) e Maria Helena (depto financeiro); desde o inicio de sua operação a direção continua sendo o seu fundador. Seu estoque atual possui 20.000 títulos, que são organizados com as seguintes que são classificados como: diamante, ouro, prata e bronze. Os valores da locação são organizados pela classificação dos livros: diamante, R$ 20,00; ouro R$ 15,00; prata R$ 10,00 e bronze R$ 5,00. Em 1995, a empresa adquiriu o seu primeiro computador e teve a necessidade de contratar uma empresa de TI (Tecnologia da Informação) para informatizar as primeiras rotinas. A empresa “Alunos da UNOPAR” assumiu esse compromisso e atua plenamente no desenvolvimento de sistema de locação de livros.
  18. 18. Organograma: Nossa Locadora de Livros 17
  19. 19. CROQUI DA LOJA “NOSSA LOCADORA DE LIVROS” 18

×