MPLS-VPN

lien de téléchargement https://drive.google.com/file/d/0B2cVZ9PGCxHiLVpDMm5uTWxNQzQ/edit?usp=sharing

CAHIER DE CHARGE DU PROJET MPLS
I- Topologie :
II- Besoins des Clients:
 Les sociétés BH, Monoprix et OneTech décident d’interconnecter leurs sites à travers la technologie
MPLS VPN
 La société BH veut avoir une architecture ‘’Hub and spoke’’, les agences communiquent avec le site
central mais n’ont pas une connexion entre eux.
 Les sites de la société OneTech de même que les sites Monoprix appartiennent au même VPN.
 Tous les sites des différentes sociétés veulent se connecter à internet.
III- Travail Réalisé:
1) Configuration d’un BackBone MPLS:
Nous allons tout d’abord adresser les interfaces (physique et logicielle) des routeurs de notre Backbone.
Pour le routeur PE1
PE1(config)#int fa0/0
PE1(config-if)# ip address 192.168.102.1 255.255.255.0
PE1(config)#int fa0/1
PE1(config-if)# ip address 192.168.92.1 255.255.255.0
PE1(config)#int fa1/0
PE1(config-if)# ip address 192.168.12.1 255.255.255.0
PE1(config)#int fa2/0
PE1(config-if)# ip address 192.168.23.1 255.255.255.0
PE1 (config)#int loopback 0
PE1(config)# ip address 2.2.2.2 255.255.255.0
PE1(config)#ip ospf network point-to-point //MAJ OSPF envoyé point par point
Pour le routeur PE2
PE2(config)#int fa0/0
PE2(config-if)# ip address 192.168.34.2 255.255.255.0
PE2(config)#int fa0/1
PE2(config-if)# ip address 192.168.84.1 255.255.255.0
PE2(config)#int fa1/0
PE2(config-if)# ip address 192.168.74.1 255.255.255.0
PE2(config)#int fa2/0
PE2(config-if)# ip address 192.168.64.1 255.255.255.0
PE2(config)#int fa3/0
PE2(config-if)# ip address 192.168.114.1 255.255.255.0
PE2(config)#int fa4/0
PE2(config-if)# ip address 192.168.54.1 255.255.255.0
PE2 (config)#int loopback 0
PE2(config)# ip address 4.4.4.4 255.255.255.0
PE2(config)#ip ospf network point-to-point //MAJ OSPF envoyé point par point
Pour le routeur P
P(config)#int fa0/0
P(config-if)# ip address 192.168.23.2 255.255.255.0
P(config)#int fa0/1
P(config-if)# ip address 192.168.34.1 255.255.255.0
P (config)#int loopback 0
P(config)# ip address 3.3.3.3 255.255.255.0
P(config)#ip ospf network point-to-point //MAJ OSPF envoyé point par point
//Activation le protocole de routage OSPF (IGP) au niveau des routeurs du Backbone
Pour le routeur PE1
PE1(config)#router ospf 1
PE1(config-router)#network 192.168.23.0 0.0.0.255 area 0
PE1(config-router)#network 2.2.2.0 0.0.0.255 AREA 0
Pour le routeur PE2
PE2(config)#router ospf 1
PE2(config-router)#network 192.168.34.0 0.0.0.255 area 0
PE2(config-router)#network 4.4.4.0 0.0.0.255 AREA 0
Pour le routeur P
P(config)#router ospf 1
P(config-router)#network 192.168.23.0 0.0.0.255 area 0
P(config-router)#network 192.168.34.0 0.0.0.255 area 0
P(config-router)#network 3.3.3.0 0.0.0.255 AREA 0
//Activation de MPLS sur les routeurs Provider Edge
Pour le routeur PE1
PE1(config)#ip cef //on l’acitve seulement au niveau des routeurs cisco
PE1(config)#mpls label protocol ldp //activation du MPLS avec le label et son protocol
PE1(config)#mpls ldp router-id loopback 0 //activation du protocol sur l’interface logicielle
PE1(config)#int fa2/0 //activation du mpls dans l’interface physique
PE1(config-if)#mpls ip
Pour le routeur PE2
PE2(config)#ip cef //on l’active seulement au niveau des routeurs cisco
PE2(config)#mpls label protocol ldp //activation du MPLS avec le label et son protocol
PE2(config)#mpls ldp router-id loopback 0 //activation du protocol sur l’interface logicielle
PE2(config)#int fa0/0 //activation du mpls dans l’interface physique
PE2(config-if)#mpls ip
// Affichage de la table LIB
// Affichage de la table LFIB
// Affichage des informations des voisins LDP
// Afficher les labels d’un chemin «Commande traceroute »
2) Connection des différents sites des societies à travers la technologie
MPLS-VPN selon les besoins :
// Création des VRF sur les routeurs PE1 et PE2
// configuration de la VRF « MONOPRIX_HQ » sur le routeur PE1
PE1(CONFIG)#IP VRF MONOPRIX_HQ
PE1(CONFIG-VRF)#RD 1:10
PE1(CONFIG-VRF)#ROUTE-TARGET EXPORT 1:1
PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11
PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 9:9
PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 6:6
PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 5:5
PE1(CONFIG-VRF)#EXIT
// configuration de la VRF « BH_HQ » sur le routeur PE1
PE1(CONFIG)#IP VRF BH_HQ
PE1(CONFIG-VRF)#RD 10:1
PE1(CONFIG-VRF)#ROUTE-TARGET EXPORT 10:10
PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11
PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 8:8
PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 7:7
PE1(CONFIG-VRF)#EXIT
// configuration de la VRF « ONETECH_BRANCH » sur le routeur PE1
PE1(CONFIG)#IP VRF ONETECH_BRANCH
PE1(CONFIG-VRF)#RD 9:1
PE1(CONFIG-VRF)#ROUTE-TARGET EXPORT 9:9
PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11
PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 1:1
PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 6:6
PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 5:5
PE1(CONFIG-VRF)#EXIT
// configuration de la VRF « ONETECH_HQ » sur le routeur PE2
PE2(CONFIG)#IP VRF ONETECH_HQ
PE2(CONFIG-VRF)#RD 6:1
PE2(CONFIG-VRF)#ROUTE-TARGET EXPORT 6:6
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 9:9
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 1:1
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 5:5
PE2(CONFIG-VRF)#EXIT
// configuration de la VRF « MONOPRIX_BRANCH » sur le routeur PE2
PE2(CONFIG)#IP VRF MONOPRIX_BRANCH
PE2(CONFIG-VRF)#RD 5:1
PE2(CONFIG-VRF)#ROUTE-TARGET EXPORT 5:5
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 9:9
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 1:1
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 6:6
PE2(CONFIG-VRF)#EXIT
// configuration de la VRF « ONETECH_HQ » sur le routeur PE2
PE2(CONFIG)#IP VRF ONETECH_HQ
PE2(CONFIG-VRF)#RD 6:1
PE2(CONFIG-VRF)#ROUTE-TARGET EXPORT 6:6
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 9:9
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 1:1
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 5:5
PE2(CONFIG-VRF)#EXIT
// configuration de la VRF « BH_BRANCH_SFAX1 » sur le routeur PE2
PE2(CONFIG)#IP VRF BH_BRANCH_SFAX1
PE2(CONFIG-VRF)#RD 8:1
PE2(CONFIG-VRF)#ROUTE-TARGET EXPORT 8:8
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 10:10
PE2(CONFIG-VRF)#EXIT
// configuration de la VRF « BH_BRANCH_SFAX2 » sur le routeur PE2
PE2(CONFIG)#IP VRF BH_BRANCH_SFAX2
PE2(CONFIG-VRF)#RD 7:1
PE2(CONFIG-VRF)#ROUTE-TARGET EXPORT 7:7
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 10:10
PE2(CONFIG-VRF)#EXIT
// configuration de la VRF « INTERNET » sur le routeur PE2
PE2(CONFIG)#IP VRF INTERNET
PE2(CONFIG-VRF)#RD 11:1
PE2(CONFIG-VRF)#ROUTE-TARGET EXPORT 11:11
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 10:10
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 9:9
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 8:8
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 7:7
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 6:6
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 1:1
PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 5:5
PE2(CONFIG-VRF)#EXIT
// Affectation d’une adresse ip à chaque vrf
PE1(config)#int fa1/0
PE1(config-if)#ip vrf forwarding MONOPRIXHQ
PE1(config-if)#ip address 192.168.12.1 255.255.255.0
PE1(config-if)#no shutdown
PE1(config)#int fa0/0
PE1(config-if)#ip vrf forwarding BHHQ
PE1(config-if)#ip address 192.168.102.1 255.255.255.0
PE1(config-if)#no shutdown
PE1(config)#int fa0/1
PE1(config-if)#ip vrf forwarding ONETECHBRANCH
PE1(config-if)#ip address 192.168.92.1 255.255.255.0
PE1(config-if)#no shutdown
PE2(config)#int fa0/1
PE2(config-if)#ip vrf forwarding BHBRANCHSFAX1
PE2(config-if)#ip address 192.168.84.1 255.255.255.0
PE2(config-if)#no shutdown
PE2(config)#int fa1/0
PE2(config-if)#ip vrf forwarding BHBRANCHSFAX2
PE2(config-if)#ip address 192.168.74.1 255.255.255.0
PE2(config-if)#no shutdown
PE2(config)#int fa2/0
PE2(config-if)#ip vrf forwarding ONETECHHQ
PE2(config-if)#ip address 192.168.64.1 255.255.255.0
PE2(config-if)#no shutdown
PE2(config)#int fa3/0
PE2(config-if)#ip vrf forwarding INTERNET
PE2(config-if)#ip address 192.168.114.1 255.255.255.0
PE2(config-if)#no shutdown
PE2(config)#int fa4/0
PE2(config-if)#ip vrf forwarding MONOPRIXBRANCH
PE2(config-if)#ip address 192.168.54.1 255.255.255.0
PE2(config-if)#no shutdown
// Verification du ping pour chaque vrf
// Activation des différents protocoles dans chaque Costumer Edge (CE)
- Protocole EIGRP
MONOPRIXHQ(config)#router eigrp 100
MONOPRIXHQ (config-router)#network 192.168.12.0 0.0.0.255
MONOPRIXHQ (config-router)#network 1.1.1.0 0.0.0.255
MONOPRIXHQ (config-router)#no auto-summary
MONOPRIXBRANCH(config)#router eigrp 100
MONOPRIXBRANCH (config-router)#network 192.168.54.0 0.0.0.255
MONOPRIXBRANCH (config-router)#network 5.5.5.0 0.0.0.255
MONOPRIXBRANCH (config-router)#no auto-summary
- Protocole OSPF
BHHQ(config)#router ospf 4
BHHQ (config-router)#network 192.168.102.0 0.0.0.255 area 0
BHHQ (config-router)#network 10.10.10.0 0.0.0.255 area 0
BHBRANCHSFAX1(config)#router ospf 5
BHBRANCHSFAX1 (config-router)#network 192.168.84.0 0.0.0.255 area 0
BHBRANCHSFAX1 (config-router)#network 8.8.8.0 0.0.0.255 area 0
BHBRANCHSFAX2(config)#router ospf 55
BHBRANCHSFAX2 (config-router)#network 192.168.74.0 0.0.0.255 area 0
BHBRANCHSFAX2 (config-router)#network 7.7.7.0 0.0.0.255 area 0
INTERNET(config)#router ospf 3
INTERNET (config-router)#network 192.168.114.0 0.0.0.255 area 0
INTERNET (config-router)#network 11.11.11.0 0.0.0.255 area 0
- Protocole RIPV2
ONETECHBRANCH(config)#router rip
ONETECHBRANCH(config)#version 2
ONETECHBRANCH (config-router)#network 192.168.92.0
ONETECHBRANCH (config-router)#network 9.9.9.0
ONETECHBH(config)#router rip
ONETECHBH(config)#version 2
ONETECHBH (config-router)#network 192.168.64.0
ONETECHBH (config-router)#network 6.6.6.0
// Activation des différentes mises à jour dans chaque vrf (PE)
Sur le routeur PE1, pour la vrf MONOPRIXHQ
PE1(config)#router eigrp 1
PE1 (config-router)#address-family ipv4 vrf MONOPRIXHQ
PE1 (config-router-af)#autonomous-system 100
PE1 (config-router-af)#network 192.168.12.0
Sur le routeur PE1, pour la vrf BHHQ
PE1(config)#router ospf 4 vrf BHHQ
PE1 (config-router)#network 192.168.102.0 0.0.0.255 area 0
Sur le routeur PE1, pour la vrf ONETECHBRANCH
PE1(config)#router rip
PE1 (config-router)#address-family ipv4 vrf ONETECHBRANCH
PE1 (config-router-af)#version 2
PE1 (config-router-af)#network 192.168.92.0
Sur le routeur PE2, pour la vrf MONOPRIXBRANCH
PE2(config)#router eigrp 1
PE2 (config-router)#address-family ipv4 vrf MONOPRIXBRANCH
PE2 (config-router-af)#autonomous-system 100
PE2 (config-router-af)#network 192.168.54.0
Sur le routeur PE2, pour la vrf BHBRANCHSFAX1
PE2(config)#router ospf 5 vrf BHBRANCHSFAX1
PE2 (config-router)#network 192.168.84.0 0.0.0.255 area 0
Sur le routeur PE2, pour la vrf BHBRANCHSFAX2
PE2(config)#router ospf 55 vrf BHBRANCHSFAX2
PE2 (config-router)#network 192.168.74.0 0.0.0.255 area 0
Sur le routeur PE2, pour la vrf INTERNET
PE2(config)#router ospf 3 vrf INTERNET
PE2 (config-router)#network 192.168.114.0 0.0.0.255 area 0
Sur le routeur PE2, pour la vrf ONETECHHQ
PE2(config)#router rip
PE2 (config-router)#address-family ipv4 vrf ONETECHHQ
PE2 (config-router-af)#version 2
PE2 (config-router-af)#network 192.168.54.0
// Déclaration des voisins dans le BGP
PE1(config)#router bgp 1
PE1 (config-router)#neighbor 4.4.4.4 remote-as 1
PE1 (config-router)#neighbor 4.4.4.4 upddate-source loopback 0 //permet de faire les MAJ dans la loopback 0
PE1 (config-router)#address-family vpnv4 //j’entre dans le MBGP pour echanger les routes vpnv4
PE1 (config-router-af)# neighbor 4.4.4.4 activate
PE1 (config-router-af)# neighbor 4.4.4.4 send-community extended //extended : peut importer et exporter à la
fois
PE2(config)#router bgp 1
PE2 (config-router)#neighbor 2.2.2.2 remote-as 1
PE2 (config-router)#neighbor 2.2.2.2 upddate-source loopback 0 //permet de faire les MAJ dans la loopback 0
PE2 (config-router)#address-family vpnv4 //j’entre dans le MBGP pour echanger les routes vpnv4
PE2 (config-router-af)# neighbor 2.2.2.2 activate
PE2 (config-router-af)# neighbor 2.2.2.2 send-community extended//extended : peut importer et exporter à la
fois
// Redistribution du EIGRP dans le BGP (MBGP)
PE2(config)#router bgp 1
PE2 (config-router)#address-family ipv4 vrf MONOPRIXBRANCH
PE2 (config-router-af)#redistribute eigrp 100
Dans le meme routeur on fait l’inverse
PE2(config)#router eigrp 1
PE2 (config-router)#address-family ipv4 vrf MONOPRIXBRANCH
PE2 (config-router-af)#redistribute bgp 1 metric 64 1000 255 1 1500
PE1(config)#router bgp 1
PE1 (config-router)#address-family ipv4 vrf MONOPRIXBH
PE1 (config-router-af)#redistribute eigrp 100
Dans le meme routeur on fait l’inverse
PE1(config)#router eigrp 1
PE1 (config-router)#address-family ipv4 vrf MONOPRIXBH
PE1 (config-router-af)#redistribute bgp 1 metric 64 1000 255 1 1500
// Redistribution du protocole OSPF dans le BGP (MBGP)
PE1(config)#router bgp 1
PE1 (config-router)#address-family ipv4 vrf BHBH
PE1 (config-router-af)#redistribute ospf 4
Dans le meme routeur je redistribue le BGP dans l’OSPF 4
PE1(config)#router ospf 4 vrf BHHQ
PE1 (config-router-af)#redistribute bgp 1 subnets
Pour le routeur PE2
PE2(config)#router bgp 1
PE2 (config-router)#address-family ipv4 vrf BHBRANCHSFAX1
PE2 (config-router-af)#redistribute ospf 5
Dans le meme routeur je redistribue le BGP dans l’OSPF 5
PE2(config)#router ospf 5 vrf BHBRANCHSFAX1
PE2 (config-router-af)#redistribute bgp 1 subnets
PE2(config)#router bgp 1
PE2 (config-router)#address-family ipv4 vrf BHBRANCHSFAX2
PE2 (config-router-af)#redistribute ospf 55
Dans le meme routeur je redistribue le BGP dans l’OSPF 55
PE2(config)#router ospf 55 vrf BHBRANCHSFAX2
PE2 (config-router-af)#redistribute bgp 1 subnets
PE2(config)#router bgp 1
PE2 (config-router)#address-family ipv4 vrf INTERNET
PE2 (config-router-af)#redistribute ospf 3 vrf INTERNET match internal external 1 external 2
PE2 (config-router-af)#default-information originate
Dans le meme routeur je redistribue le BGP dans l’OSPF 3
PE2(config)#router ospf 3 vrf INTERNET
PE2 (config-router-af)#redistribute bgp 1 subnets
// Redistribution du protocole RIP dans le BGP (MBGP)
PE2(config)#router bgp 1
PE2 (config-router)#address-family ipv4 vrf ONETECHHQ
PE2 (config-router-af)#redistribute rip
Dans le meme routeur je redistribue le bgp dans le rip
PE2(config)#router rip
PE2 (config-router)#address-family ipv4 vrf ONETECHHQ
PE2 (config-router-af)#redistribute bgp 1 metric transparent
Pour le routeur PE1
PE1(config)#router bgp 1
PE1 (config-router)#address-family ipv4 vrf ONETECHBRANCH
PE1 (config-router-af)#redistribute rip
Dans le meme routeur je redistribue le bgp dans le rip
PE1(config)#router rip
PE1 (config-router)#address-family ipv4 vrf ONETECHBRANCH
PE1 (config-router-af)#redistribute bgp 1 metric transparent
// Vérification du fonctionnement du MP-BGP
Pour connaitre toutes les routes apprises par le MP-BGP sur un routeur donné, la commande « show ip bgp vpnv4
all » peut être utilisée :
Pour le routeur internet je redirige tout d’abord le trafic vers l’intérieur à travers le NAT sur l’interface connecté
au Backbone MPLS
INTERNET(config)#int Fa 0/0
INTERNET (config-router)#ip nat inside
J’entre dans l’interface qui est connectée au cloud et je redirige le trafic vers l’extérieur
INTERNET(config)#int Fa 0/1
INTERNET (config-router)#ip nat outside
INTERNET (config-router)#ip address 192.168.137.2 255.255.255.0
INTERNET (config-router)#no shutdown
Sur le routeur INTERNET, je me connecte physiquement au réseau
INTERNET(config)#access-list 1 permit any
INTERNET (config)#ip nat pool cloud 192.168.137.100 192.168.137.200 netmask 255.255.255.0
INTERNET (config)#ip nat source list 1pool overload

Recomendados

Soutenance Finale por
Soutenance FinaleSoutenance Finale
Soutenance FinaleSlim Bejaoui
6.8K visualizações34 slides
MPLS VPN por
MPLS VPNMPLS VPN
MPLS VPNWilfried Tiani
3.5K visualizações25 slides
MPLS por
MPLSMPLS
MPLSAymen Bouzid
6.7K visualizações36 slides
Implémentation de la QoS au sein d'un IP/MPLS - Présentation por
Implémentation de la QoS au sein d'un IP/MPLS - PrésentationImplémentation de la QoS au sein d'un IP/MPLS - Présentation
Implémentation de la QoS au sein d'un IP/MPLS - PrésentationRihab Chebbah
5K visualizações23 slides
Cours3 ospf-eigrp por
Cours3 ospf-eigrpCours3 ospf-eigrp
Cours3 ospf-eigrpBadr Guennoun
4.9K visualizações98 slides
Implémentation de la QoS au sein d'un IP/MPLS - Rapport por
Implémentation de la QoS au sein d'un IP/MPLS - RapportImplémentation de la QoS au sein d'un IP/MPLS - Rapport
Implémentation de la QoS au sein d'un IP/MPLS - RapportRihab Chebbah
12.4K visualizações92 slides

Mais conteúdo relacionado

Mais procurados

Vlan-spanning tree por
Vlan-spanning treeVlan-spanning tree
Vlan-spanning treeSirine Ibrahim
1.1K visualizações43 slides
Etude et mise en place d’un VPN por
Etude et mise en place d’un VPNEtude et mise en place d’un VPN
Etude et mise en place d’un VPNCharif Khrichfa
6.7K visualizações21 slides
Protocole OSPF por
Protocole OSPFProtocole OSPF
Protocole OSPFThomas Moegli
5.5K visualizações143 slides
Travaux pratiques configuration du routage entre réseaux locaux virtuels por
Travaux pratiques   configuration du routage entre réseaux locaux virtuelsTravaux pratiques   configuration du routage entre réseaux locaux virtuels
Travaux pratiques configuration du routage entre réseaux locaux virtuelsMohamed Keita
3K visualizações6 slides
Concepts et configuration de base de la commutation por
Concepts et configuration de base de la commutationConcepts et configuration de base de la commutation
Concepts et configuration de base de la commutationEL AMRI El Hassan
2.1K visualizações41 slides
GNS3, VoIP, ToIP por
GNS3, VoIP, ToIPGNS3, VoIP, ToIP
GNS3, VoIP, ToIPDimitri LEMBOKOLO
22.9K visualizações31 slides

Mais procurados(20)

Vlan-spanning tree por Sirine Ibrahim
Vlan-spanning treeVlan-spanning tree
Vlan-spanning tree
Sirine Ibrahim1.1K visualizações
Etude et mise en place d’un VPN por Charif Khrichfa
Etude et mise en place d’un VPNEtude et mise en place d’un VPN
Etude et mise en place d’un VPN
Charif Khrichfa6.7K visualizações
Protocole OSPF por Thomas Moegli
Protocole OSPFProtocole OSPF
Protocole OSPF
Thomas Moegli5.5K visualizações
Travaux pratiques configuration du routage entre réseaux locaux virtuels por Mohamed Keita
Travaux pratiques   configuration du routage entre réseaux locaux virtuelsTravaux pratiques   configuration du routage entre réseaux locaux virtuels
Travaux pratiques configuration du routage entre réseaux locaux virtuels
Mohamed Keita3K visualizações
Concepts et configuration de base de la commutation por EL AMRI El Hassan
Concepts et configuration de base de la commutationConcepts et configuration de base de la commutation
Concepts et configuration de base de la commutation
EL AMRI El Hassan2.1K visualizações
GNS3, VoIP, ToIP por Dimitri LEMBOKOLO
GNS3, VoIP, ToIPGNS3, VoIP, ToIP
GNS3, VoIP, ToIP
Dimitri LEMBOKOLO22.9K visualizações
Mise en place de deux réseaux LAN interconnectés par un réseau WAN por Ghassen Chaieb
Mise en place de deux réseaux LAN interconnectés par un réseau WANMise en place de deux réseaux LAN interconnectés par un réseau WAN
Mise en place de deux réseaux LAN interconnectés par un réseau WAN
Ghassen Chaieb25.5K visualizações
Routage por Sirine Ibrahim
RoutageRoutage
Routage
Sirine Ibrahim4.1K visualizações
CISCO Virtual Private LAN Service (VPLS) Technical Deployment Overview por Ameen Wayok
CISCO Virtual Private LAN Service (VPLS) Technical Deployment OverviewCISCO Virtual Private LAN Service (VPLS) Technical Deployment Overview
CISCO Virtual Private LAN Service (VPLS) Technical Deployment Overview
Ameen Wayok15K visualizações
MPLS-TE por Aymen Bouzid
MPLS-TEMPLS-TE
MPLS-TE
Aymen Bouzid4.6K visualizações
Cours etherchannel por EL AMRI El Hassan
Cours etherchannelCours etherchannel
Cours etherchannel
EL AMRI El Hassan4.5K visualizações
Voice over MPLS por Tooba Shaikh
Voice over MPLSVoice over MPLS
Voice over MPLS
Tooba Shaikh6.8K visualizações
Pfe master fst_final_decembre2015 por Ghali Rahma
Pfe master fst_final_decembre2015Pfe master fst_final_decembre2015
Pfe master fst_final_decembre2015
Ghali Rahma6.9K visualizações
Cours ACL IPv4 et IPv6 por EL AMRI El Hassan
Cours ACL IPv4 et IPv6Cours ACL IPv4 et IPv6
Cours ACL IPv4 et IPv6
EL AMRI El Hassan3.7K visualizações
Routage rip por Ines Kechiche
Routage ripRoutage rip
Routage rip
Ines Kechiche1K visualizações
Tp voip por amalouwarda
Tp voipTp voip
Tp voip
amalouwarda995 visualizações
Cours routage inter-vlan por EL AMRI El Hassan
Cours routage inter-vlanCours routage inter-vlan
Cours routage inter-vlan
EL AMRI El Hassan6K visualizações
Présentation etherchannel por Lechoco Kado
Présentation etherchannelPrésentation etherchannel
Présentation etherchannel
Lechoco Kado3.8K visualizações
Mpls foudhaili oussama por Gilles Samba
Mpls foudhaili oussamaMpls foudhaili oussama
Mpls foudhaili oussama
Gilles Samba3.2K visualizações
Telephonie ip por agouassou1
Telephonie ipTelephonie ip
Telephonie ip
agouassou17.5K visualizações

Destaque

IOIO Card por
IOIO CardIOIO Card
IOIO CardEric Maxime
2K visualizações28 slides
Envoi SMS JAVA por
Envoi SMS JAVAEnvoi SMS JAVA
Envoi SMS JAVAEric Maxime
7.3K visualizações29 slides
Jeu Motus C por
Jeu Motus  CJeu Motus  C
Jeu Motus CEric Maxime
4.8K visualizações20 slides
PFE : ITIL - Gestion de parc informatique por
PFE : ITIL - Gestion de parc informatiquePFE : ITIL - Gestion de parc informatique
PFE : ITIL - Gestion de parc informatiquechammem
40.4K visualizações28 slides
Rapport PFE: Gestion de Parc Informatique por
Rapport PFE: Gestion de Parc InformatiqueRapport PFE: Gestion de Parc Informatique
Rapport PFE: Gestion de Parc InformatiqueEric Maxime
54.5K visualizações71 slides
Presentation pfe gestion parc informatique et help desk por
Presentation pfe gestion parc informatique et help deskPresentation pfe gestion parc informatique et help desk
Presentation pfe gestion parc informatique et help deskRaef Ghribi
22.7K visualizações46 slides

Destaque(10)

IOIO Card por Eric Maxime
IOIO CardIOIO Card
IOIO Card
Eric Maxime2K visualizações
Envoi SMS JAVA por Eric Maxime
Envoi SMS JAVAEnvoi SMS JAVA
Envoi SMS JAVA
Eric Maxime7.3K visualizações
Jeu Motus C por Eric Maxime
Jeu Motus  CJeu Motus  C
Jeu Motus C
Eric Maxime4.8K visualizações
PFE : ITIL - Gestion de parc informatique por chammem
PFE : ITIL - Gestion de parc informatiquePFE : ITIL - Gestion de parc informatique
PFE : ITIL - Gestion de parc informatique
chammem40.4K visualizações
Rapport PFE: Gestion de Parc Informatique por Eric Maxime
Rapport PFE: Gestion de Parc InformatiqueRapport PFE: Gestion de Parc Informatique
Rapport PFE: Gestion de Parc Informatique
Eric Maxime54.5K visualizações
Presentation pfe gestion parc informatique et help desk por Raef Ghribi
Presentation pfe gestion parc informatique et help deskPresentation pfe gestion parc informatique et help desk
Presentation pfe gestion parc informatique et help desk
Raef Ghribi22.7K visualizações
Rapport de projet de fin d'étude licence informatique et multimédia por Nazih Heni
Rapport de projet de fin d'étude licence informatique et multimédiaRapport de projet de fin d'étude licence informatique et multimédia
Rapport de projet de fin d'étude licence informatique et multimédia
Nazih Heni181.3K visualizações
Rapport De PFE por Nadir Haouari
Rapport De PFERapport De PFE
Rapport De PFE
Nadir Haouari192.1K visualizações
Projet de fin d'etude gestion informatique por jihene Ab
Projet de fin d'etude gestion informatiqueProjet de fin d'etude gestion informatique
Projet de fin d'etude gestion informatique
jihene Ab92.9K visualizações
Rapport PFE : Développement D'une application de gestion des cartes de fidéli... por Riadh K.
Rapport PFE : Développement D'une application de gestion des cartes de fidéli...Rapport PFE : Développement D'une application de gestion des cartes de fidéli...
Rapport PFE : Développement D'une application de gestion des cartes de fidéli...
Riadh K.202.1K visualizações

Similar a MPLS-VPN

soutenance.ppt por
soutenance.pptsoutenance.ppt
soutenance.pptAlbertbenBarry1
43 visualizações34 slides
soutenance.ppt por
soutenance.pptsoutenance.ppt
soutenance.pptamalbenramdhane
5 visualizações34 slides
commande 2.pdf por
commande 2.pdfcommande 2.pdf
commande 2.pdfalirayss
8 visualizações2 slides
Configuration de-base-d por
Configuration de-base-dConfiguration de-base-d
Configuration de-base-dNabil EL KASSOUMI
255 visualizações10 slides
Les commandes CISCO (routeur) por
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)EL AMRI El Hassan
8.4K visualizações4 slides
Tout atm por
Tout atmTout atm
Tout atmvanyvan10
868 visualizações13 slides

Similar a MPLS-VPN(20)

soutenance.ppt por AlbertbenBarry1
soutenance.pptsoutenance.ppt
soutenance.ppt
AlbertbenBarry143 visualizações
soutenance.ppt por amalbenramdhane
soutenance.pptsoutenance.ppt
soutenance.ppt
amalbenramdhane5 visualizações
commande 2.pdf por alirayss
commande 2.pdfcommande 2.pdf
commande 2.pdf
alirayss8 visualizações
Configuration de-base-d por Nabil EL KASSOUMI
Configuration de-base-dConfiguration de-base-d
Configuration de-base-d
Nabil EL KASSOUMI255 visualizações
Les commandes CISCO (routeur) por EL AMRI El Hassan
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)
EL AMRI El Hassan8.4K visualizações
Tout atm por vanyvan10
Tout atmTout atm
Tout atm
vanyvan10868 visualizações
Configuración de los router por JESUS EMMANUEL
Configuración de los routerConfiguración de los router
Configuración de los router
JESUS EMMANUEL154 visualizações
EIGRP - EIGRP sur frame relay por mdyabi
EIGRP - EIGRP sur frame relayEIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relay
mdyabi1.2K visualizações
Astuces cisco por CONNECT Tunisia
Astuces ciscoAstuces cisco
Astuces cisco
CONNECT Tunisia713 visualizações
Préparation de 2015 !! por Ahmed X-boy
Préparation de 2015 !!Préparation de 2015 !!
Préparation de 2015 !!
Ahmed X-boy305 visualizações
Version Final Presentation por Bedreddine Zarrouk
Version Final PresentationVersion Final Presentation
Version Final Presentation
Bedreddine Zarrouk932 visualizações
cisco_base.ppt por OuliaLahouel1
cisco_base.pptcisco_base.ppt
cisco_base.ppt
OuliaLahouel16 visualizações
Tuto VP IPSEC Site-to-site por Dimitri LEMBOKOLO
Tuto VP IPSEC Site-to-siteTuto VP IPSEC Site-to-site
Tuto VP IPSEC Site-to-site
Dimitri LEMBOKOLO10.3K visualizações
Alphorm.com Formation CCNP ENCOR 350-401 (5/8) : Architecture por Alphorm
Alphorm.com Formation CCNP ENCOR 350-401 (5/8) : ArchitectureAlphorm.com Formation CCNP ENCOR 350-401 (5/8) : Architecture
Alphorm.com Formation CCNP ENCOR 350-401 (5/8) : Architecture
Alphorm1.8K visualizações
Ciscomadesimple.be vrrp virtual router redundancy protocol por basschuck2411
Ciscomadesimple.be vrrp  virtual router redundancy protocolCiscomadesimple.be vrrp  virtual router redundancy protocol
Ciscomadesimple.be vrrp virtual router redundancy protocol
basschuck2411496 visualizações
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2) por SmartnSkilled
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
SmartnSkilled742 visualizações
Cassandra Java Driver : vers Cassandra 1.2 et au-delà por Ippon
Cassandra Java Driver : vers Cassandra 1.2 et au-delàCassandra Java Driver : vers Cassandra 1.2 et au-delà
Cassandra Java Driver : vers Cassandra 1.2 et au-delà
Ippon2.8K visualizações
Cassandra Ippevent 20 Juin 2013 por vberetti
Cassandra Ippevent 20 Juin 2013Cassandra Ippevent 20 Juin 2013
Cassandra Ippevent 20 Juin 2013
vberetti505 visualizações
Guide mise en oeuvre-pfsensev2 por Hichem Chehida
Guide mise en oeuvre-pfsensev2Guide mise en oeuvre-pfsensev2
Guide mise en oeuvre-pfsensev2
Hichem Chehida2.8K visualizações
Formation Bus de Terrain _Partie 3_3 _EthernetIP por Wojciech GOMOLKA
Formation Bus de Terrain _Partie 3_3 _EthernetIPFormation Bus de Terrain _Partie 3_3 _EthernetIP
Formation Bus de Terrain _Partie 3_3 _EthernetIP
Wojciech GOMOLKA1K visualizações

Último

La dissertation por
La dissertationLa dissertation
La dissertationGabriel Gay-Para
21 visualizações19 slides
INCENDIE_New1.ppt por
INCENDIE_New1.pptINCENDIE_New1.ppt
INCENDIE_New1.pptAcadmieSecourisme
5 visualizações120 slides
Indicateurs de développement durable pour les municipalités  : sources et rep... por
Indicateurs de développement durable pour les municipalités  : sources et rep...Indicateurs de développement durable pour les municipalités  : sources et rep...
Indicateurs de développement durable pour les municipalités  : sources et rep...Centre GéoStat, Bibliothèque, Université Laval
53 visualizações48 slides
ONU.pdf por
ONU.pdfONU.pdf
ONU.pdfChristopheFontaine13
35 visualizações2 slides
La conscience d'être libre est-elle illusoire ? (G. Gay-Para) por
La conscience d'être libre est-elle illusoire ? (G. Gay-Para)La conscience d'être libre est-elle illusoire ? (G. Gay-Para)
La conscience d'être libre est-elle illusoire ? (G. Gay-Para)Gabriel Gay-Para
19 visualizações54 slides
Exercice de révision SE - IPSET.pdf por
Exercice de révision SE - IPSET.pdfExercice de révision SE - IPSET.pdf
Exercice de révision SE - IPSET.pdfMedBechir
7 visualizações2 slides

Último(12)

La dissertation por Gabriel Gay-Para
La dissertationLa dissertation
La dissertation
Gabriel Gay-Para21 visualizações
La conscience d'être libre est-elle illusoire ? (G. Gay-Para) por Gabriel Gay-Para
La conscience d'être libre est-elle illusoire ? (G. Gay-Para)La conscience d'être libre est-elle illusoire ? (G. Gay-Para)
La conscience d'être libre est-elle illusoire ? (G. Gay-Para)
Gabriel Gay-Para19 visualizações
Exercice de révision SE - IPSET.pdf por MedBechir
Exercice de révision SE - IPSET.pdfExercice de révision SE - IPSET.pdf
Exercice de révision SE - IPSET.pdf
MedBechir7 visualizações
Formation M2i - Cadre réglementaire des IA Génératives : premiers éléments de... por M2i Formation
Formation M2i - Cadre réglementaire des IA Génératives : premiers éléments de...Formation M2i - Cadre réglementaire des IA Génératives : premiers éléments de...
Formation M2i - Cadre réglementaire des IA Génératives : premiers éléments de...
M2i Formation22 visualizações
Présentation de lancement SAE105 por JeanLucHusson
Présentation de lancement SAE105Présentation de lancement SAE105
Présentation de lancement SAE105
JeanLucHusson193 visualizações
FORMATION SUR LES PICTOGRAMMES DE SECURITE KKW.pptx por KOUADIO WILLIAMS KOUAME
FORMATION SUR LES PICTOGRAMMES DE SECURITE KKW.pptxFORMATION SUR LES PICTOGRAMMES DE SECURITE KKW.pptx
FORMATION SUR LES PICTOGRAMMES DE SECURITE KKW.pptx
KOUADIO WILLIAMS KOUAME20 visualizações
Formation M2i - Génération IA : Prenez le train de l'avenir por M2i Formation
Formation M2i - Génération IA : Prenez le train de l'avenirFormation M2i - Génération IA : Prenez le train de l'avenir
Formation M2i - Génération IA : Prenez le train de l'avenir
M2i Formation7 visualizações
Cours Audit General 2019 (1).prof tatouti .pdf por Abdelghani19
Cours Audit  General 2019 (1).prof tatouti .pdfCours Audit  General 2019 (1).prof tatouti .pdf
Cours Audit General 2019 (1).prof tatouti .pdf
Abdelghani1915 visualizações
Webinaire de formation sur les REL por Mokhtar Ben Henda
Webinaire de formation sur les RELWebinaire de formation sur les REL
Webinaire de formation sur les REL
Mokhtar Ben Henda8 visualizações

MPLS-VPN

  • 1. CAHIER DE CHARGE DU PROJET MPLS I- Topologie : II- Besoins des Clients:  Les sociétés BH, Monoprix et OneTech décident d’interconnecter leurs sites à travers la technologie MPLS VPN  La société BH veut avoir une architecture ‘’Hub and spoke’’, les agences communiquent avec le site central mais n’ont pas une connexion entre eux.  Les sites de la société OneTech de même que les sites Monoprix appartiennent au même VPN.  Tous les sites des différentes sociétés veulent se connecter à internet. III- Travail Réalisé: 1) Configuration d’un BackBone MPLS: Nous allons tout d’abord adresser les interfaces (physique et logicielle) des routeurs de notre Backbone. Pour le routeur PE1 PE1(config)#int fa0/0 PE1(config-if)# ip address 192.168.102.1 255.255.255.0 PE1(config)#int fa0/1
  • 2. PE1(config-if)# ip address 192.168.92.1 255.255.255.0 PE1(config)#int fa1/0 PE1(config-if)# ip address 192.168.12.1 255.255.255.0 PE1(config)#int fa2/0 PE1(config-if)# ip address 192.168.23.1 255.255.255.0 PE1 (config)#int loopback 0 PE1(config)# ip address 2.2.2.2 255.255.255.0 PE1(config)#ip ospf network point-to-point //MAJ OSPF envoyé point par point Pour le routeur PE2 PE2(config)#int fa0/0 PE2(config-if)# ip address 192.168.34.2 255.255.255.0 PE2(config)#int fa0/1 PE2(config-if)# ip address 192.168.84.1 255.255.255.0 PE2(config)#int fa1/0 PE2(config-if)# ip address 192.168.74.1 255.255.255.0 PE2(config)#int fa2/0 PE2(config-if)# ip address 192.168.64.1 255.255.255.0 PE2(config)#int fa3/0 PE2(config-if)# ip address 192.168.114.1 255.255.255.0 PE2(config)#int fa4/0 PE2(config-if)# ip address 192.168.54.1 255.255.255.0 PE2 (config)#int loopback 0 PE2(config)# ip address 4.4.4.4 255.255.255.0 PE2(config)#ip ospf network point-to-point //MAJ OSPF envoyé point par point Pour le routeur P P(config)#int fa0/0 P(config-if)# ip address 192.168.23.2 255.255.255.0 P(config)#int fa0/1 P(config-if)# ip address 192.168.34.1 255.255.255.0 P (config)#int loopback 0 P(config)# ip address 3.3.3.3 255.255.255.0 P(config)#ip ospf network point-to-point //MAJ OSPF envoyé point par point
  • 3. //Activation le protocole de routage OSPF (IGP) au niveau des routeurs du Backbone Pour le routeur PE1 PE1(config)#router ospf 1 PE1(config-router)#network 192.168.23.0 0.0.0.255 area 0 PE1(config-router)#network 2.2.2.0 0.0.0.255 AREA 0 Pour le routeur PE2 PE2(config)#router ospf 1 PE2(config-router)#network 192.168.34.0 0.0.0.255 area 0 PE2(config-router)#network 4.4.4.0 0.0.0.255 AREA 0 Pour le routeur P P(config)#router ospf 1 P(config-router)#network 192.168.23.0 0.0.0.255 area 0 P(config-router)#network 192.168.34.0 0.0.0.255 area 0 P(config-router)#network 3.3.3.0 0.0.0.255 AREA 0 //Activation de MPLS sur les routeurs Provider Edge Pour le routeur PE1 PE1(config)#ip cef //on l’acitve seulement au niveau des routeurs cisco PE1(config)#mpls label protocol ldp //activation du MPLS avec le label et son protocol PE1(config)#mpls ldp router-id loopback 0 //activation du protocol sur l’interface logicielle PE1(config)#int fa2/0 //activation du mpls dans l’interface physique PE1(config-if)#mpls ip Pour le routeur PE2 PE2(config)#ip cef //on l’active seulement au niveau des routeurs cisco PE2(config)#mpls label protocol ldp //activation du MPLS avec le label et son protocol PE2(config)#mpls ldp router-id loopback 0 //activation du protocol sur l’interface logicielle PE2(config)#int fa0/0 //activation du mpls dans l’interface physique PE2(config-if)#mpls ip // Affichage de la table LIB
  • 4. // Affichage de la table LFIB // Affichage des informations des voisins LDP // Afficher les labels d’un chemin «Commande traceroute » 2) Connection des différents sites des societies à travers la technologie MPLS-VPN selon les besoins : // Création des VRF sur les routeurs PE1 et PE2 // configuration de la VRF « MONOPRIX_HQ » sur le routeur PE1 PE1(CONFIG)#IP VRF MONOPRIX_HQ PE1(CONFIG-VRF)#RD 1:10 PE1(CONFIG-VRF)#ROUTE-TARGET EXPORT 1:1
  • 5. PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11 PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 9:9 PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 6:6 PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 5:5 PE1(CONFIG-VRF)#EXIT // configuration de la VRF « BH_HQ » sur le routeur PE1 PE1(CONFIG)#IP VRF BH_HQ PE1(CONFIG-VRF)#RD 10:1 PE1(CONFIG-VRF)#ROUTE-TARGET EXPORT 10:10 PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11 PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 8:8 PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 7:7 PE1(CONFIG-VRF)#EXIT // configuration de la VRF « ONETECH_BRANCH » sur le routeur PE1 PE1(CONFIG)#IP VRF ONETECH_BRANCH PE1(CONFIG-VRF)#RD 9:1 PE1(CONFIG-VRF)#ROUTE-TARGET EXPORT 9:9 PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11 PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 1:1 PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 6:6 PE1(CONFIG-VRF)#ROUTE-TARGET IMPORT 5:5 PE1(CONFIG-VRF)#EXIT // configuration de la VRF « ONETECH_HQ » sur le routeur PE2 PE2(CONFIG)#IP VRF ONETECH_HQ PE2(CONFIG-VRF)#RD 6:1 PE2(CONFIG-VRF)#ROUTE-TARGET EXPORT 6:6 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 9:9 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 1:1 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 5:5 PE2(CONFIG-VRF)#EXIT // configuration de la VRF « MONOPRIX_BRANCH » sur le routeur PE2 PE2(CONFIG)#IP VRF MONOPRIX_BRANCH PE2(CONFIG-VRF)#RD 5:1 PE2(CONFIG-VRF)#ROUTE-TARGET EXPORT 5:5 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 9:9
  • 6. PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 1:1 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 6:6 PE2(CONFIG-VRF)#EXIT // configuration de la VRF « ONETECH_HQ » sur le routeur PE2 PE2(CONFIG)#IP VRF ONETECH_HQ PE2(CONFIG-VRF)#RD 6:1 PE2(CONFIG-VRF)#ROUTE-TARGET EXPORT 6:6 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 9:9 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 1:1 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 5:5 PE2(CONFIG-VRF)#EXIT // configuration de la VRF « BH_BRANCH_SFAX1 » sur le routeur PE2 PE2(CONFIG)#IP VRF BH_BRANCH_SFAX1 PE2(CONFIG-VRF)#RD 8:1 PE2(CONFIG-VRF)#ROUTE-TARGET EXPORT 8:8 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 10:10 PE2(CONFIG-VRF)#EXIT // configuration de la VRF « BH_BRANCH_SFAX2 » sur le routeur PE2 PE2(CONFIG)#IP VRF BH_BRANCH_SFAX2 PE2(CONFIG-VRF)#RD 7:1 PE2(CONFIG-VRF)#ROUTE-TARGET EXPORT 7:7 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 11:11 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 10:10 PE2(CONFIG-VRF)#EXIT // configuration de la VRF « INTERNET » sur le routeur PE2 PE2(CONFIG)#IP VRF INTERNET PE2(CONFIG-VRF)#RD 11:1 PE2(CONFIG-VRF)#ROUTE-TARGET EXPORT 11:11 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 10:10 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 9:9 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 8:8 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 7:7 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 6:6 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 1:1 PE2(CONFIG-VRF)#ROUTE-TARGET IMPORT 5:5
  • 7. PE2(CONFIG-VRF)#EXIT // Affectation d’une adresse ip à chaque vrf PE1(config)#int fa1/0 PE1(config-if)#ip vrf forwarding MONOPRIXHQ PE1(config-if)#ip address 192.168.12.1 255.255.255.0 PE1(config-if)#no shutdown PE1(config)#int fa0/0 PE1(config-if)#ip vrf forwarding BHHQ PE1(config-if)#ip address 192.168.102.1 255.255.255.0 PE1(config-if)#no shutdown PE1(config)#int fa0/1 PE1(config-if)#ip vrf forwarding ONETECHBRANCH PE1(config-if)#ip address 192.168.92.1 255.255.255.0 PE1(config-if)#no shutdown PE2(config)#int fa0/1 PE2(config-if)#ip vrf forwarding BHBRANCHSFAX1 PE2(config-if)#ip address 192.168.84.1 255.255.255.0 PE2(config-if)#no shutdown PE2(config)#int fa1/0 PE2(config-if)#ip vrf forwarding BHBRANCHSFAX2 PE2(config-if)#ip address 192.168.74.1 255.255.255.0 PE2(config-if)#no shutdown PE2(config)#int fa2/0 PE2(config-if)#ip vrf forwarding ONETECHHQ PE2(config-if)#ip address 192.168.64.1 255.255.255.0 PE2(config-if)#no shutdown PE2(config)#int fa3/0 PE2(config-if)#ip vrf forwarding INTERNET PE2(config-if)#ip address 192.168.114.1 255.255.255.0 PE2(config-if)#no shutdown PE2(config)#int fa4/0 PE2(config-if)#ip vrf forwarding MONOPRIXBRANCH
  • 8. PE2(config-if)#ip address 192.168.54.1 255.255.255.0 PE2(config-if)#no shutdown // Verification du ping pour chaque vrf // Activation des différents protocoles dans chaque Costumer Edge (CE) - Protocole EIGRP MONOPRIXHQ(config)#router eigrp 100 MONOPRIXHQ (config-router)#network 192.168.12.0 0.0.0.255 MONOPRIXHQ (config-router)#network 1.1.1.0 0.0.0.255 MONOPRIXHQ (config-router)#no auto-summary MONOPRIXBRANCH(config)#router eigrp 100 MONOPRIXBRANCH (config-router)#network 192.168.54.0 0.0.0.255 MONOPRIXBRANCH (config-router)#network 5.5.5.0 0.0.0.255 MONOPRIXBRANCH (config-router)#no auto-summary - Protocole OSPF BHHQ(config)#router ospf 4 BHHQ (config-router)#network 192.168.102.0 0.0.0.255 area 0 BHHQ (config-router)#network 10.10.10.0 0.0.0.255 area 0 BHBRANCHSFAX1(config)#router ospf 5 BHBRANCHSFAX1 (config-router)#network 192.168.84.0 0.0.0.255 area 0 BHBRANCHSFAX1 (config-router)#network 8.8.8.0 0.0.0.255 area 0 BHBRANCHSFAX2(config)#router ospf 55 BHBRANCHSFAX2 (config-router)#network 192.168.74.0 0.0.0.255 area 0 BHBRANCHSFAX2 (config-router)#network 7.7.7.0 0.0.0.255 area 0 INTERNET(config)#router ospf 3
  • 9. INTERNET (config-router)#network 192.168.114.0 0.0.0.255 area 0 INTERNET (config-router)#network 11.11.11.0 0.0.0.255 area 0 - Protocole RIPV2 ONETECHBRANCH(config)#router rip ONETECHBRANCH(config)#version 2 ONETECHBRANCH (config-router)#network 192.168.92.0 ONETECHBRANCH (config-router)#network 9.9.9.0 ONETECHBH(config)#router rip ONETECHBH(config)#version 2 ONETECHBH (config-router)#network 192.168.64.0 ONETECHBH (config-router)#network 6.6.6.0 // Activation des différentes mises à jour dans chaque vrf (PE) Sur le routeur PE1, pour la vrf MONOPRIXHQ PE1(config)#router eigrp 1 PE1 (config-router)#address-family ipv4 vrf MONOPRIXHQ PE1 (config-router-af)#autonomous-system 100 PE1 (config-router-af)#network 192.168.12.0 Sur le routeur PE1, pour la vrf BHHQ PE1(config)#router ospf 4 vrf BHHQ PE1 (config-router)#network 192.168.102.0 0.0.0.255 area 0 Sur le routeur PE1, pour la vrf ONETECHBRANCH PE1(config)#router rip PE1 (config-router)#address-family ipv4 vrf ONETECHBRANCH PE1 (config-router-af)#version 2 PE1 (config-router-af)#network 192.168.92.0 Sur le routeur PE2, pour la vrf MONOPRIXBRANCH PE2(config)#router eigrp 1 PE2 (config-router)#address-family ipv4 vrf MONOPRIXBRANCH PE2 (config-router-af)#autonomous-system 100 PE2 (config-router-af)#network 192.168.54.0 Sur le routeur PE2, pour la vrf BHBRANCHSFAX1 PE2(config)#router ospf 5 vrf BHBRANCHSFAX1 PE2 (config-router)#network 192.168.84.0 0.0.0.255 area 0 Sur le routeur PE2, pour la vrf BHBRANCHSFAX2
  • 10. PE2(config)#router ospf 55 vrf BHBRANCHSFAX2 PE2 (config-router)#network 192.168.74.0 0.0.0.255 area 0 Sur le routeur PE2, pour la vrf INTERNET PE2(config)#router ospf 3 vrf INTERNET PE2 (config-router)#network 192.168.114.0 0.0.0.255 area 0 Sur le routeur PE2, pour la vrf ONETECHHQ PE2(config)#router rip PE2 (config-router)#address-family ipv4 vrf ONETECHHQ PE2 (config-router-af)#version 2 PE2 (config-router-af)#network 192.168.54.0 // Déclaration des voisins dans le BGP PE1(config)#router bgp 1 PE1 (config-router)#neighbor 4.4.4.4 remote-as 1 PE1 (config-router)#neighbor 4.4.4.4 upddate-source loopback 0 //permet de faire les MAJ dans la loopback 0 PE1 (config-router)#address-family vpnv4 //j’entre dans le MBGP pour echanger les routes vpnv4 PE1 (config-router-af)# neighbor 4.4.4.4 activate PE1 (config-router-af)# neighbor 4.4.4.4 send-community extended //extended : peut importer et exporter à la fois PE2(config)#router bgp 1 PE2 (config-router)#neighbor 2.2.2.2 remote-as 1 PE2 (config-router)#neighbor 2.2.2.2 upddate-source loopback 0 //permet de faire les MAJ dans la loopback 0 PE2 (config-router)#address-family vpnv4 //j’entre dans le MBGP pour echanger les routes vpnv4 PE2 (config-router-af)# neighbor 2.2.2.2 activate PE2 (config-router-af)# neighbor 2.2.2.2 send-community extended//extended : peut importer et exporter à la fois
  • 11. // Redistribution du EIGRP dans le BGP (MBGP) PE2(config)#router bgp 1 PE2 (config-router)#address-family ipv4 vrf MONOPRIXBRANCH PE2 (config-router-af)#redistribute eigrp 100 Dans le meme routeur on fait l’inverse PE2(config)#router eigrp 1 PE2 (config-router)#address-family ipv4 vrf MONOPRIXBRANCH PE2 (config-router-af)#redistribute bgp 1 metric 64 1000 255 1 1500 PE1(config)#router bgp 1 PE1 (config-router)#address-family ipv4 vrf MONOPRIXBH PE1 (config-router-af)#redistribute eigrp 100 Dans le meme routeur on fait l’inverse PE1(config)#router eigrp 1 PE1 (config-router)#address-family ipv4 vrf MONOPRIXBH PE1 (config-router-af)#redistribute bgp 1 metric 64 1000 255 1 1500 // Redistribution du protocole OSPF dans le BGP (MBGP) PE1(config)#router bgp 1 PE1 (config-router)#address-family ipv4 vrf BHBH PE1 (config-router-af)#redistribute ospf 4 Dans le meme routeur je redistribue le BGP dans l’OSPF 4 PE1(config)#router ospf 4 vrf BHHQ PE1 (config-router-af)#redistribute bgp 1 subnets Pour le routeur PE2 PE2(config)#router bgp 1 PE2 (config-router)#address-family ipv4 vrf BHBRANCHSFAX1 PE2 (config-router-af)#redistribute ospf 5 Dans le meme routeur je redistribue le BGP dans l’OSPF 5 PE2(config)#router ospf 5 vrf BHBRANCHSFAX1 PE2 (config-router-af)#redistribute bgp 1 subnets PE2(config)#router bgp 1 PE2 (config-router)#address-family ipv4 vrf BHBRANCHSFAX2 PE2 (config-router-af)#redistribute ospf 55 Dans le meme routeur je redistribue le BGP dans l’OSPF 55 PE2(config)#router ospf 55 vrf BHBRANCHSFAX2 PE2 (config-router-af)#redistribute bgp 1 subnets PE2(config)#router bgp 1 PE2 (config-router)#address-family ipv4 vrf INTERNET PE2 (config-router-af)#redistribute ospf 3 vrf INTERNET match internal external 1 external 2 PE2 (config-router-af)#default-information originate Dans le meme routeur je redistribue le BGP dans l’OSPF 3 PE2(config)#router ospf 3 vrf INTERNET
  • 12. PE2 (config-router-af)#redistribute bgp 1 subnets // Redistribution du protocole RIP dans le BGP (MBGP) PE2(config)#router bgp 1 PE2 (config-router)#address-family ipv4 vrf ONETECHHQ PE2 (config-router-af)#redistribute rip Dans le meme routeur je redistribue le bgp dans le rip PE2(config)#router rip PE2 (config-router)#address-family ipv4 vrf ONETECHHQ PE2 (config-router-af)#redistribute bgp 1 metric transparent Pour le routeur PE1 PE1(config)#router bgp 1 PE1 (config-router)#address-family ipv4 vrf ONETECHBRANCH PE1 (config-router-af)#redistribute rip Dans le meme routeur je redistribue le bgp dans le rip PE1(config)#router rip PE1 (config-router)#address-family ipv4 vrf ONETECHBRANCH PE1 (config-router-af)#redistribute bgp 1 metric transparent // Vérification du fonctionnement du MP-BGP Pour connaitre toutes les routes apprises par le MP-BGP sur un routeur donné, la commande « show ip bgp vpnv4 all » peut être utilisée :
  • 13. Pour le routeur internet je redirige tout d’abord le trafic vers l’intérieur à travers le NAT sur l’interface connecté au Backbone MPLS INTERNET(config)#int Fa 0/0 INTERNET (config-router)#ip nat inside J’entre dans l’interface qui est connectée au cloud et je redirige le trafic vers l’extérieur INTERNET(config)#int Fa 0/1 INTERNET (config-router)#ip nat outside INTERNET (config-router)#ip address 192.168.137.2 255.255.255.0 INTERNET (config-router)#no shutdown Sur le routeur INTERNET, je me connecte physiquement au réseau INTERNET(config)#access-list 1 permit any INTERNET (config)#ip nat pool cloud 192.168.137.100 192.168.137.200 netmask 255.255.255.0 INTERNET (config)#ip nat source list 1pool overload