Lógica de programação - Matrizes - VisualG

8.079 visualizações

Publicada em

Slides que explicam o que são Matrizes em Lógica de Programação, e um algoritmo de exemplo para ser executado no VisualG.

Assista também ao vídeo sobre o assunto em nosso canal do Youtube:
https://www.youtube.com/watch?v=Ww1aP4j1M6M

Publicada em: Tecnologia
1 comentário
2 gostaram
Estatísticas
Notas
Sem downloads
Visualizações
Visualizações totais
8.079
No SlideShare
0
A partir de incorporações
0
Número de incorporações
253
Ações
Compartilhamentos
0
Downloads
77
Comentários
1
Gostaram
2
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Lógica de programação - Matrizes - VisualG

  1. 1. Matrizes Arrays Bidimensionais Bóson Treinamentos Fábio dos Reis
  2. 2. Matrizes • Uma matriz é um array bidimensional, composta por linhas e colunas, como uma tabela. • Considere uma matriz como um conjunto de vetores interligados. Fábio dos Reis Bóson Treinamentos
  3. 3. Matrizes Abaixo temos um exemplo de uma matriz com 4 linhas e 4 colunas: 0 1 2 3 0 1 2 3 Fábio dos Reis Bóson Treinamentos
  4. 4. Matrizes 22 32 15 96 Abaixo a matriz com alguns dados inseridos: 0 1 2 3 0 1 2 3 Valor 22: posição 0,0 Valor 32: posição 1,2 Valor 15: posição 2,1 Valor 96: posição 3,2 Fábio dos Reis Bóson Treinamentos
  5. 5. Declaração de matrizes Declaramos uma matriz da seguinte forma: nome_matriz: vetor [x..y, w..z] de tipo Onde x..y são os limites de linhas e w..z são os limites de colunas. Exemplo: matriz com 5 linhas e 3 colunas: matriz: vetor [0..4, 0..2] de inteiro Fábio dos Reis Bóson Treinamentos
  6. 6. Atribuindo e acessando valores Para atribuir um valor a uma matriz, indique a sua posição – linha e coluna: matriz [0,0] <- 60 leia (matriz[2,3]) Para ler um valor na matriz, idem: ESCREVA (matriz[0,0]) Fábio dos Reis Bóson Treinamentos
  7. 7. Exemplo – criar e inserir valores var // declaração de uma matriz com 4 linhas e 3 colunas matriz: vetor [0..3,0..2] de inteiro linha, coluna: inteiro inicio // Preencher a matriz com dados digitados para linha de 0 ate 3 faca para coluna de 0 ate 2 faca escreval ("Digite um número para inserir na matriz") leia (matriz[linha,coluna]) fimpara fimpara // Escrever um elemento da matriz na tela: escreval (matriz[0,1]) Fábio dos Reis Bóson Treinamentos
  8. 8. Visualizar a matriz criada // Escrever a matriz toda na tela: para linha de 0 ate 3 faca para coluna de 0 ate 2 faca se coluna < 2 entao escreva (matriz[linha,coluna]) senao escreval (matriz[linha,coluna]) fimse fimpara fimpara Fábio dos Reis Bóson Treinamentos

×