Excel - Usando a função PROCV

1.410 visualizações

Publicada em

Bem vindos! É hora de aprender como trabalhar com a função PROCV no Excel, mas de um jeito bem diferente.

Arquivos utilizados no vídeo:

Vídeo:
► http://youtu.be/qFcPSLh_zG0

Arquivo do Excel
► http://www.tomasvasquez.com.br/forum/download/file.php?id=2039

SE (Função SE)
► http://office.microsoft.com/pt-br/excel-help/se-funcao-se-HA102752994.aspx

NÃO.DISP (Função NÃO.DISP)
► http://office.microsoft.com/pt-br/excel-help/nao-disp-funcao-nao-disp-HA102752925.aspx

Acesse também

BLOG ► http://www.tomasvasquez.com.br/blog/
FÓRUM ► http://www.tomasvasquez.com.br/forum/
CURSO ONLINE DE C# ► http://www.tomasvasquez.com.br/cursocsharp

Aqui também!

FACEBOOK ► https://www.facebook.com/tomasvaquezsites
TWITTER ► https://twitter.com/tomamais
GOOGLE+ ► https://plus.google.com/+TomasvasquezBr/

Roteiro, apresentação, edição, etc, etc ► eu mesmo :)

Publicada em: Educação
0 comentários
3 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
1.410
No SlideShare
0
A partir de incorporações
0
Número de incorporações
3
Ações
Compartilhamentos
0
Downloads
73
Comentários
0
Gostaram
3
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Excel - Usando a função PROCV

  1. 1. + Usando a função PROCV
  2. 2. + O que é preciso saber para usar (bem) a função PROCV  Requisitos  Ao menos conhecer o Excel  Usar fórmulas básicas  Conceitos  O que são tabelas  Linhas - Dados  Colunas – MetaDados  Conceito de Identidade  Conceito de Registro
  3. 3. + Tabelas Nome Depto Idade Henry 501 28 Stan 201 18 Larry 101 22 Mary 301 29  “Conjunto de dados dispostos, na forma de linhas e colunas, dentro de células"  Fonte: http://pt.wiktionary.org/wiki/tabela colunas linhas
  4. 4. + Linhas e Colunas Dados e MetaDados Nome Depto Idade Henry 501 28 Stan 201 18 Larry 101 22 Mary 301 29  A Linhas contém os Dados  As Colunas dão significado aos Dados, ou MetaDados colunas linhas
  5. 5. + Conceito de Identidade  Chave primária (cada valor é único)  Registro (todas as informações que compõe um entidade, ou seja, todos os dados da linha) Nome Depto Idade Henry 501 28 Stan 201 18 Larry 101 22 Mary 301 29 Nome Depto Idade Henry 501 28 Stan 201 18 Larry 101 22 Henry 301 29 ✔ ✖
  6. 6. + Conceito de Identidade  Chave primária (cada valor é único)  Registro (todas as informações que compõe uma entidade, ou seja, todos os dados da linha) Nome Depto Idade Henry 501 28 Stan 201 18 Larry 101 22 Mary 301 29 Nome Depto Idade Henry 501 28 Stan 201 18 Larry 101 22 Henry 301 29 ✔ ✖
  7. 7. + A função PROCV (VLOOKUP)  Procura Vertical (linhas)  Procura o valor informado em uma lista para poder retornar o mesmo dado e outros relacionados ao mesmo  Link oficial: http://office.microsoft.com/pt-br/excel-help/procv- HP005209335.aspx
  8. 8. + A função PROCV  Sintaxe  PROCV(valor_procurado;matriz_tabela;núm_índice_coluna ;procurar_intervalo)  Valor_procurado - Quem estou procurando na tabela  Matriz_tabela - A tabela onde estão e onde vou procurar os dados  núm_índice_coluna - Qual dado do registro estou quero ver (coluna)  Procurar_intervalo – (Não aplicável para textos)
  9. 9. + PROCV funcionando Valor Procurado  =PROCV(“DI-328” ; A2:D6 ; 2 ; FALSO) Identificação Item Custo Marcação ST-340 Carrinho de bebê US$ 145,67 30% BI-567 Babador US$ 3,56 40% DI-328 Fraldas US$ 21,45 35% WI-989 Lenços umedecidos US$ 5,12 40% AS-469 Aspirador U$ 2,56 45%  Valor Procurado: “DI-328”  Sempre na primeira coluna
  10. 10. + A B C D 1 2 3 4 5 6 PROCV funcionando Matriz Tabela  =PROCV(“DI-328” ; A2:D6 ; 2 ; FALSO) Identificação Item Custo Marcação ST-340 Carrinho de bebê US$ 145,67 30% BI-567 Babador US$ 3,56 40% DI-328 Fraldas US$ 21,45 35% WI-989 Lenços umedecidos US$ 5,12 40% AS-469 Aspirador U$ 2,56 45%  Matriz Tabela: A2:D6
  11. 11. + PROCV funcionando Passo a passo  =PROCV(“DI-328” ; A2:D6 ; 2 ; FALSO) Identificação Item Custo Marcação ST-340 Carrinho de bebê US$ 145,67 30% BI-567 Babador US$ 3,56 40% DI-328 Fraldas US$ 21,45 35% WI-989 Lenços umedecidos US$ 5,12 40% AS-469 Aspirador U$ 2,56 45%  Passo 1 – Procurar o valor (na primeira coluna)  Passo 2 – Ao encontrar, identifica a linha do registro
  12. 12. + 1 2 3 4 PROCV funcionando Passo a passo  =PROCV(“DI-328” ; A2:D6 ; 2 ; FALSO) Identificação Item Custo Marcação ST-340 Carrinho de bebê US$ 145,67 30% BI-567 Babador US$ 3,56 40% DI-328 Fraldas US$ 21,45 35% WI-989 Lenços umedecidos US$ 5,12 40% AS-469 Aspirador U$ 2,56 45%  Passo 3 – Vai até a coluna informada  Passo 4 – Retorna o valor encontrado
  13. 13. + PROCV funcionando Resultado  =PROCV(“DI-328” ; A2:D6 ; 2 ; FALSO) Identificação Item Custo Marcação ST-340 Carrinho de bebê US$ 145,67 30% BI-567 Babador US$ 3,56 40% DI-328 Fraldas US$ 21,45 35% WI-989 Lenços umedecidos US$ 5,12 40% AS-469 Aspirador U$ 2,56 45% “Fraldas”
  14. 14. + Nem tudo é perfeito  É preciso tratar valores não encontrados (#N/D)  Ex: =SE(É.NÃO.DISP(PROCV(“TV-123”,A2:D6,2,FALSO)) = VERDADEIRO, "Funcionário não encontrado", PROCV(“TV- 123”,A2:D6,2,FALSO))  Só a primeira coluna da esquerda pode ser a identificação  Não contorna valores repetidos
  15. 15. + ENTÃO VERTICAL PROCV HORIZONTAL PROCH! ENTÃO VERTICAL PROCV HORIZONTAL PROCV e PROCH ?!?!?
  16. 16. + Finito!  E é isso. Agora é com vocês! 

×