Algoritmos e programação - Aula 6

4.660 visualizações

Publicada em

Algoritmos e programação - Aula 6

Publicada em: Tecnologia
0 comentários
4 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
4.660
No SlideShare
0
A partir de incorporações
0
Número de incorporações
22
Ações
Compartilhamentos
0
Downloads
68
Comentários
0
Gostaram
4
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e programação - Aula 6

  1. 1. Profº Thyago M iP fº Th MaiaAlgoritmos e Programação Aula 6
  2. 2. Sumário S áiEstruturas Condicionais
  3. 3. Comando de Seleção Múltipla• Em algumas situações é necessário analisar mais que duas condições;• O comando se nos permite implementar tais situações, situações porém de forma limitada e em e, alguns casos, ineficiente: • Imagine implementar 100 estruturas se para 100 condições diferentes! • Tal comando obriga o programador a escrever g ; várias linhas de código;
  4. 4. Comando de Seleção Múltipla• Para várias condições, podemos utilizar o comando de seleção múltipla escolha;• Sintaxe: escolha (variavel) Caso valor_1 // Instruções que serão executadas caso // a condição seja verdadeira Caso valor 2 valor_2 // Instruções que serão executadas caso // a condição seja falsa Outrocaso // Instruções que serão executadas se // nenhuma condição anterior seja atendida fimescolha
  5. 5. Comando de Seleção Múltipla• As palavras reservadas escolha e fimescolha delimitam a região da estrutura condicional;• Tal estrutura seleciona uma variável que será comparada com os valores especificados ao lado da palavra reservada caso; p ;• O caso tem funcionamento similar ao se;• O outrocaso tem funcionamento similar ao senao, visto anteriormente; , ;
  6. 6. ExemploAlgoritmo “exemplo caso” exemplo_casoVar sexo: literalInicio escreval( Digite escreval(“Digite seu sexo (M ou F): ”) ) leia(sexo) escolha(sexo) caso “M” escreval( O escreval(“O usuário é homem”) homem ) caso “F” escreval(“O usuário é mulher”) outrocaso escreval(“Erro de caractere!”) fimescolhafimalgoritmo
  7. 7. Exemplo 2Algoritmo “exemplo caso 2” exemplo_caso_2Var time: literalInicio escreval( Digite escreval(“Digite seu time: ”) ) leia(time) escolha(time) caso “sport” escreval( Parabéns!!! ) escreval(“Parabéns!!!”) outrocaso escreval(“Meus pêsames!”) fimescolhafimalgoritmo
  8. 8. Exercícios• Faça um algoritmo que lê um número de 1 a 7 e informa o dia da semana correspondente sendo correspondente, domingo o número 1. Caso o número esteja fora da faixa, o algoritmo deverá exibir uma faixa mensagem de erro;
  9. 9. Exercícios• Faça um algoritmo que receba dois números, um caractere que representa uma operação matemática (+, -, *, /) e efetue o cálculo matemático baseado na escolha do usuário O usuário. resultado deverá ser exibido em seguida;
  10. 10. Sumário• Estruturas de Repetição • ENQUANTO...FACA
  11. 11. Estruturas de Repetição• Até o momento, quando existia a necessidade de repetir uma ou mais instruções, tínhamos que digitá- las novamente;• Tal solução é ineficiente, considerando que quanto maior o número de repetições maior será o número de linhas de código; • Solução: utilizar estruturas de repetição;
  12. 12. Estruturas de Repetição• São estruturas sintáticas que permitem a repetição de um trecho de algoritmo em uma determinada quantidade de iterações ou de acordo com um critério (condição);• Em Portugol, temos 3 estruturas de repetição: enquanto...faca, repita...até, para...faca;
  13. 13. Enquanto...faca• Nesta estrutura, uma condição lógica é avaliada. Caso a condição seja atendida, sua lista de instruções será executada;• A execução da lista é repetida até que a avaliação da condição retorne FALSO;
  14. 14. Enquanto...faca• Utilizamos as palavras reservadas ENQUANTO, FACA e FIMENQUANTO para formar o laço de repetição;• Forma geral: enquanto (condição) faca // lista de instruções fimenquanto
  15. 15. Enquanto...faca• Exemplo: Algoritmo que lê vários números positivos e exibe a raiz quadrada de cada um; Algoritmo "exemplo_enquanto" Var numero: real Inicio Leia(numero) Enquanto (numero>=0) faca Escreval(numero^0.5) Leia(numero) Fimenquanto Fimalgoritmo
  16. 16. Enquanto...faca• Exemplo: Algoritmo que escreve números entre 1 e 10; Algoritmo "exemplo_enquanto" Var numero: inteiro Inicio Numero <- 1 Enquanto (numero<=10) faca Escreval(numero) Numero <- numero + 1 Fimenquanto Fimalgoritmo
  17. 17. Exercícios• Faça um algoritmo que lê repetidamente números inteiros positivos. O algoritmo deverá encerrar a leitura dos valores quando um número negativo for digitado;
  18. 18. Exercícios• Faça um algoritmo que lê o sexo de 10 pessoas (M ou F). O mesmo deverá contar e exibir a quantidade de homens e mulheres;
  19. 19. Exercícios• Faça um algoritmo que lê repetidamente a altura de várias pessoas, até que uma altura negativa seja digitada. O algoritmo deverá calcular e exibir a média das alturas lidas;
  20. 20. Exercícios• Faça um algoritmo que receba os placares de 10 partidas entre Sport e Flamengo. Baseado nos placares lidos, o algoritmo deverá apresentar o nome do time que venceu mais confrontos.

×