Profº Thyago Maia Algoritmos e Programação Aula 5
Sumário <ul><li>Estruturas Condicionais </li></ul>
Estruturas Condicionais <ul><li>Também podemos implementar estruturas condicionais com mais de uma condição (expressão); <...
Exemplo Algoritmo “exemplo_genero” Var sexo: literal   idade: inteiro Inicio escreva(“Digite seu sexo (M ou F): ”) leia(se...
Exemplo 2 Algoritmo “exemplo_genero” Var estado: literal Inicio escreva(“Digite seu estado (PE, PB, RJ ou SP): ”) leia(est...
Exercícios <ul><li>Faça um algoritmo que lê um número inteiro e verifica se o mesmo é positivo ou negativo; </li></ul>
Exercícios <ul><li>Faça um algoritmo que receba três notas de um determinado aluno, calcula sua média e informa se o mesmo...
Exercícios <ul><li>Faça um algoritmo que verifica quanto cada pessoa deverá pagar para entrar em um cinema. O algoritmo de...
Exercícios <ul><li>Faça um algoritmo para controle de entrada em uma boate. Tal algoritmo deverá avisar se uma pessoa pode...
Comando de Seleção Múltipla <ul><li>Em algumas situações é necessário analisar mais que duas condições; </li></ul><ul><li>...
Comando de Seleção Múltipla <ul><li>Para várias condições, podemos utilizar o comando de seleção múltipla  escolha ; </li>...
Comando de Seleção Múltipla <ul><li>As palavras reservadas  escolha  e  fimescolha  delimitam a região da estrutura condic...
Exemplo Algoritmo “exemplo_caso” Var sexo: literal Inicio escreval(“Digite seu sexo (M ou F): ”) leia(sexo) escolha(sexo) ...
Exemplo 2 Algoritmo “exemplo_caso_2” Var time: literal Inicio escreval(“Digite seu time: ”) leia(time) escolha(time) caso ...
Exercícios <ul><li>Faça um algoritmo que lê um número de 1 a 7 e informa o dia da semana correspondente, sendo domingo o n...
Exercícios <ul><li>Faça um algoritmo que receba dois números, um caractere que representa uma operação matemática (+, -, *...
Próximos SlideShares
Carregando em…5
×

Algoritmos e Programação - Aula 5

3.112 visualizações

Publicada em

Algoritmos e Programação - Aula 5

Publicada em: Tecnologia
0 comentários
1 gostou
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
3.112
No SlideShare
0
A partir de incorporações
0
Número de incorporações
45
Ações
Compartilhamentos
0
Downloads
58
Comentários
0
Gostaram
1
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - Aula 5

  1. 1. Profº Thyago Maia Algoritmos e Programação Aula 5
  2. 2. Sumário <ul><li>Estruturas Condicionais </li></ul>
  3. 3. Estruturas Condicionais <ul><li>Também podemos implementar estruturas condicionais com mais de uma condição (expressão); </li></ul><ul><li>Subexpressões podem formar uma única expressão a partir do uso dos operadores E ou OU ; </li></ul><ul><li>Para sabermos se determinada expressão será verdadeira ou falsa, seguimos a mesma lógica vista nas aulas de linearização e modularização; </li></ul>
  4. 4. Exemplo Algoritmo “exemplo_genero” Var sexo: literal idade: inteiro Inicio escreva(“Digite seu sexo (M ou F): ”) leia(sexo) escreva(“Digite sua idade: ”) leia(idade) se((sexo=“M”) e (idade=18))entao escreva(“Você já se alistou nas forças armadas?”) fimse fimalgoritmo
  5. 5. Exemplo 2 Algoritmo “exemplo_genero” Var estado: literal Inicio escreva(“Digite seu estado (PE, PB, RJ ou SP): ”) leia(estado) se((estado=“PE”) ou (estado=“PB”))entao escreva(“Você é nordestino”) fimse se((estado=“RJ”) ou (estado=“SJ”))entao escreva(“Você é do sudeste”) fimse fimalgoritmo
  6. 6. Exercícios <ul><li>Faça um algoritmo que lê um número inteiro e verifica se o mesmo é positivo ou negativo; </li></ul>
  7. 7. Exercícios <ul><li>Faça um algoritmo que receba três notas de um determinado aluno, calcula sua média e informa se o mesmo está aprovado ou reprovado; </li></ul><ul><ul><li>A média final deve ser superior a 6 para que o aluno seja aprovado; </li></ul></ul>
  8. 8. Exercícios <ul><li>Faça um algoritmo que verifica quanto cada pessoa deverá pagar para entrar em um cinema. O algoritmo deverá solicitar o sexo e a idade do indivíduo. As condições de pagamento são as seguintes: </li></ul><ul><ul><li>O ingresso custa R$ 10,00 para pessoas maiores de 17 anos; </li></ul></ul><ul><ul><li>Mulheres menores de 18 anos pagam meia entrada; </li></ul></ul><ul><ul><li>Homens menores de 18 anos pagam R$ 7,00; </li></ul></ul>
  9. 9. Exercícios <ul><li>Faça um algoritmo para controle de entrada em uma boate. Tal algoritmo deverá avisar se uma pessoa pode entrar ou não, e quanto deverá pagar para entrar. </li></ul><ul><ul><li>Homens e mulheres abaixo de 18 anos não podem entrar; </li></ul></ul><ul><ul><li>Mulheres pagam R$ 10,00; </li></ul></ul><ul><ul><li>Homens pagam R$ 20,00; </li></ul></ul>
  10. 10. Comando de Seleção Múltipla <ul><li>Em algumas situações é necessário analisar mais que duas condições; </li></ul><ul><li>O comando se nos permite implementar tais situações, porém de forma limitada e, em alguns casos, ineficiente: </li></ul><ul><ul><li>Imagine implementar 100 estruturas se para 100 condições diferentes! </li></ul></ul><ul><ul><li>Tal comando obriga o programador a escrever várias linhas de código; </li></ul></ul>
  11. 11. Comando de Seleção Múltipla <ul><li>Para várias condições, podemos utilizar o comando de seleção múltipla escolha ; </li></ul><ul><li>Sintaxe: </li></ul>escolha (variavel) Caso valor_1 // Instruções que serão executadas caso // a condição seja verdadeira Caso valor_2 // Instruções que serão executadas caso // a condição seja falsa Outrocaso // Instruções que serão executadas se // nenhuma condição anterior seja atendida fimescolha
  12. 12. Comando de Seleção Múltipla <ul><li>As palavras reservadas escolha e fimescolha delimitam a região da estrutura condicional; </li></ul><ul><li>Tal estrutura seleciona uma variável que será comparada com os valores especificados ao lado da palavra reservada caso ; </li></ul><ul><li>O caso tem funcionamento similar ao se ; </li></ul><ul><li>O outrocaso tem funcionamento similar ao senao , visto anteriormente; </li></ul>
  13. 13. Exemplo Algoritmo “exemplo_caso” Var sexo: literal Inicio escreval(“Digite seu sexo (M ou F): ”) leia(sexo) escolha(sexo) caso “M” escreval(“O usuário é homem”) caso “F” escreval(“O usuário é mulher”) outrocaso escreval(“Erro de caractere!”) fimescolha fimalgoritmo
  14. 14. Exemplo 2 Algoritmo “exemplo_caso_2” Var time: literal Inicio escreval(“Digite seu time: ”) leia(time) escolha(time) caso “sport” escreval(“Parabéns!!!”) outrocaso escreval(“Meus pêsames!”) fimescolha fimalgoritmo
  15. 15. Exercícios <ul><li>Faça um algoritmo que lê um número de 1 a 7 e informa o dia da semana correspondente, sendo domingo o número 1. Caso o número esteja fora da faixa, o algoritmo deverá exibir uma mensagem de erro; </li></ul>
  16. 16. Exercícios <ul><li>Faça um algoritmo que receba dois números, um caractere que representa uma operação matemática (+, -, *, /) e efetue o cálculo matemático baseado na escolha do usuário. O resultado deverá ser exibido em seguida; </li></ul>

×