Algoritmos e programação - Aula 5

8.470 visualizações

Publicada em

Slides referentes a 5ª aula da disciplina de Algoritmos e Programação, realizada no dia 18/02/2011

Publicada em: Tecnologia
0 comentários
5 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
8.470
No SlideShare
0
A partir de incorporações
0
Número de incorporações
39
Ações
Compartilhamentos
0
Downloads
270
Comentários
0
Gostaram
5
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e programação - Aula 5

  1. 1. Algoritmos e Programação Thyago Maia Tavares de Farias Aula 5
  2. 2. Sumário <ul><li>Estrutura condicional; </li></ul>
  3. 3. Estrutura condicional <ul><li>Na vida real tomamos decisões a todo momento baseadas em escolhas; </li></ul><ul><li>Em algoritmos, chamamos tais decisões de condições ; </li></ul><ul><li>Associada a uma condição, existirá uma possível alternativa; </li></ul><ul><li>Ex.: Se o Sport não vencer o Santa Cruz na próxima partida, o técnico será demitido. </li></ul>
  4. 4. Estrutura condicional <ul><li>Analisando o exemplo anterior: </li></ul><ul><ul><li>A condição do exemplo: “o Sport não vencer o Santa Cruz”; </li></ul></ul><ul><ul><li>Possíveis respostas esta condição: Sim (Verdadeiro) ou Não (Falso). Logo, condições geram respostas lógicas ! </li></ul></ul><ul><ul><li>Se a condição for verdadeira, a ação “demitir o técnico” será executada; </li></ul></ul><ul><ul><li>Caso contrário, o técnico continuará no Sport; </li></ul></ul>
  5. 5. Estrutura condicional <ul><li>Para criarmos estruturas condicionais simples em Português Estruturado, utilizamos as palavras reservadas se , entao e fimse </li></ul><ul><li>se condicao entao </li></ul><ul><li>// lista de comandos caso a condição seja // verdadeira </li></ul><ul><li>fimse </li></ul>
  6. 6. Estrutura condicional <ul><li>Exemplo: </li></ul><ul><ul><li>Algoritmo “exemplo_se” </li></ul></ul><ul><ul><li>Var numero: inteiro </li></ul></ul><ul><ul><li>inicio </li></ul></ul><ul><ul><li>numero <- 4 </li></ul></ul><ul><ul><li>Se (numero > 3) entao </li></ul></ul><ul><ul><li>escreva(“A variável é maior que 3”) </li></ul></ul><ul><ul><li>Fimse </li></ul></ul><ul><ul><li>fimalgoritmo </li></ul></ul>
  7. 7. Estrutura condicional <ul><li>Exemplo 2: </li></ul><ul><ul><li>Algoritmo “exemplo_senha” </li></ul></ul><ul><ul><li>Var senha: literal </li></ul></ul><ul><ul><li>inicio </li></ul></ul><ul><ul><li>escreval(“Digite a senha”) </li></ul></ul><ul><ul><li>leia(senha) </li></ul></ul><ul><ul><li>Se (senha = “soueu123”) entao </li></ul></ul><ul><ul><li>escreval(“Acesso liberado!”) </li></ul></ul><ul><ul><li>Fimse </li></ul></ul><ul><ul><li>fimalgoritmo </li></ul></ul>
  8. 8. Estrutura condicional <ul><li>Para criarmos estruturas condicionais com duas opções de escolha , utilizamos as palavras reservadas se , entao, senao e fimse </li></ul><ul><li>se condicao entao </li></ul><ul><li>// lista de comandos caso a condição seja //VERDADEIRA </li></ul><ul><li>senao </li></ul><ul><li>// lista de comandos caso a condição seja FALSA </li></ul><ul><li>fimse </li></ul>
  9. 9. Estrutura condicional <ul><li>Exemplo 3: </li></ul><ul><ul><li>Algoritmo “exemplo_se_senao” </li></ul></ul><ul><ul><li>Var numero: inteiro </li></ul></ul><ul><ul><li>inicio </li></ul></ul><ul><ul><li>numero <- 4 </li></ul></ul><ul><ul><li>Se (numero > 3) entao </li></ul></ul><ul><ul><li>escreva(“A variável é maior que 3”) </li></ul></ul><ul><ul><li>senao </li></ul></ul><ul><ul><li>escreva(“A variável é menor ou igual a 3”) </li></ul></ul><ul><ul><li>Fimse </li></ul></ul><ul><ul><li>fimalgoritmo </li></ul></ul>
  10. 10. Estrutura condicional <ul><li>Exemplo 4: </li></ul><ul><ul><li>Algoritmo “exemplo_senha_2” </li></ul></ul><ul><ul><li>Var senha: literal </li></ul></ul><ul><ul><li>inicio </li></ul></ul><ul><ul><li>escreval(“Digite a senha”) </li></ul></ul><ul><ul><li>leia(senha) </li></ul></ul><ul><ul><li>Se (senha = “soueu123”) entao </li></ul></ul><ul><ul><li>escreval(“Acesso liberado!”) </li></ul></ul><ul><ul><li>senao </li></ul></ul><ul><ul><li>escreval(“Senha incorreta. Acesso proibido!”) </li></ul></ul><ul><ul><li>Fimse </li></ul></ul><ul><ul><li>fimalgoritmo </li></ul></ul>
  11. 11. Exemplo <ul><li>Algoritmo que verifica se um número inteiro digitado pelo usuário é PAR ou ÍMPAR: </li></ul><ul><ul><li>Algoritmo “par_impar” </li></ul></ul><ul><ul><li>Var numero: inteiro </li></ul></ul><ul><ul><li>Inicio </li></ul></ul><ul><ul><li>escreval(“digite um número”) </li></ul></ul><ul><ul><li>leia(numero) </li></ul></ul><ul><ul><li>se (numero % 2 = 0) entao </li></ul></ul><ul><ul><li>escreval(“O número é PAR”) </li></ul></ul><ul><ul><li>senao </li></ul></ul><ul><ul><li>escreval(“O número é IMPAR”) </li></ul></ul><ul><ul><li>fimse </li></ul></ul><ul><ul><li>fimalgoritmo </li></ul></ul>
  12. 12. Exercício <ul><li>Faça um algoritmo que verifica se um número inteiro digitado pelo usuário é positivo ou negativo; </li></ul><ul><li>Faça um algoritmo que recebe três notas de um determinado aluno (digitados por alguém), calcula a média e informe se o mesmo está aprovado ou reprovado (a média final deve ser superior a 6 para que o aluno seja aprovado); </li></ul>

×