Profº Thyago M iP fº Th      MaiaAlgoritmos e Programação         Aula 4
Sumário                S áiEstruturas Condicionais
Estruturas Condicionais• Na vida real tomamos decisões a todo  momento,  momento baseadas em escolhas;• Em algoritmos, cha...
Estruturas Condicionais• Analisando o exemplo anterior:  • A condição d exemplo: “ S t não vencer o         di ã do      l...
Estruturas Condicionais• Para criarmos estruturas condicionais simples  em Portugol, utilizamos as palavras reservadas    ...
Estruturas Condicionais• Exemplo:  Algoritmo “exemplo_se”   l   i          l  Var numero: inteiro  Inicio      escreva(“Di...
Estruturas Condicionais• Exemplo:  Algoritmo “exemplo_senha”   l   i          l     h  Var senha: literal  Inicio      esc...
Estruturas Condicionais• Para criarmos estruturas condicionais com duas  opções de escolha em Portugol utilizamos as      ...
Estruturas Condicionais• Exemplo:  Algoritmo “exemplo_se_senao”   l   i          l  Var numero: inteiro  Inicio       escr...
Estruturas Condicionais• Exemplo:  Algoritmo “exemplo_senha_2”   l   i          l     h 2  Var senha: literal  Inicio     ...
Estruturas Condicionais• Exemplo: Faça um algoritmo que lê um número  inteiro e verifica se o mesmo é par ou ímpar;
Estruturas CondicionaisAlgoritmo “Al   it   “par_impar”               i    ”Var numero: inteiroInicio    escreva(“Digite u...
Próximos SlideShares
Carregando em…5
×

Algoritmos e Programação - Aula 4

2.975 visualizações

Publicada em

Algoritmos e Programação - Aula 4

Publicada em: Tecnologia
0 comentários
1 gostou
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
2.975
No SlideShare
0
A partir de incorporações
0
Número de incorporações
66
Ações
Compartilhamentos
0
Downloads
59
Comentários
0
Gostaram
1
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - Aula 4

  1. 1. Profº Thyago M iP fº Th MaiaAlgoritmos e Programação Aula 4
  2. 2. Sumário S áiEstruturas Condicionais
  3. 3. Estruturas Condicionais• Na vida real tomamos decisões a todo momento, momento baseadas em escolhas;• Em algoritmos, chamamos tais decisões de condições;• Associada a uma condição, existirá uma possível alternativa; • Exemplo: Se o Sport não vencer o Santa Cruz na próxima partida, seu técnico será demitido;
  4. 4. Estruturas Condicionais• Analisando o exemplo anterior: • A condição d exemplo: “ S t não vencer o di ã do l “o Sport ã Santa Cruz”; • Possíveis decisões baseadas na condição: Sim (Verdadeiro) ou não (Falso); • Logo, condições geram respostas lógicas! • Se a condição for verdadeira, a ação “demitir o demitir técnico” será executada; • Caso contrário (senão) o técnico continuará no (senão), Sport;
  5. 5. Estruturas Condicionais• Para criarmos estruturas condicionais simples em Portugol, utilizamos as palavras reservadas Portugol se, entao e fimse;• Sintaxe: Se (condicao) entao // Instruções fimse
  6. 6. Estruturas Condicionais• Exemplo: Algoritmo “exemplo_se” l i l Var numero: inteiro Inicio escreva(“Digite um número: ”) leia(numero) se(numero>3)entao escreva(“O número é maior que 3!”) fimse fimalgoritmo
  7. 7. Estruturas Condicionais• Exemplo: Algoritmo “exemplo_senha” l i l h Var senha: literal Inicio escreva(“Digite a senha: ”) leia(senha) se(senha=“soueu123”)entao escreva(“Acesso liberado!”) fimse fimalgoritmo
  8. 8. Estruturas Condicionais• Para criarmos estruturas condicionais com duas opções de escolha em Portugol utilizamos as Portugol, palavras reservadas se, entao, senao e fimse;• Sintaxe: Se (condicao) entao // Instruções que serão executadas se // a condição for verdadeira Senao // Instruções que serão executadas se // a condição for falsa fimse
  9. 9. Estruturas Condicionais• Exemplo: Algoritmo “exemplo_se_senao” l i l Var numero: inteiro Inicio escreva(“Digite um número: ”) leia(numero) se(numero>3)entao escreva(“O número é maior que 3!”) senao escreva(“O número é maior ou igual a 3!”) fimse fimalgoritmo
  10. 10. Estruturas Condicionais• Exemplo: Algoritmo “exemplo_senha_2” l i l h 2 Var senha: literal Inicio escreva(“Digite a senha: ”) leia(senha) se(senha=“soueu123”)entao escreva(“Acesso liberado!”) senao escreva(“Acesso proibido!”) fimse fimalgoritmo
  11. 11. Estruturas Condicionais• Exemplo: Faça um algoritmo que lê um número inteiro e verifica se o mesmo é par ou ímpar;
  12. 12. Estruturas CondicionaisAlgoritmo “Al it “par_impar” i ”Var numero: inteiroInicio escreva(“Digite um numero: ”) leia(numero) se(numero % 2 = 0)entao escreva(“O número é PAR”) senao escreva( O escreva(“O número é ÍMPAR”) ÍMPAR ) fimsefimalgoritmo

×