Algoritmos e Programação - Aula 3

3.884 visualizações

Publicada em

Algoritmos e Programação - Aula 3

Publicada em: Tecnologia
1 comentário
1 gostou
Estatísticas
Notas
Sem downloads
Visualizações
Visualizações totais
3.884
No SlideShare
0
A partir de incorporações
0
Número de incorporações
47
Ações
Compartilhamentos
0
Downloads
142
Comentários
1
Gostaram
1
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide
  • Próxima aula de GTI
  • Algoritmos e Programação - Aula 3

    1. 1. Profº Thyago Maia Algoritmos e Programação Aula 3
    2. 2. Sumário <ul><li>Forma geral de um algoritmo; </li></ul><ul><li>Variáveis; </li></ul><ul><li>Palavras reservadas; </li></ul><ul><li>Tipos de dados; </li></ul><ul><li>Operador de atribuição; </li></ul><ul><li>Linhas de comentário </li></ul><ul><li>Comandos de entrada e saída </li></ul>
    3. 3. Forma geral de um algoritmo <ul><li>Algoritmo “ nome ” </li></ul><ul><li>Var </li></ul><ul><li>//aqui declaramos as variáveis </li></ul><ul><li>Inicio </li></ul><ul><li>//Aqui codificamos as instruções </li></ul><ul><li>//e expressões </li></ul><ul><li>fimalgoritmo </li></ul>
    4. 4. Forma geral de um algoritmo <ul><li>As palavras reservadas algoritmo e fimalgoritmo delimitam o início e o fim de um algoritmo; </li></ul><ul><li>Após a palavra reservada var (acrônimo para variables), descrevemos as variáveis e os tipos de dados que cada variável recebe; </li></ul><ul><li>Entre as palavras reservadas inicio e fimalgoritmo definimos a lista de instruções do algoritmo; </li></ul>
    5. 5. Forma geral de um algoritmo <ul><li>Palavras reservadas fazem parte da sintaxe da linguagem, e são utilizadas em casos específicos; </li></ul><ul><ul><li>Ex.: A palavra reservada algoritmo é utilizada no início de todo algoritmo... APENAS NO INÍCIO! </li></ul></ul>
    6. 6. Variáveis <ul><li>Trata-se de uma representação de uma posição de memória; </li></ul><ul><ul><li>Capaz de reter e representar um valor ou expressão; </li></ul></ul><ul><li>Tem a finalidade de armazenar dados ou informações de um programa por um curto espaço de tempo; </li></ul><ul><ul><li>Tempo de execução; </li></ul></ul>
    7. 7. Variáveis <ul><li>São associados a nomes, chamados identificadores; </li></ul><ul><li>Identificadores são usados para referenciar e diferenciar as variáveis em algoritmos; </li></ul><ul><li>Identificadores devem ser claros e precisos; </li></ul>
    8. 8. Variáveis <ul><li>Toda variável é associada a um tipo de valor; </li></ul><ul><li>O tipo de uma variável identifica o tipo de valor que ela poderá receber; </li></ul><ul><li>Declaramos variáveis logo após a palavra reservada var . Exemplo: </li></ul><ul><ul><li>Var idade: inteiro </li></ul></ul><ul><ul><li>nota1, nota2: real </li></ul></ul>
    9. 9. Variáveis <ul><li>Regras para identificação de variáveis: </li></ul><ul><ul><li>Nomes de variáveis não podem ser iguais a palavras reservadas; </li></ul></ul><ul><ul><li>Nomes de variáveis devem possuir como primeiro caractere uma letra ou sublinhado; </li></ul></ul><ul><ul><ul><li>Os demais caracteres podem ser letras, números ou sublinhado; </li></ul></ul></ul><ul><ul><li>Nomes devem ter no máximo 127 caracteres; </li></ul></ul><ul><ul><li>Nomes não podem ter espaços em branco; </li></ul></ul><ul><ul><li>Não há diferença entre letras maiúsculas e minúsculas; </li></ul></ul>
    10. 10. Palavras Reservadas <ul><li>aleatorio, abs, algoritmo, arccos, arcsen, arctan, arquivo, asc, ate, caracter, caso, compr, copia, cos, cotan, cronometro, debug, declare, e, eco, enquanto, entao, escolha, escreva, exp, faca, falso, fimalgoritmo, fimenquanto, fimescolha, fimfuncao, fimpara, fimprocedimento, fimrepita, fimse, funcao, grauprad, inicio, inteiro, interrompa, leia, literal, log, logico, logn, maiusc, mensagem, minusc, nao, numerico, numpcarac, ou, outrocaso, para, passo, pausa, pi, pos, procedimento, quad, radpgrau, raizq, rand, randi, repita, se, sem, senao, timer, tan, verdadeiro, xou; </li></ul>
    11. 11. Variáveis <ul><li>Exemplos: </li></ul><ul><ul><li>Identificadores válidos: </li></ul></ul><ul><ul><ul><li>Nome, telefone, endereco, idade_mae; </li></ul></ul></ul><ul><ul><li>Identificadores inválidos: </li></ul></ul><ul><ul><ul><li>3endereco, algoritmo, títulos; </li></ul></ul></ul>
    12. 12. Tipos de Dados TIPO DESCRIÇÃO Inteiro Representa valores inteiros Ex.: 2, 5, -3, 100, -151... Real ou numerico Representa valores reais Ex.: 10.0, 5.6, -3.45.... Literal ou caractere Representa texto entre aspas duplas Ex.: “Sport Recife”, “B”, “1234” Logico Representa os valores lógicos VERDADEIRO ou FALSO
    13. 13. Tipos de dados <ul><li>Exemplo: </li></ul><ul><li>Algoritmo “dados” </li></ul><ul><li>Var nome: literal </li></ul><ul><li>idade: inteiro </li></ul><ul><li>altura: real </li></ul><ul><li>nota1, nota2: real </li></ul><ul><li>Inicio </li></ul><ul><li>fimalgoritmo </li></ul>
    14. 14. Operador de Atribuição <ul><li>Utilizado para inserir um valor ou o resultado de uma expressão em uma variável; </li></ul><ul><li>Representado por uma seta apontando para a esquerda ( <- ); </li></ul><ul><li>Só podemos atribuir valores do mesmo tipo da variável; </li></ul>
    15. 15. Operador de Atribuição <ul><li>Exemplo: </li></ul><ul><li>Algoritmo “exemplo” </li></ul><ul><li>Var nome: literal </li></ul><ul><li>idade: inteiro </li></ul><ul><li>Inicio </li></ul><ul><li>nome <- “Thyago Maia” </li></ul><ul><li>idade <- 27 </li></ul><ul><li>fimalgoritmo </li></ul>
    16. 16. Operador de Atribuição <ul><li>Exemplo 2 (com erros de atribuição): </li></ul><ul><li>Algoritmo “exemplo” </li></ul><ul><li>Var nome: literal </li></ul><ul><li>idade: inteiro </li></ul><ul><li>Inicio </li></ul><ul><li>nome <- Thyago Maia </li></ul><ul><li>idade <- 27.34 </li></ul><ul><li>fimalgoritmo </li></ul>
    17. 17. Exercício <ul><li>Classifique os dados abaixo de acordo com seu tipo: </li></ul>0 “ abc” “ João” 5.7 1012 FALSO -49 342 569 “ Lucas” “ Verdadeiro” 0.00001 Verdadeiro “ 444” -78.1
    18. 18. Exercício <ul><li>Classifique os dados abaixo de acordo com seu tipo: </li></ul>0 inteiro “ abc” literal “ João” literal 5.7 real 101 inteiro FALSO logico -49 inteiro 342 inteiro 9 inteiro “ Lucas” literal “ Verdadeiro” literal 0.00001 real Verdadeiro logico “ 444” literal -78.1 real
    19. 19. Linhas de Comentário <ul><li>Informação textual para a documentação do algoritmo; </li></ul><ul><li>Ajudam a organizar o algoritmo, tornando-o mais legível; </li></ul><ul><li>São representadas por duas barras normais ( // ); </li></ul><ul><li>Todo texto digitado após as barras é considerado um comentário; </li></ul><ul><li>Comentários não são compilados; </li></ul>
    20. 20. Linhas de Comentário <ul><li>Exemplo: </li></ul><ul><li>// Algoritmo que atribui um nome </li></ul><ul><li>// a uma variável </li></ul><ul><li>Algoritmo “exemplo” </li></ul><ul><li>Var nome: literal </li></ul><ul><li>Inicio </li></ul><ul><li>// Linha que ocorre a atribuição </li></ul><ul><li>nome <- “Thyago Maia” </li></ul><ul><li>fimalgoritmo </li></ul>
    21. 21. Comandos de Entrada e Saída <ul><li>Comandos de saída ( escreva e escreval ) </li></ul><ul><ul><li>Utilizados para escrever mensagens ou valores de variáveis na tela do usuário (no programa terminal); </li></ul></ul><ul><ul><li>Escreva escreve algo e mantém o cursor na mesma linha, aguardando novas instruções; </li></ul></ul><ul><ul><li>Escreval escreva algo e pula uma linha; </li></ul></ul>
    22. 22. Comandos de Entrada e Saída <ul><li>Exemplo: </li></ul><ul><li>Algoritmo “escreve” </li></ul><ul><li>Var </li></ul><ul><li>Inicio </li></ul><ul><li>escreval(“Minha primeira mensagem”) </li></ul><ul><li>fimalgoritmo </li></ul>
    23. 23. Comandos de Entrada e Saída <ul><li>Exemplo: </li></ul><ul><li>Algoritmo “escreve_variavel” </li></ul><ul><li>Var idade: inteiro </li></ul><ul><li>Inicio </li></ul><ul><li>idade <- 28 </li></ul><ul><li>escreva(“Minha idade:”) </li></ul><ul><li>escreval(idade) </li></ul><ul><li>fimalgoritmo </li></ul>
    24. 24. Comandos de Entrada e Saída <ul><li>Exemplo: </li></ul><ul><li>Algoritmo “escreve_variavel_2” </li></ul><ul><li>Var idade: inteiro </li></ul><ul><li>Inicio </li></ul><ul><li>idade <- 28 </li></ul><ul><li>escreva(“Minha idade:”, idade) </li></ul><ul><li>fimalgoritmo </li></ul>
    25. 25. Comandos de Entrada e Saída <ul><li>Comando de entrada ( leia ) </li></ul><ul><ul><li>Utilizado para ler um valor digitado pelo usuário, armazenando o referido valor em uma variável indicada no comando; </li></ul></ul>
    26. 26. Comandos de Entrada e Saída <ul><li>Exemplo: </li></ul><ul><li>Algoritmo “escreve_seu_nome” </li></ul><ul><li>Var nome: literal </li></ul><ul><li>Inicio </li></ul><ul><li>escreva(“Digite seu nome”) </li></ul><ul><li>leia(nome) </li></ul><ul><li>escreval(“Seu nome é: ”) </li></ul><ul><li>escreval(nome) </li></ul><ul><li>fimalgoritmo </li></ul>
    27. 27. Comandos de Entrada e Saída <ul><li>Algoritmo “soma” </li></ul><ul><li>Var num1, num2, soma: inteiro </li></ul><ul><li>Inicio </li></ul><ul><li>escreva(“Digite o primeiro número: ”) </li></ul><ul><li>leia(num1) </li></ul><ul><li>escreva(“Digite o segundo número: ”) </li></ul><ul><li>leia(num2) </li></ul><ul><li>soma <- num1 + num2 </li></ul><ul><li>escreval(“Resultado: ”, soma) </li></ul><ul><li>fimalgoritmo </li></ul>
    28. 28. Exercícios <ul><li>Faça um algoritmo que lê o nome de um aluno, suas duas notas no semestre e calcula sua média final. O algoritmo deverá apresentar o nome digitado e a média calculada; </li></ul>
    29. 29. Exercícios <ul><li>Escreva um algoritmo que calcule a área do quadrado. O usuário deverá digitar o lado de um quadrado para que o algoritmo calcule sua área, apresentando-o logo em seguida; </li></ul><ul><ul><li>Area do quadrado = lado 2 </li></ul></ul>
    30. 30. Exercícios <ul><li>Escreva um algoritmo que lê três valores, calcula e apresenta a área do trapézio; </li></ul>

    ×