Algoritmos e Programação - 2016.2 - Aula 9

205 visualizações

Publicada em

Algoritmos e Programação - 2016.2 - Aula 9

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
205
No SlideShare
0
A partir de incorporações
0
Número de incorporações
107
Ações
Compartilhamentos
0
Downloads
2
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2016.2 - Aula 9

  1. 1. Algoritmos e Programação Prof.º Thyago Maia
  2. 2. Estrutura de Repetição PARA
  3. 3. PARA • Nesta estrutura, uma variável de controle é inicializada com um valor. Para cada iteração, seu valor é comparado com um valor final; • A execução da lista de instruções se repetirá até que a variável de controle seja maior que o valor final; • Para cada iteração, a variável de controle é incrementada; 3
  4. 4. PARA • Sintaxe: 4 PARA variavel DE val_inicial ATE val_final FACA // Lista de instruções FIMPARA
  5. 5. Exemplo • Faça um algoritmo que escreva os números entre 1 e 5 (incluindo-os). 5
  6. 6. Exemplo ALGORITMO “exemplo” VAR i: INTEIRO INICIO PARA i DE 1 ATE 5 FACA ESCREVAL (i) FIMPARA FIMALGORITMO 6
  7. 7. PARA • Para alterarmos a forma de contagem do laço (crescente ou decrescente) e quanto a variável de controle será incrementada ou decrementada, utilizamos a palavra reservada PASSO, seguida de um valor; • Forma geral: 7 PARA variavel DE val_inicial ATE val_final PASSO valor_passo FACA // Lista de instruções FIMPARA
  8. 8. Exemplo • Faça um algoritmo que escreva os números pares entre 1 e 10. 8
  9. 9. Exemplo ALGORITMO “exemplo” VAR i: INTEIRO INICIO PARA i DE 2 ATE 10 PASSO 2 FACA ESCREVAL (i) FIMPARA FIMALGORITMO 9
  10. 10. Exercícios
  11. 11. Exercícios • Utilizando a estrutura PARA, faça um algoritmo que apresente todos os números ímpares entre 0 a 100. 11
  12. 12. Exercício ALGORITMO “exercicio” VAR i: INTEIRO INICIO PARA i DE 1 ATE 100 PASSO 2 FACA ESCREVAL (i) FIMPARA FIMALGORITMO 12
  13. 13. Exercícios • Faça um algoritmo que lê o sexo de um grupo de 20 pessoas e calcula: – A quantidade total de homens; – A quantidade total de mulheres; 13
  14. 14. Exercício ALGORITMO “exercicio” VAR i, quant_h, quant_m: INTEIRO sexo: LITERAL INICIO PARA i DE 1 ATE 20 FACA ESCREVAL (“Digite seu sexo:”) LEIA (sexo) ESCOLHA(sexo) CASO “M” quant_h <- quant_h + 1 14
  15. 15. Exercício CASO “F” quant_m <- quant_m + 1 FIMESCOLHA FIMPARA ESCREVAL (“Quantidade de homens: ”, quant_h) ESCREVAL (“Quantidade de mulheres: ”, quant_m) FIMALGORITMO 15
  16. 16. Exercícios • Faça um algoritmo que lê a idade de 10 pessoas. Em seguida, o algoritmo deverá apresentar a quantidade de adolescentes (de 12 a 17 anos); 16
  17. 17. Exercício ALGORITMO “exercicio” VAR i, quant, idade: INTEIRO INICIO PARA i DE 1 ATE 20 FACA ESCREVAL (“Digite sua idade:”) LEIA (idade) SE (idade >= 12) E (idade <= 17) ENTAO quant <- quant + 1 FIMSE FIMPARA 17
  18. 18. Exercício ESCREVAL (“Quantidade de adolescentes: ”, quant) FIMALGORITMO 18
  19. 19. Exercícios • Faça um algoritmo que receba a idade de 15 pessoas, calcule e mostre a quantidade de pessoas em cada faixa: 19 FAIXA ETÁRIA IDADE 1 ATÉ 15 ANOS 2 ENTRE 16 ANOS E 30 ANOS 3 ACIMA DE 30 ANOS
  20. 20. Exercícios • Uma loja utiliza o código V para transações à vista e P para transações a prazo. Faça um algoritmo que receba o código e o valor de quinze transações, calcule e mostre: – A quantidade de compras à vista; – A quantidade de compras a prazo; – O valor total das compras à vista; – O valor total das compras a prazo; – O valor total das compras efetuadas; 20
  21. 21. Exercícios • Faça um algoritmo que receba 10 números inteiros, calcule e mostre: – A quantidade de números positivos digitados; – A soma dos números negativos digitados; 21

×