Algoritmos e Programação - 2016.1 - Aula 4

484 visualizações

Publicada em

Algoritmos e Programação - 2016.1 - Aula 4

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
484
No SlideShare
0
A partir de incorporações
0
Número de incorporações
104
Ações
Compartilhamentos
0
Downloads
32
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2016.1 - Aula 4

  1. 1. Algoritmos e Programação Prof.º Thyago Maia
  2. 2. Objetivos Aula 4 • Introduzir alguns conceitos básicos aplicados em Algoritmos e Linguagens de Programação • Práticas para treinamento em estruturas sequenciais em algoritmos (VisuAlg); 2
  3. 3. Comandos de entrada e saída no VisuAlg
  4. 4. Comandos de entrada e saída • Comando de entrada (leia) • Utilizado para ler um valor digitado pelo usuário, armazenando o referido valor em uma variável indicada no comando; 4
  5. 5. Comandos de entrada e saída • Comandos de saída (escreva ou escreval) • Utilizados para escrever mensagens ou valores de variáveis na saída padrão; 5
  6. 6. Exemplo • Faça um algoritmo que leia o nome e a idade de um indivíduo, exibindo-os logo em seguida; 6
  7. 7. Exemplo ALGORITMO “exemplo” VAR NOME: LITERAL IDADE: INTEIRO INICIO ESCREVA (“Digite seu nome: ”) LEIA (NOME) ESCREVA (“Digite sua idade”) LEIA (IDADE) ESCREVAL (“Seu nome é ”, NOME) ESCREVAL (“Sua idade: ”, IDADE) FIMALGORITMO 7
  8. 8. Exemplo • Faça um algoritmo que leia dois números inteiros, calcula e exibe a soma entre eles; 8
  9. 9. Exemplo ALGORITMO “exemplo” VAR NUM1, NUM2, SOMA: INTEIRO INICIO ESCREVAL (“Digite dois números: ”) LEIA (NUM1, NUM2) SOMA <- NUM1 + NUM2 ESCREVA (“Resultado da soma: ”, SOMA) FIMALGORITMO 9
  10. 10. Exercícios
  11. 11. Exercícios • Faça um algoritmo que calcule e mostre a área de um triângulo; – Área = (base * altura) / 2 11
  12. 12. Exemplo ALGORITMO “exemplo” VAR base, altura, area : REAL INICIO ESCREVAL (“Digite a base e a altura: ”) LEIA (base, altura) area <- (base * altura) /2 ESCREVA (area) FIMALGORITMO 12
  13. 13. Exercícios • Faça um algoritmo que lê o salário de um funcionário, calcula e exibe o novo salário, sabendo que este sofreu um aumento de 25%; 13
  14. 14. Exemplo ALGORITMO “exemplo” VAR sal, aumento, novosal : REAL INICIO ESCREVAL (“Digite seu salário: ”) LEIA (sal) aumento <- sal * 25/100 novosal <- sal + aumento ESCREVA (novosal) FIMALGORITMO 14
  15. 15. Exercícios  Faça um algoritmo que lê o preço de um produto e a quantidade adquirida por um cliente. O mesmo deverá calcular e exibir o valor total a ser pago; 15
  16. 16. Exercícios  Faça um algoritmo que receba as três notas de um determinado aluno no semestre 2015.2, calcula e exibe sua média final; 16
  17. 17. Exercícios • Faça um algoritmo que receba o ano de nascimento de uma pessoa e o ano atual, calcule e mostre: – A idade desta pessoa; – Quantos anos ela terá em 2025; 17
  18. 18. Exercícios • Um funcionário recebe um salário fixo mais 4% de comissão sobre as vendas. Faça um algoritmo que receba o salário fixo do funcionário e o valor de suas vendas, calcule e mostre a comissão e seu salário final. 18
  19. 19. Explore o assunto!
  20. 20. Explore o assunto! • Referências – Introdução aos algoritmos(TONET, B., KOLIVER, C.): Introdução e tópicos 1 a 9; – Disponível em http://www.claudiorodol fo.com/ftc/ap/manual_vi sualg.pdf 20
  21. 21. Explore o assunto! • Referências – Fundamentos da programação de computadores (ASCENCIO, A. F. G., CAMPOS, E. A. V.): Capítulos 3 (apenas os tópicos sobre algoritmos); 21

×