Algoritmos e Programação - 2016.1 - Aula 3

414 visualizações

Publicada em

Algoritmos e Programação - 2016.1 - Aula 3

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
414
No SlideShare
0
A partir de incorporações
0
Número de incorporações
91
Ações
Compartilhamentos
0
Downloads
36
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2016.1 - Aula 3

  1. 1. Algoritmos e Programação Prof.º Thyago Maia
  2. 2. Objetivos Aula 3 • Introduzir alguns conceitos básicos aplicados em Algoritmos e Linguagens de Programação • Exercitar os conceitos apresentados 2
  3. 3. Tipos de algoritmos  Português Estruturado (Portugol)  Linguagem mais restrita que o português em linguagem natural;  Simplificação extrema do português;  Significados bem definidos para todos os termos utilizados nas instruções;  Possui um conjunto de palavras e regras específicas (sintaxe da linguagem); 3
  4. 4. Tipos de algoritmos  Português Estruturado (Portugol)  Normalmente as implementações são feitas em papel, escritas a mão;  Atualmente, também são utilizados programas que interpretam, testam e executam algoritmos;  Ex.: VisuAlg (programa que utilizaremos no curso); 4
  5. 5. Estrutura sequencial em Portugol
  6. 6. Tipos de algoritmos • Forma básica de um algoritmo no VisuAlg: ALGORITMO “nome” VAR : INICIO FIMALGORITMO 6 VARIÁVEIS INSTRUÇÕES TIPOS DE DADOS
  7. 7. Variáveis
  8. 8. Variáveis • Trata-se de uma representação para uma posição de memória; • Capaz de reter e representar um valor ou expressão; • Tem a finalidade de armazenar dados ou informações de um programa por um curto espaço de tempo; • Tempo de execução; 8
  9. 9. Variáveis • São associados a nomes, chamados identificadores; • Identificadores são usados para referenciar e diferenciar as variáveis em algoritmos; • Identificadores devem ser claros e precisos; 9
  10. 10. Variáveis • Toda variável é associada a um tipo de valor; • O tipo de uma variável identifica o tipo de valor que ela poderá receber; • No Portugol, declaramos variáveis logo após a palavra reservada VAR. 10
  11. 11. Exemplo ALGORITMO “nome” VAR N1, N2, M: REAL INICIO ESCREVA (“Digite dois números: ”) LEIA (N1, N2) M <- N1 * N2 ESCREVA (M) FIMALGORITMO 11
  12. 12. Variáveis • Regras para identificação de variáveis: • Nomes de variáveis não podem ser iguais a palavras reservadas; • Nomes de variáveis devem possuir como primeiro caractere uma letra ou sublinhado; • Os demais caracteres podem ser letras, números ou sublinhado; • Nomes devem ter no máximo 127 caracteres; • Nomes não podem ter espaços em branco; • Não há diferença entre letras maiúsculas e minúsculas; 12
  13. 13. Variáveis • Exemplos: • Identificadores válidos: • Nome, telefone, endereco, idade_mae; • Identificadores inválidos: • 3endereco, algoritmo, títulos; 13
  14. 14. Tipos de dados
  15. 15. Tipos de dados 15 TIPO DESCRIÇÃO INTEIRO Representa valores inteiros Ex.: 2, 5, -3, 100, -151... REAL Representa valores reais Ex.: 5.6, -3.45, 5.00, -10.45... LITERAL Representa texto entre aspas duplas Ex.: “Sport Recife”, “B”, “1234” LOGICO Representa os valores lógicos VERDADEIRO ou FALSO
  16. 16. Exemplo ALGORITMO “exemplo” VAR NOME, ENDERECO: LITERAL IDADE: INTEIRO PESO: REAL EH_SOLTEIRO: LOGICO INICIO NOME <- “Thyago” ENDERECO <- “Rua Tal, 555” IDADE <- 29 EH_SOLTEIRO <- falso FIMALGORITMO 16
  17. 17. Operador de atribuição
  18. 18. Operador de atribuição • Utilizado para inserir um valor ou o resultado de uma expressão em uma variável; • Representado por uma seta apontando para a esquerda (<-); • Só podemos atribuir valores do mesmo tipo da variável; 18
  19. 19. Exemplo ALGORITMO “exemplo” VAR NOME, ENDERECO: LITERAL IDADE: INTEIRO PESO: REAL EH_SOLTEIRO: LOGICO INICIO NOME <- “Thyago” ENDERECO <- “Rua Tal, 555” IDADE <- 29 EH_SOLTEIRO <- falso FIMALGORITMO 19
  20. 20. Exercícios
  21. 21. Exercícios • Classifique os dados abaixo de acordo com seu tipo: 21 0 “abc” “João” 5.7 1012 FALSO -49 342 569 “Lucas” “Verdadeiro” 0.00001 Verdadeiro “444” -78.1
  22. 22. Exercícios • Classifique os dados abaixo de acordo com seu tipo: 22 0 numérico “abc” literal “João” literal 5.7 numérico 101 numérico FALSO lógico -49 numérico 342 numérico 9 numérico “Lucas” literal “Verdadeiro” literal 0.00001 numérico Verdadeiro lógico “444” literal -78.1 numérico
  23. 23. Explore o assunto!
  24. 24. Explore o assunto! • Referências – Introdução aos algoritmos(TONET, B., KOLIVER, C.): Introdução e tópicos 1 a 9; – Disponível em http://www.claudiorodol fo.com/ftc/ap/manual_vi sualg.pdf 24
  25. 25. Explore o assunto! • Referências – Fundamentos da programação de computadores (ASCENCIO, A. F. G., CAMPOS, E. A. V.): Exercícios Propostos, páginas 47, 48, 49; 25

×