Algoritmos e Programação
Prof.º Thyago Maia
2015.2
Objetivos
Aula 8
• Apresentar as estruturas de
repetição
• Apresentar a estrutura de
repetição repita...ate
2
Exercícios
Exercícios
• Faça um algoritmo que lê a idade de 15
pessoas e mostre a quantidade de pessoas
que possuam idades entre 0 e ...
Exercícios
ALGORITMO “exercicio”
VAR idade, quant, cont: INTEIRO
INICIO
REPITA
ESCREVA (“Digite sua idade:”)
LEIA (idade)
...
Exercícios
• Faça um algoritmo que lê diversos números
positivos e escreve o dobro de cada um.
Quando um número negativo f...
Exercícios
ALGORITMO “exercicio”
VAR numero: INTEIRO
INICIO
REPITA
ESCREVAL (“Digite um número:”)
LEIA (numero)
SE (numero...
Exercícios
• Faça um algoritmo que implementa o seguinte
questionário: “Você é a favor da pena de
morte no Brasil? Sim (s)...
Exercícios
ALGORITMO “exercicio”
VAR voto: LITERAL
quant_sim, quant_nao: INTEIRO
INICIO
REPITA
ESCREVAL (“Você é a favor d...
Exercícios
CASO “fim”
ESCREVAL (“Enquete Encerrada!”)
OUTROCASO
ESCREVAL (“Opção Inválida”)
FIMESCOLHA
ATE voto = “fim”
ES...
Exercícios
• Faça um programa que lê a idade de várias pessoas,
até que uma idade negativa seja digitada. O
algoritmo deve...
Exercícios
ALGORITMO “exercicio”
VAR idade, contador1, contador2: INTEIRO
INICIO
REPITA
ESCREVAL (“Digite sua idade:”)
LEI...
Exercícios
• Faça um programa que repita as seguintes
tarefas, até que a palavra ‘nao’ seja digitada:
– Leia a distância p...
Próximos SlideShares
Carregando em…5
×

Algoritmos e Programação - 2015.2 - Aula 8

277 visualizações

Publicada em

Algoritmos e Programação - 2015.2 - Aula 8

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
277
No SlideShare
0
A partir de incorporações
0
Número de incorporações
5
Ações
Compartilhamentos
0
Downloads
12
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2015.2 - Aula 8

  1. 1. Algoritmos e Programação Prof.º Thyago Maia 2015.2
  2. 2. Objetivos Aula 8 • Apresentar as estruturas de repetição • Apresentar a estrutura de repetição repita...ate 2
  3. 3. Exercícios
  4. 4. Exercícios • Faça um algoritmo que lê a idade de 15 pessoas e mostre a quantidade de pessoas que possuam idades entre 0 e 12 anos; 4
  5. 5. Exercícios ALGORITMO “exercicio” VAR idade, quant, cont: INTEIRO INICIO REPITA ESCREVA (“Digite sua idade:”) LEIA (idade) quant <- quant + 1 SE (idade >= 0) E (idade <= 12) ENTAO cont <- cont + 1 FIMSE ATE quant = 15 ESCREVA (“Quant. de pessoas com idade entre 0 e 12 anos: ”, cont) FIMALGORITMO 5
  6. 6. Exercícios • Faça um algoritmo que lê diversos números positivos e escreve o dobro de cada um. Quando um número negativo for digitado, o algoritmo deverá parar de ler números. 6
  7. 7. Exercícios ALGORITMO “exercicio” VAR numero: INTEIRO INICIO REPITA ESCREVAL (“Digite um número:”) LEIA (numero) SE (numero > 0) ENTAO ESCREVAL (numero * 2) FIMSE ATE numero < 0 FIMALGORITMO 7
  8. 8. Exercícios • Faça um algoritmo que implementa o seguinte questionário: “Você é a favor da pena de morte no Brasil? Sim (s) ou Não (n)? Digite fim para encerrar o algoritmo”. Após o encerramento da leitura dos votos, o algoritmo deverá apresentar a quantidade de votos para cada opção; 8
  9. 9. Exercícios ALGORITMO “exercicio” VAR voto: LITERAL quant_sim, quant_nao: INTEIRO INICIO REPITA ESCREVAL (“Você é a favor da pena de morte no Brasil? Sim (s) ou Não (n)? Digite fim para encerrar o algoritmo:”) LEIA (voto) ESCOLHA(voto) CASO “s” quant_sim <- quant_sim + 1 CASO “n” quant_nao <- quant_nao + 1 9
  10. 10. Exercícios CASO “fim” ESCREVAL (“Enquete Encerrada!”) OUTROCASO ESCREVAL (“Opção Inválida”) FIMESCOLHA ATE voto = “fim” ESCREVAL (“Quant. de votos SIM: ”, quant_sim) ESCREVAL (“Quant. de votos NÃO: ”, quant_nao) FIMALGORITMO 10
  11. 11. Exercícios • Faça um programa que lê a idade de várias pessoas, até que uma idade negativa seja digitada. O algoritmo deverá calcular e exibir a quantidade de pessoas, de acordo com as faixas etárias apresentadas na tabela abaixo: 11 FAIXA ETÁRIA IDADE 1ª <= 15 anos 2ª Acima de 15 anos
  12. 12. Exercícios ALGORITMO “exercicio” VAR idade, contador1, contador2: INTEIRO INICIO REPITA ESCREVAL (“Digite sua idade:”) LEIA (idade) SE (idade <= 15) ENTAO contador1 <- contador1 + 1 SENAO contador2 <- contador2 + 1 FIMSE ATE idade < 0 ESCREVAL (“Quant. Faixa 1: ”, contador1) ESCREVAL (“Quant. Faixa 2: ”, contador2) FIMALGORITMO 12
  13. 13. Exercícios • Faça um programa que repita as seguintes tarefas, até que a palavra ‘nao’ seja digitada: – Leia a distância percorrida por um atleta; – Leia o tempo que o atleta levou para percorrer a distância; – Calcule e exiba sua velocidade média: • Velocidade = distancia / tempo; – Pergunte ao usuário se o mesmo quer continuar a executar o programa (o usuário responderá ‘sim’ ou ‘nao’);

×