Algoritmos e Programação
Prof.º Thyago Maia
2015.2
Objetivos
Aula 7
• Apresentar as estruturas de
repetição
• Apresentar a estrutura de
repetição repita...ate
2
Estruturas de Repetição
Estruturas de Repetição
• Uma estrutura de repetição é utilizada quando...
– Um trecho do algoritmo (lista de instruções) ...
Repita...ate
Repita...ate
• Nesta estrutura, todas as instruções são
executadas e uma expressão lógica é avaliada;
• Sua lista de expre...
Repita...ate
• Utilizamos as palavras reservadas repita e ate
para formar o laço de repetição;
• Forma geral:
7
REPITA
// ...
Exemplo
• Faça um algoritmo que escreva os números
entre 1 e 10.
8
Exemplo
ALGORITMO “exemplo”
VAR numero: INTEIRO
INICIO
numero <- 1
REPITA
ESCREVA (numero)
numero <- numero + 1
ATE numero...
Exemplo
• Faça um algoritmo que lê vários números (O
algoritmo deverá encerrar a leitura quando o
número 0 for digitado) e...
Exemplo
ALGORITMO “exemplo”
VAR numero, contador: INTEIRO
INICIO
REPITA
ESCREVA (“Digite um número:”)
LEIA (numero)
SE (nu...
Estruturas de Repetição
• Repita...ate
– Atenção: Cuidado com laços infinitos! Devemos
nos certificar que em algum momento...
Estruturas de Repetição
• Exemplo - Algoritmo com laço infinito:
13
ALGORITMO “infinito”
VAR contador: INTEIRO
INICIO
cont...
Exercícios
Exercício
• Faça um algoritmo que lê vários números (O
algoritmo deverá encerrar a leitura quando o
número 0 for digitado)...
Exercício
ALGORITMO “exemplo”
VAR numero, contador: INTEIRO
INICIO
REPITA
ESCREVA (“Digite um número:”)
LEIA (numero)
SE (...
Exercícios
• Faça um algoritmo que exibe a frase “Sport
Campeão de 87” 10 vezes.
17
Exercícios
ALGORITMO “exemplo”
VAR contador: INTEIRO
INICIO
REPITA
ESCREVA (“Sport Campeão de 87”)
contador <- contador + ...
Explore o assunto!
Explore o assunto!
• Referências
– Introdução aos
algoritmos(TONET, B.,
KOLIVER, C.): Tópicos 12
e 13;
– Disponível em
htt...
Próximos SlideShares
Carregando em…5
×

Algoritmos e Programação - 2015.2 - Aula 7

345 visualizações

Publicada em

Algoritmos e Programação - 2015.2 - Aula 7

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
345
No SlideShare
0
A partir de incorporações
0
Número de incorporações
11
Ações
Compartilhamentos
0
Downloads
9
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2015.2 - Aula 7

  1. 1. Algoritmos e Programação Prof.º Thyago Maia 2015.2
  2. 2. Objetivos Aula 7 • Apresentar as estruturas de repetição • Apresentar a estrutura de repetição repita...ate 2
  3. 3. Estruturas de Repetição
  4. 4. Estruturas de Repetição • Uma estrutura de repetição é utilizada quando... – Um trecho do algoritmo (lista de instruções) ou até mesmo o algoritmo inteiro precisa ser repetido; • O número de repetições poderá ser fixo ou estar atrelado a uma condição; – Fixo, quando sabemos quantas vezes um determinado trecho de código será executado; – Atrelado a uma condição, quando a repetição de instruções depende de uma ação, de um cálculo, etc.; 4
  5. 5. Repita...ate
  6. 6. Repita...ate • Nesta estrutura, todas as instruções são executadas e uma expressão lógica é avaliada; • Sua lista de expressões se repetirá até que a avaliação da condição resulte em VERDADEIRO; • Cada repetição da lista de instruções contida na estrutura é chamada de iteração; • A estrutura Repita...ate também é conhecida como laço de repetição; 6
  7. 7. Repita...ate • Utilizamos as palavras reservadas repita e ate para formar o laço de repetição; • Forma geral: 7 REPITA // Lista de instruções ATE (condição)
  8. 8. Exemplo • Faça um algoritmo que escreva os números entre 1 e 10. 8
  9. 9. Exemplo ALGORITMO “exemplo” VAR numero: INTEIRO INICIO numero <- 1 REPITA ESCREVA (numero) numero <- numero + 1 ATE numero > 10 FIMALGORITMO 9
  10. 10. Exemplo • Faça um algoritmo que lê vários números (O algoritmo deverá encerrar a leitura quando o número 0 for digitado) e conta quantas vezes o número 13 foi digitado. 10
  11. 11. Exemplo ALGORITMO “exemplo” VAR numero, contador: INTEIRO INICIO REPITA ESCREVA (“Digite um número:”) LEIA (numero) SE (numero = 13) ENTAO contador <- contador + 1 FIMSE ATE numero = 0 ESCREVAL (contador) FIMALGORITMO 11
  12. 12. Estruturas de Repetição • Repita...ate – Atenção: Cuidado com laços infinitos! Devemos nos certificar que em algum momento a expressão lógica próxima a palavra reservada ate será VERDADEIRA! 12
  13. 13. Estruturas de Repetição • Exemplo - Algoritmo com laço infinito: 13 ALGORITMO “infinito” VAR contador: INTEIRO INICIO contador <- 1 REPITA ESCREVA (contador) contador <- contador + 1 ATE contador = 10 FIMALGORITMO
  14. 14. Exercícios
  15. 15. Exercício • Faça um algoritmo que lê vários números (O algoritmo deverá encerrar a leitura quando o número 0 for digitado) e conta quantos números negativos foram digitados. 15
  16. 16. Exercício ALGORITMO “exemplo” VAR numero, contador: INTEIRO INICIO REPITA ESCREVA (“Digite um número:”) LEIA (numero) SE (numero < 0) ENTAO contador <- contador + 1 FIMSE ATE numero = 0 ESCREVAL (contador) FIMALGORITMO 16
  17. 17. Exercícios • Faça um algoritmo que exibe a frase “Sport Campeão de 87” 10 vezes. 17
  18. 18. Exercícios ALGORITMO “exemplo” VAR contador: INTEIRO INICIO REPITA ESCREVA (“Sport Campeão de 87”) contador <- contador + 1 ATE contador = 10 FIMALGORITMO 18
  19. 19. Explore o assunto!
  20. 20. Explore o assunto! • Referências – Introdução aos algoritmos(TONET, B., KOLIVER, C.): Tópicos 12 e 13; – Disponível em http://www.claudiorodol fo.com/ftc/ap/manual_vi sualg.pdf 20

×