Algoritmos e Programação
Prof.º Thyago Maia
2015.2
Objetivos
Aula 5
• Apresentar as Estruturas
Condicionais
2
Estruturas Condicionais
Estruturas Condicionais
• Na vida real tomamos decisões a todo momento,
baseadas em escolhas;
• Em algoritmos, chamamos ta...
Estruturas Condicionais
• Analisando o exemplo anterior:
• A condição do exemplo: “o Sport não vencer o
Santa Cruz”;
• Pos...
Estruturas Condicionais
• Para criarmos estruturas condicionais simples
no VisuAlg, utilizamos as palavras reservadas
SE e...
Exemplo
• Faça um algoritmo que leia a idade de um
indivíduo e informe se o mesmo atingiu a
maioridade.
7
Exemplo
ALGORITMO “exemplo”
VAR idade: INTEIRO
INICIO
ESCREVA(“Digite sua idade:”)
LEIA(idade)
SE (idade >= 18) ENTAO
ESCR...
Exemplo
• Faça um algoritmo que a senha digitada pelo
usuário e informe se a mesma é válida
(supondo que a senha válida é ...
Exemplo
ALGORITMO “exemplo”
VAR senha: LITERAL
INICIO
ESCREVA (“Digite sua senha:”)
LEIA (senha)
SE (senha = “soueu123”) E...
Estruturas Condicionais
• Para criarmos estruturas condicionais com
duas opções de escolha em Portugol,
utilizamos as pala...
Estruturas Condicionais
• Sintaxe:
12
SE (condicao) ENTAO
// Instruções que serão executadas se
// a condição for verdadei...
Exemplo
• Faça um algoritmo que leia a idade de um
indivíduo e informe se o mesmo atingiu a
maioridade ou não.
13
Exemplo
ALGORITMO “exemplo”
VAR idade: INTEIRO
INICIO
ESCREVA (“Digite sua idade:”)
LEIA (idade)
SE (idade >= 18) ENTAO
ES...
Exemplo
• Faça um algoritmo que a senha digitada pelo
usuário e informe se a mesma é válida ou não
(supondo que a senha vá...
Exemplo
ALGORITMO “exemplo”
VAR senha: LITERAL
INICIO
ESCREVA (“Digite sua senha:”)
LEIA (senha)
SE (senha = “soueu123”) E...
Exercícios
Exercícios
• Faça um algoritmo que lê três notas, calcula a
média e informa se o aluno está aprovado ou
não.
– O aluno est...
Exercícios
ALGORITMO “exemplo”
VAR n1, n2, n3, media: REAL
INICIO
ESCREVA (“Digite as 3 notas do aluno:”)
LEIA (n1, n2, n3...
Exercícios
• Faça um algoritmo que lê dois números e um código
que irá identificar uma operação a ser efetuada entre
os do...
Exercícios
ALGORITMO “exemplo”
VAR num1, num2, codigo, resultado: REAL
INICIO
ESCREVA (“Digite 2 números:”)
LEIA (num1, nu...
Exercícios
• Faça um algoritmo que lê o salário atual de um
funcionário e calcula seu salário reajustado. O
percentual de ...
Exercícios
ALGORITMO “exemplo”
VAR salario, aumento, salario_novo: REAL
INICIO
ESCREVA (“Digite seu salário:”)
LEIA (salar...
Exercícios
• Faça um algoritmo que receba o valor do salário de
uma pessoa e o valor de um financiamento
pretendido. Se o ...
Explore o assunto!
Explore o assunto!
• Referências
– Introdução aos
algoritmos(TONET, B.,
KOLIVER, C.): Tópico 10;
– Disponível em
http://ww...
Próximos SlideShares
Carregando em…5
×

Algoritmos e Programação - 2015.2 - Aula 5

449 visualizações

Publicada em

Algoritmos e Programação - 2015.2 - Aula 5

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
449
No SlideShare
0
A partir de incorporações
0
Número de incorporações
3
Ações
Compartilhamentos
0
Downloads
14
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2015.2 - Aula 5

  1. 1. Algoritmos e Programação Prof.º Thyago Maia 2015.2
  2. 2. Objetivos Aula 5 • Apresentar as Estruturas Condicionais 2
  3. 3. Estruturas Condicionais
  4. 4. Estruturas Condicionais • Na vida real tomamos decisões a todo momento, baseadas em escolhas; • Em algoritmos, chamamos tais decisões de condições; • Associada a uma condição, existirá uma possível alternativa; • Exemplo: Se o Sport não vencer o Santa Cruz na próxima partida, seu técnico será demitido; 4
  5. 5. Estruturas Condicionais • Analisando o exemplo anterior: • A condição do exemplo: “o Sport não vencer o Santa Cruz”; • Possíveis decisões baseadas na condição: Sim (Verdadeiro) ou não (Falso); • Logo, condições geram respostas lógicas! • Se a condição for verdadeira, a ação “demitir o técnico” será executada; • Caso contrário (senão), o técnico continuará no Sport; 5
  6. 6. Estruturas Condicionais • Para criarmos estruturas condicionais simples no VisuAlg, utilizamos as palavras reservadas SE e ENTAO; • Sintaxe: 6 SE (condição) ENTÃO // Instruções FIMSE
  7. 7. Exemplo • Faça um algoritmo que leia a idade de um indivíduo e informe se o mesmo atingiu a maioridade. 7
  8. 8. Exemplo ALGORITMO “exemplo” VAR idade: INTEIRO INICIO ESCREVA(“Digite sua idade:”) LEIA(idade) SE (idade >= 18) ENTAO ESCREVA(“Você atingiu a maioridade”) FIMSE FIMALGORITMO 8
  9. 9. Exemplo • Faça um algoritmo que a senha digitada pelo usuário e informe se a mesma é válida (supondo que a senha válida é “soueu123”). 9
  10. 10. Exemplo ALGORITMO “exemplo” VAR senha: LITERAL INICIO ESCREVA (“Digite sua senha:”) LEIA (senha) SE (senha = “soueu123”) ENTAO ESCREVA (“Senha válida!”) FIMSE FIMALGORITMO 10
  11. 11. Estruturas Condicionais • Para criarmos estruturas condicionais com duas opções de escolha em Portugol, utilizamos as palavras reservadas SE, ENTAO e SENAO; 11
  12. 12. Estruturas Condicionais • Sintaxe: 12 SE (condicao) ENTAO // Instruções que serão executadas se // a condição for verdadeira SENAO // Instruções que serão executadas se // a condição for falsa FIMSE
  13. 13. Exemplo • Faça um algoritmo que leia a idade de um indivíduo e informe se o mesmo atingiu a maioridade ou não. 13
  14. 14. Exemplo ALGORITMO “exemplo” VAR idade: INTEIRO INICIO ESCREVA (“Digite sua idade:”) LEIA (idade) SE (idade >= 18) ENTAO ESCREVA (“Você atingiu a maioridade”) SENAO ESCREVA (“Você não atingiu a maioridade”) FIMSE FIMALGORITMO 14
  15. 15. Exemplo • Faça um algoritmo que a senha digitada pelo usuário e informe se a mesma é válida ou não (supondo que a senha válida é “soueu123”). 15
  16. 16. Exemplo ALGORITMO “exemplo” VAR senha: LITERAL INICIO ESCREVA (“Digite sua senha:”) LEIA (senha) SE (senha = “soueu123”) ENTAO ESCREVA (“Senha válida!”) SENAO ESCREVA (“Senha inválida!”) FIMSE FIMALGORITMO 16
  17. 17. Exercícios
  18. 18. Exercícios • Faça um algoritmo que lê três notas, calcula a média e informa se o aluno está aprovado ou não. – O aluno estará aprovado se sua média for maior ou igual a 7; 18
  19. 19. Exercícios ALGORITMO “exemplo” VAR n1, n2, n3, media: REAL INICIO ESCREVA (“Digite as 3 notas do aluno:”) LEIA (n1, n2, n3) media <- (n1 + n2 + n3) / 3 SE (media >= 7) ENTAO ESCREVA (“O aluno está aprovado”) SENAO ESCREVA (“O aluno está reprovado”) FIMSE FIMALGORITMO 19
  20. 20. Exercícios • Faça um algoritmo que lê dois números e um código que irá identificar uma operação a ser efetuada entre os dois números lidos (de acordo com a tabela abaixo). O algoritmo deverá exibir o resultado da operação escolhida pelo usuário. 20 CÓDIGO OPERAÇÃO 1 ADIÇÃO 2 SUBTRAÇÃO
  21. 21. Exercícios ALGORITMO “exemplo” VAR num1, num2, codigo, resultado: REAL INICIO ESCREVA (“Digite 2 números:”) LEIA (num1, num2) ESCREVA (“Digite o código da operação:”) LEIA (codigo) SE (codigo = 1) ENTAO resultado <- num1 + num2 FIMSE SE (codigo = 2) ENTAO resultado <- num1 - num2 FIMSE ESCREVA (“Resultado: ”, resultado) FIMALGORITMO 21
  22. 22. Exercícios • Faça um algoritmo que lê o salário atual de um funcionário e calcula seu salário reajustado. O percentual de aumento encontra-se na tabela abaixo: 22 SALÁRIO % DE AUMENTO Se for até R$ 300,00 35% Se for acima de R$ 300,00 15%
  23. 23. Exercícios ALGORITMO “exemplo” VAR salario, aumento, salario_novo: REAL INICIO ESCREVA (“Digite seu salário:”) LEIA (salario) SE (salario <= 300) ENTAO aumento <- salario * 0.35 SENAO aumento <- salario * 0.15 FIMSE salario_novo <- salario + aumento ESCREVA (“Salario Reajustado: ”, salario_novo) FIMALGORITMO 23
  24. 24. Exercícios • Faça um algoritmo que receba o valor do salário de uma pessoa e o valor de um financiamento pretendido. Se o financiamento for maior ou igual a 5 vezes o salário da pessoa, o algoritmo deverá escrever “Financiamento concedido”. Senão, deverá escrever “Financiamento negado”. Independente de conceder ou não o financiamento, o algoritmo deverá escrever a frase “Obrigado por nos consultar”; 24
  25. 25. Explore o assunto!
  26. 26. Explore o assunto! • Referências – Introdução aos algoritmos(TONET, B., KOLIVER, C.): Tópico 10; – Disponível em http://www.claudiorodol fo.com/ftc/ap/manual_vi sualg.pdf 26

×