Algoritmos e Programação - 2015.2 - Aula 4

414 visualizações

Publicada em

Algoritmos e Programação - 2015.2 - Aula 4

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
414
No SlideShare
0
A partir de incorporações
0
Número de incorporações
10
Ações
Compartilhamentos
0
Downloads
9
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2015.2 - Aula 4

  1. 1. Algoritmos e Programação Prof.º Thyago Maia 2015.2
  2. 2. Objetivos Aula 4 • Práticas para treinamento em estruturas sequenciais em algoritmos (VisuAlg); 2
  3. 3. Exercícios – Estruturas Sequenciais no VisuAlg
  4. 4. Exercícios  Faça um algoritmo que lê o preço de um produto e a quantidade adquirida por um cliente. O mesmo deverá calcular e exibir o valor total a ser pago; 4
  5. 5. Exercícios ALGORITMO “exercício_1” VAR preco, quantidade, total: REAL INICIO ESCREVAL (“Digite o preço do produto e a quantidade adquirida:”) LEIA (preco, quantidade) total <- preco * quantidade ESCREVA (“Total a ser pago: ”, total) FIMALGORITMO 5
  6. 6. Exercícios  Faça um algoritmo que receba as três notas de um determinado aluno no semestre 2015.2, calcula e exibe sua média final; 6
  7. 7. Exercícios ALGORITMO “exercício_2” VAR nota1, nota2, nota3, media: REAL INICIO ESCREVAL (“Digite as 3 notas do aluno:”) LEIA (nota1, nota2, nota3) media <- (nota1 + nota2 + nota3) / 3 ESCREVA (“Média final: ”, media) FIMALGORITMO 7
  8. 8. Exercícios • Faça um algoritmo que receba o ano de nascimento de uma pessoa e o ano atual, calcule e mostre: – A idade desta pessoa; – Quantos anos ela terá em 2025; 8
  9. 9. Exercícios ALGORITMO “exercicio_3” VAR ano_atual, ano_nascimento: INTEIRO idade_atual, idade_2025: INTEIRO INICIO ESCREVAL (“Digite o ano atual e de nascimento:”) LEIA (ano_atual, ano_nascimento) idade_atual <- ano_atual - ano_nascimento idade_2025 <- 2025 - ano_nascimento ESCREVAL (idade_atual) ESCREVAL (idade_2025) FIMALGORITMO 9
  10. 10. Exercícios • Um funcionário recebe um salário fixo mais 4% de comissão sobre as vendas. Faça um algoritmo que receba o salário fixo do funcionário e o valor de suas vendas, calcule e mostre a comissão e seu salário final. 10
  11. 11. Exemplo ALGORITMO “exercicio_4” VAR salario, valor_vendas: REAL comissao, salario_final: REAL INICIO ESCREVAL(“Digite o salário e o valor das vendas:”) LEIA (salario, valor_vendas) comissao <- valor_vendas * 4/100 salario_final <- salario + comissao ESCREVAL (“Comissão a receber: ”, comissao) ESCREVAL (“Salário Final: ”, salario_final) FIMALGORITMO 11
  12. 12. Explore o assunto!
  13. 13. Explore o assunto! • Referências – Introdução aos algoritmos(TONET, B., KOLIVER, C.): Introdução e tópicos 1 a 9; – Disponível em http://www.claudiorodol fo.com/ftc/ap/manual_vi sualg.pdf 13
  14. 14. Explore o assunto! • Referências – Fundamentos da programação de computadores (ASCENCIO, A. F. G., CAMPOS, E. A. V.): Capítulos 3 (apenas os tópicos sobre algoritmos); 14

×