Algoritmos e Programação - 2015.2 - Aula 3

359 visualizações

Publicada em

Algoritmos e Programação - 2015.2 - Aula 3

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
359
No SlideShare
0
A partir de incorporações
0
Número de incorporações
5
Ações
Compartilhamentos
0
Downloads
17
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2015.2 - Aula 3

  1. 1. Algoritmos e Programação Prof.º Thyago Maia 2015.2
  2. 2. Objetivos Aula 3 • Introduzir alguns conceitos básicos aplicados em Algoritmos e Linguagens de Programação • Exercitar os conceitos apresentados 2
  3. 3. Estrutura sequencial em Portugol
  4. 4. Tipos de algoritmos • Forma básica de um algoritmo no VisuAlg: ALGORITMO “nome” VAR : INICIO FIMALGORITMO 4 VARIÁVEIS INSTRUÇÕES TIPOS DE DADOS
  5. 5. Variáveis
  6. 6. Variáveis • Trata-se de uma representação para uma posição de memória; • Capaz de reter e representar um valor ou expressão; • Tem a finalidade de armazenar dados ou informações de um programa por um curto espaço de tempo; • Tempo de execução; 6
  7. 7. Variáveis • São associados a nomes, chamados identificadores; • Identificadores são usados para referenciar e diferenciar as variáveis em algoritmos; • Identificadores devem ser claros e precisos; 7
  8. 8. Variáveis • Toda variável é associada a um tipo de valor; • O tipo de uma variável identifica o tipo de valor que ela poderá receber; • No Portugol, declaramos variáveis logo após a palavra reservada VAR. 8
  9. 9. Exemplo ALGORITMO “nome” VAR N1, N2, M: REAL INICIO ESCREVA (“Digite dois números: ”) LEIA (N1, N2) M <- N1 * N2 ESCREVA (M) FIMALGORITMO 9
  10. 10. Variáveis • Regras para identificação de variáveis: • Nomes de variáveis não podem ser iguais a palavras reservadas; • Nomes de variáveis devem possuir como primeiro caractere uma letra ou sublinhado; • Os demais caracteres podem ser letras, números ou sublinhado; • Nomes devem ter no máximo 127 caracteres; • Nomes não podem ter espaços em branco; • Não há diferença entre letras maiúsculas e minúsculas; 10
  11. 11. Variáveis • Exemplos: • Identificadores válidos: • Nome, telefone, endereco, idade_mae; • Identificadores inválidos: • 3endereco, algoritmo, títulos; 11
  12. 12. Tipos de dados
  13. 13. Tipos de dados 13 TIPO DESCRIÇÃO INTEIRO Representa valores inteiros Ex.: 2, 5, -3, 100, -151... REAL Representa valores reais Ex.: 5.6, -3.45, 5.00, -10.45... LITERAL Representa texto entre aspas duplas Ex.: “Sport Recife”, “B”, “1234” LOGICO Representa os valores lógicos VERDADEIRO ou FALSO
  14. 14. Exemplo ALGORITMO “exemplo” VAR NOME, ENDERECO: LITERAL IDADE: INTEIRO PESO: REAL EH_SOLTEIRO: LOGICO INICIO NOME <- “Thyago” ENDERECO <- “Rua Tal, 555” IDADE <- 29 EH_SOLTEIRO <- falso FIMALGORITMO 14
  15. 15. Operador de atribuição
  16. 16. Operador de atribuição • Utilizado para inserir um valor ou o resultado de uma expressão em uma variável; • Representado por uma seta apontando para a esquerda (<-); • Só podemos atribuir valores do mesmo tipo da variável; 16
  17. 17. Exemplo ALGORITMO “exemplo” VAR NOME, ENDERECO: LITERAL IDADE: INTEIRO PESO: REAL EH_SOLTEIRO: LOGICO INICIO NOME <- “Thyago” ENDERECO <- “Rua Tal, 555” IDADE <- 29 EH_SOLTEIRO <- falso FIMALGORITMO 17
  18. 18. Exercícios
  19. 19. Exercícios • Classifique os dados abaixo de acordo com seu tipo: 19 0 “abc” “João” 5.7 1012 FALSO -49 342 569 “Lucas” “Verdadeiro” 0.00001 Verdadeiro “444” -78.1
  20. 20. Exercícios • Classifique os dados abaixo de acordo com seu tipo: 20 0 numérico “abc” literal “João” literal 5.7 numérico 101 numérico FALSO lógico -49 numérico 342 numérico 9 numérico “Lucas” literal “Verdadeiro” literal 0.00001 numérico Verdadeiro lógico “444” literal -78.1 numérico
  21. 21. Comandos de entrada e saída no VisuAlg
  22. 22. Comandos de entrada e saída • Comando de entrada (leia) • Utilizado para ler um valor digitado pelo usuário, armazenando o referido valor em uma variável indicada no comando; 22
  23. 23. Comandos de entrada e saída • Comandos de saída (escreva ou escreval) • Utilizados para escrever mensagens ou valores de variáveis na saída padrão; 23
  24. 24. Exemplo • Faça um algoritmo que leia o nome e a idade de um indivíduo, exibindo-os logo em seguida; 24
  25. 25. Exemplo ALGORITMO “exemplo” VAR NOME: LITERAL IDADE: INTEIRO INICIO ESCREVA (“Digite seu nome: ”) LEIA (NOME) ESCREVA (“Digite sua idade”) LEIA (IDADE) ESCREVAL (“Seu nome é ”, NOME) ESCREVAL (“Sua idade: ”, IDADE) FIMALGORITMO 25
  26. 26. Exemplo • Faça um algoritmo que leia dois números inteiros, calcula e exibe a soma entre eles; 26
  27. 27. Exemplo ALGORITMO “exemplo” VAR NUM1, NUM2, SOMA: INTEIRO INICIO ESCREVAL (“Digite dois números: ”) LEIA (NUM1, NUM2) SOMA <- NUM1 + NUM2 ESCREVA (“Resultado da soma: ”, SOMA) FIMALGORITMO 27
  28. 28. Exercícios
  29. 29. Exercícios • Faça um algoritmo que lê o salário de um funcionário, calcula e exibe o novo salário, sabendo que este sofreu um aumento de 25%; 29
  30. 30. Exemplo ALGORITMO “exemplo” VAR sal, aumento, novosal : REAL INICIO ESCREVAL (“Digite seu salário: ”) LEIA (sal) aumento <- sal * 25/100 novosal <- sal + aumento ESCREVA (novosal) FIMALGORITMO 30
  31. 31. Exercícios • Faça um algoritmo que calcule e mostre a área de um triângulo; – Área = (base * altura) / 2 31
  32. 32. Exemplo ALGORITMO “exemplo” VAR base, altura, area : REAL INICIO ESCREVAL (“Digite a base e a altura: ”) LEIA (base, altura) area <- (base * altura) /2 ESCREVA (area) FIMALGORITMO 32
  33. 33. Explore o assunto!
  34. 34. Explore o assunto! • Referências – Introdução aos algoritmos(TONET, B., KOLIVER, C.): Introdução e tópicos 1 a 9; – Disponível em http://www.claudiorodol fo.com/ftc/ap/manual_vi sualg.pdf 34
  35. 35. Explore o assunto! • Referências – Fundamentos da programação de computadores (ASCENCIO, A. F. G., CAMPOS, E. A. V.): Exercícios Propostos, páginas 47, 48, 49; 35

×