Algoritmos e Programação - 2015.2 - Aula 10

267 visualizações

Publicada em

Algoritmos e Programação - 2015.2 - Aula 10

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
267
No SlideShare
0
A partir de incorporações
0
Número de incorporações
4
Ações
Compartilhamentos
0
Downloads
10
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2015.2 - Aula 10

  1. 1. Algoritmos e Programação Prof.º Thyago Maia 2015.2
  2. 2. Objetivos Aula 10 • Apresentar as estruturas de repetição • Apresentar a estrutura de repetição PARA 2
  3. 3. Estrutura de Repetição PARA
  4. 4. PARA • Nesta estrutura, uma variável de controle é inicializada com um valor. Para cada iteração, seu valor é comparado com um valor final; • A execução da lista de instruções se repetirá até que a variável de controle seja maior que o valor final; • Para cada iteração, a variável de controle é incrementada; 4
  5. 5. PARA • Sintaxe: 5 PARA variavel DE val_inicial ATE val_final FACA // Lista de instruções FIMPARA
  6. 6. Exemplo • Faça um algoritmo que escreva os números entre 1 e 5 (incluindo-os). 6
  7. 7. Exemplo ALGORITMO “exemplo” VAR i: INTEIRO INICIO PARA i DE 1 ATE 5 FACA ESCREVAL (i) FIMPARA FIMALGORITMO 7
  8. 8. PARA • Para alterarmos a forma de contagem do laço (crescente ou decrescente) e quanto a variável de controle será incrementada ou decrementada, utilizamos a palavra reservada PASSO, seguida de um valor; • Forma geral: 8 PARA variavel DE val_inicial ATE val_final PASSO valor_passo FACA // Lista de instruções FIMPARA
  9. 9. Exemplo • Faça um algoritmo que escreva os números pares entre 1 e 10. 9
  10. 10. Exemplo ALGORITMO “exemplo” VAR i: INTEIRO INICIO PARA i DE 2 ATE 10 PASSO 2 FACA ESCREVAL (i) FIMPARA FIMALGORITMO 10
  11. 11. Exercícios
  12. 12. Exercícios • Utilizando a estrutura PARA, faça um algoritmo que apresente todos os números ímpares entre 0 a 100. 12
  13. 13. Exercício ALGORITMO “exercicio” VAR i: INTEIRO INICIO PARA i DE 1 ATE 100 PASSO 2 FACA ESCREVAL (i) FIMPARA FIMALGORITMO 13
  14. 14. Exercícios • Faça um algoritmo que lê o sexo de um grupo de 20 pessoas e calcula: – A quantidade total de homens; – A quantidade total de mulheres; 14
  15. 15. Exercício ALGORITMO “exercicio” VAR i, quant_h, quant_m: INTEIRO sexo: LITERAL INICIO PARA i DE 1 ATE 20 FACA ESCREVAL (“Digite seu sexo:”) LEIA (sexo) ESCOLHA(sexo) CASO “M” quant_h <- quant_h + 1 15
  16. 16. Exercício CASO “F” quant_m <- quant_m + 1 FIMESCOLHA FIMPARA ESCREVAL (“Quantidade de homens: ”, quant_h) ESCREVAL (“Quantidade de mulheres: ”, quant_m) FIMALGORITMO 16
  17. 17. Exercícios • Faça um algoritmo que lê a idade de 10 pessoas. Em seguida, o algoritmo deverá apresentar a quantidade de adolescentes (de 12 a 17 anos); 17
  18. 18. Exercício ALGORITMO “exercicio” VAR i, quant, idade: INTEIRO INICIO PARA i DE 1 ATE 20 FACA ESCREVAL (“Digite sua idade:”) LEIA (idade) SE (idade >= 12) E (idade <= 17) ENTAO quant <- quant + 1 FIMSE FIMPARA 18
  19. 19. Exercício ESCREVAL (“Quantidade de adolescentes: ”, quant) FIMALGORITMO 19

×