Algoritmos e Programação - 2013.1 - Aula 8

601 visualizações

Publicada em

Algoritmos e Programação - 2013.1 - Aula 8

0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
601
No SlideShare
0
A partir de incorporações
0
Número de incorporações
1
Ações
Compartilhamentos
0
Downloads
16
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2013.1 - Aula 8

  1. 1. Algoritmos e Programação Prof. Thyago Prof.º Thyago Maia 2013.1
  2. 2. Aula 8Objetivos • Apresentar as estruturas de  p ç repetição • Apresentar a estrutura de  repetição  para..faca ti ã f 2
  3. 3. Para...facaPara faca
  4. 4. Para...faca• Nesta estrutura, uma variável de controle é  inicializada com um valor inicial. Para cada iteração,  seu valor é comparado com um valor final;• A execução da lista de instruções se repetirá até que  a a á e de co o e seja a o que o a o a variável de controle seja maior que o valor final; a;• Para cada iteração a variável de controle é Para cada iteração, a variável de controle é  incrementada; 4
  5. 5. Para...faca• Utilizamos as palavras reservadas para, de, ate, faca e fimpara para formar o laço de  p p ç repetição;• Forma geral:para variavel de val_inicial ate val_finalfaca // Lista de instruções pfimpara 5
  6. 6. Para...faca• Exemplo ‐ Algoritmo que escreve os números  entre 1 e 5:algoritmo “Mostra5”var i: inteiroinicio para i de 1 ate 5 faca escreva(i) fimparafimalgoritmo 6
  7. 7. Para...faca• Para alterarmos a forma de contagem do laço  ( (crescente ou decrescente) e quanto a variável  ) q de controle será incrementada ou  decrementada, utilizamos a palavra reservada  decrementada utilizamos a palavra reservada passo, seguida de um valor;para variavel de val_inicial ate val_finalpasso valor_passo faca• Forma geral: Forma geral: // Lista de instruçõesfimpara 7
  8. 8. Para...faca• Exemplo ‐ Algoritmo que escreve os números  p pares entre 1 e 10:algoritmo “Mostra10par”var i i t i i: inteiroinicio para i de 2 ate 10 passo 2 faca escreva(i) fimparafimalgoritmofi l it 8
  9. 9. Exercícios
  10. 10. Exercícios• Utilizando a estrutura para...faca, escreva um  g q algoritmo que mostre todos os números  ímpares entre 0 a 100.  10
  11. 11. Exercícios• Faça um algoritmo que lê o nome, o peso e o  g p p sexo de um grupo de 20 pessoas e calcula: –AA quantidade total de homens; tid d t t l d h – A quantidade total de mulheres; – A média de peso do grupo;  11
  12. 12. Exercícios• Faça um algoritmo que lê a idade de 10  p pessoas. Em seguida, o algoritmo deverá  g g apresentar: – A idade do mais velho; – A idade do mais novo; – A quantidade de adolescentes (de 12 a 17 anos);  q ( ); 12
  13. 13. Explore o assunto!Explore o assunto!
  14. 14. Explore o assunto! p• Referências – Introdução aos  ç algoritmos(TONET, B.,  KOLIVER, C.): Tópico 15 e  , ) p Exercícios da Página 43; – Disponível em Disponível em   http://www.claudiorodol fo.com/ftc/ap/manual_vi fo com/ftc/ap/manual vi sualg.pdf 14
  15. 15. Explore o assunto! p• Referências – Fundamentos da  programação de  computadores  p (ASCENCIO, A. F. G.,  CAMPOS, E. A. V.):  , ) Exercícios Propostos,  p g páginas 140 a 144; ; 15

×