Algoritmos e Programação     Prof. Thyago     Prof.º Thyago Maia            2013.1
Aula 3Objetivos  • Apresentar a forma básica de um       g             p    algoritmo computacional  • Apresentar alguns r...
Forma geral de um algoritmoForma geral de um algoritmo
Forma geral de um algoritmoAlgoritmo “nome”Var //aqui declaramos as variáveisInicio//Aqui codificamos as instruções//e exp...
Forma geral de um algoritmo• As palavras reservadas algoritmo e fimalgoritmo  delimitam o início e o fim de um algoritmo;•...
Forma geral de um algoritmo• Palavras reservadas fazem parte da sintaxe da      g g  linguagem, e são utilizadas em casos ...
Variáveis
Variáveis• Trata‐se de uma representação para uma   p ç  posição de memória;  • Capaz de reter e representar um valor ou  ...
Variáveis• São associados a nomes, chamados   identificadores;• Id ifi d  Identificadores são usados para referenciar e   ...
Variáveis• Toda variável é associada a um tipo de valor;• O tipo de uma variável identifica o tipo de   valor que ela pode...
Variáveis• Regras para identificação de variáveis:  • Nomes de variáveis não podem ser iguais a palavras     reservadas;  ...
Palavras reservadas• aleatorio, abs, algoritmo, arccos, arcsen, arctan, arquivo, asc,   ate, caracter, caso, compr, copia,...
Variáveis• Exemplos:  • Identificadores válidos:     • Nome telefone endereco idade mae;       Nome, telefone, endereco, i...
Tipos de dadosTipos de dados
Tipos de dados                       p       TIPO                      DESCRIÇÃO                    Representa valores int...
Tipos de dados               p• Exemplo:Algoritmo “d d ”Al   it   “dados”Var nome: literal    idade: inteiro    altura: re...
Operador de atribuiçãoOperador de atribuição
Operador de atribuição               p                 ç• Utilizado para inserir um valor ou o resultado de uma   expressã...
Operador de atribuição              p                 ç• Exemplo:Algoritmo “Al   it   “exemplo”                l ”Var nome...
Operador de atribuição              p                 ç• Exemplo 2 (com erros de atribuição):Algoritmo “Al   it   “exemplo...
Exercícios
Exercícios• Classifique os dados abaixo de acordo com seu tipo:0                “abc”                  “João”5.7          ...
Exercícios• Classifique os dados abaixo de acordo com seu tipo:0 inteiro           “abc” literal        “João” literal5.7 ...
Linhas de comentárioLinhas de comentário
Linhas de comentário• Informação textual para a documentação do     g  algoritmo;;• Ajudam a organizar o algoritmo, tornan...
Linhas de comentário• Exemplo:// Algoritmo que atribui um nome// a uma variávelAlgoritmo “exemplo”Var nome: literalInicio ...
Comandos de entrada e saídaComandos de entrada e saída
Comandos de entrada e saída• Comandos de saída (escreva e escreval)  • Utilizados para escrever mensagens ou valores de   ...
Comandos de entrada e saída• Exemplo:Algoritmo “escreve”VarInicio    escreval(“Minha primeiramensagem”)fimalgoritmo       ...
Comandos de entrada e saída• Exemplo:Algoritmo “escreve_variavel”Var idade: inteiroInicio    idade <- 28          <    esc...
Comandos de entrada e saída• Exemplo:Algoritmo “escreve_variavel_2”Var idade: inteiroInicio    idade <- 28    escreva(“Min...
Comandos de entrada e saída• Comando de entrada (leia)  • Utilizado para ler um valor digitado pelo usuário,     armazenan...
Comandos de entrada e                     saída• Exemplo:Algoritmo “escreve_seu_nome”Var nome: literalInicio    escreval(“...
Comandos de entrada e saída• Exemplo:Algoritmo “soma”           somaVar num1, num2, soma: inteiroInicio     escreva(“Digit...
Exercícios
Exercícios• Faça um algoritmo que lê o nome de um   aluno, suas duas notas no semestre e calcula   sua média final. O algo...
Exercícios• Escreva um algoritmo que calcule a área do   q  quadrado. O usuário deverá digitar o lado de                  ...
Exercícios• Escreva um algoritmo que lê três valores,              p                     p  calcula e apresenta a área do ...
Explore o assunto!Explore o assunto!
Explore o assunto!                    p• Referências  – Introdução aos             ç    algoritmos(TONET, B.,     KOLIVER,...
Explore o assunto!                   p• Referências  – Fundamentos da     programação de     computadores         p    (AS...
Próximos SlideShares
Carregando em…5
×

Algoritmos e Programação - 2013.1 - Aula 3

973 visualizações

Publicada em

Algoritmos e Programação - 2013.1 - Aula 3

0 comentários
2 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
973
No SlideShare
0
A partir de incorporações
0
Número de incorporações
1
Ações
Compartilhamentos
0
Downloads
44
Comentários
0
Gostaram
2
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2013.1 - Aula 3

  1. 1. Algoritmos e Programação Prof. Thyago Prof.º Thyago Maia 2013.1
  2. 2. Aula 3Objetivos • Apresentar a forma básica de um  g p algoritmo computacional • Apresentar alguns recursos  utilizados no desenvolvimento de  tili d d l i t d algoritmos computacionais 2
  3. 3. Forma geral de um algoritmoForma geral de um algoritmo
  4. 4. Forma geral de um algoritmoAlgoritmo “nome”Var //aqui declaramos as variáveisInicio//Aqui codificamos as instruções//e expressõesfimalgoritmo 4
  5. 5. Forma geral de um algoritmo• As palavras reservadas algoritmo e fimalgoritmo delimitam o início e o fim de um algoritmo;• Após a palavra reservada var (acrônimo para Após a palavra reservada var (acrônimo para  variáveis), descrevemos as variáveis e os tipos de  dados que cada a á e ecebe; dados que cada variável recebe;• Entre as palavras reservadas inicio e fimalgoritmo Entre as palavras reservadas inicio e fimalgoritmo definimos a lista de instruções do algoritmo; 5
  6. 6. Forma geral de um algoritmo• Palavras reservadas fazem parte da sintaxe da  g g linguagem, e são utilizadas em casos  específicos; • Ex.: A palavra reservada algoritmo é utilizada no  início de todo algoritmo... APENAS NO INÍCIO! Í 6
  7. 7. Variáveis
  8. 8. Variáveis• Trata‐se de uma representação para uma  p ç posição de memória; • Capaz de reter e representar um valor ou  expressão;• Tem a finalidade de armazenar dados ou  f ld d d d d informações de um programa por um curto  espaço de tempo; • Tempo de execução; Tempo de execução;  8
  9. 9. Variáveis• São associados a nomes, chamados  identificadores;• Id ifi d Identificadores são usados para referenciar e  ã d f i diferenciar as variáveis em algoritmos;• Identificadores devem ser claros e precisos; Identificadores devem ser claros e precisos;  9
  10. 10. Variáveis• Toda variável é associada a um tipo de valor;• O tipo de uma variável identifica o tipo de  valor que ela poderá receber; l l d á b• Declaramos variáveis logo após a palavra  reservada var. reservada var Exemplo: – Var idade: inteiro nota1, nota2: real 10
  11. 11. Variáveis• Regras para identificação de variáveis: • Nomes de variáveis não podem ser iguais a palavras  reservadas; • Nomes de variáveis devem possuir como primeiro  caractere uma letra ou sublinhado; • Os demais caracteres podem ser letras, números ou sublinhado; • Nomes devem ter no máximo 127 caracteres; d á • Nomes não podem ter espaços em branco; • Não há diferença entre letras maiúsculas e  minúsculas;; 11
  12. 12. Palavras reservadas• aleatorio, abs, algoritmo, arccos, arcsen, arctan, arquivo, asc,  ate, caracter, caso, compr, copia, cos, cotan, cronometro,  debug, declare, e, eco, enquanto, entao, escolha, escreva,  debug declare e eco enquanto entao escolha escreva exp, faca, falso, fimalgoritmo, fimenquanto, fimescolha,  , p , p , p , fimfuncao, fimpara, fimprocedimento, fimrepita, fimse,  , funcao, grauprad, inicio, inteiro, interrompa, leia, literal, log,  logico, logn, maiusc, mensagem, minusc, nao, numerico,  numpcarac, ou, outrocaso, para, passo, pausa, pi, pos,  procedimento, quad, radpgrau, raizq, rand, randi, repita, se,  sem, senao, timer, tan, verdadeiro, xou; sem senao timer tan verdadeiro xou; 12
  13. 13. Variáveis• Exemplos: • Identificadores válidos: • Nome telefone endereco idade mae; Nome, telefone, endereco, idade_mae; • Identificadores in álidos Identificadores inválidos: • 3endereco, algoritmo, títulos; 13
  14. 14. Tipos de dadosTipos de dados
  15. 15. Tipos de dados p TIPO DESCRIÇÃO Representa valores inteiros Inteiro Ex.: 2, 5, ‐3, 100, ‐151... Ex.: 2, 5, ‐3, 100, ‐ Representa valores reais Representa valores reaisReal ou numerico Ex.: 10.0, 5.6, ‐ Ex.: 10.0, 5.6, ‐3.45.... Representa texto entre aspas duplasLiteral ou caractere Ex.: “Sport Recife”, “B”, “1234” Ex : Sport Recife B 1234 Representa os valores lógicos  Logico g VERDADEIRO ou FALSO VERDADEIRO FALSO 15
  16. 16. Tipos de dados p• Exemplo:Algoritmo “d d ”Al it “dados”Var nome: literal idade: inteiro altura: real nota1, nota2: realIniciofimalgoritmo 16
  17. 17. Operador de atribuiçãoOperador de atribuição
  18. 18. Operador de atribuição p ç• Utilizado para inserir um valor ou o resultado de uma  expressão em uma variável;• Representado por uma seta apontando para a  esquerda (< ); esquerda (<-);• Só podemos atribuir valores do mesmo tipo da  variável; 18
  19. 19. Operador de atribuição p ç• Exemplo:Algoritmo “Al it “exemplo” l ”Var nome: literal idade: inteiroInicio nome <- “Thyago Maia” idade <- 27fimalgoritmo 19
  20. 20. Operador de atribuição p ç• Exemplo 2 (com erros de atribuição):Algoritmo “Al it “exemplo” l ”Var nome: literal idade: inteiroInicio nome <- Thyago Maia idade <- 27 34 27.34fimalgoritmo 20
  21. 21. Exercícios
  22. 22. Exercícios• Classifique os dados abaixo de acordo com seu tipo:0 “abc” “João”5.7 1012 FALSO-49 342 569“Lucas” “Verdadeiro” 0.00001Verdadeiro “444” -78.1 22
  23. 23. Exercícios• Classifique os dados abaixo de acordo com seu tipo:0 inteiro “abc” literal “João” literal5.7 l5 7 real 101 i t i inteiro FALSO l i logico-49 inteiro 342 inteiro 9 inteiro“Lucas” literal “Verdadeiro” literal 0.00001 realVerdadeiro logico “444” literal -78.1 real 23
  24. 24. Linhas de comentárioLinhas de comentário
  25. 25. Linhas de comentário• Informação textual para a documentação do  g algoritmo;;• Ajudam a organizar o algoritmo, tornando‐o  mais legível; i l í l• São representadas por duas barras normais  (//);• Todo texto digitado após as barras é Todo texto digitado após as barras é  considerado um comentário;• Comentários não são interpretados;  25
  26. 26. Linhas de comentário• Exemplo:// Algoritmo que atribui um nome// a uma variávelAlgoritmo “exemplo”Var nome: literalInicio // Linha que ocorre a atribuição nome <- “Thyago Maia”fimalgoritmo 26
  27. 27. Comandos de entrada e saídaComandos de entrada e saída
  28. 28. Comandos de entrada e saída• Comandos de saída (escreva e escreval) • Utilizados para escrever mensagens ou valores de  variáveis na tela do usuário (no programa  variáveis na tela do usuário (no programa terminal); • E Escreva escreve algo e mantém o cursor na  l é mesma linha, aguardando novas instruções; • Escreval escreva algo e pula uma linha; 28
  29. 29. Comandos de entrada e saída• Exemplo:Algoritmo “escreve”VarInicio escreval(“Minha primeiramensagem”)fimalgoritmo 29
  30. 30. Comandos de entrada e saída• Exemplo:Algoritmo “escreve_variavel”Var idade: inteiroInicio idade <- 28 < escreval(“Minha idade:”) escreva(idade)fimalgoritmo 30
  31. 31. Comandos de entrada e saída• Exemplo:Algoritmo “escreve_variavel_2”Var idade: inteiroInicio idade <- 28 escreva(“Minha idade:”, idade)fimalgoritmo 31
  32. 32. Comandos de entrada e saída• Comando de entrada (leia) • Utilizado para ler um valor digitado pelo usuário,  armazenando o referido valor em uma variável  armazenando o referido valor em uma variável indicada no comando; 32
  33. 33. Comandos de entrada e  saída• Exemplo:Algoritmo “escreve_seu_nome”Var nome: literalInicio escreval(“Digite seu nome”) leia(nome) escreval(“Seu nome é: ”) escreval(nome)fimalgoritmo 33
  34. 34. Comandos de entrada e saída• Exemplo:Algoritmo “soma” somaVar num1, num2, soma: inteiroInicio escreva(“Digite o primeiro número: ”) leia(num1) escreva(“Digite o segundo número: ”) leia(num2) soma <- num1 + num2 escreval(“Resultado: ”, soma)fimalgoritmo g 34
  35. 35. Exercícios
  36. 36. Exercícios• Faça um algoritmo que lê o nome de um  aluno, suas duas notas no semestre e calcula  sua média final. O algoritmo deverá  apresentar o nome digitado e a média  apresentar o nome digitado e a média calculada; 36
  37. 37. Exercícios• Escreva um algoritmo que calcule a área do  q quadrado. O usuário deverá digitar o lado de  g um quadrado para que o algoritmo calcule sua  área, apresentando o logo em seguida; área apresentando‐o logo em seguida; • Area do quadrado = lado2 37
  38. 38. Exercícios• Escreva um algoritmo que lê três valores,  p p calcula e apresenta a área do trapézio; 38
  39. 39. Explore o assunto!Explore o assunto!
  40. 40. Explore o assunto! p• Referências – Introdução aos  ç algoritmos(TONET, B.,  KOLIVER, C.): Introdução  , ) ç e tópicos 4, 5, 7 , 8 e 9 ;  Exercícios da Página 40 e  g 41; – Disponível em Disponível em   http://www.claudiorodol fo.com/ftc/ap/manual_vi fo com/ftc/ap/manual vi sualg.pdf 40
  41. 41. Explore o assunto! p• Referências – Fundamentos da  programação de  computadores  p (ASCENCIO, A. F. G.,  CAMPOS, E. A. V.):  , ) Exercícios Propostos,  p g páginas 47, 48, 49; , , ; 41

×