Função SE (É.NÃO.DISP)

8.510 visualizações

Publicada em

  • Seja o primeiro a comentar

Função SE (É.NÃO.DISP)

  1. 1. Rotina Arquivo Pág. EXCEL DIGITADO O NOME DO CLIENTE E OBTER Função SE(É.NÃO.DISPNEW WAY O NÚMERO DO CADASTRO E VICE VICE-VERSA 01Montar a planilha abaixo: Digitar em C3: =SE(É.NÃO.DISP(PROCV(C2;B10:C1000;2;FALSO) );"NOME NÃO CADASTRADO!";PROCV(C2;B10:C1000;2;FALSOOs campos em branco que seguem a célula amarelaserão utilizados para fazer pesquisas Por estar em branco a célula C2, surge mensagem naComo vamos trabalhar com a função PROCV que célula C3procura um valor na primeira coluna (C) à esquerda deuma tabela e retorna um valor na mesma linha de umacoluna especificada . Precisamos duplicar a coluna de Digitar o nome Jorge na célula C2, correspondenteNome para que a coluna C tenha uma coluna à sua ao número de cadastro 60direitaComo padrão, a tabela, coluna C, deve estarclassificada em ordem crescente
  2. 2. Rotina Arquivo Pág. EXCEL DIGITADO O NOME DO CLIENTE E OBTER Função SE(É.NÃO.DISPNEW WAY O NÚMERO DO CADASTRO E VICE VICE-VERSA 02Digitar um nome não constante do cadastro, para ver a mensagem de alertaDigitar Gabriel em C2:Digitar em C6:=SE(É.NÃO.DISP(PROCV(C5;C10:D1000;2;FALSO));"NOME NÃOCADASTRADO!";PROCV(C5;C10:D1000;2;FALSO)) Por estar em branco a célula C5, surge mensagem na célula C6Digitar em C5 o número 20,correspondente ao número de cadastro do Cliente Antonio
  3. 3. Rotina Arquivo Pág. EXCEL DIGITADO O NOME DO CLIENTE E OBTER Função SE(É.NÃO.DISPNEW WAY O NÚMERO DO CADASTRO E VICE VICE-VERSA 031-ANÁ.LISE DA FÓRMULA DA CÉLULA C3 ANÁ.LISE=SE(É.NÃO.DISP(PROCV(C2;B10:C1000;2;FALSO));"NOME NÃOCADASTRADO!";PROCV(C2;B10:C1000;2;FALSO))2- FUNÇÕES ENVOLVIDASFunção SEFunção É.NÃO.DISPFunção PROCV3-OBSERVAÇÃOO resultado da Função SE depende das funções que lhes são subordinadasOs textos devem ser grafados entre aspas duplasAqui fica um aviso importante, Se for copiada uma fórmula Excel de um arquivo Word, por exemplo e colá no colá-laExcel, as aspas retornam simples e a fórmula não funcionará no Excel. Ou seja, depois de coladas precisa precisa-setransformá-las as aspas simples em aspas duplas. Estando no Excel, selecionar a aspa simples e com a tecla Shift laspressionada, clicar na tecla de aspas duplas do tecladoComo padrão, a tabela deve estar classificada em ordem crescente (numérica ou alfabética). A matriz é B10:C1000mas a tabela (no caso) é No.Cadastro4-SEPARAÇÃO DAS FUNÇÕES SE=SE(É.NÃO.DISP(PROCV(C2;B10:C1000;2;FALSO));"NOME NÃO CADASTRADO!"; PROCV(C2;B10:C1000;2;FALSO)5-SINTAXE DAS FUNÇÕESFunção SEFUNÇÃO SE(teste_lógico;[valor_se_verdadeiro];[valor_se_falso valor_se_falso])FUNÇÃO SE(verifica se uma condição foi satisfeita e retorna um valor se for VERDADEIRO e retorna um outro valor (verificase for FALSO)Função SE(É.NÃO.DISP(PROCV(C2;B10:C1000;2;FALSO));"NOME NÃO CADASTRADO!"; PROCV(C2;B10:C1000;2;FALSO))teste_lógico É.NÃO.DISP(PROCV(C2;B10:C1000;2;FALSO)valor caso verdadeiro NOME NÃO CADASTRADO!valor caso falso) PROCV(C2;B10:C1000;2;FALSO)FUNÇÃO É.NÃO.DISPÉ.NÃO.DISP(valor)É.NÃO.DISP(verifica se um valor é #N/D e retorna não VERDADEIRO ou FALSO)FUNÇÃO PROCVFUNÇÃO PROCV(valor_procurado;matriz_tabela;número_índice_coluna número_índice_coluna;[procurar_intervalo])FUNÇÃO PROCV(procura um valor na primeira coluna à esquerda de uma tabela e retorna um valor na mesma (procuralinha de uma coluna especificada. Como padrão, a tabela deve estar classificada em ordem crescente (numérica oualfabética)Primeira Função PROCVC2;B10:C1000;2;FALSOvalor_procurado C2 =Jorgematriz_tabela B10:C1000número_índice_coluna 2 (segunda coluna)[procurar_intervalo]) FALSO (Exige coincidência perfeita)
  4. 4. Rotina Arquivo Pág. EXCEL DDIGITADO O NOME DO CLIENTE E OBTER Função SE(É.NÃO.DISPNEW WAY O NÚMERO DO CADASTRO E VICE VICE-VERSA 04.Segunda Função PROCVC2; B10:C1000;2;FALSO)valor_procurado C2 =Jorgematriz_tabela B10:C1000número_índice_coluna 2 (segunda coluna coluna)[procurar_intervalo]) FALSO6- LEITURA DA FÓRMULA DA CÉLULA C3=SE(É.NÃO.DISP(PROCV(C2;B10:C1000;2;FALSO));"NOME NÃOCADASTRADO!";PROCV(C2;B10:C1000;2;FALSO))CADASTRADO!";PROCV(C2;B10:C1000;2;FALSO)A função SE depende do resultado das Funções É.NÃO.DISP e PROCVA função É.NÃO.DISP depende do resultado da Função PROCVAssim, vamos começar pela Função PROCVEssa é a técnica de análise; começar pela função mais interna, extrair seu resultado e passar para a Função externaque a contém. É como se estivesse trabalhando com uma equação matemática, achando as incógnitas até obter umnúmero final. No nosso caso, é chegar até o valor da célula onde a fórmula foi aplicadaA Segunda Função PROCV parte com o valor procurado C2=Jorge e, lê a matriz B10:C1000 na sua procura eretorna VERDADEIRO em C15. Assim, procura o valor da coluna 2 (No. Cadastro) que valor faz par com Jorge, queno caso é 60A Primeira Função PROCV também chega no mesmo valor 60 achado pela Segunda Função PROCVEsse valor 60 é gravado em C3 onde a formula foi acionadaA Função NÃO.DISP vai se envolver quando for digitado um nome ou número de cadastro diferente do existente natabelaSeja o exemplo abaixo que foi digitado o nome Gabriel não cadastradoLEITURA DA FÓRMULA DA CÉLULA C3 sendo digitado Gabriel=SE(É.NÃO.DISP(PROCV(C2;B10:C1000;2;FALSO));"NOME NÃOCADASTRADO!";PROCV(C2;B10:C1000;2;FALSO))CADASTRADO!";PROCV(C2;B10:C1000;2;FALSO)Ao ser digitado Gabriel, a Função NÃO.DISP retornou VERDADEIRO e a Função SE pegou ovalor_se_verdadeiro = NOME NÃO CADASTRADO!Esse aviso de alerta foi grafado em C3 onde a fórmula foi previamente acionadaSe procurar Jorge consegue achar: Jorge JORGE JOrgEMas não acharia Jorg, JORG ou jorg1-ANALISE DA FÓRMULA DA CÉLULA C6 ANALISEO processo é semelhante ao da análise da célula C3,sendo que um dado o Nome acha o No. De Cadastro o outrodado o No. de Cadastro acha o Nome

×