Comment paramétrer une connexion adsl sur un modem

CONNECT Tunisia
CONNECT Tunisialooking for better opportunities em CONNECT Tunisia
comment paramétrer une
connexion ADSL sur un modem-
routeur CISCO 837
Sommaire
Introduction
1 Connexion au routeur Cisco
1.1 Attribution d'un mot de passe par CRWS
1.2 Connexion avec Teraterm pro web
1.3 Changement du nom du routeur
2 Configuration des interfaces du routeur
2.1 ATM0
2.2 DIALER0
2.3 ETHERNET0
2.4 Paramétrer la route par défaut
2.5 Configuration de la NAT
3 Configuration des services supplémentaires
3.1 Serveur DHCP
3.2 Service DynDNS
3.3 Serveur SSH
4 Sécuriser le routeur
4.1 Le serveur HTTP
4.2 Antispoofing
4.3 ICMP et IP
5 Sauvegarde de la configuration et de l'IOS
5.1 Sauvegarder sur un serveur TFTP distant
5.2 Fichier de configuration final
Conclusion
Introduction
Cet article va vous expliquer comment paramétrer une connexion ADSL sur un modem-
routeur CISCO 837.
Le routeur utilisé est équipé d’IOS 12.4.
La connexion Internet est une Wanadoo haut-débit max (8Mb/s en débit montant et 256k/s
en débit descendant). L’adresse IP WAN est fournie par un serveur DHCP de Wanadoo.
1 Connexion au routeur Cisco
1.1 Attribution d'un mot de passe par CRWS
Ouvrez votre navigateur web sur l’adresse http://10.10.10.1
Lorsque vous êtes sur la page principale, cliquer sur Router password et entrez un mot de
passe de connexion.
Cliquez sur Apply pour terminer le paramétrage.
Fermer la fenêtre.
1.2 Connexion avec Teraterm pro web
La connexion se fait par TELNET. Connectez-vous sur l’adresse IP 10.10.10.1.
En username entrez Router et en mot de passe celui que vous avez enregistré.
1.3 Changement du nom du routeur
En premier lieu, nous changeons le nom du routeur en CISCOADSL.
Router>en
Password:
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname CISCOADSL
CISCOADSL(config)#
2 Configuration des interfaces du routeur
2.1 ATM0
On indique que l’on souhaite utiliser une adresse IP fournie par un serveur DHCP du fournisseur
d’accès et qu’elle soit positionnée sur l’interface dialer0.
On paramètre l’interface ATM pour utiliser le circuit virtuel 8/35.
On spécifie que l’on utilise PPPOE et que l’on utilisera les paramètres du pool 1.
CISCOADSL(config)#interface ATM0
CISCOADSL(config-if)#ip dhcp client client-id dialer0
CISCOADSL(config-if)#pvc 8/35
CISCOADSL(config-if-atm-vc)#pppoe-client dial-pool-number 1
CISCOADSL(config-if-atm-vc)#exit
CISCOADSL(config-if)#exit
2.2 DIALER0
L’adresse IP de dialer0 sera négociée par PPP.
On configure l’authentification PPP CHAP en utilisant le nom d’utilisateur et le mot de passe
fourni par le fournisseur d’accès. L’option callin réalise une one-way authentication. Cela
veut dire que pour la connexion s’établie, il suffit que notre équipement s’authentifie vis-à-vis
de l’équipement du fournisseur d’accès.
On récupère les adresses des serveurs DNS Wanadoo avec la commande ppp ipcp dns
request.
L’interface dialer0 est définie comme l’interface outside pour la configuration du NAT.
CISCOADSL(config)#interface dialer0
CISCOADSL(config-if)#ip address negotiated
CISCOADSL(config-if)#ip mtu 1492
CISCOADSL(config-if)#ip nat outside
CISCOADSL(config-if)#encapsulation ppp
CISCOADSL(config-if)#ip tcp adjust-mss 1452
CISCOADSL(config-if)#dialer pool 1
CISCOADSL(config-if)#dialer remote-name wanadoo
CISCOADSL(config-if)#dialer-group 1
CISCOADSL(config-if)#ppp authentication chap callin
CISCOADSL(config-if)#ppp chap hostname login_FAI
CISCOADSL(config-if)#ppp chap password 0 password_FAI
CISCOADSL(config-if)#ppp ipcp dns request
CISCOADSL(config-if)#exit
2.3 ETHERNET0
L’interface ethernet0 est définie comme l’interface inside pour la configuration du NAT.
CISCOADSL(config)#interface ethernet0
CISCOADSL(config-if)#ip nat inside
CISCOADSL(config-if)#exit
2.4 Paramétrer la route par défaut
On configure la route par défaut sur l’interface dialer0
CISCOADSL(config)#ip route 0.0.0.0 0.0.0.0 dialer0
2.5 Configuration de la NAT
La première ligne définie que les adresses inside autorisés sont définies par l’access-list 101.
L’access 101 autorise tout les paquets IP provenant du sous-réseau 10.10.10.0/24.
Dialer-list autorise le protocole IP sur le dialer group numéro 1 (ATM0).
CISCOADSL(config)#ip nat inside source list 101 interface dialer0 overload
CISCOADSL(config)#access-list 101 permit ip 10.10.10.0 0.255.255.255 any
CISCOADSL(config)#dialer-list 1 protocol ip permit
3 Configuration des services supplémentaires
3.1 Serveur DHCP
On crée un pool DHCP qui porte le nom CLIENT.
La commande import all permet d’ajouter la liste des serveurs DNS reçues par le fournisseur
d’accès dans la configuration du serveur DHCP.
Le sous-réseau attribuable est 10.10.10.0/24.
La passerelle par défaut des clients sera 10.10.10.1.
Le bail est positionné à 50 jours.
CISCOADSL(config)#ip dhcp pool CLIENT
CISCOADSL(dhcp-config)#import all
CISCOADSL(dhcp-config)#network 10.10.10.0 255.0.0.0
CISCOADSL(dhcp-config)#default-router 10.10.10.1
CISCOADSL(dhcp-config)#lease 50 0
CISCOADSL(dhcp-config)#exit
3.2 Service DynDNS
Si vous possédez un dyndns et que vous souhaitez le mettre à jour depuis votre routeur
CISCO, définissez la méthode de mise à jour par HTTP.
Spécifiez l’adresse HTTP avec testlogin qui est votre login et testpassword votre mot de passe
chez dyndns. La variable myip est volontairement laissée à vide pour que ce soit l’adresse IP
de dialer0 qui soit automatiquement positionné.
Les mises à jour sont effectuées toutes les 6 heures.
Pour faire le ?, taper simultanément sur les touches CTRL et v puis taper ?
CISCOADSL(config)#ip ddns update method myupdate
CISCOADSL(DDNS-update-method)# http
CISCOADSL(DDNS-HTTP)# add http://testlogin:testpassword@cisco.dyndns.org/nic/update?
system=dyndns&hostname=cisco.gotdns.org&myip=
CISCOADSL(DDNS-HTTP)# interval maximum O 6 0 0
CISCOADSL(DDNS-update-method)# exit
CISCOADSL(config)# interface dialer0
CISCOADSL(config-if)# ip ddns update hostname cisco.dyndns.org
CISCOADSL(config-if) ip ddns update myupdate
CISCOADSL(config-if)# exit
3.3 Serveur SSH
On veut que le serveur SSH de la machine 10.10.10.2 soit accessible depuis Internet.
On mappe le port 22 (SSH) de l’interface dialer0 sur l’adresse 10.10.10.2 en inside.
CISCOADSL(config)#ip nat inside source static tcp 10.10.10.2 22 interface dialer0 22
4 Sécuriser le routeur
4.1 Le serveur HTTP
Par défaut, l’interface de configuration CRWS est disponible depuis n’importe quel réseau.
On crée une access-list qui autorise seulement les administrateurs du réseau 10.10.10.0/24 à
s’y connecter.
CISCOADSL(config)#access-list 24 permit 10.10.10.0 0.0.0.255
CISCOADSL(config)#access-list 24 deny any
CISCOADSL(config)#ip http access-class 24
4.2 Antispoofing
On active la protection uRPF contre le spoofing.
CISCOADSL(config)#int dialer0
CISCOADSL(config-if)#ip verify unicast reverse-path
CISCOADSL(config-if)#^Z
4.3 ICMP et IP
Tous les paquets ICMP sont bloqués sur dialer0 à l’exception du MTU discovery.
Les paquets IP redirects, broadcast, mask-reply, unreachables et le source routing sont
rejetés.
CISCOADSL(config)#access-list 102 permit icmp any any 3 4
CISCOADSL(config)#access-list 102 deny icmp any any
CISCOADSL(config)#access-list 102 permit ip any any
CISCOADSL(config)#interface dialer0
CISCOADSL(config-if)#ip access-group 102 in
CISCOADSL(config-if)#no ip redirects
CISCOADSL(config-if)#no ip directed broadcast
CISCOADSL(config-if)#no ip mask-reply
CISCOADSL(config-if)#no ip unreachables
CISCOADSL(config-if)#no ip source-route
CISCOADSL(config)#exit
5 Sauvegarde de la configuration et de l'IOS
5.1 Sauvegarder sur un serveur TFTP distant
On sauvegarde sur un serveur TFTP distant, l’IOS et la configuration du routeur CISCO.
CISCOADSL#copy nvram:startup-config tftp://10.10.10.2/ciscoadsl-config
Address or name of remote host [10.10.10.2]?
Destination filename [ciscoadsl-config]?
!!
2354 bytes copied in 1.500 secs (1569 bytes/sec)
CISCOADSL#
CISCOADSL#copy flash:c837-k9o3sy6-mz.124-1a.bin tftp://10.10.10.2/c837-k9o3sy6-mz.124-
1a.bin
Address or name of remote host [10.10.10.2]?
Destination filename [c837-k9o3sy6-mz.124-1a.bin]?
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
9810496 bytes copied in 69.932 secs (140286 bytes/sec)
CISCOADSL#
5.2 Fichier de configuration final
Current configuration : 2577 bytes
!
version 12.4
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname CISCOADSL
!
boot-start-marker
boot-end-marker
!
memory-size iomem 5
enable secret 5 PASSWORD
!
no aaa new-model
!
resource policy
!
ip subnet-zero
no ip source-route
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool CLIENT
import all
network 10.0.0.0 255.0.0.0
default-router 10.10.10.1
lease 50
!
!
ip cef
no ip ips deny-action ips-interface
ip ddns update method myupdate
HTTP
add
http://testlogin:testpassword@cisco.gotdns.org/nic/update?system=dyndns&hostname=cisc
o.gotdns.org&myip=
interval maximum 0 6 0 0
!
!
!
!
username Router password 7 PASSWORD
!
!
!
!
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
hold-queue 100 out
!
interface Ethernet2
no ip address
shutdown
hold-queue 100 out
!
interface ATM0
ip dhcp client client-id Dialer0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface FastEthernet1
duplex auto
speed auto
!
interface FastEthernet2
duplex auto
speed auto
!
interface FastEthernet3
duplex auto
speed auto
!
interface FastEthernet4
duplex auto
speed auto
!
interface Dialer0
ip ddns update hostname cisco.gotdns.org
ip ddns update myupdate
ip address negotiated
ip access-group 102 in
ip verify unicast reverse-path
no ip redirects
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer remote-name wanadoo
dialer-group 1
ppp authentication chap callin
ppp chap hostname login_FAI
ppp chap password 7 password_FAI
ppp ipcp dns request
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 24
no ip http secure-server
!
ip nat inside source list 101 interface Dialer0 overload
ip nat inside source static tcp 10.10.10.2 30777 interface Dialer0 30777
!
access-list 23 permit 10.10.10.0 0.0.0.255
access-list 24 permit 10.10.10.0 0.0.0.255
access-list 24 deny any
access-list 101 permit ip 10.0.0.0 0.255.255.255 any
access-list 102 permit icmp any any packet-too-big
access-list 102 deny icmp any any
access-list 102 permit ip any any
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
line con 0
exec-timeout 120 0
no modem enable
stopbits 1
ine aux 0
line vty 0 4
access-class 23 in
exec-timeout 120 0
login local
length 0
!
scheduler max-task-time 5000
end
Conclusion
En suivant chaque étape de l'article, votre routeur cisco 837 sera opérationnel pour un accès
ADSL et disposera d'une sécurité minimum contre les attaques provenant de votre réseau
local et d'Internet. Un serveur SSH est accessible pour vous permettre d'administrer votre
réseau depuis la connexion ADSL de votre routeur.

Recomendados

Ccna4 por
Ccna4Ccna4
Ccna4Farah Zouaki
6.4K visualizações97 slides
E4 pt act_7_5_1 por
E4 pt act_7_5_1E4 pt act_7_5_1
E4 pt act_7_5_1Simo Alaoui
1.7K visualizações5 slides
Ccna 4 configuration-de_frame_ relay_hub_and_spoke por
Ccna 4 configuration-de_frame_ relay_hub_and_spokeCcna 4 configuration-de_frame_ relay_hub_and_spoke
Ccna 4 configuration-de_frame_ relay_hub_and_spokeTouré Kunda
786 visualizações2 slides
Cisco et-le-simulateur-packet-tracer por
Cisco et-le-simulateur-packet-tracerCisco et-le-simulateur-packet-tracer
Cisco et-le-simulateur-packet-tracerMed Ali Bhs
3.4K visualizações7 slides
Routeurs cisco-parametres-de-base-17126-l0xxp7 por
Routeurs cisco-parametres-de-base-17126-l0xxp7Routeurs cisco-parametres-de-base-17126-l0xxp7
Routeurs cisco-parametres-de-base-17126-l0xxp7basschuck2411
626 visualizações8 slides
Corrigé cisco wissamben por
Corrigé cisco wissambenCorrigé cisco wissamben
Corrigé cisco wissambenWissam Bencold
20.6K visualizações132 slides

Mais conteúdo relacionado

Mais procurados

Les commandes CISCO (routeur) por
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)EL AMRI El Hassan
8.4K visualizações4 slides
Lire les tables de routage por
Lire les tables de routageLire les tables de routage
Lire les tables de routagebelhadj_rached
14.4K visualizações29 slides
Services IP por
Services IPServices IP
Services IPThomas Moegli
2.3K visualizações113 slides
Astuces cisco por
Astuces ciscoAstuces cisco
Astuces ciscoCONNECT Tunisia
713 visualizações6 slides
Acl cisco por
Acl ciscoAcl cisco
Acl ciscoBou Diop
2.2K visualizações16 slides
Routage por
RoutageRoutage
RoutageSirine Ibrahim
4.1K visualizações49 slides

Mais procurados(20)

Les commandes CISCO (routeur) por EL AMRI El Hassan
Les commandes CISCO (routeur)Les commandes CISCO (routeur)
Les commandes CISCO (routeur)
EL AMRI El Hassan8.4K visualizações
Lire les tables de routage por belhadj_rached
Lire les tables de routageLire les tables de routage
Lire les tables de routage
belhadj_rached14.4K visualizações
Services IP por Thomas Moegli
Services IPServices IP
Services IP
Thomas Moegli2.3K visualizações
Astuces cisco por CONNECT Tunisia
Astuces ciscoAstuces cisco
Astuces cisco
CONNECT Tunisia713 visualizações
Acl cisco por Bou Diop
Acl ciscoAcl cisco
Acl cisco
Bou Diop2.2K visualizações
Routage por Sirine Ibrahim
RoutageRoutage
Routage
Sirine Ibrahim4.1K visualizações
Travaux pratiques configuration du routage entre réseaux locaux virtuels por Mohamed Keita
Travaux pratiques   configuration du routage entre réseaux locaux virtuelsTravaux pratiques   configuration du routage entre réseaux locaux virtuels
Travaux pratiques configuration du routage entre réseaux locaux virtuels
Mohamed Keita3K visualizações
Configuration de base_router por CONNECT Tunisia
Configuration de base_routerConfiguration de base_router
Configuration de base_router
CONNECT Tunisia2K visualizações
Fr E Routing Slm V40 por boukna abdou
Fr E Routing Slm V40Fr E Routing Slm V40
Fr E Routing Slm V40
boukna abdou18.1K visualizações
1254851542chap1 interconnexion routage por Simo Qb
1254851542chap1 interconnexion routage1254851542chap1 interconnexion routage
1254851542chap1 interconnexion routage
Simo Qb1.4K visualizações
3 switchport securité por medalaa
3 switchport securité3 switchport securité
3 switchport securité
medalaa1K visualizações
Résumé vlsm et cidr por Boubaker KHERFALLAH
Résumé vlsm et cidrRésumé vlsm et cidr
Résumé vlsm et cidr
Boubaker KHERFALLAH47.9K visualizações
Version Final Presentation por Bedreddine Zarrouk
Version Final PresentationVersion Final Presentation
Version Final Presentation
Bedreddine Zarrouk931 visualizações
Tutoriel nat pat por Dimitri LEMBOKOLO
Tutoriel nat patTutoriel nat pat
Tutoriel nat pat
Dimitri LEMBOKOLO4K visualizações
Rapport projet por Khadija Dija
Rapport projetRapport projet
Rapport projet
Khadija Dija7.4K visualizações
Ccna4 por CONNECT Tunisia
Ccna4Ccna4
Ccna4
CONNECT Tunisia1.3K visualizações
EIGRP - EIGRP sur frame relay por mdyabi
EIGRP - EIGRP sur frame relayEIGRP - EIGRP sur frame relay
EIGRP - EIGRP sur frame relay
mdyabi1.2K visualizações
Protocole OSPF por Thomas Moegli
Protocole OSPFProtocole OSPF
Protocole OSPF
Thomas Moegli5.5K visualizações
Spanning-Tree por Thomas Moegli
Spanning-TreeSpanning-Tree
Spanning-Tree
Thomas Moegli3.4K visualizações
Maintenance du système Linux por EL AMRI El Hassan
Maintenance du système LinuxMaintenance du système Linux
Maintenance du système Linux
EL AMRI El Hassan2.5K visualizações

Destaque

Guide Routeur | Technicolor TD5130 por
Guide Routeur | Technicolor TD5130Guide Routeur | Technicolor TD5130
Guide Routeur | Technicolor TD5130Maroc Telecom
93.4K visualizações9 slides
Les Satellites Geostationnaires De Telecommunication por
Les Satellites Geostationnaires De TelecommunicationLes Satellites Geostationnaires De Telecommunication
Les Satellites Geostationnaires De TelecommunicationCrissu
5.9K visualizações21 slides
Télécommunication par satellite et la technologie vsat por
Télécommunication par satellite et la technologie vsatTélécommunication par satellite et la technologie vsat
Télécommunication par satellite et la technologie vsatjosepkap
16.7K visualizações28 slides
Vsat por
VsatVsat
VsatHarshavardhan K
7.7K visualizações29 slides
Vsat por
VsatVsat
VsatAmit Pandey
25.5K visualizações18 slides
Satellites por
SatellitesSatellites
SatellitesDeo Mbanzulu
1.3K visualizações8 slides

Destaque(20)

Guide Routeur | Technicolor TD5130 por Maroc Telecom
Guide Routeur | Technicolor TD5130Guide Routeur | Technicolor TD5130
Guide Routeur | Technicolor TD5130
Maroc Telecom93.4K visualizações
Les Satellites Geostationnaires De Telecommunication por Crissu
Les Satellites Geostationnaires De TelecommunicationLes Satellites Geostationnaires De Telecommunication
Les Satellites Geostationnaires De Telecommunication
Crissu5.9K visualizações
Télécommunication par satellite et la technologie vsat por josepkap
Télécommunication par satellite et la technologie vsatTélécommunication par satellite et la technologie vsat
Télécommunication par satellite et la technologie vsat
josepkap16.7K visualizações
Vsat por Harshavardhan K
VsatVsat
Vsat
Harshavardhan K7.7K visualizações
Vsat por Amit Pandey
VsatVsat
Vsat
Amit Pandey25.5K visualizações
Satellites por Deo Mbanzulu
SatellitesSatellites
Satellites
Deo Mbanzulu1.3K visualizações
Formation vsat por Deo Mbanzulu
Formation vsatFormation vsat
Formation vsat
Deo Mbanzulu17.1K visualizações
Instrumentation por Dhaval panchal
Instrumentation Instrumentation
Instrumentation
Dhaval panchal1.1K visualizações
Telecom in West Africa: Trends and Challenges por senejug
Telecom in West Africa: Trends and ChallengesTelecom in West Africa: Trends and Challenges
Telecom in West Africa: Trends and Challenges
senejug1.4K visualizações
Pdf tp4 mesure_antennes por rachid Dakir
Pdf tp4 mesure_antennesPdf tp4 mesure_antennes
Pdf tp4 mesure_antennes
rachid Dakir1.3K visualizações
Logiciel de routage de circuit imprimé EAGLE por webmasterref68
Logiciel de routage de circuit imprimé EAGLELogiciel de routage de circuit imprimé EAGLE
Logiciel de routage de circuit imprimé EAGLE
webmasterref688K visualizações
VSAT Technology por Tariq Tauheed
VSAT TechnologyVSAT Technology
VSAT Technology
Tariq Tauheed25.6K visualizações
Tp snmp-packet-tracer por Chris Dogny
Tp snmp-packet-tracerTp snmp-packet-tracer
Tp snmp-packet-tracer
Chris Dogny3.1K visualizações
Info reseaux por hassan1488
Info reseaux Info reseaux
Info reseaux
hassan14883.7K visualizações
Vsat basics - an ExploreGate tutorial por Orit Fredkof
Vsat basics - an ExploreGate tutorialVsat basics - an ExploreGate tutorial
Vsat basics - an ExploreGate tutorial
Orit Fredkof10.1K visualizações
Vsat Training por Syed Khurram Iqbal
Vsat  TrainingVsat  Training
Vsat Training
Syed Khurram Iqbal18.1K visualizações
Comment augmenter votre debit internet por letamis
Comment augmenter votre debit internetComment augmenter votre debit internet
Comment augmenter votre debit internet
letamis22K visualizações
Plc presentation por PANKAJ BADGUJAR
Plc presentation Plc presentation
Plc presentation
PANKAJ BADGUJAR49.8K visualizações

Similar a Comment paramétrer une connexion adsl sur un modem

Adsl cisco por
Adsl ciscoAdsl cisco
Adsl ciscoCONNECT Tunisia
551 visualizações10 slides
soutenance.ppt por
soutenance.pptsoutenance.ppt
soutenance.pptAlbertbenBarry1
43 visualizações34 slides
soutenance.ppt por
soutenance.pptsoutenance.ppt
soutenance.pptamalbenramdhane
5 visualizações34 slides
Configuration de-base-d por
Configuration de-base-dConfiguration de-base-d
Configuration de-base-dNabil EL KASSOUMI
255 visualizações10 slides
Vpn por
VpnVpn
VpnZakaria Loubeidi
980 visualizações15 slides
configuration vpn-ipsec-routeur por
 configuration vpn-ipsec-routeur configuration vpn-ipsec-routeur
configuration vpn-ipsec-routeurJULIOR MIKALA
2.6K visualizações65 slides

Similar a Comment paramétrer une connexion adsl sur un modem(20)

Adsl cisco por CONNECT Tunisia
Adsl ciscoAdsl cisco
Adsl cisco
CONNECT Tunisia551 visualizações
soutenance.ppt por AlbertbenBarry1
soutenance.pptsoutenance.ppt
soutenance.ppt
AlbertbenBarry143 visualizações
soutenance.ppt por amalbenramdhane
soutenance.pptsoutenance.ppt
soutenance.ppt
amalbenramdhane5 visualizações
Configuration de-base-d por Nabil EL KASSOUMI
Configuration de-base-dConfiguration de-base-d
Configuration de-base-d
Nabil EL KASSOUMI255 visualizações
configuration vpn-ipsec-routeur por JULIOR MIKALA
 configuration vpn-ipsec-routeur configuration vpn-ipsec-routeur
configuration vpn-ipsec-routeur
JULIOR MIKALA2.6K visualizações
Les Vpn por medalaa
Les VpnLes Vpn
Les Vpn
medalaa2.2K visualizações
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x por Alphorm
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.xAlphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
Alphorm.com Formation Certification NSE4 : Fortinet Fortigate Security 6.x
Alphorm46.1K visualizações
EIGRP - Configuration por mdyabi
EIGRP - ConfigurationEIGRP - Configuration
EIGRP - Configuration
mdyabi1.2K visualizações
Dhcp3 por TECOS
Dhcp3Dhcp3
Dhcp3
TECOS408 visualizações
TP2_dhcp_linux-ubuntu-2023.pdf por aymanmikh7
TP2_dhcp_linux-ubuntu-2023.pdfTP2_dhcp_linux-ubuntu-2023.pdf
TP2_dhcp_linux-ubuntu-2023.pdf
aymanmikh73 visualizações
VPN site-to-site.pdf por gorguindiaye
VPN site-to-site.pdfVPN site-to-site.pdf
VPN site-to-site.pdf
gorguindiaye481 visualizações
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2) por SmartnSkilled
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
Support formation vidéo : Cisco CCNA Routing & Switching - Examen (200-125) (2)
SmartnSkilled742 visualizações
Ccna 2-module-2-v4 por Siham Tatiggit
Ccna 2-module-2-v4Ccna 2-module-2-v4
Ccna 2-module-2-v4
Siham Tatiggit615 visualizações
Tout atm por vanyvan10
Tout atmTout atm
Tout atm
vanyvan10868 visualizações
Réseau MiNET por Guillaume Rose
Réseau MiNETRéseau MiNET
Réseau MiNET
Guillaume Rose544 visualizações
DHCP sous fedora por Souhaib El
DHCP sous fedora DHCP sous fedora
DHCP sous fedora
Souhaib El3.2K visualizações
Admin reseaux sous linux cours 3 por Stephen Salama
Admin reseaux sous linux   cours 3Admin reseaux sous linux   cours 3
Admin reseaux sous linux cours 3
Stephen Salama447 visualizações
MPLS VPN por Wilfried Tiani
MPLS VPNMPLS VPN
MPLS VPN
Wilfried Tiani3.5K visualizações
Dhcp serrver dofara roger cyrus por Roger Cyrus DOFARA
Dhcp serrver dofara roger cyrusDhcp serrver dofara roger cyrus
Dhcp serrver dofara roger cyrus
Roger Cyrus DOFARA74 visualizações

Comment paramétrer une connexion adsl sur un modem

  • 1. comment paramétrer une connexion ADSL sur un modem- routeur CISCO 837
  • 2. Sommaire Introduction 1 Connexion au routeur Cisco 1.1 Attribution d'un mot de passe par CRWS 1.2 Connexion avec Teraterm pro web 1.3 Changement du nom du routeur 2 Configuration des interfaces du routeur 2.1 ATM0 2.2 DIALER0 2.3 ETHERNET0 2.4 Paramétrer la route par défaut 2.5 Configuration de la NAT 3 Configuration des services supplémentaires 3.1 Serveur DHCP 3.2 Service DynDNS 3.3 Serveur SSH 4 Sécuriser le routeur 4.1 Le serveur HTTP 4.2 Antispoofing 4.3 ICMP et IP 5 Sauvegarde de la configuration et de l'IOS 5.1 Sauvegarder sur un serveur TFTP distant 5.2 Fichier de configuration final Conclusion
  • 3. Introduction Cet article va vous expliquer comment paramétrer une connexion ADSL sur un modem- routeur CISCO 837. Le routeur utilisé est équipé d’IOS 12.4. La connexion Internet est une Wanadoo haut-débit max (8Mb/s en débit montant et 256k/s en débit descendant). L’adresse IP WAN est fournie par un serveur DHCP de Wanadoo. 1 Connexion au routeur Cisco 1.1 Attribution d'un mot de passe par CRWS Ouvrez votre navigateur web sur l’adresse http://10.10.10.1 Lorsque vous êtes sur la page principale, cliquer sur Router password et entrez un mot de passe de connexion. Cliquez sur Apply pour terminer le paramétrage. Fermer la fenêtre.
  • 4. 1.2 Connexion avec Teraterm pro web La connexion se fait par TELNET. Connectez-vous sur l’adresse IP 10.10.10.1. En username entrez Router et en mot de passe celui que vous avez enregistré. 1.3 Changement du nom du routeur En premier lieu, nous changeons le nom du routeur en CISCOADSL. Router>en Password: Router#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname CISCOADSL CISCOADSL(config)# 2 Configuration des interfaces du routeur 2.1 ATM0 On indique que l’on souhaite utiliser une adresse IP fournie par un serveur DHCP du fournisseur d’accès et qu’elle soit positionnée sur l’interface dialer0.
  • 5. On paramètre l’interface ATM pour utiliser le circuit virtuel 8/35. On spécifie que l’on utilise PPPOE et que l’on utilisera les paramètres du pool 1. CISCOADSL(config)#interface ATM0 CISCOADSL(config-if)#ip dhcp client client-id dialer0 CISCOADSL(config-if)#pvc 8/35 CISCOADSL(config-if-atm-vc)#pppoe-client dial-pool-number 1 CISCOADSL(config-if-atm-vc)#exit CISCOADSL(config-if)#exit 2.2 DIALER0 L’adresse IP de dialer0 sera négociée par PPP. On configure l’authentification PPP CHAP en utilisant le nom d’utilisateur et le mot de passe fourni par le fournisseur d’accès. L’option callin réalise une one-way authentication. Cela veut dire que pour la connexion s’établie, il suffit que notre équipement s’authentifie vis-à-vis de l’équipement du fournisseur d’accès. On récupère les adresses des serveurs DNS Wanadoo avec la commande ppp ipcp dns request. L’interface dialer0 est définie comme l’interface outside pour la configuration du NAT. CISCOADSL(config)#interface dialer0 CISCOADSL(config-if)#ip address negotiated CISCOADSL(config-if)#ip mtu 1492 CISCOADSL(config-if)#ip nat outside CISCOADSL(config-if)#encapsulation ppp CISCOADSL(config-if)#ip tcp adjust-mss 1452 CISCOADSL(config-if)#dialer pool 1 CISCOADSL(config-if)#dialer remote-name wanadoo CISCOADSL(config-if)#dialer-group 1 CISCOADSL(config-if)#ppp authentication chap callin CISCOADSL(config-if)#ppp chap hostname login_FAI CISCOADSL(config-if)#ppp chap password 0 password_FAI CISCOADSL(config-if)#ppp ipcp dns request CISCOADSL(config-if)#exit 2.3 ETHERNET0 L’interface ethernet0 est définie comme l’interface inside pour la configuration du NAT. CISCOADSL(config)#interface ethernet0 CISCOADSL(config-if)#ip nat inside CISCOADSL(config-if)#exit 2.4 Paramétrer la route par défaut On configure la route par défaut sur l’interface dialer0 CISCOADSL(config)#ip route 0.0.0.0 0.0.0.0 dialer0 2.5 Configuration de la NAT La première ligne définie que les adresses inside autorisés sont définies par l’access-list 101. L’access 101 autorise tout les paquets IP provenant du sous-réseau 10.10.10.0/24. Dialer-list autorise le protocole IP sur le dialer group numéro 1 (ATM0). CISCOADSL(config)#ip nat inside source list 101 interface dialer0 overload CISCOADSL(config)#access-list 101 permit ip 10.10.10.0 0.255.255.255 any CISCOADSL(config)#dialer-list 1 protocol ip permit
  • 6. 3 Configuration des services supplémentaires 3.1 Serveur DHCP On crée un pool DHCP qui porte le nom CLIENT. La commande import all permet d’ajouter la liste des serveurs DNS reçues par le fournisseur d’accès dans la configuration du serveur DHCP. Le sous-réseau attribuable est 10.10.10.0/24. La passerelle par défaut des clients sera 10.10.10.1. Le bail est positionné à 50 jours. CISCOADSL(config)#ip dhcp pool CLIENT CISCOADSL(dhcp-config)#import all CISCOADSL(dhcp-config)#network 10.10.10.0 255.0.0.0 CISCOADSL(dhcp-config)#default-router 10.10.10.1 CISCOADSL(dhcp-config)#lease 50 0 CISCOADSL(dhcp-config)#exit 3.2 Service DynDNS Si vous possédez un dyndns et que vous souhaitez le mettre à jour depuis votre routeur CISCO, définissez la méthode de mise à jour par HTTP. Spécifiez l’adresse HTTP avec testlogin qui est votre login et testpassword votre mot de passe chez dyndns. La variable myip est volontairement laissée à vide pour que ce soit l’adresse IP de dialer0 qui soit automatiquement positionné. Les mises à jour sont effectuées toutes les 6 heures. Pour faire le ?, taper simultanément sur les touches CTRL et v puis taper ? CISCOADSL(config)#ip ddns update method myupdate CISCOADSL(DDNS-update-method)# http CISCOADSL(DDNS-HTTP)# add http://testlogin:testpassword@cisco.dyndns.org/nic/update? system=dyndns&hostname=cisco.gotdns.org&myip= CISCOADSL(DDNS-HTTP)# interval maximum O 6 0 0 CISCOADSL(DDNS-update-method)# exit CISCOADSL(config)# interface dialer0 CISCOADSL(config-if)# ip ddns update hostname cisco.dyndns.org CISCOADSL(config-if) ip ddns update myupdate CISCOADSL(config-if)# exit 3.3 Serveur SSH On veut que le serveur SSH de la machine 10.10.10.2 soit accessible depuis Internet. On mappe le port 22 (SSH) de l’interface dialer0 sur l’adresse 10.10.10.2 en inside. CISCOADSL(config)#ip nat inside source static tcp 10.10.10.2 22 interface dialer0 22 4 Sécuriser le routeur 4.1 Le serveur HTTP Par défaut, l’interface de configuration CRWS est disponible depuis n’importe quel réseau. On crée une access-list qui autorise seulement les administrateurs du réseau 10.10.10.0/24 à s’y connecter. CISCOADSL(config)#access-list 24 permit 10.10.10.0 0.0.0.255 CISCOADSL(config)#access-list 24 deny any CISCOADSL(config)#ip http access-class 24 4.2 Antispoofing On active la protection uRPF contre le spoofing.
  • 7. CISCOADSL(config)#int dialer0 CISCOADSL(config-if)#ip verify unicast reverse-path CISCOADSL(config-if)#^Z 4.3 ICMP et IP Tous les paquets ICMP sont bloqués sur dialer0 à l’exception du MTU discovery. Les paquets IP redirects, broadcast, mask-reply, unreachables et le source routing sont rejetés. CISCOADSL(config)#access-list 102 permit icmp any any 3 4 CISCOADSL(config)#access-list 102 deny icmp any any CISCOADSL(config)#access-list 102 permit ip any any CISCOADSL(config)#interface dialer0 CISCOADSL(config-if)#ip access-group 102 in CISCOADSL(config-if)#no ip redirects CISCOADSL(config-if)#no ip directed broadcast CISCOADSL(config-if)#no ip mask-reply CISCOADSL(config-if)#no ip unreachables CISCOADSL(config-if)#no ip source-route CISCOADSL(config)#exit 5 Sauvegarde de la configuration et de l'IOS 5.1 Sauvegarder sur un serveur TFTP distant On sauvegarde sur un serveur TFTP distant, l’IOS et la configuration du routeur CISCO. CISCOADSL#copy nvram:startup-config tftp://10.10.10.2/ciscoadsl-config Address or name of remote host [10.10.10.2]? Destination filename [ciscoadsl-config]? !! 2354 bytes copied in 1.500 secs (1569 bytes/sec) CISCOADSL# CISCOADSL#copy flash:c837-k9o3sy6-mz.124-1a.bin tftp://10.10.10.2/c837-k9o3sy6-mz.124- 1a.bin Address or name of remote host [10.10.10.2]? Destination filename [c837-k9o3sy6-mz.124-1a.bin]? !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 9810496 bytes copied in 69.932 secs (140286 bytes/sec) CISCOADSL#
  • 8. 5.2 Fichier de configuration final Current configuration : 2577 bytes ! version 12.4 no service pad service timestamps debug uptime service timestamps log uptime service password-encryption ! hostname CISCOADSL ! boot-start-marker boot-end-marker ! memory-size iomem 5 enable secret 5 PASSWORD ! no aaa new-model ! resource policy ! ip subnet-zero no ip source-route ! ! no ip dhcp use vrf connected ip dhcp excluded-address 10.10.10.1 ! ip dhcp pool CLIENT import all network 10.0.0.0 255.0.0.0 default-router 10.10.10.1 lease 50 ! ! ip cef no ip ips deny-action ips-interface ip ddns update method myupdate HTTP add http://testlogin:testpassword@cisco.gotdns.org/nic/update?system=dyndns&hostname=cisc o.gotdns.org&myip= interval maximum 0 6 0 0 ! ! ! ! username Router password 7 PASSWORD ! ! ! ! ! interface Ethernet0 ip address 10.10.10.1 255.255.255.0 ip nat inside ip virtual-reassembly hold-queue 100 out ! interface Ethernet2
  • 9. no ip address shutdown hold-queue 100 out ! interface ATM0 ip dhcp client client-id Dialer0 no ip address no atm ilmi-keepalive dsl operating-mode auto pvc 8/35 pppoe-client dial-pool-number 1 ! ! interface FastEthernet1 duplex auto speed auto ! interface FastEthernet2 duplex auto speed auto ! interface FastEthernet3 duplex auto speed auto ! interface FastEthernet4 duplex auto speed auto ! interface Dialer0 ip ddns update hostname cisco.gotdns.org ip ddns update myupdate ip address negotiated ip access-group 102 in ip verify unicast reverse-path no ip redirects no ip unreachables ip mtu 1492 ip nat outside ip virtual-reassembly encapsulation ppp ip tcp adjust-mss 1452 dialer pool 1 dialer remote-name wanadoo dialer-group 1 ppp authentication chap callin ppp chap hostname login_FAI ppp chap password 7 password_FAI ppp ipcp dns request ! ip classless ip route 0.0.0.0 0.0.0.0 Dialer0 ! ip http server ip http access-class 24 no ip http secure-server ! ip nat inside source list 101 interface Dialer0 overload ip nat inside source static tcp 10.10.10.2 30777 interface Dialer0 30777 !
  • 10. access-list 23 permit 10.10.10.0 0.0.0.255 access-list 24 permit 10.10.10.0 0.0.0.255 access-list 24 deny any access-list 101 permit ip 10.0.0.0 0.255.255.255 any access-list 102 permit icmp any any packet-too-big access-list 102 deny icmp any any access-list 102 permit ip any any dialer-list 1 protocol ip permit ! ! control-plane ! ! line con 0 exec-timeout 120 0 no modem enable stopbits 1 ine aux 0 line vty 0 4 access-class 23 in exec-timeout 120 0 login local length 0 ! scheduler max-task-time 5000 end Conclusion En suivant chaque étape de l'article, votre routeur cisco 837 sera opérationnel pour un accès ADSL et disposera d'une sécurité minimum contre les attaques provenant de votre réseau local et d'Internet. Un serveur SSH est accessible pour vous permettre d'administrer votre réseau depuis la connexion ADSL de votre routeur.