SlideShare a Scribd company logo
1 of 8
How to Configure QinQ?
The QinQ technology is called VLAN dot1q tunnel, 802.1Q tunnel, VLAN Stacking
technology. The standard comes from IEEE 802.1ad and it is the expansion of the
802.1Q protocol. QinQ adds one layer of 802.1Q tag (VLAN tag) based on the
original 802.1Q packet head. With the double layers of tags, the VLAN quantity is
increased to 802.1Q.
How to configure the QinQ? Here we will list two occasions and they can be applied
to Huawei switches higher level than Quidway S2700 and with EI version, Huawei
S3700 switches and Quidway S5700, etc.
Example for Configuring basic QinQ
Networking Requirements
As shown in Figure 1, there are two enterprises on the network, Enterprise 1 and
Enterprise 2. Enterprise 1 has two office locations, and Enterprise 2 has 2 office
locations. The office locations of the two enterprises access SwitchA and SwitchB of
the ISP network. A non-Huawei device with the TPID value 0x9100 exists on the
public network. The requirements are as follows:
 Enterprise 1 and Enterprise 2 plans their VLANs independently.
 Traffic of the two branches is transparently transmitted on the public network.
Users using the same services in the two branches are allowed to communicate
and users using different services are isolated.
You can configure QinQ to meet the preceding requirements. VLAN 100 provided by
the public network can be used to implement communication of Enterprise 1 in the
two branches and VLAN 200 is used for Enterprise 2. You can set the TPID value in
the outer VLAN on the interface that connects the non-Huawei device to implement
communication between devices.
Figure 1Configuring basic QinQ
1
Configuration Roadmap
The configuration roadmap is as follows:
1. Configure VLAN 100 and VLAN 200 on both SwitchA and SwitchB. Set the link
type of the interface to QinQ and add the interfaces to VLAN. In this way, different
outer VLAN tags are added to different services.
2. Add interfaces connecting to the public network on SwitchA and SwitchB to VLAN
100 and VLAN 200 to permit packets from these VLANs to pass through.
3. Set the TPID values in the outer VLAN tag on interfaces connecting to the public
network on SwitchA and SwitchB to implement communication between the device
with devices from other vendors.
Procedure
Step 1 Create VLANs.
# Create VLAN 100 and VLAN 200 on SwitchA.
<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 100 200
# Create VLAN 100 and VLAN 200 on SwitchB.
<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] vlan batch 100 200
2
Step 2 Set the link type of the interface to QinQ.
# Configure GE0/0/1 and GE0/0/2 of SwitchA as QinQ interfaces. Set the VLAN of
GE0/0/1 to VLAN 100 and the VLAN of GE0/0/2 to VLAN 200.
[SwitchA] interface gigabitethernet 0/0/1
[SwitchA-GigabitEthernet0/0/1] port link-type dot1q-tunnel
[SwitchA-GigabitEthernet0/0/1] port default vlan 100
[SwitchA-GigabitEthernet0/0/1] quit
[SwitchA] interface gigabitethernet 0/0/2
[SwitchA-GigabitEthernet0/0/2] port link-type dot1q-tunnel
[SwitchA-GigabitEthernet0/0/2] port default vlan 200
[SwitchA-GigabitEthernet0/0/2] quit
# Configure GE0/0/1 and GE0/0/2 of SwitchB as QinQ interfaces. Set the VLAN of
GE0/0/1 to
VLAN 100 and the VLAN of GE0/0/2 to VLAN 200. The configuration procedure of
SwitchB is the same as that of SwitchA.
Step 3 Configure the interface connecting to the public network on the switch.
# Add GE0/0/3 of SwitchA to VLAN 100 and VLAN 200.
[SwitchA] interface gigabitethernet 0/0/3
[SwitchA-GigabitEthernet0/0/3] port link-type trunk
[SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 200
[SwitchA-GigabitEthernet0/0/3] quit
# Add GE0/0/3 of SwitchB to VLAN 100 and VLAN 200. The configuration
procedure of
SwitchB is the same as that of SwitchA.
Step 4 Configure the TPID value for an outer VLAN tag
# Set the TPID value of an outer VLAN tag to 0x9100 on SwitchA.
[SwitchA] interface gigabitethernet 0/0/3
[SwitchA-GigabitEthernet0/0/3] qinq protocol 9100
# Set the TPID value of an outer VLAN tag to 0x9100 on SwitchB.
[SwitchB] interface gigabitethernet 0/0/3
[SwitchB-GigabitEthernet0/0/3] qinq protocol 9100
Step 5 Verify the configuration.
In Enterprise 1, ping a PC of a VLAN in a branch from a PC of the same VLAN in
another branch. If the two PCs can ping each other, internal users of Enterprise 1 can
communicate.
In Enterprise 2, ping a PC of a VLAN in a branch from a PC of the same VLAN in
3
another branch. If the two PCs can ping each other, internal users of Enterprise 2 can
communicate.
Ping a PC in a VLAN of Enterprise 2 in a branch from a PC in the same VLAN of
Enterprise 1 in either branch. If the two PCs cannot ping each other, users in
Enterprise 1 and Enterprise 2 are isolated.
----End
Configuration Files
Configuration file of SwitchA
#
sysname SwitchA
#
vlan batch 100 200
#
interface GigabitEthernet0/0/1
port link-type dot1q-tunnel
port default vlan 100
#
interface GigabitEthernet0/0/2
port link-type dot1q-tunnel
port default vlan 200
#
interface GigabitEthernet0/0/3
qinq protocol 9100
port link-type trunk
port trunk allow-pass vlan 100 200
#
return
Configuration file of SwitchB
#
sysname SwitchB
#
vlan batch 100 200
#
interface GigabitEthernet0/0/1
port link-type dot1q-tunnel
port default vlan 100
#
interface GigabitEthernet0/0/2
port link-type dot1q-tunnel
port default vlan 200
#
interface GigabitEthernet0/0/3
4
qinq protocol 9100
port link-type trunk
port trunk allow-pass vlan 100 200
#
return
Example for Configuring Selective QinQ
Networking Requirements
As shown in Figure 2, Internet access users (using PCs) and VoIP users (using VoIP
terminals) connect to the ISP network through SwitchA and SwitchB and
communicate with each other through the ISP network.
It is required that packets of PCs and VoIP terminals be tagged VLAN 2 and VLAN 3
when the packets are transmitted through the ISP network.
Figure 2 Networking diagram for configuring selective QinQ
Configuration Roadmap
The configuration roadmap is as follows:
1. Create VLANs on SwitchA and SwitchB.
2. Configure link types of interfaces on SwitchA and SwitchB and add interfaces to
VLANs.
3. Configure selective QinQ on the interfaces of SwitchA and SwitchB.
Procedure
Step 1 Create VLANs.
# On SwitchA, create VLAN 2 and VLAN 3, that is, VLAN IDs of the outer VLAN
tag to be added.
<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 2 3
5
# On SwitchB, create VLAN 2 and VLAN 3, that is, VLAN IDs of the outer VLAN
tag to be added.
<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] vlan batch 2 3
Step 2 Configure selective QinQ on interfaces.
# Configure GE0/0/1 on SwitchA.
[SwitchA] interface gigabitethernet 0/0/1
[SwitchA-GigabitEthernet0/0/1] port link-type hybrid
[SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 2 3
[SwitchA-GigabitEthernet0/0/1] qinq vlan-translation enable
[SwitchA-GigabitEthernet0/0/1] port vlan-stacking vlan 100 stack-vlan 2
[SwitchA-GigabitEthernet0/0/1] port vlan-stacking vlan 300 stack-vlan 3
[SwitchA-GigabitEthernet0/0/1] quit
# Configure GE0/0/1 on SwitchB.
[SwitchB] interface gigabitethernet 0/0/1
[SwitchB-GigabitEthernet0/0/1] port link-type hybrid
[SwitchB-GigabitEthernet0/0/1] port hybrid untagged vlan 2 3
[SwitchB-GigabitEthernet0/0/1] qinq vlan-translation enable
[SwitchB-GigabitEthernet0/0/1] port vlan-stacking vlan 100 stack-vlan 2
[SwitchB-GigabitEthernet0/0/1] port vlan-stacking vlan 300 stack-vlan 3
[SwitchB-GigabitEthernet0/0/1] quit
Step 3 Configure other interfaces.
# Add GE0/0/2 to VLAN 2 and VLAN 3 on SwitchA.
[SwitchA] interface gigabitethernet 0/0/2
[SwitchA-GigabitEthernet0/0/2] port link-type trunk
[SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3
[SwitchA-GigabitEthernet0/0/2] quit
# Add GE0/0/2 to VLAN 2 and VLAN 3 on SwitchB.
[SwitchB] interface gigabitethernet 0/0/2
[SwitchB-GigabitEthernet0/0/2] port link-type trunk
[SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3
[SwitchB-GigabitEthernet0/0/2] quit
Step 4 Verify the configuration.
If the configurations on SwitchA and SwitchB are correct:
 PCs can communicate with each other through the ISP network.
 VoIP terminals can communicate with each other through the ISP network.
----End
6
Configuration Files
Configuration file of SwitchA
#
sysname SwitchA
#
vlan batch 2 to 3
#
interface GigabitEthernet0/0/1
qinq vlan-translation enable
port hybrid untagged vlan 2 to 3
port vlan-stacking vlan 100 stack-vlan 2
port vlan-stacking vlan 300 stack-vlan 3
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 3
#
return
Configuration file of SwitchB
#
sysname SwitchB
#
vlan batch 2 to 3
#
interface GigabitEthernet0/0/1
qinq vlan-translation enable
port hybrid untagged vlan 2 to 3
port vlan-stacking vlan 100 stack-vlan 2
port vlan-stacking vlan 300 stack-vlan 3
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 3
#
return
The more information about technical support you can consult with our engineer the
e-mail address is as below:
support@huanetwork.com
More related topics
7
How to Configure the QinQ VLAN?
The Difference between Layer2/Layer3 Switches
How to Replace a Power Module or Fan Module for Huawei Switches?
How to Configure the QinQ VLAN Private Line Service for Huawei MA5616?
More Huawei products and Reviews you can visit: http://www.huanetwork.com/blog
Huanetwork.com is a world leading Huawei networking products supplier, we supply original new
Huawei networking equipments, including Huawei switches, Huawei routers, Huaweisymantec
security products, Huawei IAD, Huawei SFP and other Huawei networking products. Our
customers include telecom operators, Huawei resellers, ISP and system integrators. Right now
most of our sales are contributed by regular customers.
In Huanetwork Lab, also we have Huawei OLT, MDU, DSLAM and switch for customer do
remote testing, any potential customer are welcome to login to our lab. If you need a total Huawei
FTTx solution or Huawei ADSL solution for your network, also you may feel free to contact us.
Our website: http://www.huanetwork.com
Telephone: +852-30501940
Email: sales@huanetwork.com
Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong
8

More Related Content

What's hot

debugging openstack neutron /w openvswitch
debugging openstack neutron /w openvswitchdebugging openstack neutron /w openvswitch
debugging openstack neutron /w openvswitch
어형 이
 

What's hot (20)

Taking Security Groups to Ludicrous Speed with OVS (OpenStack Summit 2015)
Taking Security Groups to Ludicrous Speed with OVS (OpenStack Summit 2015)Taking Security Groups to Ludicrous Speed with OVS (OpenStack Summit 2015)
Taking Security Groups to Ludicrous Speed with OVS (OpenStack Summit 2015)
 
Introduction to OpenFlow
Introduction to OpenFlowIntroduction to OpenFlow
Introduction to OpenFlow
 
Introduction to nexux from zero to Hero
Introduction to nexux  from zero to HeroIntroduction to nexux  from zero to Hero
Introduction to nexux from zero to Hero
 
Cours eigrp i pv4 et ipv6
Cours eigrp i pv4 et ipv6Cours eigrp i pv4 et ipv6
Cours eigrp i pv4 et ipv6
 
Introduction to vxlan
Introduction to vxlanIntroduction to vxlan
Introduction to vxlan
 
2014 OpenStack Summit - Neutron OVS to LinuxBridge Migration
2014 OpenStack Summit - Neutron OVS to LinuxBridge Migration2014 OpenStack Summit - Neutron OVS to LinuxBridge Migration
2014 OpenStack Summit - Neutron OVS to LinuxBridge Migration
 
Bgp tutorial for ISP
Bgp tutorial for ISPBgp tutorial for ISP
Bgp tutorial for ISP
 
Linux Networking Explained
Linux Networking ExplainedLinux Networking Explained
Linux Networking Explained
 
Cours VTP
Cours VTPCours VTP
Cours VTP
 
Troubleshooting BGP
Troubleshooting BGPTroubleshooting BGP
Troubleshooting BGP
 
Ccnp3 lab 3_4_en
Ccnp3 lab 3_4_enCcnp3 lab 3_4_en
Ccnp3 lab 3_4_en
 
debugging openstack neutron /w openvswitch
debugging openstack neutron /w openvswitchdebugging openstack neutron /w openvswitch
debugging openstack neutron /w openvswitch
 
MPLS Traffic Engineering
MPLS Traffic EngineeringMPLS Traffic Engineering
MPLS Traffic Engineering
 
Dynamic ARP Inspection (DAI)
Dynamic ARP Inspection (DAI)Dynamic ARP Inspection (DAI)
Dynamic ARP Inspection (DAI)
 
DDoS Mitigation using BGP Flowspec
DDoS Mitigation using BGP Flowspec DDoS Mitigation using BGP Flowspec
DDoS Mitigation using BGP Flowspec
 
MPLS L3 VPN Deployment
MPLS L3 VPN DeploymentMPLS L3 VPN Deployment
MPLS L3 VPN Deployment
 
Ovs dpdk hwoffload way to full offload
Ovs dpdk hwoffload way to full offloadOvs dpdk hwoffload way to full offload
Ovs dpdk hwoffload way to full offload
 
Cilium - Container Networking with BPF & XDP
Cilium - Container Networking with BPF & XDPCilium - Container Networking with BPF & XDP
Cilium - Container Networking with BPF & XDP
 
DPDK & Layer 4 Packet Processing
DPDK & Layer 4 Packet ProcessingDPDK & Layer 4 Packet Processing
DPDK & Layer 4 Packet Processing
 
Service Function Chaining with SRv6
Service Function Chaining with SRv6Service Function Chaining with SRv6
Service Function Chaining with SRv6
 

Viewers also liked

Viewers also liked (19)

Huawei Router Basic Configuration Command
Huawei Router Basic Configuration CommandHuawei Router Basic Configuration Command
Huawei Router Basic Configuration Command
 
What’s the Difference Between GPON and EPON
What’s the Difference Between GPON and EPONWhat’s the Difference Between GPON and EPON
What’s the Difference Between GPON and EPON
 
How to configure the logical distance of gpon
How to configure the logical distance of gponHow to configure the logical distance of gpon
How to configure the logical distance of gpon
 
How to configure eo c services for huawei ol ts
How to configure eo c services for huawei ol tsHow to configure eo c services for huawei ol ts
How to configure eo c services for huawei ol ts
 
The Review of Huawei OLT
The Review of Huawei OLTThe Review of Huawei OLT
The Review of Huawei OLT
 
Huawei ac6005
Huawei ac6005Huawei ac6005
Huawei ac6005
 
Huawei s5710-ei-power-module-test-report
Huawei s5710-ei-power-module-test-reportHuawei s5710-ei-power-module-test-report
Huawei s5710-ei-power-module-test-report
 
OptiX OSN 8800 Slot Description
OptiX OSN 8800 Slot DescriptionOptiX OSN 8800 Slot Description
OptiX OSN 8800 Slot Description
 
Configuring the Device as a PPPoE Client on Huawei AR1200
Configuring the Device as a PPPoE Client on Huawei AR1200Configuring the Device as a PPPoE Client on Huawei AR1200
Configuring the Device as a PPPoE Client on Huawei AR1200
 
What is gpon
What is gponWhat is gpon
What is gpon
 
How to query traffic of a port on the huawei ma5616
How to query traffic of a port on the huawei ma5616How to query traffic of a port on the huawei ma5616
How to query traffic of a port on the huawei ma5616
 
Huawei HG8245 Two Version GE / FE
Huawei HG8245 Two Version GE / FEHuawei HG8245 Two Version GE / FE
Huawei HG8245 Two Version GE / FE
 
How to add and delete ont on the olt device
How to add and delete ont on the olt deviceHow to add and delete ont on the olt device
How to add and delete ont on the olt device
 
Huawei ftth c b e2 e solution
Huawei ftth c b e2 e solutionHuawei ftth c b e2 e solution
Huawei ftth c b e2 e solution
 
Ont, olt and mdu in gpon technology
Ont, olt and mdu in gpon technologyOnt, olt and mdu in gpon technology
Ont, olt and mdu in gpon technology
 
Cisco vs. huawei CLI Commands
Cisco vs. huawei CLI CommandsCisco vs. huawei CLI Commands
Cisco vs. huawei CLI Commands
 
Wiki and solution in ftth technology
Wiki and solution in ftth technologyWiki and solution in ftth technology
Wiki and solution in ftth technology
 
Huawei osn3500 typical networking in packet mode
Huawei osn3500 typical networking in packet modeHuawei osn3500 typical networking in packet mode
Huawei osn3500 typical networking in packet mode
 
dBm : a mathematical interpretation
dBm : a mathematical interpretationdBm : a mathematical interpretation
dBm : a mathematical interpretation
 

Similar to How to Configure QinQ?

3.4.6-lab---configure-vlans-and-trunking.pdf
3.4.6-lab---configure-vlans-and-trunking.pdf3.4.6-lab---configure-vlans-and-trunking.pdf
3.4.6-lab---configure-vlans-and-trunking.pdf
arif hamidi
 
VIRTUAL LANS
VIRTUAL LANSVIRTUAL LANS
VIRTUAL LANS
anilinvns
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2
alan moreno
 
Exercise 4c stp rapid pvst+ question
Exercise 4c   stp rapid pvst+ questionExercise 4c   stp rapid pvst+ question
Exercise 4c stp rapid pvst+ question
sufi1248
 
Pe1 configuring pvst+ rapid pvst+
Pe1   configuring pvst+  rapid pvst+Pe1   configuring pvst+  rapid pvst+
Pe1 configuring pvst+ rapid pvst+
mohdsyahmi789
 
6.5.1.3 packet tracer layer 2 vlan security instructor
6.5.1.3 packet tracer   layer 2 vlan security instructor6.5.1.3 packet tracer   layer 2 vlan security instructor
6.5.1.3 packet tracer layer 2 vlan security instructor
Salem Trabelsi
 

Similar to How to Configure QinQ? (20)

3.4.6-lab---configure-vlans-and-trunking.pdf
3.4.6-lab---configure-vlans-and-trunking.pdf3.4.6-lab---configure-vlans-and-trunking.pdf
3.4.6-lab---configure-vlans-and-trunking.pdf
 
Presentation
PresentationPresentation
Presentation
 
Presentation
PresentationPresentation
Presentation
 
Day 5 VIRTUAL LANS
Day 5 VIRTUAL LANSDay 5 VIRTUAL LANS
Day 5 VIRTUAL LANS
 
VIRTUAL LANS
VIRTUAL LANSVIRTUAL LANS
VIRTUAL LANS
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2
 
Exercise 4c stp rapid pvst+ question
Exercise 4c   stp rapid pvst+ questionExercise 4c   stp rapid pvst+ question
Exercise 4c stp rapid pvst+ question
 
Pe1 configuring pvst+ rapid pvst+
Pe1   configuring pvst+  rapid pvst+Pe1   configuring pvst+  rapid pvst+
Pe1 configuring pvst+ rapid pvst+
 
Vlan lab
Vlan labVlan lab
Vlan lab
 
6.5.1.3 packet tracer layer 2 vlan security instructor
6.5.1.3 packet tracer   layer 2 vlan security instructor6.5.1.3 packet tracer   layer 2 vlan security instructor
6.5.1.3 packet tracer layer 2 vlan security instructor
 
Ccna3 lab 9_1_5b_en
Ccna3 lab 9_1_5b_enCcna3 lab 9_1_5b_en
Ccna3 lab 9_1_5b_en
 
Virtual LAN and Vlan Trunking Protocol.pptx
Virtual LAN and Vlan Trunking Protocol.pptxVirtual LAN and Vlan Trunking Protocol.pptx
Virtual LAN and Vlan Trunking Protocol.pptx
 
Switch inter vlan_routing
Switch inter vlan_routingSwitch inter vlan_routing
Switch inter vlan_routing
 
69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phone69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phone
 
Virtual Local Area Network
Virtual Local Area NetworkVirtual Local Area Network
Virtual Local Area Network
 
VLANs_Module_3.pptx
VLANs_Module_3.pptxVLANs_Module_3.pptx
VLANs_Module_3.pptx
 
Lab6.4.1
Lab6.4.1Lab6.4.1
Lab6.4.1
 
Day 14.2 configuringvla ns
Day 14.2 configuringvla nsDay 14.2 configuringvla ns
Day 14.2 configuringvla ns
 
corporate network
corporate networkcorporate network
corporate network
 
CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6
 

More from Huanetwork

Huawei net engine5000e core router chassis and features
Huawei net engine5000e core router chassis and featuresHuawei net engine5000e core router chassis and features
Huawei net engine5000e core router chassis and features
Huanetwork
 

More from Huanetwork (20)

Huanetwork x dsl solution - huawei adsl2+ and vdsl2 solution)
Huanetwork x dsl solution - huawei adsl2+ and vdsl2 solution)Huanetwork x dsl solution - huawei adsl2+ and vdsl2 solution)
Huanetwork x dsl solution - huawei adsl2+ and vdsl2 solution)
 
What are the differences between huawei and cisco wlan products
What are the differences between huawei and cisco wlan productsWhat are the differences between huawei and cisco wlan products
What are the differences between huawei and cisco wlan products
 
How to configure inband management for huawei ma5616
How to configure inband management for huawei ma5616How to configure inband management for huawei ma5616
How to configure inband management for huawei ma5616
 
What is huawei quidway s5300 gigabit switches
What is huawei quidway s5300 gigabit switchesWhat is huawei quidway s5300 gigabit switches
What is huawei quidway s5300 gigabit switches
 
Huawei osn3500 typical networking in packet mode
Huawei osn3500 typical networking in packet modeHuawei osn3500 typical networking in packet mode
Huawei osn3500 typical networking in packet mode
 
Huawei opti x osn 1500 boards
Huawei opti x osn 1500 boardsHuawei opti x osn 1500 boards
Huawei opti x osn 1500 boards
 
Huawei net engine5000e core router chassis and features
Huawei net engine5000e core router chassis and featuresHuawei net engine5000e core router chassis and features
Huawei net engine5000e core router chassis and features
 
Huawei s3700 cables
Huawei s3700 cablesHuawei s3700 cables
Huawei s3700 cables
 
Differences of Huawei S5700 Series LI, SI, EI and HI
Differences of Huawei S5700 Series LI, SI, EI and HIDifferences of Huawei S5700 Series LI, SI, EI and HI
Differences of Huawei S5700 Series LI, SI, EI and HI
 
Huawei s9300 terabit routing switch
Huawei s9300 terabit routing switchHuawei s9300 terabit routing switch
Huawei s9300 terabit routing switch
 
Huanetwork Design the Network Solution Free for You
Huanetwork Design the Network Solution Free for YouHuanetwork Design the Network Solution Free for You
Huanetwork Design the Network Solution Free for You
 
Configuration difference between ipv6 and ipv4
Configuration difference between ipv6 and ipv4Configuration difference between ipv6 and ipv4
Configuration difference between ipv6 and ipv4
 
How to configure the gpon ftth layer 2 internet access service on the nms
How to configure the gpon ftth layer 2 internet access service on the nmsHow to configure the gpon ftth layer 2 internet access service on the nms
How to configure the gpon ftth layer 2 internet access service on the nms
 
How to configure i pv6 services in the fttb c (no hgws) scenario
How to configure i pv6 services in the fttb c (no hgws) scenarioHow to configure i pv6 services in the fttb c (no hgws) scenario
How to configure i pv6 services in the fttb c (no hgws) scenario
 
Version support for huawei s7700 components (1)
Version support for huawei s7700 components (1)Version support for huawei s7700 components (1)
Version support for huawei s7700 components (1)
 
Huawei router component selection guide – purchase list
Huawei router component selection guide – purchase listHuawei router component selection guide – purchase list
Huawei router component selection guide – purchase list
 
Naming conventions of huawei parts
Naming conventions of huawei partsNaming conventions of huawei parts
Naming conventions of huawei parts
 
Huawei AR Series Routers Application Comparison and Overview
Huawei AR Series Routers Application Comparison and OverviewHuawei AR Series Routers Application Comparison and Overview
Huawei AR Series Routers Application Comparison and Overview
 
The feature of huawei ma5600
The feature of huawei ma5600The feature of huawei ma5600
The feature of huawei ma5600
 
Optical module
Optical moduleOptical module
Optical module
 

Recently uploaded

Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers:  A Deep Dive into Serverless Spatial Data and FMECloud Frontiers:  A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
Safe Software
 
+971581248768>> SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHA...
+971581248768>> SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHA...+971581248768>> SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHA...
+971581248768>> SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHA...
?#DUbAI#??##{{(☎️+971_581248768%)**%*]'#abortion pills for sale in dubai@
 

Recently uploaded (20)

Artificial Intelligence Chap.5 : Uncertainty
Artificial Intelligence Chap.5 : UncertaintyArtificial Intelligence Chap.5 : Uncertainty
Artificial Intelligence Chap.5 : Uncertainty
 
Emergent Methods: Multi-lingual narrative tracking in the news - real-time ex...
Emergent Methods: Multi-lingual narrative tracking in the news - real-time ex...Emergent Methods: Multi-lingual narrative tracking in the news - real-time ex...
Emergent Methods: Multi-lingual narrative tracking in the news - real-time ex...
 
MINDCTI Revenue Release Quarter One 2024
MINDCTI Revenue Release Quarter One 2024MINDCTI Revenue Release Quarter One 2024
MINDCTI Revenue Release Quarter One 2024
 
A Beginners Guide to Building a RAG App Using Open Source Milvus
A Beginners Guide to Building a RAG App Using Open Source MilvusA Beginners Guide to Building a RAG App Using Open Source Milvus
A Beginners Guide to Building a RAG App Using Open Source Milvus
 
Navi Mumbai Call Girls 🥰 8617370543 Service Offer VIP Hot Model
Navi Mumbai Call Girls 🥰 8617370543 Service Offer VIP Hot ModelNavi Mumbai Call Girls 🥰 8617370543 Service Offer VIP Hot Model
Navi Mumbai Call Girls 🥰 8617370543 Service Offer VIP Hot Model
 
AXA XL - Insurer Innovation Award Americas 2024
AXA XL - Insurer Innovation Award Americas 2024AXA XL - Insurer Innovation Award Americas 2024
AXA XL - Insurer Innovation Award Americas 2024
 
Connector Corner: Accelerate revenue generation using UiPath API-centric busi...
Connector Corner: Accelerate revenue generation using UiPath API-centric busi...Connector Corner: Accelerate revenue generation using UiPath API-centric busi...
Connector Corner: Accelerate revenue generation using UiPath API-centric busi...
 
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers:  A Deep Dive into Serverless Spatial Data and FMECloud Frontiers:  A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
 
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
 
A Year of the Servo Reboot: Where Are We Now?
A Year of the Servo Reboot: Where Are We Now?A Year of the Servo Reboot: Where Are We Now?
A Year of the Servo Reboot: Where Are We Now?
 
2024: Domino Containers - The Next Step. News from the Domino Container commu...
2024: Domino Containers - The Next Step. News from the Domino Container commu...2024: Domino Containers - The Next Step. News from the Domino Container commu...
2024: Domino Containers - The Next Step. News from the Domino Container commu...
 
Powerful Google developer tools for immediate impact! (2023-24 C)
Powerful Google developer tools for immediate impact! (2023-24 C)Powerful Google developer tools for immediate impact! (2023-24 C)
Powerful Google developer tools for immediate impact! (2023-24 C)
 
ICT role in 21st century education and its challenges
ICT role in 21st century education and its challengesICT role in 21st century education and its challenges
ICT role in 21st century education and its challenges
 
Apidays Singapore 2024 - Building Digital Trust in a Digital Economy by Veron...
Apidays Singapore 2024 - Building Digital Trust in a Digital Economy by Veron...Apidays Singapore 2024 - Building Digital Trust in a Digital Economy by Veron...
Apidays Singapore 2024 - Building Digital Trust in a Digital Economy by Veron...
 
How to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerHow to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected Worker
 
Apidays New York 2024 - The Good, the Bad and the Governed by David O'Neill, ...
Apidays New York 2024 - The Good, the Bad and the Governed by David O'Neill, ...Apidays New York 2024 - The Good, the Bad and the Governed by David O'Neill, ...
Apidays New York 2024 - The Good, the Bad and the Governed by David O'Neill, ...
 
GenAI Risks & Security Meetup 01052024.pdf
GenAI Risks & Security Meetup 01052024.pdfGenAI Risks & Security Meetup 01052024.pdf
GenAI Risks & Security Meetup 01052024.pdf
 
+971581248768>> SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHA...
+971581248768>> SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHA...+971581248768>> SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHA...
+971581248768>> SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHA...
 
Apidays Singapore 2024 - Scalable LLM APIs for AI and Generative AI Applicati...
Apidays Singapore 2024 - Scalable LLM APIs for AI and Generative AI Applicati...Apidays Singapore 2024 - Scalable LLM APIs for AI and Generative AI Applicati...
Apidays Singapore 2024 - Scalable LLM APIs for AI and Generative AI Applicati...
 
Apidays Singapore 2024 - Modernizing Securities Finance by Madhu Subbu
Apidays Singapore 2024 - Modernizing Securities Finance by Madhu SubbuApidays Singapore 2024 - Modernizing Securities Finance by Madhu Subbu
Apidays Singapore 2024 - Modernizing Securities Finance by Madhu Subbu
 

How to Configure QinQ?

  • 1. How to Configure QinQ? The QinQ technology is called VLAN dot1q tunnel, 802.1Q tunnel, VLAN Stacking technology. The standard comes from IEEE 802.1ad and it is the expansion of the 802.1Q protocol. QinQ adds one layer of 802.1Q tag (VLAN tag) based on the original 802.1Q packet head. With the double layers of tags, the VLAN quantity is increased to 802.1Q. How to configure the QinQ? Here we will list two occasions and they can be applied to Huawei switches higher level than Quidway S2700 and with EI version, Huawei S3700 switches and Quidway S5700, etc. Example for Configuring basic QinQ Networking Requirements As shown in Figure 1, there are two enterprises on the network, Enterprise 1 and Enterprise 2. Enterprise 1 has two office locations, and Enterprise 2 has 2 office locations. The office locations of the two enterprises access SwitchA and SwitchB of the ISP network. A non-Huawei device with the TPID value 0x9100 exists on the public network. The requirements are as follows:  Enterprise 1 and Enterprise 2 plans their VLANs independently.  Traffic of the two branches is transparently transmitted on the public network. Users using the same services in the two branches are allowed to communicate and users using different services are isolated. You can configure QinQ to meet the preceding requirements. VLAN 100 provided by the public network can be used to implement communication of Enterprise 1 in the two branches and VLAN 200 is used for Enterprise 2. You can set the TPID value in the outer VLAN on the interface that connects the non-Huawei device to implement communication between devices. Figure 1Configuring basic QinQ 1
  • 2. Configuration Roadmap The configuration roadmap is as follows: 1. Configure VLAN 100 and VLAN 200 on both SwitchA and SwitchB. Set the link type of the interface to QinQ and add the interfaces to VLAN. In this way, different outer VLAN tags are added to different services. 2. Add interfaces connecting to the public network on SwitchA and SwitchB to VLAN 100 and VLAN 200 to permit packets from these VLANs to pass through. 3. Set the TPID values in the outer VLAN tag on interfaces connecting to the public network on SwitchA and SwitchB to implement communication between the device with devices from other vendors. Procedure Step 1 Create VLANs. # Create VLAN 100 and VLAN 200 on SwitchA. <HUAWEI> system-view [HUAWEI] sysname SwitchA [SwitchA] vlan batch 100 200 # Create VLAN 100 and VLAN 200 on SwitchB. <HUAWEI> system-view [HUAWEI] sysname SwitchB [SwitchB] vlan batch 100 200 2
  • 3. Step 2 Set the link type of the interface to QinQ. # Configure GE0/0/1 and GE0/0/2 of SwitchA as QinQ interfaces. Set the VLAN of GE0/0/1 to VLAN 100 and the VLAN of GE0/0/2 to VLAN 200. [SwitchA] interface gigabitethernet 0/0/1 [SwitchA-GigabitEthernet0/0/1] port link-type dot1q-tunnel [SwitchA-GigabitEthernet0/0/1] port default vlan 100 [SwitchA-GigabitEthernet0/0/1] quit [SwitchA] interface gigabitethernet 0/0/2 [SwitchA-GigabitEthernet0/0/2] port link-type dot1q-tunnel [SwitchA-GigabitEthernet0/0/2] port default vlan 200 [SwitchA-GigabitEthernet0/0/2] quit # Configure GE0/0/1 and GE0/0/2 of SwitchB as QinQ interfaces. Set the VLAN of GE0/0/1 to VLAN 100 and the VLAN of GE0/0/2 to VLAN 200. The configuration procedure of SwitchB is the same as that of SwitchA. Step 3 Configure the interface connecting to the public network on the switch. # Add GE0/0/3 of SwitchA to VLAN 100 and VLAN 200. [SwitchA] interface gigabitethernet 0/0/3 [SwitchA-GigabitEthernet0/0/3] port link-type trunk [SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 200 [SwitchA-GigabitEthernet0/0/3] quit # Add GE0/0/3 of SwitchB to VLAN 100 and VLAN 200. The configuration procedure of SwitchB is the same as that of SwitchA. Step 4 Configure the TPID value for an outer VLAN tag # Set the TPID value of an outer VLAN tag to 0x9100 on SwitchA. [SwitchA] interface gigabitethernet 0/0/3 [SwitchA-GigabitEthernet0/0/3] qinq protocol 9100 # Set the TPID value of an outer VLAN tag to 0x9100 on SwitchB. [SwitchB] interface gigabitethernet 0/0/3 [SwitchB-GigabitEthernet0/0/3] qinq protocol 9100 Step 5 Verify the configuration. In Enterprise 1, ping a PC of a VLAN in a branch from a PC of the same VLAN in another branch. If the two PCs can ping each other, internal users of Enterprise 1 can communicate. In Enterprise 2, ping a PC of a VLAN in a branch from a PC of the same VLAN in 3
  • 4. another branch. If the two PCs can ping each other, internal users of Enterprise 2 can communicate. Ping a PC in a VLAN of Enterprise 2 in a branch from a PC in the same VLAN of Enterprise 1 in either branch. If the two PCs cannot ping each other, users in Enterprise 1 and Enterprise 2 are isolated. ----End Configuration Files Configuration file of SwitchA # sysname SwitchA # vlan batch 100 200 # interface GigabitEthernet0/0/1 port link-type dot1q-tunnel port default vlan 100 # interface GigabitEthernet0/0/2 port link-type dot1q-tunnel port default vlan 200 # interface GigabitEthernet0/0/3 qinq protocol 9100 port link-type trunk port trunk allow-pass vlan 100 200 # return Configuration file of SwitchB # sysname SwitchB # vlan batch 100 200 # interface GigabitEthernet0/0/1 port link-type dot1q-tunnel port default vlan 100 # interface GigabitEthernet0/0/2 port link-type dot1q-tunnel port default vlan 200 # interface GigabitEthernet0/0/3 4
  • 5. qinq protocol 9100 port link-type trunk port trunk allow-pass vlan 100 200 # return Example for Configuring Selective QinQ Networking Requirements As shown in Figure 2, Internet access users (using PCs) and VoIP users (using VoIP terminals) connect to the ISP network through SwitchA and SwitchB and communicate with each other through the ISP network. It is required that packets of PCs and VoIP terminals be tagged VLAN 2 and VLAN 3 when the packets are transmitted through the ISP network. Figure 2 Networking diagram for configuring selective QinQ Configuration Roadmap The configuration roadmap is as follows: 1. Create VLANs on SwitchA and SwitchB. 2. Configure link types of interfaces on SwitchA and SwitchB and add interfaces to VLANs. 3. Configure selective QinQ on the interfaces of SwitchA and SwitchB. Procedure Step 1 Create VLANs. # On SwitchA, create VLAN 2 and VLAN 3, that is, VLAN IDs of the outer VLAN tag to be added. <HUAWEI> system-view [HUAWEI] sysname SwitchA [SwitchA] vlan batch 2 3 5
  • 6. # On SwitchB, create VLAN 2 and VLAN 3, that is, VLAN IDs of the outer VLAN tag to be added. <HUAWEI> system-view [HUAWEI] sysname SwitchB [SwitchB] vlan batch 2 3 Step 2 Configure selective QinQ on interfaces. # Configure GE0/0/1 on SwitchA. [SwitchA] interface gigabitethernet 0/0/1 [SwitchA-GigabitEthernet0/0/1] port link-type hybrid [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 2 3 [SwitchA-GigabitEthernet0/0/1] qinq vlan-translation enable [SwitchA-GigabitEthernet0/0/1] port vlan-stacking vlan 100 stack-vlan 2 [SwitchA-GigabitEthernet0/0/1] port vlan-stacking vlan 300 stack-vlan 3 [SwitchA-GigabitEthernet0/0/1] quit # Configure GE0/0/1 on SwitchB. [SwitchB] interface gigabitethernet 0/0/1 [SwitchB-GigabitEthernet0/0/1] port link-type hybrid [SwitchB-GigabitEthernet0/0/1] port hybrid untagged vlan 2 3 [SwitchB-GigabitEthernet0/0/1] qinq vlan-translation enable [SwitchB-GigabitEthernet0/0/1] port vlan-stacking vlan 100 stack-vlan 2 [SwitchB-GigabitEthernet0/0/1] port vlan-stacking vlan 300 stack-vlan 3 [SwitchB-GigabitEthernet0/0/1] quit Step 3 Configure other interfaces. # Add GE0/0/2 to VLAN 2 and VLAN 3 on SwitchA. [SwitchA] interface gigabitethernet 0/0/2 [SwitchA-GigabitEthernet0/0/2] port link-type trunk [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3 [SwitchA-GigabitEthernet0/0/2] quit # Add GE0/0/2 to VLAN 2 and VLAN 3 on SwitchB. [SwitchB] interface gigabitethernet 0/0/2 [SwitchB-GigabitEthernet0/0/2] port link-type trunk [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3 [SwitchB-GigabitEthernet0/0/2] quit Step 4 Verify the configuration. If the configurations on SwitchA and SwitchB are correct:  PCs can communicate with each other through the ISP network.  VoIP terminals can communicate with each other through the ISP network. ----End 6
  • 7. Configuration Files Configuration file of SwitchA # sysname SwitchA # vlan batch 2 to 3 # interface GigabitEthernet0/0/1 qinq vlan-translation enable port hybrid untagged vlan 2 to 3 port vlan-stacking vlan 100 stack-vlan 2 port vlan-stacking vlan 300 stack-vlan 3 # interface GigabitEthernet0/0/2 port link-type trunk port trunk allow-pass vlan 2 to 3 # return Configuration file of SwitchB # sysname SwitchB # vlan batch 2 to 3 # interface GigabitEthernet0/0/1 qinq vlan-translation enable port hybrid untagged vlan 2 to 3 port vlan-stacking vlan 100 stack-vlan 2 port vlan-stacking vlan 300 stack-vlan 3 # interface GigabitEthernet0/0/2 port link-type trunk port trunk allow-pass vlan 2 to 3 # return The more information about technical support you can consult with our engineer the e-mail address is as below: support@huanetwork.com More related topics 7
  • 8. How to Configure the QinQ VLAN? The Difference between Layer2/Layer3 Switches How to Replace a Power Module or Fan Module for Huawei Switches? How to Configure the QinQ VLAN Private Line Service for Huawei MA5616? More Huawei products and Reviews you can visit: http://www.huanetwork.com/blog Huanetwork.com is a world leading Huawei networking products supplier, we supply original new Huawei networking equipments, including Huawei switches, Huawei routers, Huaweisymantec security products, Huawei IAD, Huawei SFP and other Huawei networking products. Our customers include telecom operators, Huawei resellers, ISP and system integrators. Right now most of our sales are contributed by regular customers. In Huanetwork Lab, also we have Huawei OLT, MDU, DSLAM and switch for customer do remote testing, any potential customer are welcome to login to our lab. If you need a total Huawei FTTx solution or Huawei ADSL solution for your network, also you may feel free to contact us. Our website: http://www.huanetwork.com Telephone: +852-30501940 Email: sales@huanetwork.com Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong 8