COLEGIO DE ESTUDIOS CIENTÍFICOS Y TECNOLÓGICOS DEL ESTADO DE                                 MÉXICO                       ...
INDICE1)    KAREL2)    ABUELITA3)    NORTE4)    RECOGE5)    MURO6)    INSTRUCCIONES7)    KARELOTITLAN 18)    RECOGE BASURA...
Práctica numero 1KAREL 1iniciar-programa  inicia-ejecucion  avanza;  gira-izquierda;  gira-izquierda;  gira-izquierda;  av...
avanza;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquie...
gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquie...
avanza;deja-zumbador;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda; avanza;gira-izquie...
gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;ava...
avanza;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquie...
deja-zumbador;gira-izquierda;gira-izquierda; avanza;gira-izquierda;gira-izquierda;gira-izquierda; avanza;gira-izquierda;gi...
avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquie...
gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;ava...
apagate;  termina-ejecucionfinalizar-programa
Práctica numero 2ABUELITADescripción: Tiene que visitar a su abuelita, la casa de la abuelita se encuentra siempre adelant...
Práctica numero 3NORTEDescripción:Este tiene que llevar la instrucción de llevar a Karel al norte confinalidad de orientar...
Ejemplo:      Antes   después
Práctica numero 4RECOGEDescripción:En esta Karel debe de recoger los zumbadores y colocarlos en lapared que se encuentra e...
Fin;  Termina-ejecucion;    Apágate; Fin; Fin; Fin; Termina-ejecucionFinalizar-programaEjemplo:Antes Despues
Práctica numero 5MURODescripción:En esta práctica tenemos que hacer que Karel se asome para quevea que hay en el otro lado...
Práctica numero 6InstruccionesDescripción:La descripción sobre esta práctica es que tenemos que hacer que Karel sigalas si...
Define-nueva-instruccion sur como inicioMientras no orientado-al-sur hacer gira-izquierda;Fin;Define-nueva-instruccion est...
Avanza;     Este;     Avanza;     Oeste;     Avanza;     media-vuelta;     Caminar-hasta-pared;  Apágate;  Termina-ejecuci...
Práctica numero 7KARELOTITLAN 1Descripción:    Por su naturaleza, Karel es un robot muy ordenado y le gusta tener todossus...
Define-nueva-instruccion vuelta-atras como inicioRepetir 2 veces gira-izquierda;Fin;Define-nueva-instruccion hazlo como in...
Práctica numero 8RECOGE BASURADescripción:En esta Práctica karel deberá recoger todo aquel zumbador queencuentre y a la mi...
Si orientado-al-sur y frente-bloqueado entonces iniciogira-izquierda; avanza;Fin;Fin;  Inicia-ejecución;       Apágate;  T...
Práctica numero 9LABERINTODescripción:En este tenemos que poner un laberinto y tenemos que hacer queKarel vaya llevándose ...
Mientras frente-libre hacer inicioAvanza;Mientras junto-a-zumbador hacerCoge-zumbador;Mientras frente-libre y algún-zumbad...
Práctica numero 10KARELOTILTLAN 2Descripción:Se le ha pedido a Karel que siembre zanahorias en un terrenorectangular de un...
Deja-zumbador;Avanza;Fin;Si frente-bloqueado entonces inicioSi no junto-a-zumbador entoncesDeja-zumbador;gira-izquierda;gi...
Fin;Mientras derecha-bloqueada y frente-libre hacerAvanza; Mientras izquierda-libre y orientado-al-sur y algun-zumbador-en...
gira-izquierda;  Mientras frente-libre hacer  Avanza;  Fin; Mientras algun-zumbador-en-la-mochila hacer inicio  Deja;  Fin...
Práctica numero 11TORRE MAS ALTADescripción:Tenemos que hacer que Karel suba a la torre hasta que llegue a lomás altoCódig...
si frente-bloqueado entonces iniciogira-izquierda;si frente-libre y junto-a-zumbador entonces iniciocoge-zumbador;fin;si f...
gira-izquierda;gira-izquierda;fin;fin;fin;mientras frente-libre y no junto-a-zumbador hacer inicioavanza;fin;mientras fren...
mientras ningun-zumbador-en-la-mochila y frente-libre hacer  alta;  mientras frente-bloqueado hacer  gira;    apagate;  te...
Práctica numero 12KARELOTITLAN 3Descripción:Es bien sabido que en la ciudad e Karelotitlán todos los habitantestienen sus ...
fin;define-nueva-instruccion vuelta como iniciorepetir 2 veces gira-izquierda;fin;define-nueva-instruccion regresa como in...
Práctica numero 13KARELOTITLAN 4Descripción:La empresa de construcción ya trajo los tabiques, pero los hadejado en desorde...
gira-izquierda;avanza;fin;si orientado-al-este y derecha-bloqueada y frente-libre entoncesgira-izquierda;si frente-bloquea...
avanza;si frente-bloqueado y orientado-al-norte y derecha-bloqueada entoncesrepetir 2 veces gira-izquierda;si derecha-bloq...
mientras no-junto-a-zumbador y frente-libre hacer iniciosi no-junto-a-zumbador y orientado-al-oeste y izquierda-libre y fr...
mientras frente-libre hacer  dd;apagate;  termina-ejecucionfinalizar-programaEjemplo:Antes                           Después
Práctica numero 14KARELOTITLAN 5Descripción:Ayuda a Karelerac a construir una media pirámide crecientehacia la derecha con...
repetir 2 veces gira-izquierda;fin;define-nueva-instruccion regresa como iniciosur;mientras frente-libre hacer avanza;gira...
finsino inicioeste;avanza;si ningun-zumbador-en-la-mochila entonces apagate;si no-junto-a-zumbador y algun-zumbador-en-la-...
apagate;  termina-ejecucionfinalizar-programaEjemplo:Antes                 Después
Práctica numero 15KARELOTITLAN 6Descripción:Ayuda a Carelerak a construir su Edimárip aidem creciente haciala izquierda co...
fin;define-nueva-instruccion regresa como iniciosur;mientras frente-libre hacer avanza;gira-izquierda;fin;define-nueva-ins...
si ningun-zumbador-en-la-mochila entonces apagate;si no-junto-a-zumbador y algun-zumbador-en-la-mochila entonces iniciodej...
Ejemplo:Antes      Después
ConclusiónKarel el robot, es un lenguaje de programación que no tiene ningún fin práctico,es decir, no voy a usar Karel pa...
Próximos SlideShares
Carregando em…5
×

Mis practicas de karel 2

478 visualizações

Publicada em

ANDREA YAÑEZ 404
ABIGAIL ZEA CABRERA

0 comentários
1 gostou
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
478
No SlideShare
0
A partir de incorporações
0
Número de incorporações
2
Ações
Compartilhamentos
0
Downloads
6
Comentários
0
Gostaram
1
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Mis practicas de karel 2

  1. 1. COLEGIO DE ESTUDIOS CIENTÍFICOS Y TECNOLÓGICOS DEL ESTADO DE MÉXICO PLANTEL TECAMAC ALUMNA: ANDREA YAÑEZ FLORES ABIGAIL RUBY ZEA CABRERA GRUPO: 404MATERIA: APLICAR LOS PINCIPIOS DE PROGRAMACIÓN EN LA SOLUCIÓN DE PROBLEMAS PROFESOR: ING. DOMINGUEZ ESCALONA RENE TURNO: MATUTINO
  2. 2. INDICE1) KAREL2) ABUELITA3) NORTE4) RECOGE5) MURO6) INSTRUCCIONES7) KARELOTITLAN 18) RECOGE BASURA9) LABERINTO10) KARELOTITLAN 211) TORRE MAS ALTA12) KARELOTITLAN 313) KARELOTITLAN 414) KARELOTITLAN 515) KARELOTITLAN 6
  3. 3. Práctica numero 1KAREL 1iniciar-programa inicia-ejecucion avanza; gira-izquierda; gira-izquierda; gira-izquierda; avanza; gira-izquierda; gira-izquierda; gira-izquierda; avanza; gira-izquierda; avanza; gira-izquierda; avanza; gira-izquierda; gira-izquierda; gira-izquierda; avanza; gira-izquierda; gira-izquierda; gira-izquierda; avanza; gira-izquierda;
  4. 4. avanza;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;avanza;coge-zumbador;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;
  5. 5. gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;
  6. 6. avanza;deja-zumbador;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda; avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;
  7. 7. gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;avanza;coge-zumbador;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;
  8. 8. avanza;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;avanza;
  9. 9. deja-zumbador;gira-izquierda;gira-izquierda; avanza;gira-izquierda;gira-izquierda;gira-izquierda; avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;
  10. 10. avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;avanza;coge-zumbador;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;
  11. 11. gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;gira-izquierda;gira-izquierda;avanza;gira-izquierda;avanza;gira-izquierda;avanza;deja-zumbador;
  12. 12. apagate; termina-ejecucionfinalizar-programa
  13. 13. Práctica numero 2ABUELITADescripción: Tiene que visitar a su abuelita, la casa de la abuelita se encuentra siempre adelante deKarel, en la primera posición que tiene la izquierda y se está junto a un zumbador, y ktiene que llevar a su abuelitaCódigo:Iniciar-programa Inicia-ejecucion Mientras izquierda-libre o no junto-a-zumbador hacer inicio Avanza; Fin; Apágate; Termina-ejecuciónFinalizar-programaEjemplo: Antes después
  14. 14. Práctica numero 3NORTEDescripción:Este tiene que llevar la instrucción de llevar a Karel al norte confinalidad de orientarseCódigo:Iniciar-programa Inicia-ejecución Si orientado-al-norte entonces inicio Fin; Si orientado-al-sur entonces inicio Repetir 2 veces gira-izquierda; Fin; Si orientado-al-este entonces inicio gira-izquierda; Fin; Si orientado-al-oeste entonces inicio Repetir 3 veces gira-izquierda; Fin;Apágate; Termina-ejecucionFinalizar-programa
  15. 15. Ejemplo: Antes después
  16. 16. Práctica numero 4RECOGEDescripción:En esta Karel debe de recoger los zumbadores y colocarlos en lapared que se encuentra enfrente de el.Código:Iniciar-programa Inicia-ejecucionMientras frente-libre hacer inicio Avanza; Mientras junto-a-zumbador hacer coge-zumbador; Si frente-bloqueado entonces inicio Mientras algún-zumbador-en-la-mochila hacer deja-zumbador; gira-izquierda; gira-izquierda; gira-izquierda; Avanza; gira-izquierda; gira-izquierda; gira-izquierda; Avanza; Mientras junto-a-zumbador hacer coge-zumbador; Mientras algún-zumbador-en-la-mochila hacer deja-zumbador; Fin;
  17. 17. Fin; Termina-ejecucion; Apágate; Fin; Fin; Fin; Termina-ejecucionFinalizar-programaEjemplo:Antes Despues
  18. 18. Práctica numero 5MURODescripción:En esta práctica tenemos que hacer que Karel se asome para quevea que hay en el otro lado del muro.Código:Iniciar-programa Inicia-ejecucion Repetir 19 veces inicio avanza; Fin; Apágate; Termina-ejecucionFinalizar-programaEjemplo:Antes después
  19. 19. Práctica numero 6InstruccionesDescripción:La descripción sobre esta práctica es que tenemos que hacer que Karel sigalas siguientes instruccionesCódigo:Iniciar-programaDefine-nueva-instruccion derecha como inicioRepetir 3 veces gira-izquierda;Fin;Define-nueva-instrucción recogetodo como inicioMientras junto-a-zumbador hacer coge-zumbador;Fin;Define-nueva-instruccion dejatodo como inicioMientras algún-zumbador-en-la-mochila hacer deja-zumbador;Fin;Define-nueva-instrucción media-vuelta como inicioRepetir 2 veces gira-izquierda;Fin;Define-nueva-instrucción norte como inicioMientras no orientado-al-norte hacer gira-izquierda;Fin;
  20. 20. Define-nueva-instruccion sur como inicioMientras no orientado-al-sur hacer gira-izquierda;Fin;Define-nueva-instruccion este como inicioMientras no orientado-al-este hacer gira-izquierda;Fin;Define-nueva-instruccion oeste como inicioMientras no orientado-al-oeste hacer gira-izquierda;Fin;Define-nueva-instruccion caminar-hasta-pared como inicioMientras frente-libre hacer avanza;Fin;Inicia-ejecución Derecha; Avanza; recogetodo; Avanza; Dejatodo; Avanza; Norte; Avanza; Sur;
  21. 21. Avanza; Este; Avanza; Oeste; Avanza; media-vuelta; Caminar-hasta-pared; Apágate; Termina-ejecuciónFinalizar-programaAntes Despues
  22. 22. Práctica numero 7KARELOTITLAN 1Descripción: Por su naturaleza, Karel es un robot muy ordenado y le gusta tener todossus zumbadores acomodados en montones. Tras un fin de semana de juegos, Karel tiene su cuarto lleno dezumbadores regados en columnas, por lo que ahora deberá juntar loszumbadores de cada columna y hacer un montón con ellos en la base de lamisma.Código:Iniciar-programaDefine-nueva-instruccion come como inicioSi no orientado-al-norte entonces iniciogira-izquierda;Fin;Mientras junto-a-zumbador y no frente-bloqueado hacer inicioMientras junto-a-zumbador y no frente-bloqueado hacer coge-zumbador;Avanza;Mientras junto-a-zumbador y frente-bloqueado hacerCoge-zumbador;Fin;Fin;Define-nueva-instruccion dejalotodo como inicioMientras algún-zumbador-en-la-mochila hacer deja-zumbador;Fin;
  23. 23. Define-nueva-instruccion vuelta-atras como inicioRepetir 2 veces gira-izquierda;Fin;Define-nueva-instruccion hazlo como inicioCome;Vuelta-atras;Mientras frente-libre hacer inicioAvanza;Fin;dejalotodo;gira-izquierda;Avanza;gira-izquierda;Fin;Inicia-ejecucionMientras junto-a-zumbador hacer hazlo;Apágate; Termina-ejecucionFinalizar-programaEjemplo:Antes después
  24. 24. Práctica numero 8RECOGE BASURADescripción:En esta Práctica karel deberá recoger todo aquel zumbador queencuentre y a la misma vez deberá dejarlos en un punto fijoCódigo:Iniciar-programaDefine-nueva-instrucción eso como inicioMientras frente-libre o no-junto-a-zumbador hacer inicioAvanza;Mientras junto-a-zumbador hacer coge-zumbador;Mientras algún-zumbador-en-la-mochila y orientado-al-oeste y frente-bloqueadoy izquierda-bloqueada y derecha-libreHacer inicioDeja-zumbador;Fin;Mientras orientado-al-oeste y frente-bloqueado y izquierda-bloqueada yderecha-libreHacer apágate;Si orientado-al-sur y frente-bloqueado y izquierda-libre entonces iniciogira-izquierda; avanza; gira-izquierda;Fin;Si orientado-al-sur y izquierda-bloqueada y frente-bloqueado entoncesRepetir 3 veces gira-izquierda;Si frente-bloqueado entonces inicioRepetir 2 veces gira-izquierda;Fin; fin;
  25. 25. Si orientado-al-sur y frente-bloqueado entonces iniciogira-izquierda; avanza;Fin;Fin; Inicia-ejecución; Apágate; Termina-ejecuciónFinalizar-programaEjemplo:Antes después
  26. 26. Práctica numero 9LABERINTODescripción:En este tenemos que poner un laberinto y tenemos que hacer queKarel vaya llevándose los zumbadores que encuentre.Código:Iniciar-programaDefine-nueva-instruccion lab como inicioMientras junto-a-zumbador hacerCoge-zumbador;Mientras frente-libre hacer inicioAvanza;Mientras junto-a-zumbador hacerCoge-zumbador;Mientras frente-libre y algún-zumbador-en-la-mochila y izquierda-libre yderecha-libre hacerDeja-zumbador;Si ningún-zumbador-en-la-mochila y derecha-libre y izquierda-libre entoncesApágate;Fin;Si frente-bloqueado y derecha-bloqueada entoncesgira-izquierda;Si frente-bloqueado y izquierda-bloqueada entoncesRepetir 3 veces gira-izquierda;
  27. 27. Mientras frente-libre hacer inicioAvanza;Mientras junto-a-zumbador hacerCoge-zumbador;Mientras frente-libre y algún-zumbador-en-la-mochila y izquierda-libre yderecha-libre hacerDeja-zumbador;si ningún-zumbador-en-la-mochila entoncesapagate;fin;si frente-bloqueado y izquierda-bloqueada entoncesRepetir 3 veces gira-izquierda;Fin;Inicia-ejecucionRepetir 100 veces Lab;Apágate; Termina-ejecuciónFinalizar-programaAntes Despues
  28. 28. Práctica numero 10KARELOTILTLAN 2Descripción:Se le ha pedido a Karel que siembre zanahorias en un terrenorectangular de un mínimo de 3x1 hasta un máximo de 9x10.Código:Iniciar-programaDefine-nueva-instrucción hazlo como inicioMientras izquierda-bloqueada y frente-libre hacerAvanza;Si izquierda-libre entoncesgira-izquierda;Si izquierda-libre y derecha-libre y frente-libre entoncesAvanza; Fin; Define-nueva-instruccion deja como inicio Mientras frente-bloqueado hacer gira-izquierda; Mientras frente-libre hacer inicio Mientras no-junto-a-zumbador hacer
  29. 29. Deja-zumbador;Avanza;Fin;Si frente-bloqueado entonces inicioSi no junto-a-zumbador entoncesDeja-zumbador;gira-izquierda;gira-izquierda;Fin;Mientras frente-libre hacerAvanza;si frente-bloqueado y derecha-libre entoncesRepetir 3 vecesgira-izquierda;Si frente-libre entoncesAvanza;Mientras no-orientado-al-norte hacergira-izquierda;Si izquierda-bloqueada y junto-a-zumbador entonces inicioMientras izquierda-bloqueada hacerAvanza;Si izquierda-libre entoncesgira-izquierda;Avanza;gira-izquierda;Avanza;
  30. 30. Fin;Mientras derecha-bloqueada y frente-libre hacerAvanza; Mientras izquierda-libre y orientado-al-sur y algun-zumbador-en-la-mochilahacerDeja-zumbador;si ningún-zumbador-en-la-mochila entoncesapágate; fin; Inicia-ejecucion Mientras no-orientado-al-este hacer gira-izquierda; Mientras izquierda-libre hacer inicioAvanza;Fin;Mientras junto-a-zumbador hacer inicioCoge-zumbador;Fin;Mientras frente-libre hacer inicio Hazlo; Fin; Si frente-bloqueado entonces inicio
  31. 31. gira-izquierda; Mientras frente-libre hacer Avanza; Fin; Mientras algun-zumbador-en-la-mochila hacer inicio Deja; Fin; Apagate; Termina-ejecucionFinalizar-programaEjemplo:Antes después
  32. 32. Práctica numero 11TORRE MAS ALTADescripción:Tenemos que hacer que Karel suba a la torre hasta que llegue a lomás altoCódigo:iniciar-programadefine-nueva-instruccion alta como inicio mientras frente-libre hacer avanza; si frente-bloqueado entonces gira-izquierda; mientras frente-libre hacer avanza; si frente-bloqueado entonces gira-izquierda; mientras frente-libre hacer avanza; fin; define-nueva-instruccion gira como inicio
  33. 33. si frente-bloqueado entonces iniciogira-izquierda;si frente-libre y junto-a-zumbador entonces iniciocoge-zumbador;fin;si frente-libre entoncesavanza;si frente-libre y no junto-a-zumbador entonces iniciogira-izquierda;fin;fin;mientras frente-libre y no junto-a-zumbador haceravanza;si junto-a-zumbador entoncesmientras no orientado-al-sur hacergira-izquierda;si frente-bloqueado entonces iniciogira-izquierda;gira-izquierda;gira-izquierda;si frente-libre y no junto-a-zumbador entonces inicioavanza;si frente-libre y no junto-a-zumbador entonces iniciogira-izquierda;
  34. 34. gira-izquierda;gira-izquierda;fin;fin;fin;mientras frente-libre y no junto-a-zumbador hacer inicioavanza;fin;mientras frente-libre hacer iniciosi junto-a-zumbador entoncescoge-zumbador;avanza;si junto-a-zumbador entoncescoge-zumbador;fin;si frente-bloqueado y algun-zumbador-en-la-mochila entoncesapagate;fin;inicia-ejecucionmientras no orientado-al-este hacergira-izquierda;
  35. 35. mientras ningun-zumbador-en-la-mochila y frente-libre hacer alta; mientras frente-bloqueado hacer gira; apagate; termina-ejecucionfinalizar-programaEjemplo:Antes Después
  36. 36. Práctica numero 12KARELOTITLAN 3Descripción:Es bien sabido que en la ciudad e Karelotitlán todos los habitantestienen sus casas en forma de pirámides, sin embargo, el excéntricoKarel quiere ser diferente a los demás y desea construir su casacon sólo la mitad de una pirámide.Código:iniciar-programadefine-nueva-instruccion derecha como iniciogira-izquierda; gira-izquierda; gira-izquierda;fin;define-nueva-instruccion sur como iniciomientras no-orientado-al-sur hacer gira-izquierda;fin;define-nueva-instruccion norte como iniciomientras no-orientado-al-norte hacer gira-izquierda;fin;define-nueva-instruccion oeste como iniciomientras no-orientado-al-oeste hacer gira-izquierda;fin;define-nueva-instruccion este como iniciomientras no-orientado-al-este hacer gira-izquierda;
  37. 37. fin;define-nueva-instruccion vuelta como iniciorepetir 2 veces gira-izquierda;fin;define-nueva-instruccion regresa como iniciosur;mientras frente-libre hacer avanza;gira-izquierda;si frente-libre entonces inicioavanza;finsino inicioapagate;fin;Ejemplo:Antes
  38. 38. Práctica numero 13KARELOTITLAN 4Descripción:La empresa de construcción ya trajo los tabiques, pero los hadejado en desorden en el piso, en columnas de diferente altura.Tu tarea consiste en acomodar los tabiques de manera que se forme la pareddeseada, haciendo que todas las columnas de tabiques tengan la misma altura.Código:iniciar-programadefine-nueva-instruccion aa como iniciosi orientado-al-norte y izquierda-libre y derecha-bloqueada y frente-bloqueadoentoncesrepetir 2 veces gira-izquierda;mientras junto-a-zumbador y orientado-al-norte y frente-libre haceravanza;si no-junto-a-zumbador y orientado-al-norte entoncesrepetir 2 veces gira-izquierda;mientras frente-libre y orientado-al-sur hacer inicioavanza;mientras junto-a-zumbador hacercoge-zumbador;fin;mientras junto-a-zumbador hacercoge-zumbador;si frente-bloqueado y orientado-al-sur y izquierda-libre entonces inicio
  39. 39. gira-izquierda;avanza;fin;si orientado-al-este y derecha-bloqueada y frente-libre entoncesgira-izquierda;si frente-bloqueado y orientado-al-este y derecha-bloqueada entoncesgira-izquierda;si orientado-al-sur y frente-bloqueado y izquierda-bloqueada y derecha-libreentoncesrepetir 3 veces gira-izquierda;fin;define-nueva-instruccion bb como iniciosi orientado-al-oeste y frente-libre entoncesavanza;si no-junto-a-zumbador y orientado-al-oeste y algun-zumbador-en-la-mochilaentoncesdeja-zumbador;si frente-bloqueado y orientado-al-oeste entoncesrepetir 2 veces gira-izquierda;mientras frente-libre y orientado-al-este haceravanza;si frente-bloqueado y orientado-al-este y algun-zumbador-en-la-mochilaentoncesdeja-zumbador;si frente-bloqueado y orientado-al-este entoncesgira-izquierda;si frente-libre y orientado-al-norte y derecha-bloqueada entonces inicio
  40. 40. avanza;si frente-bloqueado y orientado-al-norte y derecha-bloqueada entoncesrepetir 2 veces gira-izquierda;si derecha-bloqueada y frente-libre entoncesgira-izquierda;fin;fin;define-nueva-instruccion cc como iniciosi frente-libre y izquierda-libre y derecha-libre y orientado-al-norte entoncesrepetir 2 veces gira-izquierda;mientras frente-libre y orientado-al-sur haceravanza;si frente-bloqueado y izquierda-bloqueada y orientado-al-sur entoncesrepetir 3 veces gira-izquierda;fin;define-nueva-instruccion dd como iniciomientras frente-libre y junto-a-zumbador haceravanza;si frente-bloqueado y orientado-al-oeste entoncesrepetir 2 veces gira-izquierda;si frente-bloqueado y orientado-al-este entonces iniciogira-izquierda;avanza;gira-izquierda;fin;
  41. 41. mientras no-junto-a-zumbador y frente-libre hacer iniciosi no-junto-a-zumbador y orientado-al-oeste y izquierda-libre y frente-libreentoncesavanza;si frente-libre y orientado-al-norte y izquierda-libre y derecha-libre y no-junto-a-zumbador entoncesapagate;si junto-a-zumbador entonces coge-zumbador;fin;si no-junto-a-zumbador y frente-bloqueado y orientado-al-oeste entoncesrepetir 2 veces gira-izquierda;mientras frente-libre y no-junto-a-zumbador y orientado-al-este haceravanza;si frente-bloqueado y orientado-al-este y no-junto-a-zumbador entonces iniciogira-izquierda;avanza;fin;si derecha-bloqueada y frente-libre y orientado-al-norte entoncesgira-izquierda;fin;inicia-ejecucion mientras orientado-al-norte hacer aa; mientras orientado-al-oeste hacer bb; cc;
  42. 42. mientras frente-libre hacer dd;apagate; termina-ejecucionfinalizar-programaEjemplo:Antes Después
  43. 43. Práctica numero 14KARELOTITLAN 5Descripción:Ayuda a Karelerac a construir una media pirámide crecientehacia la derecha con los zumbadores que lleva en la mochila.Código:iniciar-programadefine-nueva-instruccion derecha como iniciogira-izquierda; gira-izquierda; gira-izquierda;fin;define-nueva-instruccion sur como iniciomientras no-orientado-al-sur hacer gira-izquierda;fin;define-nueva-instruccion norte como iniciomientras no-orientado-al-norte hacer gira-izquierda;fin;define-nueva-instruccion oeste como iniciomientras no-orientado-al-oeste hacer gira-izquierda;fin;define-nueva-instruccion este como iniciomientras no-orientado-al-este hacer gira-izquierda;fin;define-nueva-instruccion vuelta como inicio
  44. 44. repetir 2 veces gira-izquierda;fin;define-nueva-instruccion regresa como iniciosur;mientras frente-libre hacer avanza;gira-izquierda;si frente-libre entonces inicioavanza;finsino inicioapagate;fin;norte;fin;define-nueva-instruccion checarlado como iniciooeste;si frente-libre entonces inicioavanza;si junto-a-zumbador entonces inicioeste;avanza;si ningun-zumbador-en-la-mochila entonces apagate;si no-junto-a-zumbador y algun-zumbador-en-la-mochila entonces deja-zumbador;norte;avanza;checarlado;
  45. 45. finsino inicioeste;avanza;si ningun-zumbador-en-la-mochila entonces apagate;si no-junto-a-zumbador y algun-zumbador-en-la-mochila entonces deja-zumbador;regresa;checarlado;fin;finsino iniciovuelta;avanza;norte;si ningun-zumbador-en-la-mochila entonces apagate;checarlado;fin;fin; define-nueva-instruccion piramide como iniciosi ningun-zumbador-en-la-mochila entonces apagate;si no-junto-a-zumbador y algun-zumbador-en-la-mochila entonces deja-zumbador;checarlado;fin; inicia-ejecucion norte; piramide;
  46. 46. apagate; termina-ejecucionfinalizar-programaEjemplo:Antes Después
  47. 47. Práctica numero 15KARELOTITLAN 6Descripción:Ayuda a Carelerak a construir su Edimárip aidem creciente haciala izquierda con los zumbadores que tiene en la mochilaCódigo:iniciar-programadefine-nueva-instruccion izquierda como iniciogira-izquierda; gira-izquierda; gira-izquierda;fin;define-nueva-instruccion sur como iniciomientras no-orientado-al-sur hacer gira-izquierda;fin;define-nueva-instruccion norte como iniciomientras no-orientado-al-norte hacer gira-izquierda;fin;define-nueva-instruccion oeste como iniciomientras no-orientado-al-oeste hacer gira-izquierda;fin;define-nueva-instruccion este como iniciomientras no-orientado-al-este hacer gira-izquierda;fin;define-nueva-instruccion vuelta como iniciorepetir 2 veces gira-izquierda;
  48. 48. fin;define-nueva-instruccion regresa como iniciosur;mientras frente-libre hacer avanza;gira-izquierda;fin;define-nueva-instruccion regresados como iniciooeste;si frente-libre entonces inicioavanza;finsino iniciosal-de-instruccion;fin;norte;avanza;este;si ningun-zumbador-en-la-mochila entonces apagate;si no-junto-a-zumbador y algun-zumbador-en-la-mochila entonces deja-zumbador;regresados;fin;define-nueva-instruccion checarlado como inicioeste;mientras frente-libre y junto-a-zumbador hacer iniciosi frente-bloqueado y orientado-al-este entonces apagate;avanza;
  49. 49. si ningun-zumbador-en-la-mochila entonces apagate;si no-junto-a-zumbador y algun-zumbador-en-la-mochila entonces iniciodeja-zumbador;regresados;regresa;fin;fin;si frente-bloqueado y orientado-al-este entonces apagate;fin;define-nueva-instruccion piramide como iniciosi ningun-zumbador-en-la-mochila entonces apagate;si no-junto-a-zumbador y algun-zumbador-en-la-mochila entonces deja-zumbador;checarlado;fin;inicia-ejecucion norte; piramide; apagate; termina-ejecucionfinalizar-programa
  50. 50. Ejemplo:Antes Después
  51. 51. ConclusiónKarel el robot, es un lenguaje de programación que no tiene ningún fin práctico,es decir, no voy a usar Karel para hacer un sistema de bases de datos parauna empresa, ni nada porel estilo. Sin embargo es un simulador de un robotque usa instrucciones muy sencillas y bien estructuradas que lo hacen muy útilpara enseñarnos acerca de la programación. Yo lo he visto útil para desarrollarla lógica necesaria para resolver problemas con la computadora.

×