SlideShare uma empresa Scribd logo
1 de 1
Baixar para ler offline
NETWORK ADDRESS TRANSLATION                                                                             packetlife.net
                      Example Topology                                             Address Classification
                                                                                         An actual address assigned to
                                                                         Inside Local
                                                                                         an inside host
                                                                             An inside address seen from
                                                                        Inside Global
                                                                             the outside
                                                                             An actual address assigned to
    FastEthernet0                          FastEthernet1      Outside Global
                                                                             an outside host
     10.0.0.1/16                          174.143.212.1/22
     NAT Inside                             NAT Outside                                  An outside address seen from
                                                                    Outside Local
                                                                                         the inside
              NAT Boundary Configuration                                                           Perspective
interface FastEthernet0                                                                    Local                 Global
 ip address 10.0.0.1 255.255.0.0
 ip nat inside




                                                             Location
!                                                                         Inside       Inside Local        Inside Global
interface FastEthernet1
 ip address 174.143.212.1 255.255.252.0
 ip nat outside                                                           Outside     Outside Local       Outside Global

                     Static Source Translation                                             Terminology

! One line per static translation                                         NAT Pool
ip nat inside source static 10.0.0.19 192.0.2.1                           A pool of IP addresses to be used as inside
ip nat inside source static 10.0.1.47 192.0.2.2                           global or outside local addresses in translations
ip nat outside source static 174.143.212.133 10.0.0.47                    Port Address Translation (PAT)
ip nat outside source static 174.143.213.240 10.0.2.181
                                                                          An extension to NAT that translates information
                                                                          at layer four and above, such as TCP and UDP
                    Dynamic Source Translation                            port numbers; dynamic PAT configurations
                                                                          include the overload keyword
! Create an access list to match inside local addresses
access-list 10 permit 10.0.0.0 0.0.255.255                                Extendable Translation
!                                                                         The extendable keyword must be appended
! Create NAT pool of inside global addresses                              when multiple overlapping static translations are
ip nat pool MyPool 192.0.2.1 192.0.2.254 prefix-length 24                 configured
!
! Combine them with a translation rule                                              Special NAT Pool Types
ip nat inside source list 10 pool MyPool                                      Rotary Used for load balancing
!
! Dynamic translations can be combined with static entries                    Match- Preserves the host portion of
ip nat inside source static 10.0.0.42 192.0.2.42                               Host the address after translation

               Port Address Translation (PAT)                                           Troubleshooting

! Static layer four port translations                                     show ip nat translations [verbose]
ip nat inside source static tcp 10.0.0.3 8080 192.0.2.1 80
                                                                          show ip nat statistics
ip nat inside source static udp 10.0.0.14 53 192.0.2.2 53
ip nat outside source static tcp 174.143.212.4 23 10.0.0.8 23             clear ip nat translations
!
! Dynamic port translation with a pool                                              NAT Translations Tuning
ip nat inside source list 11 pool MyPool overload
!                                                                         ip nat translation tcp-timeout <seconds>
! Dynamic translation with interface overloading                          ip nat translation udp-timeout <seconds>
ip nat inside source list 11 interface FastEthernet1 overload             ip nat translation max-entries <number>

                                       Inside Destination Translation

! Create a rotary NAT pool
ip nat pool LoadBalServers 10.0.99.200 10.0.99.203 prefix-length 24 type rotary
!
! Enable load balancing across inside hosts for incoming traffic
ip nat inside destination list 12 pool LoadBalServers

by Jeremy Stretch                                                                                                         v1.0

Mais conteúdo relacionado

Mais procurados

Cisco presentation2
Cisco presentation2Cisco presentation2
Cisco presentation2ehsan nazer
 
Cisco IPv6 Tutorial by Hinwoto
Cisco IPv6 Tutorial by HinwotoCisco IPv6 Tutorial by Hinwoto
Cisco IPv6 Tutorial by HinwotoFebrian ‎
 
IPv6 Best Practice
IPv6 Best PracticeIPv6 Best Practice
IPv6 Best Practiceflyingpotato
 
Ipv6 introduction - MUM 2011 presentation
Ipv6 introduction - MUM 2011 presentationIpv6 introduction - MUM 2011 presentation
Ipv6 introduction - MUM 2011 presentationIDEA4PRO
 
Jingle: Cutting Edge VoIP
Jingle: Cutting Edge VoIPJingle: Cutting Edge VoIP
Jingle: Cutting Edge VoIPmattjive
 
Introduction to ipv6 v1.3
Introduction to ipv6 v1.3Introduction to ipv6 v1.3
Introduction to ipv6 v1.3Karunakant Rai
 
Hands on Experience with IPv6 Routing and Switching Services
Hands on Experience with IPv6 Routing and Switching ServicesHands on Experience with IPv6 Routing and Switching Services
Hands on Experience with IPv6 Routing and Switching ServicesCisco Canada
 
IPv6 Transition & Deployment, including IPv6-only in cellular and broadband
IPv6 Transition & Deployment, including IPv6-only in cellular and broadbandIPv6 Transition & Deployment, including IPv6-only in cellular and broadband
IPv6 Transition & Deployment, including IPv6-only in cellular and broadbandAPNIC
 
Hands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and ServicesHands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and ServicesCisco Canada
 
Hands-on Experience with IPv6 Routing and Switching
Hands-on Experience with IPv6 Routing and Switching Hands-on Experience with IPv6 Routing and Switching
Hands-on Experience with IPv6 Routing and Switching Cisco Canada
 
Samba and Vista with IPv6
Samba and Vista with IPv6Samba and Vista with IPv6
Samba and Vista with IPv6dinomasch
 

Mais procurados (20)

Cisco presentation2
Cisco presentation2Cisco presentation2
Cisco presentation2
 
Day 17.1 nat pat
Day 17.1 nat pat Day 17.1 nat pat
Day 17.1 nat pat
 
Nat
NatNat
Nat
 
Cisco IPv6 Tutorial by Hinwoto
Cisco IPv6 Tutorial by HinwotoCisco IPv6 Tutorial by Hinwoto
Cisco IPv6 Tutorial by Hinwoto
 
IPv6 Best Practice
IPv6 Best PracticeIPv6 Best Practice
IPv6 Best Practice
 
IPv6_Quick_Start_Guide
IPv6_Quick_Start_GuideIPv6_Quick_Start_Guide
IPv6_Quick_Start_Guide
 
Autoconfig
AutoconfigAutoconfig
Autoconfig
 
Ipv6 introduction - MUM 2011 presentation
Ipv6 introduction - MUM 2011 presentationIpv6 introduction - MUM 2011 presentation
Ipv6 introduction - MUM 2011 presentation
 
Jingle: Cutting Edge VoIP
Jingle: Cutting Edge VoIPJingle: Cutting Edge VoIP
Jingle: Cutting Edge VoIP
 
Introduction to ipv6 v1.3
Introduction to ipv6 v1.3Introduction to ipv6 v1.3
Introduction to ipv6 v1.3
 
Hands on Experience with IPv6 Routing and Switching Services
Hands on Experience with IPv6 Routing and Switching ServicesHands on Experience with IPv6 Routing and Switching Services
Hands on Experience with IPv6 Routing and Switching Services
 
IPv6 Transition & Deployment, including IPv6-only in cellular and broadband
IPv6 Transition & Deployment, including IPv6-only in cellular and broadbandIPv6 Transition & Deployment, including IPv6-only in cellular and broadband
IPv6 Transition & Deployment, including IPv6-only in cellular and broadband
 
I pv6 autoconfig20c
I pv6 autoconfig20cI pv6 autoconfig20c
I pv6 autoconfig20c
 
IPv6 theoryfinalx
IPv6 theoryfinalxIPv6 theoryfinalx
IPv6 theoryfinalx
 
Hands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and ServicesHands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and Services
 
Hands-on Experience with IPv6 Routing and Switching
Hands-on Experience with IPv6 Routing and Switching Hands-on Experience with IPv6 Routing and Switching
Hands-on Experience with IPv6 Routing and Switching
 
Introduction to IPv6
Introduction to IPv6Introduction to IPv6
Introduction to IPv6
 
NAT Traversal
NAT TraversalNAT Traversal
NAT Traversal
 
mpls-04
mpls-04mpls-04
mpls-04
 
Samba and Vista with IPv6
Samba and Vista with IPv6Samba and Vista with IPv6
Samba and Vista with IPv6
 

Destaque (20)

The itil foundation_certificate_syllabus (2) (1)
The itil foundation_certificate_syllabus (2) (1)The itil foundation_certificate_syllabus (2) (1)
The itil foundation_certificate_syllabus (2) (1)
 
TCP Filtering on ASA
TCP Filtering on ASATCP Filtering on ASA
TCP Filtering on ASA
 
Fit nessecheatsheet
Fit nessecheatsheetFit nessecheatsheet
Fit nessecheatsheet
 
Packet Inspection on ASA
Packet Inspection on ASAPacket Inspection on ASA
Packet Inspection on ASA
 
23100136 mpls
23100136 mpls23100136 mpls
23100136 mpls
 
Eigrp
EigrpEigrp
Eigrp
 
Voip basics
Voip basicsVoip basics
Voip basics
 
I pv6
I pv6I pv6
I pv6
 
Ospf
OspfOspf
Ospf
 
Ios i pv4_access_lists
Ios i pv4_access_listsIos i pv4_access_lists
Ios i pv4_access_lists
 
Ios zone based-firewall
Ios zone based-firewallIos zone based-firewall
Ios zone based-firewall
 
I pv4 multicast
I pv4 multicastI pv4 multicast
I pv4 multicast
 
Acl
AclAcl
Acl
 
Dev + Ops + Azure = VL
Dev + Ops + Azure = VLDev + Ops + Azure = VL
Dev + Ops + Azure = VL
 
QoS Cheatsheet by packetlife.net
QoS Cheatsheet by packetlife.netQoS Cheatsheet by packetlife.net
QoS Cheatsheet by packetlife.net
 
I psec
I psecI psec
I psec
 
vPC_Final
vPC_FinalvPC_Final
vPC_Final
 
Frame mode mpls
Frame mode mplsFrame mode mpls
Frame mode mpls
 
Ios interior routing_protocols
Ios interior routing_protocolsIos interior routing_protocols
Ios interior routing_protocols
 
Ieee 802.1 x
Ieee 802.1 xIeee 802.1 x
Ieee 802.1 x
 

Semelhante a Nat

Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccnarobertoxe
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)Netwax Lab
 
Chapter 5-Network Address Translation.pdf
Chapter 5-Network Address Translation.pdfChapter 5-Network Address Translation.pdf
Chapter 5-Network Address Translation.pdfBuntha Chhay
 
Network address translations
Network address translations Network address translations
Network address translations Shahzad shareef
 
Basic ASA Configuration, NAT in ASA Firewall
Basic ASA Configuration,NAT in ASA FirewallBasic ASA Configuration,NAT in ASA Firewall
Basic ASA Configuration, NAT in ASA Firewall NetProtocol Xpert
 
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9Waqas Ahmed Nawaz
 
NAT and PAT
NAT and PATNAT and PAT
NAT and PATMuuluu
 
Module (10) NAT for IPV4.pptx
Module (10) NAT for IPV4.pptxModule (10) NAT for IPV4.pptx
Module (10) NAT for IPV4.pptxGeorgeThoreJr
 
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 Configuring a Cisco Router as a PPPoE Client for DSL Connectivity Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity3Anetwork com
 
Network Address Translation (NAT)
Network Address Translation (NAT)Network Address Translation (NAT)
Network Address Translation (NAT)Joud Khattab
 
NAT- Network Address Translation
NAT- Network Address TranslationNAT- Network Address Translation
NAT- Network Address TranslationEng. Emad Al-Atoum
 

Semelhante a Nat (20)

Nat
NatNat
Nat
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
Nat 07
Nat 07Nat 07
Nat 07
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)
 
Chapter 5-Network Address Translation.pdf
Chapter 5-Network Address Translation.pdfChapter 5-Network Address Translation.pdf
Chapter 5-Network Address Translation.pdf
 
Network address translations
Network address translations Network address translations
Network address translations
 
Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5
 
N at
N atN at
N at
 
NAT_Final
NAT_FinalNAT_Final
NAT_Final
 
Day 17 nat and pat
Day 17 nat and patDay 17 nat and pat
Day 17 nat and pat
 
Basic ASA Configuration, NAT in ASA Firewall
Basic ASA Configuration,NAT in ASA FirewallBasic ASA Configuration,NAT in ASA Firewall
Basic ASA Configuration, NAT in ASA Firewall
 
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
 
NAT and PAT
NAT and PATNAT and PAT
NAT and PAT
 
Module (10) NAT for IPV4.pptx
Module (10) NAT for IPV4.pptxModule (10) NAT for IPV4.pptx
Module (10) NAT for IPV4.pptx
 
Icnd210 s07l01
Icnd210 s07l01Icnd210 s07l01
Icnd210 s07l01
 
Nat 03
Nat 03Nat 03
Nat 03
 
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 Configuring a Cisco Router as a PPPoE Client for DSL Connectivity Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 
Network Address Translation (NAT)
Network Address Translation (NAT)Network Address Translation (NAT)
Network Address Translation (NAT)
 
NAT- Network Address Translation
NAT- Network Address TranslationNAT- Network Address Translation
NAT- Network Address Translation
 

Mais de Swapnil Kapate (20)

Training development382
Training development382Training development382
Training development382
 
E governance
E governanceE governance
E governance
 
D2014082010
D2014082010D2014082010
D2014082010
 
Ccnp workbook network bulls
Ccnp workbook network bullsCcnp workbook network bulls
Ccnp workbook network bulls
 
Cloud computing e gov-12
Cloud computing e gov-12Cloud computing e gov-12
Cloud computing e gov-12
 
Cctns trg syllabus
Cctns trg syllabusCctns trg syllabus
Cctns trg syllabus
 
Advanced troubleshooting
Advanced troubleshootingAdvanced troubleshooting
Advanced troubleshooting
 
Ccna read
Ccna readCcna read
Ccna read
 
certificate
certificatecertificate
certificate
 
Networking
NetworkingNetworking
Networking
 
Ip addressing and subnetting instructors workbook
Ip addressing and subnetting   instructors workbookIp addressing and subnetting   instructors workbook
Ip addressing and subnetting instructors workbook
 
Vla ns
Vla nsVla ns
Vla ns
 
Tcpdump
TcpdumpTcpdump
Tcpdump
 
Spanning tree
Spanning treeSpanning tree
Spanning tree
 
Scapy
ScapyScapy
Scapy
 
Rip
RipRip
Rip
 
Qo s
Qo sQo s
Qo s
 
Ppp
PppPpp
Ppp
 
Physical terminations
Physical terminationsPhysical terminations
Physical terminations
 
Media wiki
Media wikiMedia wiki
Media wiki
 

Nat

  • 1. NETWORK ADDRESS TRANSLATION packetlife.net Example Topology Address Classification An actual address assigned to Inside Local an inside host An inside address seen from Inside Global the outside An actual address assigned to FastEthernet0 FastEthernet1 Outside Global an outside host 10.0.0.1/16 174.143.212.1/22 NAT Inside NAT Outside An outside address seen from Outside Local the inside NAT Boundary Configuration Perspective interface FastEthernet0 Local Global ip address 10.0.0.1 255.255.0.0 ip nat inside Location ! Inside Inside Local Inside Global interface FastEthernet1 ip address 174.143.212.1 255.255.252.0 ip nat outside Outside Outside Local Outside Global Static Source Translation Terminology ! One line per static translation NAT Pool ip nat inside source static 10.0.0.19 192.0.2.1 A pool of IP addresses to be used as inside ip nat inside source static 10.0.1.47 192.0.2.2 global or outside local addresses in translations ip nat outside source static 174.143.212.133 10.0.0.47 Port Address Translation (PAT) ip nat outside source static 174.143.213.240 10.0.2.181 An extension to NAT that translates information at layer four and above, such as TCP and UDP Dynamic Source Translation port numbers; dynamic PAT configurations include the overload keyword ! Create an access list to match inside local addresses access-list 10 permit 10.0.0.0 0.0.255.255 Extendable Translation ! The extendable keyword must be appended ! Create NAT pool of inside global addresses when multiple overlapping static translations are ip nat pool MyPool 192.0.2.1 192.0.2.254 prefix-length 24 configured ! ! Combine them with a translation rule Special NAT Pool Types ip nat inside source list 10 pool MyPool Rotary Used for load balancing ! ! Dynamic translations can be combined with static entries Match- Preserves the host portion of ip nat inside source static 10.0.0.42 192.0.2.42 Host the address after translation Port Address Translation (PAT) Troubleshooting ! Static layer four port translations show ip nat translations [verbose] ip nat inside source static tcp 10.0.0.3 8080 192.0.2.1 80 show ip nat statistics ip nat inside source static udp 10.0.0.14 53 192.0.2.2 53 ip nat outside source static tcp 174.143.212.4 23 10.0.0.8 23 clear ip nat translations ! ! Dynamic port translation with a pool NAT Translations Tuning ip nat inside source list 11 pool MyPool overload ! ip nat translation tcp-timeout <seconds> ! Dynamic translation with interface overloading ip nat translation udp-timeout <seconds> ip nat inside source list 11 interface FastEthernet1 overload ip nat translation max-entries <number> Inside Destination Translation ! Create a rotary NAT pool ip nat pool LoadBalServers 10.0.99.200 10.0.99.203 prefix-length 24 type rotary ! ! Enable load balancing across inside hosts for incoming traffic ip nat inside destination list 12 pool LoadBalServers by Jeremy Stretch v1.0