SlideShare a Scribd company logo
1 of 7
Configuring a Cisco Router as a PPPoE Client for DSL connectivity
PPPoE: Point-to-Point Protocol over Ethernet. The PPP over Ethernet Client feature
provides PPP over Ethernet (PPPoE) Client support on routers on customer premises.
Configuring a Cisco routers as a PPPoE client for DSL connectivity, there are two cases,
one for the Ethernet interfaces, and another for the ATM interfaces
A. PPPoE on Ethernet interfaces—PPPoE functionality is configured on a CPE
router with two Ethernet interfaces. One Ethernet interface is subscriber-facing,
the other provider facing.
B. PPPoE on ATM interfaces—PPPoE functionality is configured on a CPE router
with one Ethernet interface and one ATM interface. The Ethernet interface is
subscriber-facing whereas the ATM interface is provider-facing.
Note: I noticed that on some books no one mentioned the configuration of IP domain
lookup command and ISP DNS options in DHCP server configuration. Without these
DSL connection will not work. Also pay attention if DSL connection did not work, to check
the state of all interfaces by using show ip interface brief and make sure to issue no
shutdown command on all of them.
A. PPPoE on Ethernet interfaces
DSL configuration brief steps:
1. Internal Ethernet interface configuration
2. External Ethernet interface configuration
3. Dialer interface configuration
4. Configuring Access List
5. NAT/PAT configuration
6. Configuring IP domain Lookup
7. DHCP server services configuration
8. Static default route configuration
DSL configuration detailed steps:
1. Internal Ethernet interface configuration
interface FastEthernet 0/1
description internal interface
ip address 172.16.1.1 255.255.255.0
1
ip nat inside
no shut
OR (incase you are using Cisco 877 router)
interface Vlan1
description internal interface
ip address 172.16.1.1 255.255.255.0
ip nat inside
no shut
2. External Ethernet interface configuration
Interface FastEthernet 0/0
Description DSL interface
no ip address
pppoe enable
pppoe-client dial-pool-number 1
no shut
3. Dialer interface configuration
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp pap sent-username USERNAME password P@ssw0rd (this is the password that
ISP gave it to you
ppp chap hostname HOSTNAME (This is the username that ISP gave it to you)
ppp chap password P@ssw0rd
no shut
4. Configuring Access List
ip access-list extended DSL_ACCESSLIST
100 permit ip 10.10.10.0 0.0.0.255 any
5. Configuring NAT/PAT
ip nat inside source list DSL_ACCESSLIST interface dialer 1 overload
2
6. Configuring IP domain Lookup
ip domain lookup
ip name-server Primary DNS IP address (obtained from your ISP)
ip name-server Secondary DNS IP address (obtained from your ISP)
7. DHCP server services configuration
ip dhcp pool DSL_DHCP
network 10.10.10.0 /29
dns-server Primary DNS IP address Secondary DNS IP address (obtained from your
ISP)
default-router 10.10.10.1 (internal VLAN or Ethernet interface Ip address)
import all
8. Static default route configuration
Finally, configure a static default route. It should point to the dialer interface rather
than an IP address as in the below example.
ip route 0.0.0.0 0.0.0.0 dialer 1
B. PPPoE on ATM interfaces
DSL configuration brief steps:
1. Internal Ethernet interface configuration
2. External ATM interface configuration (in case you are using Cisco 877 Router)
3. Dialer interface configuration
4. Configuring Access List
5. NAT/PAT configuration
6. Configuring IP domain Lookup
7. DHCP server services configuration
8. Static default route configuration
DSL configuration detailed steps:
1. Internal VLAN interface configuration (using Cisco 877 Router)
interface Vlan1
description internal interface
3
ip address 172.16.1.1 255.255.255.0
ip nat inside
no shut
OR (if you are using configurable internal Ethernet interface)
interface FastEthernet 0/1
description internal interface
ip address 172.16.1.1 255.255.255.0
ip nat inside
no shut
2. External ATM interface configuration
interface ATM 0
description DSL interface
ip directed-broadcast
ip mask-reply
ip route-cache flow
no ip address
dsl operating-mode auto
pvc 8/35
no shutdown
pppoe-client dial-pool-number 1
3. Dialer interface configuration
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp pap sent-username USERNAME password P@ssw0rd (this is the password that
ISP gave it to you
ppp chap hostname HOSTNAME (This is the username that ISP gave it to you)
ppp chap password P@ssw0rd
no shut
4. Configuring Access List
ip access-list extended DSL_ACCESSLIST
4
100 permit ip 10.10.10.0 0.0.0.255 any
5. Configuring NAT/PAT
ip nat inside source list DSL_ACCESSLIST interface dialer 1 overload
6. Configuring IP domain Lookup
ip domain lookup
ip name-server Primary DNS IP address (obtained from your ISP)
ip name-server Secondary DNS IP address (obtained from your ISP)
7. DHCP server services configuration
ip dhcp pool DSL_DHCP
network 10.10.10.0 /29
dns-server Primary DNS IP address Secondary DNS IP address (obtained from your
ISP)
default-router 10.10.10.1 (internal VLAN or Ethernet interface Ip address)
import all
8. Static default route configuration
Finally, configure a static default route. It should point to the dialer interface rather
than an IP address as in the below example.
ip route 0.0.0.0 0.0.0.0 dialer 1
More related:
Cisco Router 1941 Commands
How to recover Cisco 1921 router default password?
Cisco 2911 SNMP not working
How To Recover Cisco Router Password
The Difference of The Cisco Catalyst 2900 and Cisco Catalyst 1900
More Cisco products and Reviews you can visit: http://www.3anetwork.com/blog
3Anetwork.com is a world leading Cisco networking products wholesaler, we wholesale
original new Cisco networking equipments, including Cisco Catalyst switches, Cisco
5
routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards
products at competitive price and ship to worldwide.
Our website: http://www.3anetwork.com
Telephone: +852-3069-7733
Email: info@3Anetwork.com
Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong
6
routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards
products at competitive price and ship to worldwide.
Our website: http://www.3anetwork.com
Telephone: +852-3069-7733
Email: info@3Anetwork.com
Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong
6

More Related Content

What's hot

Netmanias L2,L3 Training (5) L3 SW Architecture
Netmanias L2,L3 Training (5) L3 SW ArchitectureNetmanias L2,L3 Training (5) L3 SW Architecture
Netmanias L2,L3 Training (5) L3 SW ArchitectureChris Changmo Yoo
 
CCNA 200-301 Chapter 1-Introduction to TCP IP Networking.pptx
CCNA 200-301 Chapter 1-Introduction to TCP IP Networking.pptxCCNA 200-301 Chapter 1-Introduction to TCP IP Networking.pptx
CCNA 200-301 Chapter 1-Introduction to TCP IP Networking.pptxBabarYunus1
 
1000 Ccna Questions And Answers
1000 Ccna Questions And Answers1000 Ccna Questions And Answers
1000 Ccna Questions And AnswersCCNAResources
 
Spanning Tree Protocol
Spanning Tree ProtocolSpanning Tree Protocol
Spanning Tree ProtocolManoj Gharate
 
Cisco router-commands
Cisco router-commandsCisco router-commands
Cisco router-commandsRobin Rohit
 
5.5.1.2 packet tracer configure ios intrusion prevention system (ips) using...
5.5.1.2 packet tracer   configure ios intrusion prevention system (ips) using...5.5.1.2 packet tracer   configure ios intrusion prevention system (ips) using...
5.5.1.2 packet tracer configure ios intrusion prevention system (ips) using...Salem Trabelsi
 
Session Initiation Protocol
Session Initiation ProtocolSession Initiation Protocol
Session Initiation ProtocolMatt Bynum
 
Linux Networking Explained
Linux Networking ExplainedLinux Networking Explained
Linux Networking ExplainedThomas Graf
 
Netmanias L2,L3 Training (1) L2 Ethernet
Netmanias L2,L3 Training (1) L2 EthernetNetmanias L2,L3 Training (1) L2 Ethernet
Netmanias L2,L3 Training (1) L2 EthernetChris Changmo Yoo
 
Wireshark
WiresharkWireshark
Wiresharkbtohara
 
Troubleshooting BGP
Troubleshooting BGPTroubleshooting BGP
Troubleshooting BGPAPNIC
 

What's hot (20)

Implementing cisco mpls
Implementing cisco mplsImplementing cisco mpls
Implementing cisco mpls
 
Netmanias L2,L3 Training (5) L3 SW Architecture
Netmanias L2,L3 Training (5) L3 SW ArchitectureNetmanias L2,L3 Training (5) L3 SW Architecture
Netmanias L2,L3 Training (5) L3 SW Architecture
 
CCNA 200-301 Chapter 1-Introduction to TCP IP Networking.pptx
CCNA 200-301 Chapter 1-Introduction to TCP IP Networking.pptxCCNA 200-301 Chapter 1-Introduction to TCP IP Networking.pptx
CCNA 200-301 Chapter 1-Introduction to TCP IP Networking.pptx
 
OSPF Fundamental
OSPF FundamentalOSPF Fundamental
OSPF Fundamental
 
1000 Ccna Questions And Answers
1000 Ccna Questions And Answers1000 Ccna Questions And Answers
1000 Ccna Questions And Answers
 
Spanning Tree Protocol
Spanning Tree ProtocolSpanning Tree Protocol
Spanning Tree Protocol
 
L2 tp
L2 tpL2 tp
L2 tp
 
IMS ENUM & DNS Mechanism
IMS ENUM & DNS MechanismIMS ENUM & DNS Mechanism
IMS ENUM & DNS Mechanism
 
Cisco router-commands
Cisco router-commandsCisco router-commands
Cisco router-commands
 
5.5.1.2 packet tracer configure ios intrusion prevention system (ips) using...
5.5.1.2 packet tracer   configure ios intrusion prevention system (ips) using...5.5.1.2 packet tracer   configure ios intrusion prevention system (ips) using...
5.5.1.2 packet tracer configure ios intrusion prevention system (ips) using...
 
Session Initiation Protocol
Session Initiation ProtocolSession Initiation Protocol
Session Initiation Protocol
 
Linux Networking Explained
Linux Networking ExplainedLinux Networking Explained
Linux Networking Explained
 
EtherChannel
EtherChannelEtherChannel
EtherChannel
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
Netmanias L2,L3 Training (1) L2 Ethernet
Netmanias L2,L3 Training (1) L2 EthernetNetmanias L2,L3 Training (1) L2 Ethernet
Netmanias L2,L3 Training (1) L2 Ethernet
 
Wireshark
WiresharkWireshark
Wireshark
 
Troubleshooting BGP
Troubleshooting BGPTroubleshooting BGP
Troubleshooting BGP
 
Ipv6
Ipv6Ipv6
Ipv6
 
Router commands
Router commandsRouter commands
Router commands
 
03 ospf
03 ospf 03 ospf
03 ospf
 

Viewers also liked

CCNA 4.1 - Capítulo 06 configuração básica de roteadores cisco
CCNA 4.1 - Capítulo 06   configuração básica de roteadores ciscoCCNA 4.1 - Capítulo 06   configuração básica de roteadores cisco
CCNA 4.1 - Capítulo 06 configuração básica de roteadores ciscoSergio Maia
 
Subnetting and routing
Subnetting and routingSubnetting and routing
Subnetting and routingGaurav Juneja
 
Network switches, functions & role in networks
Network switches, functions & role in networksNetwork switches, functions & role in networks
Network switches, functions & role in networksIT Tech
 
Internet control message protocol
Internet control message protocolInternet control message protocol
Internet control message protocolasimnawaz54
 

Viewers also liked (7)

Pppoe,pppoa
Pppoe,pppoaPppoe,pppoa
Pppoe,pppoa
 
CCNA 4.1 - Capítulo 06 configuração básica de roteadores cisco
CCNA 4.1 - Capítulo 06   configuração básica de roteadores ciscoCCNA 4.1 - Capítulo 06   configuração básica de roteadores cisco
CCNA 4.1 - Capítulo 06 configuração básica de roteadores cisco
 
Subnetting and routing
Subnetting and routingSubnetting and routing
Subnetting and routing
 
Network switches, functions & role in networks
Network switches, functions & role in networksNetwork switches, functions & role in networks
Network switches, functions & role in networks
 
Http Vs Https .
Http Vs Https . Http Vs Https .
Http Vs Https .
 
Dhcp ppt
Dhcp pptDhcp ppt
Dhcp ppt
 
Internet control message protocol
Internet control message protocolInternet control message protocol
Internet control message protocol
 

Similar to Configure Cisco Router as PPPoE Client for DSL

Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccnarobertoxe
 
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docxCCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docxketurahhazelhurst
 
Chapter 15 : routing concepts
Chapter 15 : routing conceptsChapter 15 : routing concepts
Chapter 15 : routing conceptsteknetir
 
CCNA Network Services
CCNA Network ServicesCCNA Network Services
CCNA Network ServicesDsunte Wilson
 
CCNAv5 - S2: Chapter4 Routing Concepts
CCNAv5 - S2: Chapter4 Routing ConceptsCCNAv5 - S2: Chapter4 Routing Concepts
CCNAv5 - S2: Chapter4 Routing ConceptsVuz Dở Hơi
 
KPUCC-Rs instructor ppt_chapter4_final
KPUCC-Rs instructor ppt_chapter4_finalKPUCC-Rs instructor ppt_chapter4_final
KPUCC-Rs instructor ppt_chapter4_finalFisal Anwari
 
Chapter 04 - Routing Concepts
Chapter 04 - Routing ConceptsChapter 04 - Routing Concepts
Chapter 04 - Routing ConceptsYaser Rahmati
 
How to configure static nat on cisco routers
How to configure static nat on cisco routersHow to configure static nat on cisco routers
How to configure static nat on cisco routersIT Tech
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)Netwax Lab
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configurationsamreenghauri786
 
CCNA 2 Routing and Switching v5.0 Chapter 4
CCNA 2 Routing and Switching v5.0 Chapter 4CCNA 2 Routing and Switching v5.0 Chapter 4
CCNA 2 Routing and Switching v5.0 Chapter 4Nil Menon
 

Similar to Configure Cisco Router as PPPoE Client for DSL (20)

Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
scg basic
scg basicscg basic
scg basic
 
Nat 03
Nat 03Nat 03
Nat 03
 
Nat 07
Nat 07Nat 07
Nat 07
 
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docxCCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
 
Day 17.1 nat pat
Day 17.1 nat pat Day 17.1 nat pat
Day 17.1 nat pat
 
Chapter 15 : routing concepts
Chapter 15 : routing conceptsChapter 15 : routing concepts
Chapter 15 : routing concepts
 
CCNA Network Services
CCNA Network ServicesCCNA Network Services
CCNA Network Services
 
CCNA Icnd110 s05l04
CCNA Icnd110 s05l04CCNA Icnd110 s05l04
CCNA Icnd110 s05l04
 
CCNAv5 - S2: Chapter4 Routing Concepts
CCNAv5 - S2: Chapter4 Routing ConceptsCCNAv5 - S2: Chapter4 Routing Concepts
CCNAv5 - S2: Chapter4 Routing Concepts
 
KPUCC-Rs instructor ppt_chapter4_final
KPUCC-Rs instructor ppt_chapter4_finalKPUCC-Rs instructor ppt_chapter4_final
KPUCC-Rs instructor ppt_chapter4_final
 
Chapter 04 - Routing Concepts
Chapter 04 - Routing ConceptsChapter 04 - Routing Concepts
Chapter 04 - Routing Concepts
 
How to configure static nat on cisco routers
How to configure static nat on cisco routersHow to configure static nat on cisco routers
How to configure static nat on cisco routers
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configuration
 
CCNA 2 Routing and Switching v5.0 Chapter 4
CCNA 2 Routing and Switching v5.0 Chapter 4CCNA 2 Routing and Switching v5.0 Chapter 4
CCNA 2 Routing and Switching v5.0 Chapter 4
 
N at
N atN at
N at
 
Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5
 
520scg basic
520scg basic520scg basic
520scg basic
 

More from 3Anetwork com

Cisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routersCisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routers3Anetwork com
 
Cisco catalyst 2960 x series
Cisco catalyst 2960 x seriesCisco catalyst 2960 x series
Cisco catalyst 2960 x series3Anetwork com
 
Cisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switchesCisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switches3Anetwork com
 
Cisco switches for small business
Cisco switches for small businessCisco switches for small business
Cisco switches for small business3Anetwork com
 
How to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services routerHow to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services router3Anetwork com
 
Cisco 4 and 8-port gigabit ethernet ehwi cs
Cisco 4  and 8-port gigabit ethernet ehwi csCisco 4  and 8-port gigabit ethernet ehwi cs
Cisco 4 and 8-port gigabit ethernet ehwi cs3Anetwork com
 
Configuring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup programConfiguring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup program3Anetwork com
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration3Anetwork com
 
Cisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheetCisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheet3Anetwork com
 
Cisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overviewCisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overview3Anetwork com
 
Enterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stickEnterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stick3Anetwork com
 
Cisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X DatasheetCisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X Datasheet3Anetwork com
 
How to configure a catalyst 3750 x
How to configure a catalyst 3750 xHow to configure a catalyst 3750 x
How to configure a catalyst 3750 x3Anetwork com
 
Hubs vs switches vs routers
Hubs vs switches vs routersHubs vs switches vs routers
Hubs vs switches vs routers3Anetwork com
 
Installing and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modulesInstalling and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modules3Anetwork com
 
Dmvpn with configuration example
Dmvpn with configuration exampleDmvpn with configuration example
Dmvpn with configuration example3Anetwork com
 
Cisco unified access from vision to reality
Cisco unified access from vision to realityCisco unified access from vision to reality
Cisco unified access from vision to reality3Anetwork com
 
How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)3Anetwork com
 
Cisco router command configuration overview
Cisco router command configuration overviewCisco router command configuration overview
Cisco router command configuration overview3Anetwork com
 

More from 3Anetwork com (20)

Cisco sfp modules
Cisco sfp modulesCisco sfp modules
Cisco sfp modules
 
Cisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routersCisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routers
 
Cisco catalyst 2960 x series
Cisco catalyst 2960 x seriesCisco catalyst 2960 x series
Cisco catalyst 2960 x series
 
Cisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switchesCisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switches
 
Cisco switches for small business
Cisco switches for small businessCisco switches for small business
Cisco switches for small business
 
How to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services routerHow to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services router
 
Cisco 4 and 8-port gigabit ethernet ehwi cs
Cisco 4  and 8-port gigabit ethernet ehwi csCisco 4  and 8-port gigabit ethernet ehwi cs
Cisco 4 and 8-port gigabit ethernet ehwi cs
 
Configuring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup programConfiguring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup program
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration
 
Cisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheetCisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheet
 
Cisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overviewCisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overview
 
Enterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stickEnterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stick
 
Cisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X DatasheetCisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X Datasheet
 
How to configure a catalyst 3750 x
How to configure a catalyst 3750 xHow to configure a catalyst 3750 x
How to configure a catalyst 3750 x
 
Hubs vs switches vs routers
Hubs vs switches vs routersHubs vs switches vs routers
Hubs vs switches vs routers
 
Installing and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modulesInstalling and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modules
 
Dmvpn with configuration example
Dmvpn with configuration exampleDmvpn with configuration example
Dmvpn with configuration example
 
Cisco unified access from vision to reality
Cisco unified access from vision to realityCisco unified access from vision to reality
Cisco unified access from vision to reality
 
How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)
 
Cisco router command configuration overview
Cisco router command configuration overviewCisco router command configuration overview
Cisco router command configuration overview
 

Recently uploaded

『澳洲文凭』买詹姆士库克大学毕业证书成绩单办理澳洲JCU文凭学位证书
『澳洲文凭』买詹姆士库克大学毕业证书成绩单办理澳洲JCU文凭学位证书『澳洲文凭』买詹姆士库克大学毕业证书成绩单办理澳洲JCU文凭学位证书
『澳洲文凭』买詹姆士库克大学毕业证书成绩单办理澳洲JCU文凭学位证书rnrncn29
 
办理(UofR毕业证书)罗切斯特大学毕业证成绩单原版一比一
办理(UofR毕业证书)罗切斯特大学毕业证成绩单原版一比一办理(UofR毕业证书)罗切斯特大学毕业证成绩单原版一比一
办理(UofR毕业证书)罗切斯特大学毕业证成绩单原版一比一z xss
 
Top 10 Interactive Website Design Trends in 2024.pptx
Top 10 Interactive Website Design Trends in 2024.pptxTop 10 Interactive Website Design Trends in 2024.pptx
Top 10 Interactive Website Design Trends in 2024.pptxDyna Gilbert
 
SCM Symposium PPT Format Customer loyalty is predi
SCM Symposium PPT Format Customer loyalty is prediSCM Symposium PPT Format Customer loyalty is predi
SCM Symposium PPT Format Customer loyalty is predieusebiomeyer
 
Film cover research (1).pptxsdasdasdasdasdasa
Film cover research (1).pptxsdasdasdasdasdasaFilm cover research (1).pptxsdasdasdasdasdasa
Film cover research (1).pptxsdasdasdasdasdasa494f574xmv
 
『澳洲文凭』买拉筹伯大学毕业证书成绩单办理澳洲LTU文凭学位证书
『澳洲文凭』买拉筹伯大学毕业证书成绩单办理澳洲LTU文凭学位证书『澳洲文凭』买拉筹伯大学毕业证书成绩单办理澳洲LTU文凭学位证书
『澳洲文凭』买拉筹伯大学毕业证书成绩单办理澳洲LTU文凭学位证书rnrncn29
 
Potsdam FH学位证,波茨坦应用技术大学毕业证书1:1制作
Potsdam FH学位证,波茨坦应用技术大学毕业证书1:1制作Potsdam FH学位证,波茨坦应用技术大学毕业证书1:1制作
Potsdam FH学位证,波茨坦应用技术大学毕业证书1:1制作ys8omjxb
 
Q4-1-Illustrating-Hypothesis-Testing.pptx
Q4-1-Illustrating-Hypothesis-Testing.pptxQ4-1-Illustrating-Hypothesis-Testing.pptx
Q4-1-Illustrating-Hypothesis-Testing.pptxeditsforyah
 
PHP-based rendering of TYPO3 Documentation
PHP-based rendering of TYPO3 DocumentationPHP-based rendering of TYPO3 Documentation
PHP-based rendering of TYPO3 DocumentationLinaWolf1
 
Font Performance - NYC WebPerf Meetup April '24
Font Performance - NYC WebPerf Meetup April '24Font Performance - NYC WebPerf Meetup April '24
Font Performance - NYC WebPerf Meetup April '24Paul Calvano
 
Contact Rya Baby for Call Girls New Delhi
Contact Rya Baby for Call Girls New DelhiContact Rya Baby for Call Girls New Delhi
Contact Rya Baby for Call Girls New Delhimiss dipika
 
Call Girls Near The Suryaa Hotel New Delhi 9873777170
Call Girls Near The Suryaa Hotel New Delhi 9873777170Call Girls Near The Suryaa Hotel New Delhi 9873777170
Call Girls Near The Suryaa Hotel New Delhi 9873777170Sonam Pathan
 
NSX-T and Service Interfaces presentation
NSX-T and Service Interfaces presentationNSX-T and Service Interfaces presentation
NSX-T and Service Interfaces presentationMarko4394
 
办理多伦多大学毕业证成绩单|购买加拿大UTSG文凭证书
办理多伦多大学毕业证成绩单|购买加拿大UTSG文凭证书办理多伦多大学毕业证成绩单|购买加拿大UTSG文凭证书
办理多伦多大学毕业证成绩单|购买加拿大UTSG文凭证书zdzoqco
 
Call Girls In The Ocean Pearl Retreat Hotel New Delhi 9873777170
Call Girls In The Ocean Pearl Retreat Hotel New Delhi 9873777170Call Girls In The Ocean Pearl Retreat Hotel New Delhi 9873777170
Call Girls In The Ocean Pearl Retreat Hotel New Delhi 9873777170Sonam Pathan
 

Recently uploaded (17)

『澳洲文凭』买詹姆士库克大学毕业证书成绩单办理澳洲JCU文凭学位证书
『澳洲文凭』买詹姆士库克大学毕业证书成绩单办理澳洲JCU文凭学位证书『澳洲文凭』买詹姆士库克大学毕业证书成绩单办理澳洲JCU文凭学位证书
『澳洲文凭』买詹姆士库克大学毕业证书成绩单办理澳洲JCU文凭学位证书
 
办理(UofR毕业证书)罗切斯特大学毕业证成绩单原版一比一
办理(UofR毕业证书)罗切斯特大学毕业证成绩单原版一比一办理(UofR毕业证书)罗切斯特大学毕业证成绩单原版一比一
办理(UofR毕业证书)罗切斯特大学毕业证成绩单原版一比一
 
Top 10 Interactive Website Design Trends in 2024.pptx
Top 10 Interactive Website Design Trends in 2024.pptxTop 10 Interactive Website Design Trends in 2024.pptx
Top 10 Interactive Website Design Trends in 2024.pptx
 
SCM Symposium PPT Format Customer loyalty is predi
SCM Symposium PPT Format Customer loyalty is prediSCM Symposium PPT Format Customer loyalty is predi
SCM Symposium PPT Format Customer loyalty is predi
 
Film cover research (1).pptxsdasdasdasdasdasa
Film cover research (1).pptxsdasdasdasdasdasaFilm cover research (1).pptxsdasdasdasdasdasa
Film cover research (1).pptxsdasdasdasdasdasa
 
『澳洲文凭』买拉筹伯大学毕业证书成绩单办理澳洲LTU文凭学位证书
『澳洲文凭』买拉筹伯大学毕业证书成绩单办理澳洲LTU文凭学位证书『澳洲文凭』买拉筹伯大学毕业证书成绩单办理澳洲LTU文凭学位证书
『澳洲文凭』买拉筹伯大学毕业证书成绩单办理澳洲LTU文凭学位证书
 
Potsdam FH学位证,波茨坦应用技术大学毕业证书1:1制作
Potsdam FH学位证,波茨坦应用技术大学毕业证书1:1制作Potsdam FH学位证,波茨坦应用技术大学毕业证书1:1制作
Potsdam FH学位证,波茨坦应用技术大学毕业证书1:1制作
 
Q4-1-Illustrating-Hypothesis-Testing.pptx
Q4-1-Illustrating-Hypothesis-Testing.pptxQ4-1-Illustrating-Hypothesis-Testing.pptx
Q4-1-Illustrating-Hypothesis-Testing.pptx
 
PHP-based rendering of TYPO3 Documentation
PHP-based rendering of TYPO3 DocumentationPHP-based rendering of TYPO3 Documentation
PHP-based rendering of TYPO3 Documentation
 
Font Performance - NYC WebPerf Meetup April '24
Font Performance - NYC WebPerf Meetup April '24Font Performance - NYC WebPerf Meetup April '24
Font Performance - NYC WebPerf Meetup April '24
 
young call girls in Uttam Nagar🔝 9953056974 🔝 Delhi escort Service
young call girls in Uttam Nagar🔝 9953056974 🔝 Delhi escort Serviceyoung call girls in Uttam Nagar🔝 9953056974 🔝 Delhi escort Service
young call girls in Uttam Nagar🔝 9953056974 🔝 Delhi escort Service
 
Contact Rya Baby for Call Girls New Delhi
Contact Rya Baby for Call Girls New DelhiContact Rya Baby for Call Girls New Delhi
Contact Rya Baby for Call Girls New Delhi
 
Call Girls Near The Suryaa Hotel New Delhi 9873777170
Call Girls Near The Suryaa Hotel New Delhi 9873777170Call Girls Near The Suryaa Hotel New Delhi 9873777170
Call Girls Near The Suryaa Hotel New Delhi 9873777170
 
NSX-T and Service Interfaces presentation
NSX-T and Service Interfaces presentationNSX-T and Service Interfaces presentation
NSX-T and Service Interfaces presentation
 
办理多伦多大学毕业证成绩单|购买加拿大UTSG文凭证书
办理多伦多大学毕业证成绩单|购买加拿大UTSG文凭证书办理多伦多大学毕业证成绩单|购买加拿大UTSG文凭证书
办理多伦多大学毕业证成绩单|购买加拿大UTSG文凭证书
 
Call Girls In The Ocean Pearl Retreat Hotel New Delhi 9873777170
Call Girls In The Ocean Pearl Retreat Hotel New Delhi 9873777170Call Girls In The Ocean Pearl Retreat Hotel New Delhi 9873777170
Call Girls In The Ocean Pearl Retreat Hotel New Delhi 9873777170
 
Hot Sexy call girls in Rk Puram 🔝 9953056974 🔝 Delhi escort Service
Hot Sexy call girls in  Rk Puram 🔝 9953056974 🔝 Delhi escort ServiceHot Sexy call girls in  Rk Puram 🔝 9953056974 🔝 Delhi escort Service
Hot Sexy call girls in Rk Puram 🔝 9953056974 🔝 Delhi escort Service
 

Configure Cisco Router as PPPoE Client for DSL

  • 1. Configuring a Cisco Router as a PPPoE Client for DSL connectivity PPPoE: Point-to-Point Protocol over Ethernet. The PPP over Ethernet Client feature provides PPP over Ethernet (PPPoE) Client support on routers on customer premises. Configuring a Cisco routers as a PPPoE client for DSL connectivity, there are two cases, one for the Ethernet interfaces, and another for the ATM interfaces A. PPPoE on Ethernet interfaces—PPPoE functionality is configured on a CPE router with two Ethernet interfaces. One Ethernet interface is subscriber-facing, the other provider facing. B. PPPoE on ATM interfaces—PPPoE functionality is configured on a CPE router with one Ethernet interface and one ATM interface. The Ethernet interface is subscriber-facing whereas the ATM interface is provider-facing. Note: I noticed that on some books no one mentioned the configuration of IP domain lookup command and ISP DNS options in DHCP server configuration. Without these DSL connection will not work. Also pay attention if DSL connection did not work, to check the state of all interfaces by using show ip interface brief and make sure to issue no shutdown command on all of them. A. PPPoE on Ethernet interfaces DSL configuration brief steps: 1. Internal Ethernet interface configuration 2. External Ethernet interface configuration 3. Dialer interface configuration 4. Configuring Access List 5. NAT/PAT configuration 6. Configuring IP domain Lookup 7. DHCP server services configuration 8. Static default route configuration DSL configuration detailed steps: 1. Internal Ethernet interface configuration interface FastEthernet 0/1 description internal interface ip address 172.16.1.1 255.255.255.0 1
  • 2. ip nat inside no shut OR (incase you are using Cisco 877 router) interface Vlan1 description internal interface ip address 172.16.1.1 255.255.255.0 ip nat inside no shut 2. External Ethernet interface configuration Interface FastEthernet 0/0 Description DSL interface no ip address pppoe enable pppoe-client dial-pool-number 1 no shut 3. Dialer interface configuration interface Dialer1 ip address negotiated ip mtu 1492 ip nat outside encapsulation ppp dialer pool 1 ppp authentication chap pap callin ppp pap sent-username USERNAME password P@ssw0rd (this is the password that ISP gave it to you ppp chap hostname HOSTNAME (This is the username that ISP gave it to you) ppp chap password P@ssw0rd no shut 4. Configuring Access List ip access-list extended DSL_ACCESSLIST 100 permit ip 10.10.10.0 0.0.0.255 any 5. Configuring NAT/PAT ip nat inside source list DSL_ACCESSLIST interface dialer 1 overload 2
  • 3. 6. Configuring IP domain Lookup ip domain lookup ip name-server Primary DNS IP address (obtained from your ISP) ip name-server Secondary DNS IP address (obtained from your ISP) 7. DHCP server services configuration ip dhcp pool DSL_DHCP network 10.10.10.0 /29 dns-server Primary DNS IP address Secondary DNS IP address (obtained from your ISP) default-router 10.10.10.1 (internal VLAN or Ethernet interface Ip address) import all 8. Static default route configuration Finally, configure a static default route. It should point to the dialer interface rather than an IP address as in the below example. ip route 0.0.0.0 0.0.0.0 dialer 1 B. PPPoE on ATM interfaces DSL configuration brief steps: 1. Internal Ethernet interface configuration 2. External ATM interface configuration (in case you are using Cisco 877 Router) 3. Dialer interface configuration 4. Configuring Access List 5. NAT/PAT configuration 6. Configuring IP domain Lookup 7. DHCP server services configuration 8. Static default route configuration DSL configuration detailed steps: 1. Internal VLAN interface configuration (using Cisco 877 Router) interface Vlan1 description internal interface 3
  • 4. ip address 172.16.1.1 255.255.255.0 ip nat inside no shut OR (if you are using configurable internal Ethernet interface) interface FastEthernet 0/1 description internal interface ip address 172.16.1.1 255.255.255.0 ip nat inside no shut 2. External ATM interface configuration interface ATM 0 description DSL interface ip directed-broadcast ip mask-reply ip route-cache flow no ip address dsl operating-mode auto pvc 8/35 no shutdown pppoe-client dial-pool-number 1 3. Dialer interface configuration interface Dialer1 ip address negotiated ip mtu 1492 ip nat outside encapsulation ppp dialer pool 1 ppp authentication chap pap callin ppp pap sent-username USERNAME password P@ssw0rd (this is the password that ISP gave it to you ppp chap hostname HOSTNAME (This is the username that ISP gave it to you) ppp chap password P@ssw0rd no shut 4. Configuring Access List ip access-list extended DSL_ACCESSLIST 4
  • 5. 100 permit ip 10.10.10.0 0.0.0.255 any 5. Configuring NAT/PAT ip nat inside source list DSL_ACCESSLIST interface dialer 1 overload 6. Configuring IP domain Lookup ip domain lookup ip name-server Primary DNS IP address (obtained from your ISP) ip name-server Secondary DNS IP address (obtained from your ISP) 7. DHCP server services configuration ip dhcp pool DSL_DHCP network 10.10.10.0 /29 dns-server Primary DNS IP address Secondary DNS IP address (obtained from your ISP) default-router 10.10.10.1 (internal VLAN or Ethernet interface Ip address) import all 8. Static default route configuration Finally, configure a static default route. It should point to the dialer interface rather than an IP address as in the below example. ip route 0.0.0.0 0.0.0.0 dialer 1 More related: Cisco Router 1941 Commands How to recover Cisco 1921 router default password? Cisco 2911 SNMP not working How To Recover Cisco Router Password The Difference of The Cisco Catalyst 2900 and Cisco Catalyst 1900 More Cisco products and Reviews you can visit: http://www.3anetwork.com/blog 3Anetwork.com is a world leading Cisco networking products wholesaler, we wholesale original new Cisco networking equipments, including Cisco Catalyst switches, Cisco 5
  • 6. routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards products at competitive price and ship to worldwide. Our website: http://www.3anetwork.com Telephone: +852-3069-7733 Email: info@3Anetwork.com Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong 6
  • 7. routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards products at competitive price and ship to worldwide. Our website: http://www.3anetwork.com Telephone: +852-3069-7733 Email: info@3Anetwork.com Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong 6