SlideShare uma empresa Scribd logo
1 de 26
1
Dynamic Routing

Advantages of Dynamic over static :
• There is no need to know the destination networks.
•

Need to advertise the directly connected networks.

•

Updates the topology changes dynamically.

•

Administrative work is reduced

•

Used for large organizations.

2
Types of Dynamic Routing Protocols

• Distance Vector Protocol

• Link State Protocol

• Hybrid Protocol

3
Distance Vector Protocol

• Works with Bellman Ford algorithm
• Periodic updates
• Classful routing protocol
• Full Routing tables are exchanged
• Updates are through broadcast
• Also known as “Routing By Rumor”
• Example: RIP, IGRP

4
Link State Protocol

• Works with Dijkstra algorithm
• Link state updates
• Classless routing protocol
• Missing routes are exchanged
• Updates are through multicast
• Also known as “ Routing by Intelligence”
• Example : OSPF, IS-IS

5
Hybrid Protocol

• Works with DUAL algorithm
• Link state updates
• Classless routing protocol
• Missing routes are exchanged
• Updates are through multicast
• Also known as “ Routing by Intelligence”
• Example : EIGRP

6
Routing Information Protocol

• Open Standard Protocol
• Classful routing protocol
• Updates are broadcasted via 255.255.255.255
• Administrative distance is 120
• Metric : Hop count
Max Hop counts : 15

Max routers : 16

• Load Balancing of 4 equal paths
• Used for small organizations

7
Rip Timers
• Update timer : 30 sec
– Time between consecutive updates
• Invalid timer : 180 sec
– Time a router waits to hear updates
– The route is marked unreachable if there is no
update during this interval.
• Flush timer : 240 sec
– Time before the invalid route is purged from the
routing table
• Holddown timer : 180sec
– Specifies the amount of time for which the

8
information about poorer routes are ignored.
RIP - Network Diagram

10.0.0.1/8
S0

HYD

11.0.0.1/8
S0

S1
10.0.0.2/8

E0
192.168.1.150/24

LAN - 192.168.1.0/24

CHE

S1
11.0.0.2/8

E0
192.168.2.150/24

LAN - 192.168.2.0/24

BAN

E0
192.168.3.150/2

LAN - 192.168.3.0/24

9
Disadvantages of RIP

• More Bandwidth utilization
• Doesn’t consider the bandwidth, works only with hop
counts
• Slow convergence
• Formation of Routing loops

10
11
Microsoft Windows 2000 [Version 5.00.2195]
(C) Copyright 1985-2000 Microsoft Corp.
C:> telnet 192.168.1.150
Connecting .....
================================
Welcome to Hyderabad Router
================================
User Access Verification
password : ****
Directly Connected Networks on
Directly Connected Networks on
Hyderabad> enable
HYDERABAD Router
password : ****
HYDERABAD Router
Hyderabad# configure terminal
192.168.1.0
192.168.1.0
Enter configuration commands, one per line. End with CNTL/Z.
10.0.0.0
10.0.0.0
Hyderabad(config)# interface serial 0
Hyderabad(config-if)# ip address 10.0.0.1 255.0.0.0
Hyderabad(config-if)# no shut
Hyderabad(config-if)# clockrate 64000
Hyderabad(config-if)# encapsulation hdlc
Hyderabad(config-if)# exit
Hyderabad(config)#

12

Diagram
Hyderabad(config)# no ip routing
Hyderabad(config)# ip routing
Hyderabad(config)# router rip
Hyderabad(config-router)# network 192.168.1.0
Hyderabad(config-router)# network 10.0.0.0
Hyderabad(config-router)#
Configuring RIP
Configuring RIP
Router(config)# router rip
Router(config)# router rip
Router(config-router)# network <Network ID>
Router(config-router)# network <Network ID>

13

Diagram
Hyderabad(config)# no ip routing
Hyderabad(config)# ip routing
Hyderabad(config)# router rip
Hyderabad(config-router)# network 192.168.1.0
Hyderabad(config-router)# network 10.0.0.0
Hyderabad(config-router)# ^Z
Hyderabad# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i- IS-IS, L1-IS-IS level-1, L2-IS-IS level-2,*- candidate default
U - per-user static route, o - ODR

Gateway of last resort is not set
C
10.0.0.0/8 is directly connected, Serial0
R
11.0.0.0/8 [120/1] via 10.0.0.2, 00:00:25, Serial0
C
192.168.1.0/24 is directly connected, Ethernet0
R
192.168.2.0/24 [120/1]nothingbut
via of Rip
120 is Metric 10.0.0.2, 00:00:25, Serial0
Metricof Rip
120 isnothing but
R – for RIP routes
– for RIP routes
Administrative Distance 00:00:25, Serial0
R R 192.168.3.0/24 [120/2] Hop Count
via Distance
Administrative 10.0.0.2,
Hop Count
Hyderabad#
Diagram

14
Hyderabad# show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 13 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface
Send Recv
Key-chain
Ethernet0
1
1 2
Serial0
1
1 2
Routing for Networks:
192.168.1.0
10.0.0.0
Routing Information Sources:
Gateway
Distance
Last Update
10.0.0.2
120
00:00:00
Distance: (default is 120)
Hyderabad#

15

Diagram
Microsoft Windows 2000 [Version 5.00.2195]
(C) Copyright 1985-2000 Microsoft Corp.
C:> telnet 192.168.2.150
Connecting .....
================================
Welcome to Chennai Router
================================
User Access Verification
password : ****
Directly Connected Networks on
Chennai> enable Directly Connected Networks on
CHENNAI Router
password : ****
CHENNAI Router
Chennai# configure terminal
192.168.2.0
192.168.2.0
Enter configuration commands, one per line. End with CNTL/Z.
10.0.0.0
10.0.0.0
Chennai(config)# interface serial 1
11.0.0.0
11.0.0.0
Chennai(config-if)# ip address 10.0.0.2 255.0.0.0
Chennai(config-if)# no shut
Chennai(config-if)# encapsulation hdlc
Chennai(config-if)# interface serial 0
Chennai(config-if)# ip address 11.0.0.1 255.0.0.0
Chennai(config-if)# no shut
Chennai(config-if)# encapsulation hdlc
Diagram

16
Chennai(config)# no ip routing
Chennai(config)# ip routing
Chennai(config)# router rip
Chennai(config-router)# network 192.168.2.0
Chennai(config-router)# network 10.0.0.0
Chennai(config-router)# network 11.0.0.0
Configuring RIP
Configuring RIP
Chennai(config-router)#
Router(config)# router rip
Router(config)# router rip
Router(config-router)# network <Network ID>
Router(config-router)# network <Network ID>

17

Diagram
Chennai(config)# no ip routing
Chennai(config)# ip routing
Chennai(config)# router rip
Chennai(config-router)# network 192.168.2.0
Chennai(config-router)# network 10.0.0.0
Chennai(config-router)# network 11.0.0.0
^
Chennai(config-router)# Z
Chennai# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i- IS-IS, L1-IS-IS level-1, L2-IS-IS level-2,*- candidate default
U - per-user static route, o - ODR

Gateway of last resort is not set
C
10.0.0.0/8 is directly connected, Serial1
C
11.0.0.0/8 is directly connected, Serial0
R
192.168.1.0/24 [120/1] via 10.0.0.1, 00:00:01, Serial1
C
192.168.2.0/24 is directly connected, Ethernet0
R
192.168.3.0/24 [120/1] viaMetricofbut 00:00:12, Serial0
11.0.0.2,
120 is Metric ofbut
120 isnothing Rip
nothing Rip
R – for RIP routes
Diagram
R – for
Chennai# RIP routes Administrative Count
Hop Count
AdministrativeDistance
Distance
18
Hop
Chennai# show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 5 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface
Send Recv
Key-chain
Ethernet0
1
1 2
Serial0
1
1 2
Serial1
1
1 2
Routing for Networks:
192.168.2.0
10.0.0.0
11.0.0.0
Routing Information Sources:
Gateway
Distance
Last Update
11.0.0.2
120
00:00:23
10.0.0.1
120
00:00:03
Distance: (default is 120)
Chennai#
Diagram

19
Microsoft Windows 2000 [Version 5.00.2195]
(C) Copyright 1985-2000 Microsoft Corp.
C:> telnet 192.168.3.150
Connecting .....
================================
Welcome to Banglore Router
================================
User Access Verification
password : ****
Directly Connected Networks on
Banglore> enableDirectly Connected Networks on
Banglore Router
password : ****
Banglore Router
Banglore# configure terminal
192.168.3.0
192.168.3.0
Enter configuration commands, one per line. End with CNTL/Z.
11.0.0.0
11.0.0.0
Banglore(config)# interface serial 1
Banglore(config-if)# ip address 11.0.0.2 255.0.0.0
Banglore(config-if)# no shut
Banglore(config-if)# clockrate 64000
Banglore(config-if)# encapsulation hdlc
Banglore(config-if)# exit
Banglore(config)#

20

Diagram
Banglore(config)# no ip routing
Banglore(config)# ip routing
Banglore(config)# router rip
Banglore(config-router)# network 192.168.3.0
Banglore(config-router)# network 11.0.0.0
Banglore(config-router)#
Configuring RIP
Configuring RIP
Router(config)# router rip
Router(config)# router rip
Router(config-router)# network <Network ID>
Router(config-router)# network <Network ID>

21

Diagram
Banglore(config)# no ip routing
Banglore(config)# ip routing
Banglore(config)# router rip
Banglore(config-router)# network 192.168.3.0
Banglore(config-router)# network 11.0.0.0
Banglore(config-router)# ^Z
Banglore# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i- IS-IS, L1-IS-IS level-1, L2-IS-IS level-2,*- candidate default
U - per-user static route, o - ODR

Gateway of last resort is not set
R
10.0.0.0/8 [120/1] via 11.0.0.1, 00:00:04, Serial1
C
11.0.0.0/8 is directly connected, Serial1
R
192.168.1.0/24 [120/2] via 11.0.0.1, 00:00:04, Serial1
120 is Metric ofbut
Metric of Rip
120 isnothing Rip
R – for RIP routes [120/1]nothing but
– for RIP routes
R R 192.168.2.0/24
via Distance
Administrative Count
Hop 11.0.0.1,
AdministrativeDistance 00:00:04, Serial1
Hop Count
C
192.168.3.0/24 is directly connected, Ethernet0
Banglore#

22

Diagram
Banglore# show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 15 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface
Send Recv
Key-chain
Ethernet0
1
1 2
Serial1
1
1 2
Routing for Networks:
192.168.3.0
11.0.0.0
12.0.0.0
Routing Information Sources:
Gateway
Distance
Last Update
11.0.0.1
120
00:00:06
Distance: (default is 120)
Banglore#

23

Diagram
Hyderabad# ping 192.168.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms

Hyderabad# ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms

Hyderabad#

24

Diagram
Chennai# ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms

Chennai# ping 192.168.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms

Chennai#

25

Diagram
Banglore# ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms

Banglore# ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms

Banglore#

26

Diagram

Mais conteúdo relacionado

Mais procurados

Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRP
Kishore Kumar
 

Mais procurados (20)

ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
 
Ppt of routing protocols
Ppt of routing protocolsPpt of routing protocols
Ppt of routing protocols
 
OSPF Basics
OSPF BasicsOSPF Basics
OSPF Basics
 
Chapter 17 : static routing
Chapter 17 : static routingChapter 17 : static routing
Chapter 17 : static routing
 
Ospf.ppt
Ospf.pptOspf.ppt
Ospf.ppt
 
CCNA PPT
CCNA PPTCCNA PPT
CCNA PPT
 
CCNA v6.0 ITN - Chapter 05
CCNA v6.0 ITN - Chapter 05CCNA v6.0 ITN - Chapter 05
CCNA v6.0 ITN - Chapter 05
 
Cisco ospf
Cisco ospf Cisco ospf
Cisco ospf
 
Presentation on arp protocol
Presentation on arp protocolPresentation on arp protocol
Presentation on arp protocol
 
CCNA 2 Routing and Switching v5.0 Chapter 2
CCNA 2 Routing and Switching v5.0 Chapter 2CCNA 2 Routing and Switching v5.0 Chapter 2
CCNA 2 Routing and Switching v5.0 Chapter 2
 
CCNA PPT
CCNA PPTCCNA PPT
CCNA PPT
 
CCNA v6.0 ITN - Chapter 01
CCNA v6.0 ITN - Chapter 01CCNA v6.0 ITN - Chapter 01
CCNA v6.0 ITN - Chapter 01
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRP
 
CCNA 1 Routing and Switching v5.0 Chapter 9
CCNA 1 Routing and Switching v5.0 Chapter 9CCNA 1 Routing and Switching v5.0 Chapter 9
CCNA 1 Routing and Switching v5.0 Chapter 9
 
Network monitoring tools
Network monitoring toolsNetwork monitoring tools
Network monitoring tools
 
Chapter 10 - DHCP
Chapter 10 - DHCPChapter 10 - DHCP
Chapter 10 - DHCP
 
Overview of Spanning Tree Protocol
Overview of Spanning Tree ProtocolOverview of Spanning Tree Protocol
Overview of Spanning Tree Protocol
 
IP Address - IPv4 & IPv6
IP Address - IPv4 & IPv6IP Address - IPv4 & IPv6
IP Address - IPv4 & IPv6
 
Ipv4 ppt
Ipv4 pptIpv4 ppt
Ipv4 ppt
 
CCNA v6.0 ITN - Chapter 04
CCNA v6.0 ITN - Chapter 04CCNA v6.0 ITN - Chapter 04
CCNA v6.0 ITN - Chapter 04
 

Destaque

Destaque (20)

CCNA presentation.
CCNA presentation.CCNA presentation.
CCNA presentation.
 
Password Recovery
Password RecoveryPassword Recovery
Password Recovery
 
RIP Overview
RIP OverviewRIP Overview
RIP Overview
 
OSPF 3
OSPF 3OSPF 3
OSPF 3
 
Internal & External of Routers
Internal & External of RoutersInternal & External of Routers
Internal & External of Routers
 
Switching 2
Switching 2Switching 2
Switching 2
 
TomTom Dynamic Routing
TomTom Dynamic RoutingTomTom Dynamic Routing
TomTom Dynamic Routing
 
OSPF 2
OSPF 2OSPF 2
OSPF 2
 
Ip addressing
Ip addressingIp addressing
Ip addressing
 
Switching 1
Switching 1Switching 1
Switching 1
 
Sept 2017 dynamic routing
Sept 2017   dynamic routingSept 2017   dynamic routing
Sept 2017 dynamic routing
 
Ch13
Ch13Ch13
Ch13
 
Dynamic Routing
Dynamic RoutingDynamic Routing
Dynamic Routing
 
Dynamic Routing All Algorithms, Working And Basics
Dynamic Routing All Algorithms, Working And BasicsDynamic Routing All Algorithms, Working And Basics
Dynamic Routing All Algorithms, Working And Basics
 
RIP - Routing Information Protocol
RIP - Routing Information ProtocolRIP - Routing Information Protocol
RIP - Routing Information Protocol
 
Routing Information Protocol (RIP)
Routing Information Protocol(RIP)Routing Information Protocol(RIP)
Routing Information Protocol (RIP)
 
Day 10 rip
Day 10 ripDay 10 rip
Day 10 rip
 
Rip Update Timers
Rip Update TimersRip Update Timers
Rip Update Timers
 
Routing protocols
Routing protocolsRouting protocols
Routing protocols
 
RIP Update Timers
RIP Update TimersRIP Update Timers
RIP Update Timers
 

Semelhante a Dynamic Routing RIP

Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
97148881557
 
Practice exam #2
Practice exam #2Practice exam #2
Practice exam #2
Kris Mofu
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
robertoxe
 
Ccna2 mod3-configuring a-router
Ccna2 mod3-configuring a-routerCcna2 mod3-configuring a-router
Ccna2 mod3-configuring a-router
97148881557
 

Semelhante a Dynamic Routing RIP (20)

Multi Static Routng & Default Routing
Multi Static Routng & Default RoutingMulti Static Routng & Default Routing
Multi Static Routng & Default Routing
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
 
RIP Routing Information Protocol Extreme Networks
RIP Routing Information Protocol Extreme NetworksRIP Routing Information Protocol Extreme Networks
RIP Routing Information Protocol Extreme Networks
 
Wan Interface Configuration
Wan Interface ConfigurationWan Interface Configuration
Wan Interface Configuration
 
Frame Relay
Frame RelayFrame Relay
Frame Relay
 
Frame Relay
Frame RelayFrame Relay
Frame Relay
 
acit mumbai - ospf rouitng
acit mumbai - ospf rouitng acit mumbai - ospf rouitng
acit mumbai - ospf rouitng
 
Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0
 
Acn Experiment No 5
Acn Experiment No 5Acn Experiment No 5
Acn Experiment No 5
 
Ccna 4 Final 4 Version 4.0 Answers
Ccna 4 Final 4 Version 4.0 AnswersCcna 4 Final 4 Version 4.0 Answers
Ccna 4 Final 4 Version 4.0 Answers
 
CCNA part 5 routing
CCNA part 5 routingCCNA part 5 routing
CCNA part 5 routing
 
Practice exam #2
Practice exam #2Practice exam #2
Practice exam #2
 
ivesgimpaya2
ivesgimpaya2ivesgimpaya2
ivesgimpaya2
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
 
Network
NetworkNetwork
Network
 
02_N2_Chapter 2.pptx
02_N2_Chapter 2.pptx02_N2_Chapter 2.pptx
02_N2_Chapter 2.pptx
 
ivesgimpaya3
ivesgimpaya3ivesgimpaya3
ivesgimpaya3
 
Ccna2 mod3-configuring a-router
Ccna2 mod3-configuring a-routerCcna2 mod3-configuring a-router
Ccna2 mod3-configuring a-router
 

Mais de Kishore Kumar

Route Authentication
Route AuthenticationRoute Authentication
Route Authentication
Kishore Kumar
 
Recognizing security threats
Recognizing security threatsRecognizing security threats
Recognizing security threats
Kishore Kumar
 
Ccna simulation exam practice guide
Ccna simulation exam practice guideCcna simulation exam practice guide
Ccna simulation exam practice guide
Kishore Kumar
 
Integrated Service Digital Network
Integrated Service Digital NetworkIntegrated Service Digital Network
Integrated Service Digital Network
Kishore Kumar
 

Mais de Kishore Kumar (17)

Switching Types
Switching TypesSwitching Types
Switching Types
 
Switching Types
Switching TypesSwitching Types
Switching Types
 
Route Authentication
Route AuthenticationRoute Authentication
Route Authentication
 
Recognizing security threats
Recognizing security threatsRecognizing security threats
Recognizing security threats
 
Ccna simulation exam practice guide
Ccna simulation exam practice guideCcna simulation exam practice guide
Ccna simulation exam practice guide
 
Integrated Service Digital Network
Integrated Service Digital NetworkIntegrated Service Digital Network
Integrated Service Digital Network
 
Initial Configuration of Router
Initial Configuration of RouterInitial Configuration of Router
Initial Configuration of Router
 
OSI Layers
OSI LayersOSI Layers
OSI Layers
 
Password Recovery
Password RecoveryPassword Recovery
Password Recovery
 
OSPF 3
OSPF 3OSPF 3
OSPF 3
 
OSPF 2
OSPF 2OSPF 2
OSPF 2
 
IP Addressing
IP AddressingIP Addressing
IP Addressing
 
Internal & External of Routers
Internal & External of RoutersInternal & External of Routers
Internal & External of Routers
 
Integrated Service Digital Network
Integrated Service Digital NetworkIntegrated Service Digital Network
Integrated Service Digital Network
 
Initial Configuration of Router
Initial Configuration of RouterInitial Configuration of Router
Initial Configuration of Router
 
Dynamic Routing RIP
Dynamic Routing RIPDynamic Routing RIP
Dynamic Routing RIP
 
Subnetting
SubnettingSubnetting
Subnetting
 

Último

Seal of Good Local Governance (SGLG) 2024Final.pptx
Seal of Good Local Governance (SGLG) 2024Final.pptxSeal of Good Local Governance (SGLG) 2024Final.pptx
Seal of Good Local Governance (SGLG) 2024Final.pptx
negromaestrong
 
Russian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in Delhi
Russian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in DelhiRussian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in Delhi
Russian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in Delhi
kauryashika82
 
Spellings Wk 3 English CAPS CARES Please Practise
Spellings Wk 3 English CAPS CARES Please PractiseSpellings Wk 3 English CAPS CARES Please Practise
Spellings Wk 3 English CAPS CARES Please Practise
AnaAcapella
 

Último (20)

UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdfUGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
 
microwave assisted reaction. General introduction
microwave assisted reaction. General introductionmicrowave assisted reaction. General introduction
microwave assisted reaction. General introduction
 
Seal of Good Local Governance (SGLG) 2024Final.pptx
Seal of Good Local Governance (SGLG) 2024Final.pptxSeal of Good Local Governance (SGLG) 2024Final.pptx
Seal of Good Local Governance (SGLG) 2024Final.pptx
 
Dyslexia AI Workshop for Slideshare.pptx
Dyslexia AI Workshop for Slideshare.pptxDyslexia AI Workshop for Slideshare.pptx
Dyslexia AI Workshop for Slideshare.pptx
 
Russian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in Delhi
Russian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in DelhiRussian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in Delhi
Russian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in Delhi
 
Key note speaker Neum_Admir Softic_ENG.pdf
Key note speaker Neum_Admir Softic_ENG.pdfKey note speaker Neum_Admir Softic_ENG.pdf
Key note speaker Neum_Admir Softic_ENG.pdf
 
General Principles of Intellectual Property: Concepts of Intellectual Proper...
General Principles of Intellectual Property: Concepts of Intellectual  Proper...General Principles of Intellectual Property: Concepts of Intellectual  Proper...
General Principles of Intellectual Property: Concepts of Intellectual Proper...
 
Unit-IV; Professional Sales Representative (PSR).pptx
Unit-IV; Professional Sales Representative (PSR).pptxUnit-IV; Professional Sales Representative (PSR).pptx
Unit-IV; Professional Sales Representative (PSR).pptx
 
TỔNG ÔN TẬP THI VÀO LỚP 10 MÔN TIẾNG ANH NĂM HỌC 2023 - 2024 CÓ ĐÁP ÁN (NGỮ Â...
TỔNG ÔN TẬP THI VÀO LỚP 10 MÔN TIẾNG ANH NĂM HỌC 2023 - 2024 CÓ ĐÁP ÁN (NGỮ Â...TỔNG ÔN TẬP THI VÀO LỚP 10 MÔN TIẾNG ANH NĂM HỌC 2023 - 2024 CÓ ĐÁP ÁN (NGỮ Â...
TỔNG ÔN TẬP THI VÀO LỚP 10 MÔN TIẾNG ANH NĂM HỌC 2023 - 2024 CÓ ĐÁP ÁN (NGỮ Â...
 
Spellings Wk 3 English CAPS CARES Please Practise
Spellings Wk 3 English CAPS CARES Please PractiseSpellings Wk 3 English CAPS CARES Please Practise
Spellings Wk 3 English CAPS CARES Please Practise
 
Magic bus Group work1and 2 (Team 3).pptx
Magic bus Group work1and 2 (Team 3).pptxMagic bus Group work1and 2 (Team 3).pptx
Magic bus Group work1and 2 (Team 3).pptx
 
Third Battle of Panipat detailed notes.pptx
Third Battle of Panipat detailed notes.pptxThird Battle of Panipat detailed notes.pptx
Third Battle of Panipat detailed notes.pptx
 
Making communications land - Are they received and understood as intended? we...
Making communications land - Are they received and understood as intended? we...Making communications land - Are they received and understood as intended? we...
Making communications land - Are they received and understood as intended? we...
 
SOC 101 Demonstration of Learning Presentation
SOC 101 Demonstration of Learning PresentationSOC 101 Demonstration of Learning Presentation
SOC 101 Demonstration of Learning Presentation
 
Explore beautiful and ugly buildings. Mathematics helps us create beautiful d...
Explore beautiful and ugly buildings. Mathematics helps us create beautiful d...Explore beautiful and ugly buildings. Mathematics helps us create beautiful d...
Explore beautiful and ugly buildings. Mathematics helps us create beautiful d...
 
Application orientated numerical on hev.ppt
Application orientated numerical on hev.pptApplication orientated numerical on hev.ppt
Application orientated numerical on hev.ppt
 
How to Create and Manage Wizard in Odoo 17
How to Create and Manage Wizard in Odoo 17How to Create and Manage Wizard in Odoo 17
How to Create and Manage Wizard in Odoo 17
 
SKILL OF INTRODUCING THE LESSON MICRO SKILLS.pptx
SKILL OF INTRODUCING THE LESSON MICRO SKILLS.pptxSKILL OF INTRODUCING THE LESSON MICRO SKILLS.pptx
SKILL OF INTRODUCING THE LESSON MICRO SKILLS.pptx
 
How to Manage Global Discount in Odoo 17 POS
How to Manage Global Discount in Odoo 17 POSHow to Manage Global Discount in Odoo 17 POS
How to Manage Global Discount in Odoo 17 POS
 
Food safety_Challenges food safety laboratories_.pdf
Food safety_Challenges food safety laboratories_.pdfFood safety_Challenges food safety laboratories_.pdf
Food safety_Challenges food safety laboratories_.pdf
 

Dynamic Routing RIP

  • 1. 1
  • 2. Dynamic Routing Advantages of Dynamic over static : • There is no need to know the destination networks. • Need to advertise the directly connected networks. • Updates the topology changes dynamically. • Administrative work is reduced • Used for large organizations. 2
  • 3. Types of Dynamic Routing Protocols • Distance Vector Protocol • Link State Protocol • Hybrid Protocol 3
  • 4. Distance Vector Protocol • Works with Bellman Ford algorithm • Periodic updates • Classful routing protocol • Full Routing tables are exchanged • Updates are through broadcast • Also known as “Routing By Rumor” • Example: RIP, IGRP 4
  • 5. Link State Protocol • Works with Dijkstra algorithm • Link state updates • Classless routing protocol • Missing routes are exchanged • Updates are through multicast • Also known as “ Routing by Intelligence” • Example : OSPF, IS-IS 5
  • 6. Hybrid Protocol • Works with DUAL algorithm • Link state updates • Classless routing protocol • Missing routes are exchanged • Updates are through multicast • Also known as “ Routing by Intelligence” • Example : EIGRP 6
  • 7. Routing Information Protocol • Open Standard Protocol • Classful routing protocol • Updates are broadcasted via 255.255.255.255 • Administrative distance is 120 • Metric : Hop count Max Hop counts : 15 Max routers : 16 • Load Balancing of 4 equal paths • Used for small organizations 7
  • 8. Rip Timers • Update timer : 30 sec – Time between consecutive updates • Invalid timer : 180 sec – Time a router waits to hear updates – The route is marked unreachable if there is no update during this interval. • Flush timer : 240 sec – Time before the invalid route is purged from the routing table • Holddown timer : 180sec – Specifies the amount of time for which the 8 information about poorer routes are ignored.
  • 9. RIP - Network Diagram 10.0.0.1/8 S0 HYD 11.0.0.1/8 S0 S1 10.0.0.2/8 E0 192.168.1.150/24 LAN - 192.168.1.0/24 CHE S1 11.0.0.2/8 E0 192.168.2.150/24 LAN - 192.168.2.0/24 BAN E0 192.168.3.150/2 LAN - 192.168.3.0/24 9
  • 10. Disadvantages of RIP • More Bandwidth utilization • Doesn’t consider the bandwidth, works only with hop counts • Slow convergence • Formation of Routing loops 10
  • 11. 11
  • 12. Microsoft Windows 2000 [Version 5.00.2195] (C) Copyright 1985-2000 Microsoft Corp. C:> telnet 192.168.1.150 Connecting ..... ================================ Welcome to Hyderabad Router ================================ User Access Verification password : **** Directly Connected Networks on Directly Connected Networks on Hyderabad> enable HYDERABAD Router password : **** HYDERABAD Router Hyderabad# configure terminal 192.168.1.0 192.168.1.0 Enter configuration commands, one per line. End with CNTL/Z. 10.0.0.0 10.0.0.0 Hyderabad(config)# interface serial 0 Hyderabad(config-if)# ip address 10.0.0.1 255.0.0.0 Hyderabad(config-if)# no shut Hyderabad(config-if)# clockrate 64000 Hyderabad(config-if)# encapsulation hdlc Hyderabad(config-if)# exit Hyderabad(config)# 12 Diagram
  • 13. Hyderabad(config)# no ip routing Hyderabad(config)# ip routing Hyderabad(config)# router rip Hyderabad(config-router)# network 192.168.1.0 Hyderabad(config-router)# network 10.0.0.0 Hyderabad(config-router)# Configuring RIP Configuring RIP Router(config)# router rip Router(config)# router rip Router(config-router)# network <Network ID> Router(config-router)# network <Network ID> 13 Diagram
  • 14. Hyderabad(config)# no ip routing Hyderabad(config)# ip routing Hyderabad(config)# router rip Hyderabad(config-router)# network 192.168.1.0 Hyderabad(config-router)# network 10.0.0.0 Hyderabad(config-router)# ^Z Hyderabad# show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i- IS-IS, L1-IS-IS level-1, L2-IS-IS level-2,*- candidate default U - per-user static route, o - ODR Gateway of last resort is not set C 10.0.0.0/8 is directly connected, Serial0 R 11.0.0.0/8 [120/1] via 10.0.0.2, 00:00:25, Serial0 C 192.168.1.0/24 is directly connected, Ethernet0 R 192.168.2.0/24 [120/1]nothingbut via of Rip 120 is Metric 10.0.0.2, 00:00:25, Serial0 Metricof Rip 120 isnothing but R – for RIP routes – for RIP routes Administrative Distance 00:00:25, Serial0 R R 192.168.3.0/24 [120/2] Hop Count via Distance Administrative 10.0.0.2, Hop Count Hyderabad# Diagram 14
  • 15. Hyderabad# show ip protocols Routing Protocol is "rip" Sending updates every 30 seconds, next due in 13 seconds Invalid after 180 seconds, hold down 180, flushed after 240 Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set Redistributing: rip Default version control: send version 1, receive any version Interface Send Recv Key-chain Ethernet0 1 1 2 Serial0 1 1 2 Routing for Networks: 192.168.1.0 10.0.0.0 Routing Information Sources: Gateway Distance Last Update 10.0.0.2 120 00:00:00 Distance: (default is 120) Hyderabad# 15 Diagram
  • 16. Microsoft Windows 2000 [Version 5.00.2195] (C) Copyright 1985-2000 Microsoft Corp. C:> telnet 192.168.2.150 Connecting ..... ================================ Welcome to Chennai Router ================================ User Access Verification password : **** Directly Connected Networks on Chennai> enable Directly Connected Networks on CHENNAI Router password : **** CHENNAI Router Chennai# configure terminal 192.168.2.0 192.168.2.0 Enter configuration commands, one per line. End with CNTL/Z. 10.0.0.0 10.0.0.0 Chennai(config)# interface serial 1 11.0.0.0 11.0.0.0 Chennai(config-if)# ip address 10.0.0.2 255.0.0.0 Chennai(config-if)# no shut Chennai(config-if)# encapsulation hdlc Chennai(config-if)# interface serial 0 Chennai(config-if)# ip address 11.0.0.1 255.0.0.0 Chennai(config-if)# no shut Chennai(config-if)# encapsulation hdlc Diagram 16
  • 17. Chennai(config)# no ip routing Chennai(config)# ip routing Chennai(config)# router rip Chennai(config-router)# network 192.168.2.0 Chennai(config-router)# network 10.0.0.0 Chennai(config-router)# network 11.0.0.0 Configuring RIP Configuring RIP Chennai(config-router)# Router(config)# router rip Router(config)# router rip Router(config-router)# network <Network ID> Router(config-router)# network <Network ID> 17 Diagram
  • 18. Chennai(config)# no ip routing Chennai(config)# ip routing Chennai(config)# router rip Chennai(config-router)# network 192.168.2.0 Chennai(config-router)# network 10.0.0.0 Chennai(config-router)# network 11.0.0.0 ^ Chennai(config-router)# Z Chennai# show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i- IS-IS, L1-IS-IS level-1, L2-IS-IS level-2,*- candidate default U - per-user static route, o - ODR Gateway of last resort is not set C 10.0.0.0/8 is directly connected, Serial1 C 11.0.0.0/8 is directly connected, Serial0 R 192.168.1.0/24 [120/1] via 10.0.0.1, 00:00:01, Serial1 C 192.168.2.0/24 is directly connected, Ethernet0 R 192.168.3.0/24 [120/1] viaMetricofbut 00:00:12, Serial0 11.0.0.2, 120 is Metric ofbut 120 isnothing Rip nothing Rip R – for RIP routes Diagram R – for Chennai# RIP routes Administrative Count Hop Count AdministrativeDistance Distance 18 Hop
  • 19. Chennai# show ip protocols Routing Protocol is "rip" Sending updates every 30 seconds, next due in 5 seconds Invalid after 180 seconds, hold down 180, flushed after 240 Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set Redistributing: rip Default version control: send version 1, receive any version Interface Send Recv Key-chain Ethernet0 1 1 2 Serial0 1 1 2 Serial1 1 1 2 Routing for Networks: 192.168.2.0 10.0.0.0 11.0.0.0 Routing Information Sources: Gateway Distance Last Update 11.0.0.2 120 00:00:23 10.0.0.1 120 00:00:03 Distance: (default is 120) Chennai# Diagram 19
  • 20. Microsoft Windows 2000 [Version 5.00.2195] (C) Copyright 1985-2000 Microsoft Corp. C:> telnet 192.168.3.150 Connecting ..... ================================ Welcome to Banglore Router ================================ User Access Verification password : **** Directly Connected Networks on Banglore> enableDirectly Connected Networks on Banglore Router password : **** Banglore Router Banglore# configure terminal 192.168.3.0 192.168.3.0 Enter configuration commands, one per line. End with CNTL/Z. 11.0.0.0 11.0.0.0 Banglore(config)# interface serial 1 Banglore(config-if)# ip address 11.0.0.2 255.0.0.0 Banglore(config-if)# no shut Banglore(config-if)# clockrate 64000 Banglore(config-if)# encapsulation hdlc Banglore(config-if)# exit Banglore(config)# 20 Diagram
  • 21. Banglore(config)# no ip routing Banglore(config)# ip routing Banglore(config)# router rip Banglore(config-router)# network 192.168.3.0 Banglore(config-router)# network 11.0.0.0 Banglore(config-router)# Configuring RIP Configuring RIP Router(config)# router rip Router(config)# router rip Router(config-router)# network <Network ID> Router(config-router)# network <Network ID> 21 Diagram
  • 22. Banglore(config)# no ip routing Banglore(config)# ip routing Banglore(config)# router rip Banglore(config-router)# network 192.168.3.0 Banglore(config-router)# network 11.0.0.0 Banglore(config-router)# ^Z Banglore# show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i- IS-IS, L1-IS-IS level-1, L2-IS-IS level-2,*- candidate default U - per-user static route, o - ODR Gateway of last resort is not set R 10.0.0.0/8 [120/1] via 11.0.0.1, 00:00:04, Serial1 C 11.0.0.0/8 is directly connected, Serial1 R 192.168.1.0/24 [120/2] via 11.0.0.1, 00:00:04, Serial1 120 is Metric ofbut Metric of Rip 120 isnothing Rip R – for RIP routes [120/1]nothing but – for RIP routes R R 192.168.2.0/24 via Distance Administrative Count Hop 11.0.0.1, AdministrativeDistance 00:00:04, Serial1 Hop Count C 192.168.3.0/24 is directly connected, Ethernet0 Banglore# 22 Diagram
  • 23. Banglore# show ip protocols Routing Protocol is "rip" Sending updates every 30 seconds, next due in 15 seconds Invalid after 180 seconds, hold down 180, flushed after 240 Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set Redistributing: rip Default version control: send version 1, receive any version Interface Send Recv Key-chain Ethernet0 1 1 2 Serial1 1 1 2 Routing for Networks: 192.168.3.0 11.0.0.0 12.0.0.0 Routing Information Sources: Gateway Distance Last Update 11.0.0.1 120 00:00:06 Distance: (default is 120) Banglore# 23 Diagram
  • 24. Hyderabad# ping 192.168.3.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms Hyderabad# ping 192.168.2.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms Hyderabad# 24 Diagram
  • 25. Chennai# ping 192.168.1.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms Chennai# ping 192.168.3.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms Chennai# 25 Diagram
  • 26. Banglore# ping 192.168.1.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms Banglore# ping 192.168.2.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms Banglore# 26 Diagram