Aula 5 - Estruturas de seleção encadeada - parte 2

4.529 visualizações

Publicada em

Publicada em: Educação, Negócios, Tecnologia
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
4.529
No SlideShare
0
A partir de incorporações
0
Número de incorporações
803
Ações
Compartilhamentos
0
Downloads
0
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Aula 5 - Estruturas de seleção encadeada - parte 2

  1. 1. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Estruturas de Seleção – Parte IISeleção EncadeadaSOLUÇÃO DE EXERCÍCIO PROPOSTOProf. Dr. Edson PimentelCentro de Matemática, Computação eCognição
  2. 2. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Objetivos Aprender a resolver problemas que requeiram o uso deESTRUTURAS DE SELEÇÃO ENCADEADAS com aaplicação da Técnica de Interpretação de Enunciados
  3. 3. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Relembrando...
  4. 4. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Sequências de estruturas Se-Então-Senãousadas para o teste de múltiplos casosse ( media >= 9.0 ) entãoEscreva(“Conceito A”);senãose ( media >= 7.0 ) entãoEscreva(“Conceito B”);senãose ( media >= 6.0 ) entãoEscreva (“Conceito C”);senãoEscreva(“Conceito P”);fimsefimsefimseEstrutura de Seleção Encadeada
  5. 5. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Estrutura de Seleção EncadeadaO que será impresso se a médiafor 9.5?
  6. 6. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2“B”: Indentado“A”: NÃO IndentadoNote que no INDENTADO a cada“início“ { de BLOCO há um pequenodeslocamento do código pra direitaIndentar, Identar ou Endentar
  7. 7. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2EXERCÍCIODISCUSSÃO ESOLUÇÃO
  8. 8. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Escreva um algoritmo (em PORTUGOL) para ler o preço de etiqueta de umproduto e calcular o preço a pagar pelo cliente de acordo com a seguintetabela:CÓDIGO CONDIÇÃO DE PAGAMENTO DESCONTO0 A VISTA 25%1 Cheque (30 dias) 20%2 Cartão Crédito (2x) 10%3 Cartão Crédito (3x) 5%outra Negociada com vendedor Sem descontoProblema
  9. 9. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Escreva um algoritmo (em PORTUGOL) para ler o preço de etiqueta de umproduto e calcular o preço a pagar pelo cliente de acordo com a seguintetabela: SAÍDA: Quais os resultados que o algoritmo deve fornecer ?CÓDIGO CONDIÇÃO DE PAGAMENTO DESCONTO0 A VISTA 25%1 Cheque (30 dias) 20%2 Cartão Crédito (2x) 10%3 Cartão Crédito (3x) 5%outra Negociada com vendedor Sem descontoProblema
  10. 10. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Escreva um algoritmo (em PORTUGOL) para ler o preço de etiqueta de umproduto e calcular o preço a pagar pelo cliente de acordo com aseguinte tabela: SAÍDA: preço a pagar (preco)CÓDIGO CONDIÇÃO DE PAGAMENTO DESCONTO0 A VISTA 25%1 Cheque (30 dias) 20%2 Cartão Crédito (2x) 10%3 Cartão Crédito (3x) 5%outra Negociada com vendedor Sem descontoProblema
  11. 11. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Escreva um algoritmo (em PORTUGOL) para ler o preço de etiqueta de umproduto e calcular o preço a pagar pelo cliente de acordo com a seguintetabela: SAÍDA: preço a pagar (preco)CÓDIGO CONDIÇÃO DE PAGAMENTO DESCONTO0 A VISTA 25%1 Cheque (30 dias) 20%2 Cartão Crédito (2x) 10%3 Cartão Crédito (3x) 5%outra Negociada com vendedor Sem descontoProblema ENTRADA: Quais os insumos necessários para se obter a saída?
  12. 12. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Escreva um algoritmo (em PORTUGOL) para ler o preço de etiquetade um produto e calcular o preço a pagar pelo cliente de acordocom a seguinte tabela: SAÍDA: preço a pagar (precoPagar)CÓDIGO CONDIÇÃO DE PAGAMENTO DESCONTO0 A VISTA 25%1 Cheque (30 dias) 20%2 Cartão Crédito (2x) 10%3 Cartão Crédito (3x) 5%outra Negociada com vendedor Sem descontoProblema ENTRADA: preço de etiqueta (precoOriginal) e condição pagamento (codigo)
  13. 13. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Escreva um algoritmo (em PORTUGOL) para ler o preço de etiqueta de umproduto e calcular o preço a pagar pelo cliente de acordo com a seguintetabela: SAÍDA: preço a pagar (precoPagar)CÓDIGO CONDIÇÃO DE PAGAMENTO DESCONTO0 A VISTA 25%1 Cheque (30 dias) 20%2 Cartão Crédito (2x) 10%3 Cartão Crédito (3x) 5%outra Negociada com vendedor Sem descontoProblema ENTRADA: preço de etiqueta (precoOriginal) e condição pagamento (codigo) PROCESSAMENTO: Como transformar os insumos na saída?
  14. 14. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2SAÍDA:precoPagarCÓDIGO CONDIÇÃO DE PAGAMENTO DESCONTO0 A VISTA 25%1 Cheque (30 dias) 20%2 Cartão Crédito (2x) 10%3 Cartão Crédito (3x) 5%outra Negociada com vendedor Sem descontoENTRADA:precoOriginal, codigoPROCESSAMENTO Se ( codigo == 0) Então precoPagar = precoOriginal * 0.75 Senão Se ( codigo == 1) Então precoPagar = precoOriginal * 0.80 Senão Se ( codigo == 2) Então precoPagar = precoOriginal * 0.90 Senão..... fimse fimse
  15. 15. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2SAÍDA:precoPagar... Cartão Crédito (2x) 10%3 Cartão Crédito (3x) 5%outra Negociada comvendedorSem descontoENTRADA:precoOriginal, codigoPROCESSAMENTO Se ( codigo == 0) Então precoPagar = precoOriginal * 0.75 Senão Se ( codigo == 1) Então precoPagar = precoOriginal * 0.80 Senão Se ( codigo == 2) Então precoPagar = precoOriginal * 0.90 Senão Se ( codigo == 3) Então precoPagar = precoOriginal * 0.95 Senão precoPagar = precoOriginal Fimse Fimse Fimse Fimse
  16. 16. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Solução em Portugol
  17. 17. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2Solução em Portugol
  18. 18. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2TESTE 1
  19. 19. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2TESTE 2
  20. 20. Bacharelado em Ciência e TecnologiaProcessamento da InformaçãoEstruturas de Seleção – Parte 2AGORA ÉPRATICAR!!!

×