Algoritmo1

96 visualizações

Publicada em

Publicada em: Indústria automotiva
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
96
No SlideShare
0
A partir de incorporações
0
Número de incorporações
1
Ações
Compartilhamentos
0
Downloads
4
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmo1

  1. 1. 1 Algoritmo Y Programación 1º Parcial Serie Nº 1 INTEGRANTES: *FIGUEROA OLMEDO, Diana Sabrina. *ESQUIVEL, Nicolás Ariel. *SCHELOVER, Gonzalo
  2. 2. 2 INDICE TP#1: “BOLILLAS INFINITAS” CUADRO DE VARIABLE ............................................................................................................................... 3 DIAGRAMA DE FLUJO................................................................................................................................. 3 PRUEBA DE ESCRITORIO..........................................................................................................................4-5 PSEUDOCODIGO .....................................................................................................................................6-7 PASOS......................................................................................................................................................7-9 INFORME.................................................................................................................................................. 10 TP#2:”BOLILLAS EXACTAS” CUADRO DE VARIABLE ................................................................................................................................. DIAGRAMA DE FLUJO................................................................................................................................... PRUEBA DE ESCRITORIO............................................................................................................................... PSEUDOCODIGO .......................................................................................................................................... PASOS........................................................................................................................................................... INFORME......................................................................................................................................................
  3. 3. 3 INICIO CA<-0 CR<-0 CN<-0 BOLILLA<>”0” AMARILLAS SON: “CA” ROJAS SON: “CR” NEGRAS SON: “CN” FIN BOLILLA=”A” CA=CA+1 BOLILLA=”R” CR=CR+1 CN=CN+1 1 BOLILLA 1 TP#1: “BOLILLAS INFINITAS”  CUADRO DE VARIABLE TIPO LONGITUD RANGO SIRVE PARA… COLOR CA 1 -------------------- INGRESAR COLOR (A)MARILLO CR 1 ------------------ INGRESAR COLOR (R)OJO CN 1 ---------------------- INGRESAR COLOR (N)EGRO CA VA 4 0-999 CONTAR LA CANTIDADA DE BOLILLAS (A)MARILLAS CR VR 4 0-999 CONTAR LA CANTIDAD DE BOLILLAS (R)OJAS CN VN 4 0-999 CONTAR LA CANTIDAD DE BOLILLAS (N)EGRAS  DIAGRAMA DE FLUJO SI NO SI NO SI NO INDICE
  4. 4. 4  PRUEBA DE ESCRITORIO CA CR CN 0 0 0 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 8 8 6 7 A-A-A-N-R-N- N-A-R-R-N-A- R-R-A-N-N-R- A-A-N-0
  5. 5. 5 INDICE
  6. 6. 6 INDICE
  7. 7. 7  PSEUDOCÓDIGO 1 Proceso BOLILLAS_INFINITAS_ Escribir "_____BOLILLAS___INFINITAS______" ; CA<-0; CR<-0; CN<-0; Leer Bolilla; Mientras Bolilla<>'0' Hacer Si Bolilla='A' Entonces CA<-CA+1; Sino Si Bolilla='R' Entonces CR<-CR+1; Sino CN<-CN+1; FinSi FinSi Leer Bolilla; FinMientras Escribir "______INFORME FINAL______" ; Escribir "Cantidad de Amarillas :" CA; Escribir "Cantidad de Rojas :" CR; Escribir "Cantidad de Negras :" CN; FinProceso 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 INDICE
  8. 8. 8  PASOS (a modo de ejemplo) INDICE
  9. 9. 9 INDICE
  10. 10. 10 INDICE
  11. 11. 11  IMPRESIÓN-INFORME TP#2: ”BOLILLAS EXACTAS”  CUADRO DE VARIABLE TIPO LONGITUD RANGO SIRVE PARA… COLOR CA 1 0-50 INGRESAR BOLILLA COLOR (A)MARILLO Y CONTAR CR 1 0-50 INGRESAR BOLILLA COLOR (R)OJO Y CONTAR CN 1 0-50 INGRESAR BOLILLA COLOR (N)EGRO Y CONTAR CA VA 2 0-50 CONTAR LA CANTIDADA DE BOLILLAS (A)MARILLAS CR VR 2 0-50 CONTAR LA CANTIDAD DE BOLILLAS (R)OJAS CN VN 2 0-50 CONTAR LA CANTIDAD DE BOLILLAS (N)EGRAS INDICE
  12. 12. 12 INICIO CA<-0 CR<-0 CN<-0 CB<-0 BOLILLA=”A” CA=CA+1 BOLILLA=”R” CR=CR+1 CN=CN+1 1 BOLILLA COLOR 1 BOLILLA<>”51” AMARILLAS SON: “CA” ROJAS SON: “CR” NEGRAS SON: “CN” FIN CB=CB+1  DIAGRAMA DE FLUJO SI NO SI NO SI NO INDICE
  13. 13. 13  PRUEBA DE ESCRITORIO CA CR CN (CA+CR+CN) 0 0 0 0 1 1 1 3 2 2 2 6 3 3 3 9 4 4 4 12 5 5 5 15 6 6 6 18 7 7 7 21 8 8 8 24 9 9 9 27 10 10 10 30 11 11 11 33 12 12 12 36 13 13 13 39 14 14 14 42 15 15 44 16 16 46 17 47 18 48 19 49 20 14 16 20 50 A-A-R-N-R-R-N-A-N-R- R-A-A-N-R-N-N-R-N-N- A-A-N-R-R-N-R-N-N-A- N-N-R-A-A-A-A-N-R-N- R-N-A-N-N-R-R-R-A-N - 51
  14. 14. 14 INDICE
  15. 15. 15  PSEUDOCÓDIGO 1 Proceso BOLILLAS_EXACTAS Escribir "_____BOLILLAS___EXACTAS______" ; CA<-0; CR<-0; CN<-0; CB<-0; Leer Bolilla; Mientras Bolilla<>”51” Hacer Si Bolilla='A' Entonces CA<-CA+1; Sino Si Bolilla='R' Entonces CR<-CR+1; Sino CN<-CN+1; FinSi FinSi Leer Bolilla; FinMientras Escribir "______INFORME FINAL______" ; Escribir "Cantidad de Amarillas :" CA; Escribir "Cantidad de Rojas :" CR; Escribir "TOTAL DE BOLILLAS :" (CA+CR+CN); FinProceso 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 INDICE
  16. 16. 16  PASOS (a modo de ejemplo) INDICE
  17. 17. 17 INDICE
  18. 18. 18 INDICE
  19. 19. 19  IMPRESIÓN-INFORME A MODO DE EJEMPLO SEGÚN CONSIGNA, BOLILLAS EXACTAS: 50 INDICE
  20. 20. 20 TP#3:”PARES ENTEROS POSITIVOS”  DIAGRAMA DE FLUJO INDICE CD=CD+1 1 INICIO NUMERO 1 NUMERO<>”0 ” “TOTAL DE ENTEROS PARES POSITIVOS:” CPP “TOTAL DE DESCARTADOS:” CD FIN CPP= 0 CD = 0 NUMERO>0 CPP=CPP+1NUMERO MOD (N,2) CD=CD+1
  21. 21. 21  CUADRO DE VARIABLES  PRUEBA DE ESCRITORIO CD CPP (CD+CPP) 0 0 0 1 1 2 2 2 4 3 3 6 4 4 8 5 5 10 6 6 12 7 7 14 8 8 16 9 17 10 18 11 19 12 20 12 8 20 TIPO LONGITUD RANGO SIRVE PARA… NUMERO NUM 9999 0-9999 INGRESAR NUMEROS NUMERO PAR POSITIVO CPP 9999 0-9999 CONTAR LA CANTIDADA DE NUMEROS PARES POSTIVOS NUMEROS DESCARTADOS CD 9999 0-9999 CONTAR LA CANTIDAD DE NUMEROS NO PARES POSITIVOS Y NUMEROS NO POSITIVOS 8, 7, -5, 24, 03, 109, 3567,-7, 35, 3, 56, 102, 38, 507, 44, -3, - 27, 408, 3500, 0
  22. 22. 22
  23. 23. 23  PSEUDOCODIGO 1 Proceso ENTEROS_PARES_POSITIVOS Escribir “***ENTEROS PARES POSITIVOS***” ; CPP<-0; CD <-0; Escribir “INGRESE NUMERO" ; Leer NUMERO ; Mientras NUMERO<>0 Hacer Si NUMERO > 0 Entonces Si NUMERO MOD 2 = 0 Entonces CPP <- CPP + 1; Escribir "ES PAR POSITIVO” ; Sino CD <- CD + 1; Escribir "ES IMPAR POSITIVO" ; FinSi Sino CD <- CD + 1; Escribir "ES NUMERO NEGATIVO" ; FinSi Escribir "INGRESE OTRO NUMERO:" ; Leer NUMERO; FinMientras Escribir "______INFORME FINAL______" ; Escribir "TOTAL DE ENTEROS PARES POSITIVOS :" CPP; Escribir "TOTAL DE DESCARTADOS :" CR; Escribir "TOTAL DE NUMEROS INGRESADOS :” CD+CPP ; FinProceso 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
  24. 24. 24  PASOS (a modo de ejemplo)
  25. 25. 25
  26. 26. 26  IMPRESIÓN-INFORME
  27. 27. 27 TP#4: “MESES DEL AÑO”  DIAGRAMA DE FLUJO 3 1 3 -NOMBRE -MESDENAC -DIANAC 1 CV = 0 CI = 0 CO = 0 CP=0 INICIO NOMBRE=” “ “CUMPLEAÑOS DE AMIGOS” “NOMBRE NACIO EN:” “NOMBRE MES” “TOTAL DE CUMPLEAÑOS EN:” “VERANO:” CV; “OTOÑO:” CO; “INVIERNO:” CI; PRIMAVERA:” CP; FIN MES DE NAC =1 MESDENAC =”ENERO” =2 MESDENAC =”FEBRERO ” =3 MESDENAC =”MARZO” =7 MESDENAC =”JULIO” =8 MESDENAC =”AGOSTO ” =4 MESDENAC =”ABRIL” =5 MESDENAC =”MAYO” =6 MESDENAC =”JUNIO” OTHER WISE=12 MESDENAC= ”DICIEMBRE” =11 MESDE NAC = ”NOVIEM BRE” =10 MESDENAC =”OCTU BRE” =9 MESDENAC =”SEPTIEM BRE” 2 CI=CI+1 DIANA C>20 CP=CP+1 DIANA C>20 CO=CO+1 DIANA C>20 CV=CV+1 DIANA C>20 2
  28. 28. 28  PRUEBA DE ESCRITORIO CI CO CP CV (CI+CO+CP+CV) 0 0 0 0 0 1 1 1 1 4 2 2 2 2 8 2 2 2 2 8 INFORME AMIGOS *Diana: 01/08 *Gonzalo: 24/05 *Nico: 12/07 *Cesar: 29/04 *Mauro: 28/02 *Veronica: 20/11 *Tamara: 22/12 *Alicia: 21/09
  29. 29. 29
  30. 30. 30  PSEUDOCODIGO
  31. 31. 31
  32. 32. 32  PASOS (a modo de ejemplo)
  33. 33. 33
  34. 34. 34  IMPRESIÓN-INFORME
  35. 35. 35 OBS=”AP” CA=CA+1 OBS=”DES” 1 CD=CD+1 NOMBRE, NOTA1, NOTA2, NOTA3, PR, OBS PR=(NOTA1+NOTA+NOTA3) /3 INICIO CA=0 CD=0 ALUMNO=”” “TOTAL DE APROBADOS:” “TOTAL DE DESAPROBADOS:” “% APROBADOS:” “% DESAPROBADOS:” “TOTAL DE ALUMNOS REGISTRADOS:” FIN PR >= 6 ALUMNO NOTA1 NOTA2 NOTA3 1 TP#5: “APROBANDO LA CÁTEDRA”  DIAGRAMA DE FLUJO
  36. 36. 36  PRUEBA DE ESCRITORIO CA CD (CA+CD) 0 0 0 1 1 2 2 2 4 3 3 6 4 4 8 5 9 6 10 6 4 10 LISTA DE ALUMNOS ALUMNOS N1 N2 N3 PR OBS DIANA 5 6 8 6,33 AP GONZALO 8 10 9,50 9,16 AP NICOLAS 5 1 6 4 DES MARIA 4 3,50 5 4,16 DES FRANCISCO 6,75 8 9,25 8 AP MARINA 6 6 7,50 6,50 AP MAURICIA 6 7 5 6 AP LUCAS 7,50 5 5 5,83 DES BIANCA 9,50 8 10 9,16 AP JULIO 3 8 5 5,33 DES
  37. 37. 37
  38. 38. 38  PSEUDOCODIGO
  39. 39. 39  PASOS (a modo de ejemplo)
  40. 40. 40
  41. 41. 41  IMPRESIÓN-INFORME
  42. 42. 42 TP#6: “APROBANDO LA CATEDRA-PONDERACIONES”  DIAGRAMA DE FLUJO PR=(NOTA1+NOTA+NOTA3) /3 TP=TP+1 PD = (CD/(CA+CD)) X 100 PA= (CA/(CA+CD)) X 100 INICIO CA=0 CD=0 TP=0 ALUMNO=”” “TOTAL DE APROBADOS:” CA “TOTAL DE DESAPROBADOS:” CD “% APROBADOS:” PA “% DESAPROBADOS:” PD “TOTAL DE ALUMNOS REGISTRADOS:” TP FIN PR >= 6 ALUMNO NOTA1 NOTA2 NOTA3 1 OBS=”AP” CA=CA+1 OBS=”DES” CD=CD+1 NOMBRE, NOTA1, NOTA2, NOTA3, PR, OBS PR >= 5.50
  43. 43. 43  PRUEBA DE ESCRITORIO CA CD (CA+CD) TPOND 0 0 0 0 1 1 2 1 2 2 4 2 3 3 6 3 4 4 8 4 5 9 5 6 10 6 7 11 7 8 12 9 13 9 4 13 LISTA DE ALUMNOS ALUMNOS N1 N2 N3 PR OBS DIANA 5.75 6 5 5.58 AP GONZALO 6 5.50 5.50 5.66 AP NICOLAS 7.50 6 5 6.16 AP MARIA 5 5.50 5.50 5.33 DES FRANCISCO 5.45 5.45 5.65 5.51 AP MARINA 5.60 6.45 5.45 5.83 AP MAURICIA 5.50 5.50 5.60 5.53 AP LUCAS 5.45 5.60 5.50 5.51 AP BIANCA 5.30 5.75 5.30 5.45 DES JULIO 5.30 5.75 5.41 5.48 DES MACARENA 8.50 6 5 6.50 AP YOSELIN 4 5.30 5 4.76 DES NORMA 5.60 6.45 5.45 5.83 AP
  44. 44. 44
  45. 45. 45  PSEUDOCODIGO
  46. 46. 46  PASOS (a modo de ejemplo)
  47. 47. 47
  48. 48. 48  IMPRESIÓN-INFORME
  49. 49. 49
  50. 50. 50 TP#7: “APROBANDO LA CATEDRA-PONDERACIONES, PARTE2”  DIAGRAMA DE FLUJO REDON(PR) PR=(NOTA1+NOTA+NOTA3) /3 TP=TP+1 PD = (CD/(CA+CD)) X 100 PA= (CA/(CA+CD)) X 100 INICIO CA=0 CD=0 TP=0 ALUMNO=”” “TOTAL DE APROBADOS:” CA “TOTAL DE DESAPROBADOS:” CD “% APROBADOS:” PA “% DESAPROBADOS:” PD “TOTAL DE ALUMNOS REGISTRADOS:” TP FIN PR >= 6 ALUMNO NOTA1 NOTA2 NOTA3 1 OBS=”AP” CA=CA+1 OBS=”DES” 1 CD=CD+1 NOMBRE, NOTA1, NOTA2, NOTA3, PR, OBS PR >= 5.50
  51. 51. 51  PRUEBA DE ESCRITORIO CA CD (CA+CD) TPOND 0 0 0 0 1 1 2 1 2 2 4 2 3 3 6 3 4 4 8 4 5 9 5 6 10 6 7 11 7 8 12 9 13 9 4 13 LISTA DE ALUMNOS ALUMNOS N1 N2 N3 PR OBS DIANA 5.75 6 5 5.58 AP GONZALO 6 5.50 5.50 5.66 AP NICOLAS 7.50 6 5 6.16 AP MARIA 5 5.50 5.50 5.33 DES FRANCISCO 5.45 5.45 5.65 5.51 AP MARINA 5.60 6.45 5.45 5.83 AP MAURICIA 5.50 5.50 5.60 5.53 AP LUCAS 5.45 5.60 5.50 5.51 AP BIANCA 5.30 5.75 5.30 5.45 DES JULIO 5.30 5.75 5.41 5.48 DES MACARENA 8.50 6 5 6.50 AP YOSELIN 4 5.30 5 4.76 DES NORMA 5.60 6.45 5.45 5.83 AP
  52. 52. 52
  53. 53. 53  PSEUDOCODIGO
  54. 54. 54
  55. 55. 55  PASOS (a modo de ejemplo)
  56. 56. 56
  57. 57. 57  IMPRESIÓN-INFORME
  58. 58. 58
  59. 59. 59 TP#8: “TEMPERATURAS”  DIAGRAMA DE FLUJO INICIO TEMPERATURA TEMP=999 PROM=ACUM/CT CTMY>CTN OBS=”TEMPLADO-CALIDO” OBS=”INVIERNO-PROLONGADO” ACUM=ACUM+TEMP CT=CT+1 TEMP>0 CTMY=CTMY+1 CTMN=CTMN+1 ACUMT= 0 CTMN= 0 CT= 0 CTMY = 0 1 “TEMPERATURA PROMEDIO ANUAL:” PROM “TEMPERATURA REGISTRADA MENOR A 0º:” CTMN “TEMPERATURA MAYOR A 0º:” CTMY “LUGAR CON CLIMA:” OBS FIN 1
  60. 60. 60  PRUEBA DE ESCRITORIO CLIMA TEMPLADO-CALIDO ACUMT CT CTMN CTMY 0 0 0 0 5 1 1 1 9 2 2 2 7 3 3 4 3 4 2 2 REGISTROS DE TEMPERATURA 5, 4, -2, -4, 999…
  61. 61. 61
  62. 62. 62
  63. 63. 63 CLIMA INVIERNO-PROLONGADO ACUMT CT CTMN CTMY 0 0 0 0 -3 1 1 1 -8 2 2 2 -10 3 3 -11 4 4 -6 5 0 6 0 6 4 2 REGISTRO DE TEMPERATURAS -3, -5, -2, -1, 5, 6, 999…
  64. 64. 64
  65. 65. 65
  66. 66. 66 PSEUDOCODIGO
  67. 67. 67 PASOS
  68. 68. 68
  69. 69. 69 IMPRESIÓN-INFORME
  70. 70. 70 TP#9: “TEMPERATURAS-PARTE 2”  DIAGRAMA DE FLUJO INICIO TEMPERATURA TEMP=999 PROM=ACUM/CT CTMY>CTN OBS=”TEMPLADO-CALIDO” OBS=”INVIERNO-PROLONGADO” ACUM=ACUM+TEMP CT=CT+1 TEMP>MY MY = TEMP CTMN=CTMN+1 ACUMT= 0 CTMN= 0 CT= 0 CTMY = 0 1 “TEMPERATURA PROMEDIO ANUAL:” PROM “TEMPERATURA REGISTRADA MENOR A 0º:” CTMN “TEMPERATURA MAYOR A 0º:” CTMY “LUGAR CON CLIMA:” OBS “MENOR TEMPERATURA REGISTRADA DURANTE EL AÑO:” MN “MAYOR TEMPERATURA REGISTRADA DURANTE EL AÑO:” MY FIN 1 TEMP>MN MN = TEMP TEMP>= 0 CTMY = CTMY+1
  71. 71. 71 PREUBA DE ESCRITORIO ACUMT CT CTMN CTMY MN MY 0 0 0 0 999 -999 -3 1 1 1 -3 -3 -8 2 2 2 -5 -2 -10 3 3 -1 -11 4 4 -5 -6 5 -6 0 6 REGISTRO DE TEMPERATUR AS -3, -5, -2, -1, 5, 6, 999…
  72. 72. 72
  73. 73. 73
  74. 74. 74 PSEUDOCODIGO
  75. 75. 75 PASOS
  76. 76. 76
  77. 77. 77 IMPRESIÓN-INFORME
  78. 78. 78
  79. 79. 79 TP#9: “TEMPERATURAS-PARTE 2”

×