Algoritmos e Programação - 2016.1 - Aula 7

387 visualizações

Publicada em

Algoritmos e Programação - 2016.1 - Aula 7

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
387
No SlideShare
0
A partir de incorporações
0
Número de incorporações
105
Ações
Compartilhamentos
0
Downloads
28
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2016.1 - Aula 7

  1. 1. Algoritmos e Programação Prof.º Thyago Maia
  2. 2. Objetivos Aula 7 • Apresentar a estrutura de seleção múltipla 2
  3. 3. Comando de Seleção Múltipla
  4. 4. Comando de Seleção Múltipla • Em algumas situações, existem situações mutuamente exclusivas: – Se uma situação for executada, as demais não serão; • Em casos desse tipo, um comando de seleção múltipla é mais indicado do que o comando SE; 4
  5. 5. Comando de Seleção Múltipla • Sintaxe: 5 ESCOLHA (VARIAVEL) CASO VALOR_1 // Instruções que serão executadas caso // VARIAVEL seja igual a VALOR_1 CASO VALOR_2 // Instruções que serão executadas caso // VARIAVEL seja igual a VALOR_2 OUTROCASO // Instruções que serão executadas caso // VARIAVEL NÃO seja igual a VALOR_1 e VALOR_2 FIMESCOLHA
  6. 6. Comando de Seleção Múltipla • As palavras reservadas escolha e fimescolha delimitam a região da estrutura condicional; • Tal estrutura seleciona uma variável que será comparada com os valores especificados ao lado da palavra reservada caso; • O caso tem funcionamento similar ao se; • O outrocaso tem funcionamento similar ao senao, visto anteriormente; 6
  7. 7. Exemplo • Faça um algoritmo que lê o sexo de um indivíduo (M ou F) e informa se o mesmo é homem ou mulher; 7
  8. 8. Exemplo ALGORITMO “exemplo” VAR sexo: LITERAL INICIO ESCREVA (“Digite seu sexo:”) LEIA (sexo) ESCOLHA (sexo) CASO “M” ESCREVA (“É um homem”) CASO “F” ESCREVA (“É uma mulher”) OUTROCASO ESCREVA (“Caractere inválido!”) FIMESCOLHA 8
  9. 9. Exemplo FIMALGORITMO 9
  10. 10. Exemplo • Faça um algoritmo que lê o time de futebol de um indivíduo. – Caso o usuário digite Sport, o algoritmo deverá escrever uma mensagem dando os parabéns pela escolha; – Caso contrário, o algoritmo deverá “dar os pêsames”! =P 10
  11. 11. Exemplo ALGORITMO “exemplo” VAR time: LITERAL INICIO ESCREVA (“Digite seu time:”) LEIA (time) ESCOLHA (time) CASO “Sport” ESCREVA (“Parabéns pela escolha!”) OUTROCASO ESCREVA (“Meus pêsames!”) FIMESCOLHA FIMALGORITMO 11
  12. 12. Exercícios
  13. 13. Exercícios • Faça um algoritmo que lê um número de 1 a 7 e informa o dia da semana correspondente, sendo domingo o número 1. Caso o número esteja fora da faixa, o algoritmo deverá exibir uma mensagem de erro. 13
  14. 14. Exercício ALGORITMO “exercicio” VAR dia: INTEIRO INICIO ESCREVA (“Digite o número equivalente a um dia da semana:”) LEIA (dia) ESCOLHA (dia) CASO 1 ESCREVA (“Domingo”) CASO 2 ESCREVA (“Segunda”) CASO 3 ESCREVA (“Terça”) 14
  15. 15. Exercício CASO 4 ESCREVA (“Quarta”) CASO 5 ESCREVA (“Quinta”) CASO 6 ESCREVA (“Sexta”) CASO 7 ESCREVA (“Sábado”) OUTROCASO ESCREVA (“Dia inexistente”) FIMESCOLHA FIMALGORITMO 15
  16. 16. Exercícios • Faça um algoritmo que receba dois números, um caractere que representa uma operação matemática (+, -, *, /) e efetue o cálculo matemático baseado na escolha do usuário. O resultado deverá ser exibido em seguida. 16
  17. 17. Exercício ALGORITMO “exercicio” VAR num1, num2, resultado: REAL operador: LITERAL INICIO ESCREVA (“Digite dois números e o operador:”) LEIA (num1, num2, operador) ESCOLHA (operador) CASO “+” resultado <- num1 + num2 CASO “-” resultado <- num1 - num2 CASO “*” resultado <- num1 * num2 17
  18. 18. Exercício CASO “/” resultado <- num1 / num2 OUTROCASO ESCREVA (“Operador inválido”) FIMESCOLHA ESCREVA (resultado) FIMALGORITMO 18
  19. 19. Explore o assunto!
  20. 20. Explore o assunto! • Referências – Introdução aos algoritmos(TONET, B., KOLIVER, C.): Tópicos 12 e 13; – Disponível em http://www.claudiorodol fo.com/ftc/ap/manual_vi sualg.pdf 20

×