Algoritmos e Programação
Prof.º Thyago Maia
2015.2
Objetivos
Aula 9
• Apresentar as estruturas de
repetição
• Apresentar a estrutura de
repetição ENQUANTO
2
Enquanto
Enquanto
• Nesta estrutura, uma expressão lógica é
avaliada. Enquanto a mesma for verdadeira,
uma lista de comandos será e...
Enquanto
• Forma geral:
5
ENQUANTO (condição) FACA
// Lista de instruções
FIMENQUANTO
Exemplo
• Faça um algoritmo que lê diversos números
positivos e escreve o dobro de cada um.
Quando um número negativo for ...
Exemplo
ALGORITMO “exemplo”
VAR numero, dobro: REAL
INICIO
ESCREVAL (“Digite um número:”)
LEIA (numero)
ENQUANTO (numero >...
Exemplo
• Faça um algoritmo que escreve os números
entre 1 e 10 (incluindo-os).
8
Exemplo
ALGORITMO “teste”
VAR numero: INTEIRO
INICIO
numero <- 1
ENQUANTO (numero <= 10) FACA
ESCREVAL (numero)
numero <- ...
Estruturas de Repetição
• Enquanto...faca
– Atenção: Cuidado com laços infinitos! Devemos
nos certificar que em algum mome...
Estruturas de Repetição
• Exemplo - Algoritmo com laço infinito:
11
ALGORITMO “infinito”
VAR contador: INTEIRO
INICIO
ENQU...
Exercícios
Exercícios
• Faça um algoritmo que receba números
inteiros e, enquanto números positivos forem
digitados, verifica se cada...
Exemplo
ALGORITMO “teste”
VAR numero: INTEIRO
INICIO
ESCREVAL (“Digite um número:”)
LEIA (numero)
ENQUANTO (numero >= 0) F...
Exercícios
• Faça um algoritmo que lê a idade de várias pessoas,
até que uma idade negativa seja digitada. O
algoritmo dev...
Exercício
ALGORITMO “exercicio”
VAR idade, faixa1, faixa2, faixa3: INTEIRO
INICIO
ESCREVAL (“Digite sua idade:”)
LEIA (ida...
Exercício
SE (idade >= 16) E (idade <= 30) ENTAO
faixa2 <- faixa2 + 1
FIMSE
SE (idade > 30) ENTAO
faixa3 <- faixa3 + 1
FIM...
Exercícios
• Faça um algoritmo que receba vários números
inteiros positivos (o algoritmo deverá
encerrar quando um número ...
Exercício
ALGORITMO “exercicio”
VAR numero, maior: INTEIRO
INICIO
ESCREVAL (“Digite um número:”)
LEIA (numero)
ENQUANTO (n...
Exercício
ESCREVAL (“O maior número digitado: ”, maior)
FIMALGORITMO
20
Próximos SlideShares
Carregando em…5
×

Algoritmos e Programação - 2015.2 - Aula 9

242 visualizações

Publicada em

Algoritmos e Programação - 2015.2 - Aula 9

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
242
No SlideShare
0
A partir de incorporações
0
Número de incorporações
10
Ações
Compartilhamentos
0
Downloads
9
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2015.2 - Aula 9

  1. 1. Algoritmos e Programação Prof.º Thyago Maia 2015.2
  2. 2. Objetivos Aula 9 • Apresentar as estruturas de repetição • Apresentar a estrutura de repetição ENQUANTO 2
  3. 3. Enquanto
  4. 4. Enquanto • Nesta estrutura, uma expressão lógica é avaliada. Enquanto a mesma for verdadeira, uma lista de comandos será executada; • A execução da lista se repetirá até que a avaliação da condição resulte em FALSO; 4
  5. 5. Enquanto • Forma geral: 5 ENQUANTO (condição) FACA // Lista de instruções FIMENQUANTO
  6. 6. Exemplo • Faça um algoritmo que lê diversos números positivos e escreve o dobro de cada um. Quando um número negativo for digitado, o algoritmo deverá parar de ler números. 6
  7. 7. Exemplo ALGORITMO “exemplo” VAR numero, dobro: REAL INICIO ESCREVAL (“Digite um número:”) LEIA (numero) ENQUANTO (numero >= 0) FACA dobro <- numero * 2 ESCREVAL (dobro) ESCREVAL (“Digite um número:”) LEIA (numero) FIMENQUANTO FIMALGORITMO 7
  8. 8. Exemplo • Faça um algoritmo que escreve os números entre 1 e 10 (incluindo-os). 8
  9. 9. Exemplo ALGORITMO “teste” VAR numero: INTEIRO INICIO numero <- 1 ENQUANTO (numero <= 10) FACA ESCREVAL (numero) numero <- numero + 1 FIMENQUANTO FIMALGORITMO 9
  10. 10. Estruturas de Repetição • Enquanto...faca – Atenção: Cuidado com laços infinitos! Devemos nos certificar que em algum momento a expressão lógica próxima a palavra reservada enquanto será FALSA! 10
  11. 11. Estruturas de Repetição • Exemplo - Algoritmo com laço infinito: 11 ALGORITMO “infinito” VAR contador: INTEIRO INICIO ENQUANTO (contador < 10) FACA contador <- 1 ESCREVA (contador) contador <- contador + 1 FIMENQUANTO FIMALGORITMO
  12. 12. Exercícios
  13. 13. Exercícios • Faça um algoritmo que receba números inteiros e, enquanto números positivos forem digitados, verifica se cada número é menor que 5 (escrevendo uma mensagem afirmando o referido fato); 13
  14. 14. Exemplo ALGORITMO “teste” VAR numero: INTEIRO INICIO ESCREVAL (“Digite um número:”) LEIA (numero) ENQUANTO (numero >= 0) FACA SE (numero < 5) ENTAO ESCREVAL (“O número digitado é menor que 5!”) FIMSE ESCREVA (“Digite um número:”) LEIA (numero) FIMENQUANTO FIMALGORITMO 14
  15. 15. Exercícios • Faça um algoritmo que lê a idade de várias pessoas, até que uma idade negativa seja digitada. O algoritmo deverá calcular e exibir a quantidade de pessoas, de acordo com as faixas etárias apresentadas na tabela abaixo: 15 FAIXA ETÁRIA IDADE 1ª <= 15 anos 2ª De 16 a 30 anos 3ª > 30 anos
  16. 16. Exercício ALGORITMO “exercicio” VAR idade, faixa1, faixa2, faixa3: INTEIRO INICIO ESCREVAL (“Digite sua idade:”) LEIA (idade) ENQUANTO (idade >= 0) FACA SE (idade <= 15) ENTAO faixa1 <- faixa1 + 1 FIMSE 16
  17. 17. Exercício SE (idade >= 16) E (idade <= 30) ENTAO faixa2 <- faixa2 + 1 FIMSE SE (idade > 30) ENTAO faixa3 <- faixa3 + 1 FIMSE ESCREVAL (“Digite sua idade:”) LEIA (idade) FIMENQUANTO ESCREVAL (“Quantidade de pessoas na faixa 1: ”, faixa1) ESCREVAL (“Quantidade de pessoas na faixa 2: ”, faixa2) ESCREVAL (“Quantidade de pessoas na faixa 3: ”, faixa3) FIMALGORITMO 17
  18. 18. Exercícios • Faça um algoritmo que receba vários números inteiros positivos (o algoritmo deverá encerrar quando um número negativo for digitado). O mesmo deverá exibir o maior número digitado; 18
  19. 19. Exercício ALGORITMO “exercicio” VAR numero, maior: INTEIRO INICIO ESCREVAL (“Digite um número:”) LEIA (numero) ENQUANTO (numero >= 0) FACA SE (numero > maior) ENTAO maior <- numero FIMSE ESCREVAL (“Digite outro número:”) LEIA (numero) FIMENQUANTO 19
  20. 20. Exercício ESCREVAL (“O maior número digitado: ”, maior) FIMALGORITMO 20

×