Algoritmos e Programação
Prof.º Thyago Maia
2015.2
Objetivos
Aula 6
• Apresentar as estruturas
condicionais (continuação)
2
Estruturas Condicionais
Estruturas Condicionais
• Também podemos implementar estruturas
condicionais com mais de uma condição (expressão);
• Subex...
Exemplo
• Uso do operador lógico E:
– Faça um algoritmo que lê três números e informa
qual o maior número digitado (consid...
Exemplo
ALGORITMO “exemplo”
VAR num1, num2, num3: INTEIRO
INICIO
ESCREVA (“Digite três números:”)
LEIA (num1, num2, num3)
...
Exemplo
// ...
SE (num3 > num1) E (num3 > num2) ENTAO
ESCREVA (num3)
FIMSE
FIMALGORITMO
7
Exemplo
• Uso do operador lógico OU:
– Faça um algoritmo que lê uma sigla de um estado
brasileiro (considere que o usuário...
Exemplo
ALGORITMO “exemplo”
VAR sigla: LITERAL
INICIO
ESCREVA (“Digite uma sigla (PE, PB, RJ, SP):”)
LEIA (sigla)
SE (sigl...
Exercícios
Exercícios
• Faça um algoritmo que verifica quanto cada
pessoa deverá pagar para entrar em um
cinema. O algoritmo deverá s...
Exercício
ALGORITMO “exercicio”
VAR sexo: LITERAL
idade: INTEIRO
INICIO
ESCREVA (“Digite o sexo (M ou F) e a idade do clie...
Exercício
SE (idade < 17) E (sexo = “M”) ENTAO
ESCREVA (“Total a pagar: R$ 7,00”)
FIMSE
FIMALGORITMO
13
Comando de Seleção Múltipla
Comando de Seleção Múltipla
• Em algumas situações, existem situações
mutuamente exclusivas:
– Se uma situação for executa...
Comando de Seleção Múltipla
• Sintaxe:
16
ESCOLHA (VARIAVEL)
CASO VALOR_1
// Instruções que serão executadas caso
// VARIA...
Comando de Seleção Múltipla
• As palavras reservadas escolha e fimescolha
delimitam a região da estrutura condicional;
• T...
Exemplo
• Faça um algoritmo que lê o sexo de um
indivíduo (M ou F) e informa se o mesmo é
homem ou mulher;
18
Exemplo
ALGORITMO “exemplo”
VAR sexo: LITERAL
INICIO
ESCREVA (“Digite seu sexo:”)
LEIA (sexo)
ESCOLHA (sexo)
CASO “M”
ESCR...
Exemplo
FIMALGORITMO
20
Exemplo
• Faça um algoritmo que lê o time de futebol de
um indivíduo.
– Caso o usuário digite Sport, o algoritmo deverá
es...
Exemplo
ALGORITMO “exemplo”
VAR time: LITERAL
INICIO
ESCREVA (“Digite seu time:”)
LEIA (time)
ESCOLHA (time)
CASO “Sport”
...
Exercícios
Exercícios
• Faça um algoritmo que lê um número de 1 a 7
e informa o dia da semana correspondente,
sendo domingo o número ...
Exercício
ALGORITMO “exercicio”
VAR dia: INTEIRO
INICIO
ESCREVA (“Digite o número equivalente a um dia da
semana:”)
LEIA (...
Exercício
CASO 4
ESCREVA (“Quarta”)
CASO 5
ESCREVA (“Quinta”)
CASO 6
ESCREVA (“Sexta”)
CASO 7
ESCREVA (“Sábado”)
OUTROCASO...
Exercícios
• Faça um algoritmo que receba dois números,
um caractere que representa uma operação
matemática (+, -, *, /) e...
Exercício
ALGORITMO “exercicio”
VAR num1, num2, resultado: REAL
operador: LITERAL
INICIO
ESCREVA (“Digite dois números e o...
Exercício
CASO “/”
resultado <- num1 / num2
OUTROCASO
ESCREVA (“Operador inválido”)
FIMESCOLHA
ESCREVA (resultado)
FIMALGO...
Explore o assunto!
Explore o assunto!
• Referências
– Introdução aos
algoritmos(TONET, B.,
KOLIVER, C.): Tópico 10;
– Disponível em
http://ww...
Próximos SlideShares
Carregando em…5
×

Algoritmos e Programação - 2015.2 - Aula 6

284 visualizações

Publicada em

Algoritmos e Programação - 2015.2 - Aula 6

Publicada em: Educação
0 comentários
0 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

  • Seja a primeira pessoa a gostar disto

Sem downloads
Visualizações
Visualizações totais
284
No SlideShare
0
A partir de incorporações
0
Número de incorporações
4
Ações
Compartilhamentos
0
Downloads
12
Comentários
0
Gostaram
0
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos e Programação - 2015.2 - Aula 6

  1. 1. Algoritmos e Programação Prof.º Thyago Maia 2015.2
  2. 2. Objetivos Aula 6 • Apresentar as estruturas condicionais (continuação) 2
  3. 3. Estruturas Condicionais
  4. 4. Estruturas Condicionais • Também podemos implementar estruturas condicionais com mais de uma condição (expressão); • Subexpressões podem formar uma única expressão a partir do uso dos operadores lógicos E ou OU; • Para sabermos se determinada expressão será verdadeira ou falsa, deveremos checar a saída lógica de cada subexpressão; 4
  5. 5. Exemplo • Uso do operador lógico E: – Faça um algoritmo que lê três números e informa qual o maior número digitado (considere nos testes que o usuário sempre irá digitar valores distintos para cada número). 5
  6. 6. Exemplo ALGORITMO “exemplo” VAR num1, num2, num3: INTEIRO INICIO ESCREVA (“Digite três números:”) LEIA (num1, num2, num3) SE (num1 > num2) E (num1 > num3) ENTAO ESCREVA (num1) FIMSE SE (num2 > num1) E (num2 > num3) ENTAO ESCREVA (num2) FIMSE // ... 6
  7. 7. Exemplo // ... SE (num3 > num1) E (num3 > num2) ENTAO ESCREVA (num3) FIMSE FIMALGORITMO 7
  8. 8. Exemplo • Uso do operador lógico OU: – Faça um algoritmo que lê uma sigla de um estado brasileiro (considere que o usuário só ira digitar um dos seguintes estados: PE, PB, SP ou RJ) e informa se o estado digitado pertence ao Nordeste ou ao Sudeste. 8
  9. 9. Exemplo ALGORITMO “exemplo” VAR sigla: LITERAL INICIO ESCREVA (“Digite uma sigla (PE, PB, RJ, SP):”) LEIA (sigla) SE (sigla = “PE”) OU (sigla = “PB”) ENTAO ESCREVA (“É do Nordeste!”) FIMSE SE (sigla = “RJ”) OU (sigla = “SP”) ENTAO ESCREVA (“É do Sudeste!”) FIMSE FIMALGORITMO 9
  10. 10. Exercícios
  11. 11. Exercícios • Faça um algoritmo que verifica quanto cada pessoa deverá pagar para entrar em um cinema. O algoritmo deverá solicitar o sexo e a idade do indivíduo. As condições de pagamento são as seguintes: • O ingresso custa R$ 10,00 para pessoas com idade maior ou igual a 17 anos; • Mulheres com idade inferior a 17 anos pagam meia entrada (R$ 5,00); • Homens com idade inferior a 17 anos pagam R$ 7,00; 11
  12. 12. Exercício ALGORITMO “exercicio” VAR sexo: LITERAL idade: INTEIRO INICIO ESCREVA (“Digite o sexo (M ou F) e a idade do cliente:”) LEIA (sexo, idade) SE (idade >= 17) ENTAO ESCREVA (“Total a pagar: R$ 10,00”) FIMSE SE (idade < 17) E (sexo = “F”) ENTAO ESCREVA (“Total a pagar: R$ 5,00”) FIMSE 12
  13. 13. Exercício SE (idade < 17) E (sexo = “M”) ENTAO ESCREVA (“Total a pagar: R$ 7,00”) FIMSE FIMALGORITMO 13
  14. 14. Comando de Seleção Múltipla
  15. 15. Comando de Seleção Múltipla • Em algumas situações, existem situações mutuamente exclusivas: – Se uma situação for executada, as demais não serão; • Em casos desse tipo, um comando de seleção múltipla é mais indicado do que o comando SE; 15
  16. 16. Comando de Seleção Múltipla • Sintaxe: 16 ESCOLHA (VARIAVEL) CASO VALOR_1 // Instruções que serão executadas caso // VARIAVEL seja igual a VALOR_1 CASO VALOR_2 // Instruções que serão executadas caso // VARIAVEL seja igual a VALOR_2 OUTROCASO // Instruções que serão executadas caso // VARIAVEL NÃO seja igual a VALOR_1 e VALOR_2 FIMESCOLHA
  17. 17. Comando de Seleção Múltipla • As palavras reservadas escolha e fimescolha delimitam a região da estrutura condicional; • Tal estrutura seleciona uma variável que será comparada com os valores especificados ao lado da palavra reservada caso; • O caso tem funcionamento similar ao se; • O outrocaso tem funcionamento similar ao senao, visto anteriormente; 17
  18. 18. Exemplo • Faça um algoritmo que lê o sexo de um indivíduo (M ou F) e informa se o mesmo é homem ou mulher; 18
  19. 19. Exemplo ALGORITMO “exemplo” VAR sexo: LITERAL INICIO ESCREVA (“Digite seu sexo:”) LEIA (sexo) ESCOLHA (sexo) CASO “M” ESCREVA (“É um homem”) CASO “F” ESCREVA (“É uma mulher”) OUTROCASO ESCREVA (“Caractere inválido!”) FIMESCOLHA 19
  20. 20. Exemplo FIMALGORITMO 20
  21. 21. Exemplo • Faça um algoritmo que lê o time de futebol de um indivíduo. – Caso o usuário digite Sport, o algoritmo deverá escrever uma mensagem dando os parabéns pela escolha; – Caso contrário, o algoritmo deverá “dar os pêsames”! =P 21
  22. 22. Exemplo ALGORITMO “exemplo” VAR time: LITERAL INICIO ESCREVA (“Digite seu time:”) LEIA (time) ESCOLHA (time) CASO “Sport” ESCREVA (“Parabéns pela escolha!”) OUTROCASO ESCREVA (“Meus pêsames!”) FIMESCOLHA FIMALGORITMO 22
  23. 23. Exercícios
  24. 24. Exercícios • Faça um algoritmo que lê um número de 1 a 7 e informa o dia da semana correspondente, sendo domingo o número 1. Caso o número esteja fora da faixa, o algoritmo deverá exibir uma mensagem de erro. 24
  25. 25. Exercício ALGORITMO “exercicio” VAR dia: INTEIRO INICIO ESCREVA (“Digite o número equivalente a um dia da semana:”) LEIA (dia) ESCOLHA (dia) CASO 1 ESCREVA (“Domingo”) CASO 2 ESCREVA (“Segunda”) CASO 3 ESCREVA (“Terça”) 25
  26. 26. Exercício CASO 4 ESCREVA (“Quarta”) CASO 5 ESCREVA (“Quinta”) CASO 6 ESCREVA (“Sexta”) CASO 7 ESCREVA (“Sábado”) OUTROCASO ESCREVA (“Dia inexistente”) FIMESCOLHA FIMALGORITMO 26
  27. 27. Exercícios • Faça um algoritmo que receba dois números, um caractere que representa uma operação matemática (+, -, *, /) e efetue o cálculo matemático baseado na escolha do usuário. O resultado deverá ser exibido em seguida. 27
  28. 28. Exercício ALGORITMO “exercicio” VAR num1, num2, resultado: REAL operador: LITERAL INICIO ESCREVA (“Digite dois números e o operador:”) LEIA (num1, num2, operador) ESCOLHA (operador) CASO “+” resultado <- num1 + num2 CASO “-” resultado <- num1 - num2 CASO “*” resultado <- num1 * num2 28
  29. 29. Exercício CASO “/” resultado <- num1 / num2 OUTROCASO ESCREVA (“Operador inválido”) FIMESCOLHA ESCREVA (resultado) FIMALGORITMO 29
  30. 30. Explore o assunto!
  31. 31. Explore o assunto! • Referências – Introdução aos algoritmos(TONET, B., KOLIVER, C.): Tópico 10; – Disponível em http://www.claudiorodol fo.com/ftc/ap/manual_vi sualg.pdf 31

×